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109 Accessing the Properties panel
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111.3 Cue size
111.4 Play

112 Playback settings
113 Appearance settings

113.1 Leading space
113.2 Measure width
113.3 Minimum distance
113.4 Offset
113.5 Snap to grid
113.6 Arrange
113.7 Color

114 Saving and restoring default settings
114.1 Adjusting elements directly

115 Changing the position of elements
116 Changing the shape of elements
117 Working with lines

117.1 Changing the range of a line
117.2 Creating diagonal lines
117.3 Editing line text

118 See also
118.1 Parts

119 Opening a part
120 Closing a part
121 Creating custom parts

121.1 Reveal instruments in default parts
121.2 Create a new part
121.3 Choose which voices appear in each part

122 Applying styles to parts
123 Renaming, duplicating and deleting parts
124 Exporting and printing parts

124.1 Default keyboard shortcuts
125 Navigation

125.1 Page navigation
125.2 Score navigation

126 Note input
126.1 General
126.2 Duration
126.3 Pitch
126.4 Tablature

127 Selecting
128 Editing

128.1 General
128.2 Duration
128.3 Pitch
128.4 Notation
128.5 Manual adjustment

129 Text
129.1 General
129.2 Formatting
129.3 Lyrics
129.4 Chord symbols, Roman numeral analysis, Nashville numbers, figured bass

130 Other score elements
131 Score setup and formatting
132 File Operations
133 User interface

133.1 Playback
134 Notation: Instruments, staves, and systems
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134.1 Working with instruments
135 Overview
136 Adding and ordering instruments

136.1 Accessing the Instruments panel
136.2 Adding instruments
136.3 Deleting instruments
136.4 Changing the order of instruments

137 Instrument settings
137.1 Hiding/showing instruments
137.2 Renaming instruments
137.3 Replacing instruments

138 Adding and configuring staves
138.1 To add a staff to an existing instrument
138.2 To add a linked staff to an existing instrument
138.3 Configuring a staff
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140.1 Hiding all empty staves
140.2 Excluding specific staves from being hidden

141 Temporary staves
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144.1 Implode and explode
145 Implode

145.1 Combine notes from multiple voices in a single staff into one voice
145.2 Combine notes from multiple staves into multiple voices on a single staff
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146.1 Copy passage of single notes to multiple staves
146.2 Separate a passage of chords into its constituent notes

147 Mid-score instrument changes
148 Adding an instrument change
149 Working with instrument changes

149.1 Removing an instrument change
149.2 Re-labelling an instrument change
149.3 Instrument changes in the mixer
149.4 Changing staff type

150 Staff type change
151 Adding a staff type change
152 Setting staff properties

152.1 Staff/Part properties
153 Overview
154 Staff properties
155 Advanced style properties

155.1 Template (all staves)
155.2 Standard and Percussion staff options only
155.3 Tablature options only

155.3.1 Fret Marks tab
155.3.2 Note Values tab

156 Part properties
156.1 Instrument
156.2 Names
156.3 Usable pitch range
156.4 Transposition
156.5 Strings and frets

157 Brackets
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159 Editing brackets

159.1 Changing bracket type
159.2 Changing bracket span
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161 Customizing bracket appearance
162 Notation: Rhythm, meter, and measures
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162.1 Time signatures
163 Overview
164 Setting the initial time signature for your score
165 Adding a time signature change to your score
166 Deleting a time signature
167 Controlling the visibility of time signatures
168 Creating a custom time signature
169 Adding a local time signature for a single staff
170 Resizing a time signature
171 Time signature properties

171.1 Appearance
171.2 Beam Groups

172 Time signature style
172.1 Stems and flags

173 Stem direction
173.1 Default stem direction
173.2 Flipping stem direction

174 Changing stem length
175 Creating stemless notes
176 Stem and flag properties
177 Stem and flag style
178 See also

178.1 Beams
179 Controlling which notes are beamed

179.1 Setting the default beaming for a time signature
179.2 Changing the beaming for selected notes

180 Controlling the appearance of beams
180.1 Changing the angle of a selected beam
180.2 Creating a feathered beam

181 Beam properties
182 Beam style

182.1 Regroup rhythms
183 Overview
184 Regrouping rhythms
185 See also

185.1 Tuplets
186 Creating tuplets

186.1 Simple tuplets
186.1.1 In note input mode
186.1.2 In normal mode
186.1.3 Consecutive tuplets

186.2 Custom tuplets
186.3 Nested tuplets

187 Changing the display of tuplets
188 Tuplet properties
189 Tuplet style

189.1 Barlines
190 Adding double and other special barlines

190.1 Changing barline type for all staves
190.2 Changing barline type for a single staff
190.3 Adding mid-measure barlines

191 Changing barline length
191.1 Extending all barlines in a staff
191.2 Extending selected barlines in a staff
191.3 Creating partial barlines
191.4 Creating barlines between staves only (Mensurstrich)

192 Barline properties
193 Barline style
194 See also

194.1 Measure numbering
195 Showing and hiding measure numbers

195.1 Showing measure numbers automatically
195.2 Showing measure numbers manually
195.3 Hiding measure numbers
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196 Changing the measure number sequence
196.1 Excluding a measure from the count
196.2 Altering the numbering of a measure
196.3 Resetting measure numbering for a new section

197 Changing the position of measure numbers
198 Measure number properties
199 Measure number style
200 See also

200.1 Measure rests and multimeasure rests
201 Measure rest
202 Multimeasure rest

202.1 Enabling and disabling multimeasure rests
202.2 Breaking multimeasure rests
202.3 Multimeasure rest properties
202.4 Multimeasure rest style

203 See also
203.1 Pickup and non-metered measures

204 Creating a pickup measure
204.1 Specifying the pickup duration during score creation
204.2 Converting a measure into a pickup

205 Creating non-metered measures
205.1 Inserting notes and rests

205.1.1 Using a keyboard shortcut
205.1.2 Using Insert mode

205.2 Joining measures
205.3 Splitting a measure

206 See also
206.1 Measure properties

207 Opening and using the dialog
208 Staves
209 Measure duration
210 Other
211 See also
212 Notation: Pitch

212.1 Clefs
213 Setting the initial clef for a staff
214 Adding or changing a clef

214.1 Add/Change a start clef
214.2 Add/Change a mid-measure clef

215 Delete
216 Controlling the visibility of clefs

216.1 Standard clefs
216.2 Courtesy clefs

217 Clefs and transposition
217.1 Using octave clefs
217.2 Using different clefs for transposed and concert pitch

218 Clef properties
219 Clef style

219.1 Key signatures
220 Overview
221 Setting the initial key signature for your score
222 Adding a key signature change to your score
223 Adding a local key signature for a single staff
224 Selecting a key signature for a single staff
225 Replacing an existing key signature
226 Deleting a key signature
227 Controlling the visibility of key signatures
228 Key signatures and transposing instruments

228.1 Open/Atonal key signature
229 Creating a custom key signature
230 Key signature properties
231 Key signature style

231.1 Format→Style→Page
231.2 Format→Style→Accidentals

https://musescore.org/en/print/book/export/html/329209?toc=1#Format%E2%86%92Style%E2%86%92Page
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231.3 Format→Style→Measure
232 See also

232.1 Transposition
233 Overview
234 Transposing with keyboard shortcuts

234.1 Transpose chromatically
234.2 Transpose diatonically
234.3 Transpose by an octave

235 Using the transpose dialog
235.1 Transpose Chromatically

235.1.1 To transpose chromatically to a specific key:
235.1.2 To transpose chromatically by interval

235.2 Transpose Diatonically
236 Working with transposing instruments

236.1 Transposed and concert pitch
236.2 Setting the interval of transposition
236.3 Controlling enharmonic spelling

237 Octave lines
238 Overview
239 Adding an octave line to your score
240 Octave line properties

240.1 Style tab
240.2 Text tab

241 Octave line style
241.1 Noteheads

242 Changing notehead direction
243 Changing notehead shape
244 Sharing noteheads between voices

244.1 Remove duplicate fretmarks in tablature
245 Alternative notehead schemes
246 Adding pitch and velocity information to notes
247 Notehead properties

247.1 Ambitus
248 Adding an ambitus to your score
249 Changing the range of an ambitus
250 Ambitus properties

250.1 Respell pitches
251 Manually changing the enharmonic spelling of notes
252 Automatically respelling all notes in a selection

252.1 Respell pitches
253 Notation: Expressive markings

253.1 Articulations
254 Adding articulations to your score

254.1 Toolbar
254.2 Articulations palette
254.3 Keyboard shortcuts

255 Articulations playback
256 Articulation properties
257 Articulation style

257.1 Alignment options
257.2 Combined articulation options

258 Dynamics
259 Adding dynamics to your score

259.1 Dynamics palette
259.2 Combining dynamics with expression text

259.2.1 To snap expression text to a dynamic
259.2.2 To add text to a dynamic

259.3 Keyboard shortcuts for adding dynamics
260 Dynamics properties
261 Dynamics style

261.1 Hairpins
262 Types of hairpin
263 Adding a hairpin to your score

https://musescore.org/en/print/book/export/html/329209?toc=1#Format%E2%86%92Style%E2%86%92Measure
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263.1 Lines palette
263.2 Keyboard shortcuts

264 Changing appearance of hairpins
264.1 Range
264.2 Height
264.3 Set at angle
264.4 Other adjustments

265 Changing playback of hairpins
266 Hairpin properties

266.1 Style tab
266.2 Text tab

267 Hairpin style
267.1 Slurs

268 Adding a slur to your score
268.1 Adding slurs in normal mode

268.1.1 Method 1
268.1.2 Method 2

268.2 Adding slurs in note input mode
269 Multi-voice and cross-staff slurs
270 Changing appearance of slurs
271 Slur properties
272 Slur style

272.1 Breaths and pauses
273 Types of pauses

273.1 Fermata
273.2 Breath mark
273.3 Caesura

274 Adding a pause to your score
275 Changing pause playback
276 Pause properties
277 Pause style

277.1 Ornaments
278 Adding an ornament to your score

278.1 Add an ornament
278.2 Add an ornament line

279 Changing ornament intervals (adding accidentals)
280 Ornament properties

280.1 Accidental visibility
280.2 Placement
280.3 Accidental properties

281 Ornament style
281.1 Arpeggios and glissandi

282 Arpeggios
282.1 Adding an arpeggio/strum to your score
282.2 Adjusting the height of an arpeggio/strum
282.3 Creating multi-voice or cross-staff arpeggios

282.3.1 Multi-voice arpeggios
282.3.2 Cross-staff arpeggios

282.4 Changing playback of arpeggios
282.5 Arpeggio style

283 Glissandi
283.1 Adding a glissando to your score
283.2 Editing range of a glissando
283.3 Changing appearance of glissandi
283.4 Changing playback of glissandi
283.5 Glissando properties

284 Bends
284.1 Types of bends
284.2 Adding a bend to your score
284.3 Changing appearance of bends

285 Grace notes
286 Types of grace notes
287 Adding a grace note to your score

287.1 Add grace note with keyboard shortcut
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287.2 Add grace note from palette
288 Multiple grace notes

288.1 Sequential grace notes
288.2 Grace note chords

289 Editing grace notes
289.1 Change duration
289.2 Change pitch

290 Changing playback of grace notes
291 Grace note style

291.1 Tremolo and rolls
292 Types of tremolo and rolls

292.1 Single note tremolo
292.2 Tremolo between notes
292.3 Buzz roll

293 Adding a tremolo to a single note
294 Adding a tremolo between notes/chords
295 Changing appearance of tremolos

295.1 Other lines
296 Overview
297 Adding a line to your score
298 Adjusting a line
299 Types of lines

299.1 Guitar-related lines
299.2 Tempo lines
299.3 Staff and System Text lines
299.4 Trill lines
299.5 Standard lines

300 Line properties
300.1 Style tab
300.2 Text tab

301 Line style
301.1 Other symbols

302 The Symbols palette
302.1 View
302.2 Search

303 Adding symbols to your score
303.1 Add a symbol
303.2 Add to other symbols
303.3 Reposition symbols
303.4 See also

304 Notation: Repeats
304.1 Repeat signs

305 Adding repeat signs to your score
305.1 Simple repeats
305.2 Multiple ending repeats

306 Changing playback of repeat signs
307 Changing appearance of repeat signs
308 Repeat properties
309 Repeat style

309.1 Voltas
310 Adding voltas to your score
311 Changing appearance of voltas
312 Changing playback of voltas

312.1 Example of a complex Volta setting
313 Volta properties
314 Voltas style

314.1 Jumps and markers
315 Types of jumps and markers
316 Adding a jump or marker to your score
317 Changing appearance of jumps and markers
318 Changing playback of jumps and markers
319 Jump and marker properties
320 Jump and marker style

320.1 Measure and multi-measure repeats
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321 Adding a measure or multi-measure repeat to your score
322 Measure repeat properties
323 Measure repeat style

323.1 Repeat playback
324 Turning repeat playback on and off
325 Idiomatic notation: Keyboard

325.1 Pedal
326 Types of pedal markings
327 Adding pedal markings to your score
328 Creating pedal changes
329 Pedal properties
330 Pedal style

330.1 Cross-staff notation
331 Creating cross-staff notation
332 Changing appearance of cross-staff notation
333 See also

333.1 Accordion notation
334 Adding accordion symbols to your score
335 Idiomatic notation: Guitar

335.1 Fretboard diagrams
336 Adding a fretboard diagram to your score

336.1 Chord symbols linked to fretboard diagrams
337 Creating a custom fretboard diagram

337.1 Finger markers
337.2 Alternative notation styles

338 Fretboard diagram appearance
339 Fretboard diagram properties

339.1 General (tab)
339.2 Settings (tab)

340 Fretboard diagram style
341 See also

341.1 Guitar techniques
342 Adding a bend symbol to your score

342.1 Apply a bend
342.2 Edit a bend
342.3 Adjust bend height
342.4 Reposition bend

343 Adding a tremolo bar symbol to your score
344 Adding a slide to your score

344.1 Add a slide
344.2 Edit properties
344.3 Adjust start and end points of a slide

345 Adding a barre line to your score
346 Adding hammer-on and pull-off symbols to your score
347 Notating harmonics

347.1 Standard staff
347.2 Tablature
347.3 Staff/Tablature pairs

348 Notating guitar fingering
348.1 Creating a tablature staff

349 Overview
350 Types of tablature staves
351 Adding a tablature staff to your score

351.1 Add tablature using the New Score dialog
351.2 Add tablature using the "Add or remove Instruments" dialog
351.3 Change an existing staff from standard to tablature

352 Creating paired standard and tablature staves
352.1 Create paired standard/tab staves using the New Score Wizard
352.2 Create paired standard/tab staves using the Instruments dialog

353 Entering and editing tablature notation
354 Computer keyboard entry
355 Mouse entry
356 Selecting note duration
357 Period tablature notation
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358 Editing tablature notation
358.1 Changing the pitch
358.2 Moving the fretmark to a different string
358.3 Changing the duration
358.4 Crosshead/Ghost notes

359 Customizing a tablature staff
360 Changing tuning
361 Adding or removing strings

361.1 Add a string
361.2 Delete a string

362 Mark unfretted string “open”
363 Change number of instrument frets
364 Changing tablature staff type

364.1 Change staff type from Instruments panel
364.2 Change staff type from Staff/Part properties

365 Customizing appearance of tablature
365.1 Applying capos

366 Overview
367 Applying a capo to your score

367.1 To apply a capo to a staff:
368 Adjusting capo settings

368.1 Turning capo on or off
368.2 Setting capo position
368.3 Specifying partial capo placement
368.4 Customizing capo text appearance
368.5 To place the capo text beneath the staff:

369 Changing capo setting mid-score
370 Idiomatic notation: Harp
371 Overview
372 Adding a harp pedal diagram to your score

372.1 To apply a harp pedal diagram to a staff:
373 Reading harp pedal diagrams

373.1 Visual diagram
373.2 Text diagram

374 Idiomatic notation: Percussion
374.1 Entering and editing percussion notation

375 Overview
375.1 Types of percussion staves
375.2 Adding a percussion staff to your score

376 Entering notes and rests in percussion staves
376.1 Mouse entry using the Drum input palette
376.2 Using keyboard shortcuts
376.3 Using a MIDI controller
376.4 Using the on-screen piano keyboard

377 Drumset customization
378 Introduction
379 Customizing a drumset definition

379.1 Selecting a sound
379.2 Defining the note

379.2.1 Name
379.2.2 Noteheads
379.2.3 Other properties

380 Saving and loading drumset definitions
380.1 Other percussion notation

381 Diddles
382 Pedal lines
383 Rolls
384 Sticking
385 Alternative notation

385.1 Mensural notation and Mensurstrich
386 Adding a mensural time signature to your score
387 Using mensural note symbols
388 Working with non-metered music
389 Working with Mensurstrich
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389.1 Adding barlines between staves
390 Displaying note values across measure boundaries
391 See also

391.1 Slash notation
392 Filling a range with beat slashes
393 Creating rhythmic slash notation

393.1 Accompaniment rhythms on the staff
393.2 Accent rhythms above or below the staff

394 Custom staff types
395 Customizing appearance of staff lines
396 Customizing appearance of generated elements
397 Customizing appearance of notes
398 Changing staff type mid-score
399 Text

399.1 Entering and editing text
400 Overview
401 Adding text to your score

401.1 Add text from a palette
401.2 Add text from a menu
401.3 Add text using a shortcut

402 Deleting text objects from your score
403 Editing text

403.1 Keyboard shortcuts
403.2 Special characters

404 Types of text
404.1 Formatting text

405 Overview—levels of formatting
405.1 Text style
405.2 Text object properties
405.3 Character formatting
405.4 Formatting hierarchy

406 Applying text properties
406.1 Apply to a text object
406.2 Apply to characters

407 Setting style defaults
408 Selecting different text styles
409 Position

409.1 Staff and system text
410 Overview
411 Adding staff text to your score
412 Adding expression text to your score
413 Adding system text to your score
414 Repeating system text on other staves
415 Staff and system text properties
416 Staff and system text style

416.1 Tempo markings
417 Overview
418 Adding a tempo mark to your score

418.1 Using metronome markings
418.2 Using text markings

419 Changing appearance of tempo markings
420 Changing playback of tempo markings

420.1 Metronome marks
420.2 Tempo text
420.3 Metric modulations
420.4 Tempo change lines

421 Repeating tempo markings on other staves
422 Tempo properties
423 Tempo style

423.1 Lyrics
424 Overview
425 Adding lyrics to your score

425.1 Entering syllables
425.2 Entering a melisma
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425.3 Entering multiple verses
425.4 Entering lyrics onto rests
425.5 Special characters within lyrics

425.5.1 Elision slur
425.6 Escaping characters (that cannot be normally typed while entering Lyrics)

426 Editing existing lyrics
427 Delete lyrics
428 Entering lyrics above the staff
429 Changing verse number of lyrics
430 Copying lyrics

430.1 Copying lyrics within MuseScore
430.1.1 Copy to the same verse
430.1.2 Copy to a different verse

430.2 Copying lyrics to other programs
431 Lyrics properties
432 Lyrics style

432.1 Lyrics text
432.2 Lyrics dash
432.3 Lyrics melisma

433 Fingering
434 Types of fingering
435 Adding fingering to your score

435.1 Adding fingering from a palette
435.2 Adding fingering using a keyboard shortcut
435.3 Adding fingering using the menu

436 Adjusting position
437 Changing the appearance of fingering
438 Fingering properties
439 Fingering style
440 See also

440.1 Chord symbols
441 Overview
442 Adding chord symbols to your score

442.1 Entering a chord symbol
442.1.1 Chord names and accidentals
442.1.2 Navigation commands
442.1.3 Chord symbol syntax
442.1.4 Editing a chord symbol

442.2 Entering Roman numeral analysis
442.2.1 Enter RNA
442.2.2 Examples of RNA

442.3 Entering a Nashville number
443 Aligning chord symbols

443.1 Using the Style menu
443.2 Using the Properties panel

444 Transposition of chord symbols
444.1 Transposing instruments
444.2 Transpose dialog
444.3 Capo fret position

445 Changing Spelling of Chord Symbols
445.1 Chord Spelling Systems
445.2 Automatic Capitalization

446 Changing appearance of chord symbols
447 Changing Playback of Chord Symbols

447.1 Enabling and disabling playback
447.2 Customizing playback
447.3 Generating chord voicings onto a staff

448 Chord symbol properties
449 Chord symbol style

449.1 Appearance
449.2 Spelling
449.3 Positioning
449.4 Playback

450 Figured bass
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451 Overview
452 Adding figured bass to your score

452.1 Entering a figure
452.2 Text format

452.2.1 Digits
452.2.2 Accidentals
452.2.3 Combined shapes
452.2.4 Parentheses
452.2.5 Editing existing figured basses

452.3 Navigating by note, beat, or measure
452.4 Duration
452.5 Entering continuation lines

453 Figured bass properties
454 Figured bass style
455 Figured bass keyboard shortcuts

455.1 Rehearsal marks
456 Overview
457 Adding a rehearsal mark to your score

457.1 Manual placement and naming
457.2 Automatic placement and naming

458 Using measure numbers in rehearsal marks
459 Resequencing rehearsal marks
460 Finding rehearsal marks
461 Repeating rehearsal marks on other staves
462 Changing appearance of rehearsal marks
463 Rehearsal mark properties
464 Rehearsal mark style
465 External links

465.1 Header and footer
466 Overview
467 Adding a header or footer to your score
468 Using metadata
469 Changing how headers and footers are displayed
470 Header and footer properties
471 Header and footer style

471.1 Text blocks
472 Overview
473 Adding text blocks to your score
474 Changing the appearance of text blocks
475 Text block text properties
476 Text block text style
477 See also
478 Formatting

478.1 Page layout concepts
479 Definitions

479.1 Staff
479.2 Grand staff
479.3 System
479.4 Frame
479.5 Margin

480 Positioning of elements
481 Default position
482 Auto-place

482.1 Vertical collision avoidance
482.2 Horizontal collision avoidance
482.3 Vertical alignment
482.4 Disabling auto-place

483 Manual adjustment
484 Manual alignment

484.1 Score size and spacing
485 Page settings

485.1 Page and margin sizes
485.2 Staff size
485.3 Other settings
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485.4 Actions
486 Style settings

486.1 Horizontal spacing
486.2 Vertical spacing

486.2.1 Music margins
486.2.2 Distance between staves within systems
486.2.3 Distance between systems

487 Staff/part properties
487.1 Systems and horizontal spacing

488 Features
488.1 System breaks
488.2 Layout stretch
488.3 Horizontal frames
488.4 Keep measures on the same system

489 Tasks
489.1 Placing fewer measures on a system
489.2 Placing more measures on a system
489.3 Changing the relative spacing of measures within a system
489.4 Creating space between measures
489.5 Creating space at the beginning or end of a system
489.6 Adjusting the width of the final system
489.7 Grouping measures

490 Pages and vertical spacing
491 Features

491.1 Page breaks
491.2 Spacers
491.3 Vertical frames
491.4 System dividers

492 Tasks
492.1 Placing fewer systems on a page
492.2 Placing more systems on a page
492.3 Adjusting the spacing on sparse pages
492.4 Adjusting space between specific systems
492.5 Adjusting space between specific staves

493 Using frames for additional content
494 Overview
495 Uses of frames
496 Adding frames between or before/after systems

496.1 Text frames
496.1.1 Adding a text frame
496.1.2 Adding text

496.2 Vertical frames
496.2.1 Adding a vertical frame
496.2.2 Adding text
496.2.3 Adding an image
496.2.4 Size

496.3 Position and alignment of content
496.4 Spacing

497 Adding frames between measures
497.1 Horizontal frames

497.1.1 Adding a horizontal frame
497.1.2 Adding text
497.1.3 Adding an image
497.1.4 Size
497.1.5 Spacing
497.1.6 Other horizontal frame properties

498 See also
498.1 Working with images

499 Adding images
499.1 Frames
499.2 Other elements

500 Image properties
500.1 Using sections for multiple movements or songs

501 Overview
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501.1 Features
501.2 Time and key signatures

502 Adding section breaks
503 Section break properties

503.1 Pause
503.2 Instrument names
503.3 Bar numbers

504 Sound and playback
504.1 Playback controls

505 Overview
506 Playback commands

506.1 Start/stop
506.1.1 To play back all the instrument parts
506.1.2 To play back selected instrument parts only
506.1.3 To stop playback

506.2 Rewind
506.3 Loop
506.4 Metronome
506.5 Play position and tempo

507 Other commands
507.1 Enable MIDI input
507.2 Play repeats
507.3 Play chord symbols
507.4 Pan score automatically

508 Mixer
509 Overview
510 Opening the mixer
511 Mixer controls
512 Sound
513 Audio FX

513.1 To add an Audio FX plugin
513.2 To disable an Audio FX plugin
513.3 To remove an Audio FX plugin
513.4 Muse Reverb

514 Aux sends
514.1 To show/hide an Aux send row (slot)
514.2 To disable an Aux send row (slot)

515 Aux channels
515.1 To show/hide Aux channels
515.2 To add Audio FX to an Aux channel
515.3 To adjust an Aux channel's level
515.4 To apply the effect(s) of an Aux channel to an instrument

516 See also
517 SoundFonts
518 Install a SoundFont

518.1 Drag and drop installation
518.2 File directory installation

519 Uninstall a SoundFont
520 Selecting sounds with a SoundFont
521 Editing Soundfonts
522 A note on the Zerberus player and SFZs
523 See also

523.1 Installing Muse Sounds
524 Installation via Muse Hub
525 Using Muse Sounds in MuseScore
526 Available sounds in Muse Sounds

526.1 Choir
526.2 Strings
526.3 Woodwinds
526.4 Brass
526.5 Percussion
526.6 Keys
526.7 Harp

527 Capo playback (MS 4.0.2 and before)
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528 Adding a capo marking to your score (before MuseScore 4.1)
528.1 Adding a capo to a single staff
528.2 Adding a capo to a staff / tablature pair

529 See also
529.1 Swing playback

530 Overview
531 Adding a swing or straight marking to your score

531.1 To add a swing marking
531.2 To add a straight marking

532 Changing swing playback
532.1 Adjust the type and degree of swing
532.2 Apply swing to one staff only

533 Working with MIDI
534 Working with VST and VSTi
535 Introduction to VST
536 Installing VSTs
537 Enabling, disabling, removing and replacing VST plugins

537.1 See also
538 File management

538.1 Opening and saving scores
539 Overview
540 Opening a score

540.1 File → Open
540.2 File → Open recent
540.3 Home tab → Scores

541 Import file formats
542 Saving a score

542.1 Save to computer
542.2 Save to the cloud

542.2.1 Name
542.2.2 Visibility
542.2.3 Never
542.2.4 Always
542.2.5 Every x saves

543 File export
544 Overview
545 Exporting your score
546 File formats

546.1 Graphical formats
546.2 Audio formats
546.3 MIDI format
546.4 Score formats
546.5 Customizing export settings

547 MIDI import
548 Working with MusicXML files
549 Overview
550 Cleaning up an imported score
551 Preparing a score for export

551.1 Backup and recovered files
551.2 Project properties

552 Overview
553 Changing score properties
554 Adding new properties
555 Accessing project properties in your score

555.1 Metatags for parts
555.2 Score comparison
555.3 Publish to musescore.com

556 Overview
557 Creating a MuseScore account
558 Saving only to Musescore.com
559 Publish locally saved scores
560 Visibility in score manager
561 Manage generation of mp3 during upload

https://musescore.org/en/print/book/export/html/329209?toc=1#File_%E2%86%92_Open
https://musescore.org/en/print/book/export/html/329209?toc=1#File_%E2%86%92_Open_recent
https://musescore.org/en/print/book/export/html/329209?toc=1#Home_tab_%E2%86%92_Scores
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561.1 Never
561.2 Always
561.3 Every x saves

562 Share on Audio.com
563 Overview

563.1 To share audio from your score on Audio.com:
564 Customization

564.1 Language
565 Overview

565.1 Change language
565.1.1 Update translations

565.2 See also
566 Appearance
567 Overview
568 Theme and Colors
569 Fonts

569.1 Toolbars and windows
570 Overview
571 Toolbars

571.1 Showing and hiding toolbars
571.2 Rearranging toolbars
571.3 Customizing contents of toolbars

572 Windows and Panels
572.1 Docking and undocking panels
572.2 Customizing contents of panels

573 Templates and styles
574 Overview

574.1 Templates
574.2 Style files

575 Templates
575.1 Saving your score as a template
575.2 Creating a score from your template

576 Style files
576.1 Saving style settings for your score to a file
576.2 Loading style settings into your score from a file
576.3 Setting a default style for your score

577 Palettes
578 Adding palettes
579 Hiding and deleting palettes
580 Changing the order of palettes
581 Customizing palette contents

581.1 Adding elements from the Master Palette window
581.2 Adding elements from an opened score
581.3 Moving elements between palettes
581.4 Deleting elements from palettes
581.5 Resetting a palette

582 Saving and loading palettes
583 Palettes menu
584 Palette properties
585 See also

585.1 Workspaces
586 Overview
587 Creating a new workspace
588 Deleting a workspace
589 Switching between workspaces

589.1 Keyboard shortcuts
590 Overview
591 Defining a shortcut
592 Resetting and clearing shortcuts

592.1 To reset a shortcut to its default:
592.2 To clear (i.e. delete) a shortcut:

593 Importing and exporting shortcuts
593.1 Preferences

594 General
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595 Appearance
596 Canvas
597 Note input
598 MIDI device mapping
599 Score
600 I/O
601 Import
602 Shortcuts
603 Update
604 Advanced

604.1 Plugins
605 Overview

605.1 Installing a new plugin
605.1.1 Updating existing plugins

605.2 Enabling and disabling plugins
606 Running a plugin
607 Pre-installed plugins
608 See also
609 Support

609.1 Getting help
610 Overview
611 Learn
612 Forums
613 Issue tracker
614 GitHub
615 Mastering MuseScore

615.1 Revert to factory settings
616 Overview
617 Reverting to factory settings from the menu
618 Reverting to factory settings from the command line

618.1 Windows
618.2 macOS
618.3 Linux

619 Troubleshooting
620 Installation issues
621 Score issues
622 Display issues
623 Sound issues
624 Printing issues

624.1 Known incompatibilities
625 Appendix

625.1 Command line usage
625.1.1 NAME
625.1.2 SYNOPSIS
625.1.3 DESCRIPTION
625.1.4 Batch conversion job JSON format
625.1.5 ENVIRONMENT
625.1.6 FILES
625.1.7 EXAMPLES

625.1.7.1 Convert a score to PDF from the command line
625.1.7.2 Run a batch job converting multiple documents
625.1.7.3 MIDI import operations

625.1.8 DIAGNOSTICS
625.1.9 SEE ALSO
625.1.10 STANDARDS
625.1.11 HISTORY
625.1.12 AUTHORS
625.1.13 CAVEATS
625.1.14 BUGS

625.2 All keyboard shortcuts
626 Keyboard Map
627 Navigation

627.1 Page navigation
627.2 Score navigation
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628 Note input
628.1 General
628.2 Duration
628.3 Pitch
628.4 Tablature

629 Selecting
630 Editing

630.1 General
630.2 Duration
630.3 Pitch
630.4 Notation
630.5 Manual adjustment

631 Text
631.1 General
631.2 Formatting
631.3 Lyrics
631.4 Chord symbols, Roman numeral analysis, Nashville numbers, figured bass

632 Other score elements
633 Score setup and formatting
634 File Operations
635 User interface

635.1 Playback
635.2 Accessibility
635.3 Other

636 Known incompatibilities
637 Upgrade from MuseScore 3.x
638 Overview
639 Keyboard Shortcuts
640 Other changes
641 Missing Features

641.1 Upgrade from MuseScore 2.x or 1.x
641.2 Handbook for MuseScore 3.x
641.3 Handbook for MuseScore 2.x
641.4 Handbook for MuseScore 1.x
641.5 Glossary

641.5.1 A
641.5.2 B
641.5.3 C
641.5.4 D
641.5.5 E
641.5.6 F
641.5.7 G
641.5.8 H
641.5.9 I
641.5.10 J
641.5.11 K
641.5.12 L
641.5.13 M
641.5.14 N
641.5.15 O
641.5.16 P
641.5.17 Q
641.5.18 R
641.5.19 S
641.5.20 T
641.5.21 U
641.5.22 V
641.5.23 W
641.5.24 External links

641.6 Full Table of Contents
642 Editing the Handbook
643 Introduction to MuseScore

643.1 Download and installation
643.1.1 Windows
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643.1.2 macOS
643.1.3 Linux

643.2 New features in MuseScore 4
643.2.1 New user interface
643.2.2 Instruments and parts
643.2.3 Inspector
643.2.4 New playback and VSTi support
643.2.5 Engraving improvements
643.2.6 Cloud storage
643.2.7 Other changes

643.3 Create your first score
643.3.1 Entering score information
643.3.2 Entering notes
643.3.3 Adding items from the palettes
643.3.4 Making adjustments in Properties
643.3.5 Inserting and deleting measures
643.3.6 Exporting your score
643.3.7 Saving your score

644 Viewing and navigation
644.1 Accessibility

644.1.1 Setup
644.1.2 Working with the user interface
644.1.3 Working with your score

644.2 The user interface
644.2.1 Menu bar
644.2.2 Home tab
644.2.3 Score tab
644.2.4 Publish tab

644.3 Navigating your score
644.3.1 Scrolling
644.3.2 Element navigation
644.3.3 Navigator
644.3.4 Timeline
644.3.5 Views
644.3.6 Zoom
644.3.7 Find/Go to

644.4 Timeline
644.4.1 Overview
644.4.2 Meta elements
644.4.3 Basic interactions
644.4.4 Scrolling
644.4.5 Labels interaction
644.4.6 Zooming
644.4.7 Context menus

645 Basics
645.1 Setting up your score

645.1.1 Overview
645.1.2 Instruments
645.1.3 Additional score information
645.1.4 Changing instruments after score creation

645.2 Entering notes and rests
645.2.1 Overview
645.2.2 Entering notes
645.2.3 Entering chords
645.2.4 Entering rests
645.2.5 Accidentals
645.2.6 Ties
645.2.7 See also

645.3 Working with multiple voices
645.3.1 Overview
645.3.2 Entering notes and rests in multiple voices
645.3.3 Editing notes and rests in multiple voices
645.3.4 See also

645.4 Alternative note input methods



14/09/2023, 18:51Handbook for MuseScore 4

Page 24 of 270https://musescore.org/en/print/book/export/html/329209?toc=1

645.4.1 Accessing alternative note input methods
645.4.2 Rhythm only
645.4.3 Re-pitch
645.4.4 Real-time
645.4.5 Insert

645.5 Adding and removing measures
645.5.1 Inserting measures
645.5.2 Deleting measures
645.5.3 See also

645.6 Selecting elements
645.6.1 Selecting a single element
645.6.2 Selecting a list of individual elements
645.6.3 Selecting a range of measures and staves
645.6.4 Excluding elements from a range selection

645.7 Editing notes and rests
645.7.1 Overview
645.7.2 Making changes in note input mode
645.7.3 Making changes in normal mode
645.7.4 See also

645.8 Copy and paste
645.8.1 Accessing the commands
645.8.2 Copying a range
645.8.3 Copying a single element or list of elements
645.8.4 Moving elements
645.8.5 Swapping a selection with the clipboard
645.8.6 Repeating a selection
645.8.7 Copying a selection to multiple staves
645.8.8 Paste half/double duration
645.8.9 Duplicating individual elements
645.8.10 See also

645.9 Using the palettes
645.9.1 Overview
645.9.2 Accessing the palettes panel
645.9.3 Adding palette items to your score
645.9.4 Expanding and collapsing palettes
645.9.5 Searching and navigating the palettes
645.9.6 Accessing more palette items
645.9.7 Adding more palettes
645.9.8 See also

645.10 Properties panel
645.10.1 Accessing the Properties panel
645.10.2 Global settings
645.10.3 General settings
645.10.4 Playback settings
645.10.5 Appearance settings
645.10.6 Saving and restoring default settings

645.11 Adjusting elements directly
645.11.1 Changing the position of elements
645.11.2 Changing the shape of elements
645.11.3 Working with lines
645.11.4 See also

645.12 Parts
645.12.1 Opening a part
645.12.2 Closing a part
645.12.3 Creating custom parts
645.12.4 Applying styles to parts
645.12.5 Renaming, duplicating and deleting parts
645.12.6 Exporting and printing parts

645.13 Default keyboard shortcuts
645.13.1 Navigation
645.13.2 Note input
645.13.3 Selecting
645.13.4 Editing
645.13.5 Text
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645.13.6 Other score elements
645.13.7 Score setup and formatting
645.13.8 File Operations
645.13.9 User interface

646 Notation: Instruments, staves, and systems
646.1 Working with instruments

646.1.1 Overview
646.1.2 Instrument settings
646.1.3 Adding and configuring staves

646.2 Showing staves only where needed
646.2.1 Hiding empty staves
646.2.2 Temporary staves
646.2.3 Cutaway staves
646.2.4 Ossia
646.2.5 Other invisible measures

646.3 Implode and explode
646.3.1 Implode
646.3.2 Explode

646.4 Mid-score instrument changes
646.4.1 Adding an instrument change
646.4.2 Working with instrument changes

646.5 Staff type change
646.5.1 Adding a staff type change
646.5.2 Setting staff properties

646.6 Staff/Part properties
646.6.1 Overview
646.6.2 Staff properties
646.6.3 Advanced style properties
646.6.4 Part properties

646.7 Brackets
646.7.1 Adding brackets
646.7.2 Editing brackets
646.7.3 Deleting brackets
646.7.4 Customizing bracket appearance

647 Notation: Rhythm, meter, and measures
647.1 Time signatures

647.1.1 Overview
647.1.2 Setting the initial time signature for your score
647.1.3 Adding a time signature change to your score
647.1.4 Deleting a time signature
647.1.5 Controlling the visibility of time signatures
647.1.6 Creating a custom time signature
647.1.7 Adding a local time signature for a single staff
647.1.8 Time signature properties
647.1.9 Time signature style

647.2 Stems and flags
647.2.1 Stem direction
647.2.2 Changing stem length
647.2.3 Creating stemless notes
647.2.4 Stem and flag properties
647.2.5 Stem and flag style
647.2.6 See also

647.3 Beams
647.3.1 Controlling which notes are beamed
647.3.2 Controlling the appearance of beams
647.3.3 Beam properties
647.3.4 Beam style

647.4 Regroup rhythms
647.4.1 Overview
647.4.2 Regrouping rhythms
647.4.3 See also

647.5 Tuplets
647.5.1 Creating tuplets
647.5.2 Changing the display of tuplets
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647.5.3 Tuplet properties
647.5.4 Tuplet style

647.6 Barlines
647.6.1 Adding double and other special barlines
647.6.2 Changing barline length
647.6.3 Barline properties
647.6.4 Barline style
647.6.5 See also

647.7 Measure numbering
647.7.1 Showing and hiding measure numbers
647.7.2 Changing the measure number sequence
647.7.3 Changing the position of measure numbers
647.7.4 Measure number properties
647.7.5 Measure number style
647.7.6 See also

647.8 Measure rests and multimeasure rests
647.8.1 Measure rest
647.8.2 Multimeasure rest
647.8.3 See also

647.9 Pickup and non-metered measures
647.9.1 Creating a pickup measure
647.9.2 Creating non-metered measures
647.9.3 See also

647.10 Measure properties
647.10.1 Opening and using the dialog
647.10.2 Staves
647.10.3 Measure duration
647.10.4 Other
647.10.5 See also

648 Notation: Pitch
648.1 Clefs

648.1.1 Setting the initial clef for a staff
648.1.2 Adding or changing a clef
648.1.3 Delete
648.1.4 Controlling the visibility of clefs
648.1.5 Clefs and transposition
648.1.6 Clef properties
648.1.7 Clef style

648.2 Key signatures
648.2.1 Overview
648.2.2 Setting the initial key signature for your score
648.2.3 Adding a key signature change to your score
648.2.4 Adding a local key signature for a single staff
648.2.5 Selecting a key signature for a single staff
648.2.6 Replacing an existing key signature
648.2.7 Deleting a key signature
648.2.8 Controlling the visibility of key signatures
648.2.9 Key signatures and transposing instruments
648.2.10 Creating a custom key signature
648.2.11 Key signature properties
648.2.12 Key signature style
648.2.13 See also

648.3 Transposition
648.3.1 Overview
648.3.2 Transposing with keyboard shortcuts
648.3.3 Using the transpose dialog
648.3.4 Working with transposing instruments

648.4 Octave lines
648.4.1 Overview
648.4.2 Adding an octave line to your score
648.4.3 Octave line properties
648.4.4 Octave line style

648.5 Noteheads
648.5.1 Changing notehead direction
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648.5.2 Changing notehead shape
648.5.3 Sharing noteheads between voices
648.5.4 Alternative notehead systems
648.5.5 Adding pitch and velocity information to notes
648.5.6 Notehead properties

648.6 Ambitus
648.6.1 Adding an ambitus to your score
648.6.2 Changing the range of an ambitus
648.6.3 Ambitus properties

648.7 Respell pitches
648.7.1 Manually changing the enharmonic spelling of notes
648.7.2 Automatically respelling all notes in a selection

649 Notation: Expressive markings
649.1 Articulations

649.1.1 Adding articulations to your score
649.1.2 Articulations playback
649.1.3 Articulation properties
649.1.4 Articulation style

649.2 Dynamics
649.2.1 Adding dynamics to your score
649.2.2 Changing playback of dynamics
649.2.3 Dynamics properties
649.2.4 Dynamics style

649.3 Hairpins
649.3.1 Types of hairpin
649.3.2 Adding a hairpin to your score
649.3.3 Changing appearance of hairpins
649.3.4 Changing playback of hairpins
649.3.5 Hairpin properties
649.3.6 Hairpin style

649.4 Slurs
649.4.1 Adding a slur to your score
649.4.2 Multi-voice and cross-staff slurs
649.4.3 Changing appearance of slurs
649.4.4 Slur properties
649.4.5 Slur style

649.5 Breaths and pauses
649.5.1 Types of pauses
649.5.2 Adding a pause to your score
649.5.3 Changing pause playback
649.5.4 Pause properties
649.5.5 Pause style

649.6 Ornaments
649.6.1 Adding an ornament to your score
649.6.2 Adding accidentals to ornaments
649.6.3 Ornament properties
649.6.4 Ornament style

649.7 Arpeggios and glissandi
649.7.1 Arpeggios
649.7.2 Glissandi
649.7.3 Bends

649.8 Grace notes
649.8.1 Types of grace notes
649.8.2 Adding a grace note to your score
649.8.3 Multiple grace notes
649.8.4 Editing grace notes
649.8.5 Changing playback of grace notes
649.8.6 Grace note style

649.9 Tremolo and rolls
649.9.1 Types of tremolo and rolls
649.9.2 Adding a tremolo to a single note
649.9.3 Adding a tremolo between notes/chords
649.9.4 Changing appearance of tremolos

649.10 Other lines
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649.10.1 Overview
649.10.2 Adding a line to your score
649.10.3 Adjusting a line
649.10.4 Types of lines
649.10.5 Line properties
649.10.6 Line style

649.11 Other symbols
649.11.1 The Symbols palette
649.11.2 Adding symbols to your score

650 Notation: Repeats
650.1 Repeat signs

650.1.1 Adding repeat signs to your score
650.1.2 Changing playback of repeat signs
650.1.3 Changing appearance of repeat signs
650.1.4 Repeat properties
650.1.5 Repeat style

650.2 Voltas
650.2.1 Adding voltas to your score
650.2.2 Changing appearance of voltas
650.2.3 Changing playback of voltas
650.2.4 Volta properties
650.2.5 Voltas style

650.3 Jumps and markers
650.3.1 Types of jumps and markers
650.3.2 Adding a jump or marker to your score
650.3.3 Changing appearance of jumps and markers
650.3.4 Changing playback of jumps and markers
650.3.5 Jump and marker properties
650.3.6 Jump and marker style

650.4 Measure and multi-measure repeats
650.4.1 Adding a measure or multi-measure repeat to your score
650.4.2 Measure repeat properties
650.4.3 Measure repeat style

650.5 Repeat playback
650.5.1 Turning repeat playback on and off
650.5.2 Unrolling repeats

651 Idiomatic notation: Keyboard
651.1 Pedal

651.1.1 Types of pedal markings
651.1.2 Adding pedal markings to your score
651.1.3 Creating pedal changes
651.1.4 Pedal properties
651.1.5 Pedal style

651.2 Cross-staff notation
651.2.1 Creating cross-staff notation
651.2.2 Changing appearance of cross-staff notation

651.3 Accordion notation
651.3.1 Adding accordion symbols to your score

652 Idiomatic notation: Guitar
652.1 Fretboard diagrams

652.1.1 Adding a fretboard diagram to your score
652.1.2 Creating a custom fretboard diagram
652.1.3 Fretboard diagram appearance
652.1.4 Fretboard diagram properties
652.1.5 Fretboard diagram style
652.1.6 See also

652.2 Guitar techniques
652.2.1 Adding a bend symbol to your score
652.2.2 Adding a tremolo bar symbol to your score
652.2.3 Adding a slide to your score
652.2.4 Adding a barre line to your score
652.2.5 Adding hammer-on and pull-off symbols to your score
652.2.6 Notating harmonics
652.2.7 Notating guitar fingering
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652.3 Creating a tablature staff
652.3.1 Overview
652.3.2 Types of tablature staves
652.3.3 Adding a tablature staff to your score
652.3.4 Creating paired standard and tablature staves

652.4 Entering and editing tablature notation
652.4.1 Computer keyboard entry
652.4.2 Mouse entry
652.4.3 Selecting note duration
652.4.4 Period tablature notation
652.4.5 Editing tablature notation

652.5 Customizing a tablature staff
652.5.1 Changing tuning
652.5.2 Adding or removing strings
652.5.3 Mark unfretted string “open”
652.5.4 Change number of instrument frets
652.5.5 Changing tablature staff type
652.5.6 Customizing appearance of tablature

653 Idiomatic notation: Percussion
653.1 Entering and editing percussion notation

653.1.1 Overview
653.1.2 Entering notes and rests in percussion staves

653.2 Drumset customization
653.2.1 Introduction
653.2.2 Customizing a drumset definition
653.2.3 Saving and loading drumset definitions

653.3 Other percussion notation
653.3.1 Diddles
653.3.2 Pedal lines
653.3.3 Rolls
653.3.4 Sticking

654 Alternative notation
654.1 Mensural notation and Mensurstrich

654.1.1 Adding a mensural time signature to your score
654.1.2 Using mensural note symbols
654.1.3 Working with non-metered music
654.1.4 Working with Mensurstrich
654.1.5 Displaying note values across measure boundaries
654.1.6 See also

654.2 Slash notation
654.2.1 Filling a range with beat slashes
654.2.2 Creating rhythmic slash notation

654.3 Custom staff types
654.3.1 Customizing appearance of staff lines
654.3.2 Customizing appearance of generated elements
654.3.3 Customizing appearance of notes
654.3.4 Changing staff type mid-score

655 Text
655.1 Entering and editing text

655.1.1 Overview
655.1.2 Adding text to your score
655.1.3 Editing text
655.1.4 Types of text

655.2 Formatting text
655.2.1 Overview—levels of formatting
655.2.2 Applying text properties
655.2.3 Setting style defaults
655.2.4 Selecting different text styles
655.2.5 Position

655.3 Staff and system text
655.3.1 Overview
655.3.2 Adding staff text to your score
655.3.3 Adding expression text to your score
655.3.4 Adding system text to your score

https://musescore.org/en/print/book/export/html/329209?toc=1#Mark_unfretted_string_%E2%80%9Copen%E2%80%9D
https://musescore.org/en/print/book/export/html/329209?toc=1#Overview%E2%80%94levels_of_formatting
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655.3.5 Repeating system text on other staves
655.3.6 Staff and system text properties
655.3.7 Staff and system text style

655.4 Tempo markings
655.4.1 Overview
655.4.2 Adding a tempo mark to your score
655.4.3 Changing appearance of tempo markings
655.4.4 Changing playback of tempo markings
655.4.5 Repeating tempo markings on other staves
655.4.6 Tempo properties
655.4.7 Tempo style

655.5 Lyrics
655.5.1 Overview
655.5.2 Adding lyrics to your score
655.5.3 Editing existing lyrics
655.5.4 Delete lyrics
655.5.5 Entering lyrics above the staff
655.5.6 Changing verse number of lyrics
655.5.7 Copying lyrics
655.5.8 Lyrics properties
655.5.9 Lyrics style

655.6 Fingering
655.6.1 Types of fingering
655.6.2 Adding fingering to your score
655.6.3 Adjusting position
655.6.4 Changing the appearance of fingering
655.6.5 Fingering properties
655.6.6 Fingering style
655.6.7 See also

655.7 Chord symbols
655.7.1 Overview
655.7.2 Adding chord symbols to your score
655.7.3 Aligning chord symbols
655.7.4 Transposition of chord symbols
655.7.5 Changing Spelling of Chord Symbols
655.7.6 Changing appearance of chord symbols
655.7.7 Changing Playback of Chord Symbols
655.7.8 Chord symbol properties
655.7.9 Chord symbol style

655.8 Figured bass
655.8.1 Overview
655.8.2 Adding figured bass to your score
655.8.3 Figured bass properties
655.8.4 Figured bass style
655.8.5 Figured bass keyboard shortcuts

655.9 Rehearsal marks
655.9.1 Overview
655.9.2 Adding a rehearsal mark to your score
655.9.3 Using measure numbers in rehearsal marks
655.9.4 Resequencing rehearsal marks
655.9.5 Finding rehearsal marks
655.9.6 Repeating rehearsal marks on other staves
655.9.7 Changing appearance of rehearsal marks
655.9.8 Rehearsal mark properties
655.9.9 Rehearsal mark style
655.9.10 External links

655.10 Header and footer
655.10.1 Overview
655.10.2 Adding a header or footer to your score
655.10.3 Using metadata
655.10.4 Changing how headers and footers are displayed
655.10.5 Header and footer properties
655.10.6 Header and footer style

655.11 Text blocks
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655.11.1 Overview
655.11.2 Adding text blocks to your score
655.11.3 Changing the appearance of text blocks
655.11.4 Text block text properties
655.11.5 Text block text style

656 Formatting
656.1 Page layout concepts

656.1.1 Definitions
656.2 Positioning of elements

656.2.1 Default position
656.2.2 Auto-place
656.2.3 Manual adjustment
656.2.4 Manual alignment

656.3 Score size and spacing
656.3.1 Page settings
656.3.2 Style settings
656.3.3 Staff/part properties

656.4 Systems and horizontal spacing
656.4.1 Features
656.4.2 Tasks

656.5 Pages and vertical spacing
656.5.1 Features
656.5.2 Tasks

656.6 Using frames for additional content
656.6.1 Adding frames between or before/after systems
656.6.2 Adding frames between measures
656.6.3 See also

656.7 Working with images
656.7.1 Adding images
656.7.2 Image properties

656.8 Using sections for multiple movements or songs
656.8.1 Overview
656.8.2 Adding section breaks
656.8.3 Section break properties

657 Sound and playback
657.1 Playback controls

657.1.1 Overview
657.1.2 Playback commands
657.1.3 Other commands

657.2 Mixer
657.2.1 Opening the mixer
657.2.2 Mixer controls
657.2.3 Audio FX and sounds
657.2.4 See also

657.3 SoundFonts
657.3.1 Install a SoundFont
657.3.2 Uninstall a SoundFont
657.3.3 A note on the Zerberus player and SFZs

657.4 Installing Muse Sounds
657.4.1 Installation via Muse Hub
657.4.2 Using Muse Sounds in MuseScore
657.4.3 Available sounds in Muse Sounds

657.5 Piano roll editor
657.6 Capo playback

657.6.1 Overview
657.6.2 Adding a capo marking to your score
657.6.3 See also

657.7 Swing playback
657.7.1 Overview
657.7.2 Adding a swing or straight marking to your score
657.7.3 Changing swing playback

657.8 Working with MIDI
657.9 Working with VSTi

657.9.1 Introduction to VSTi Plugins
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657.9.2 Enabling, disabling, removing and replacing VST plugins
658 File management

658.1 Opening and saving scores
658.1.1 Overview
658.1.2 Opening a score
658.1.3 Import file formats
658.1.4 Saving a score

658.2 File export
658.2.1 Overview
658.2.2 Exporting your score
658.2.3 File formats

658.3 MIDI import
658.4 Working with MusicXML files

658.4.1 Overview
658.4.2 Cleaning up an imported score
658.4.3 Preparing a score for export

658.5 Backup and recovered files
658.6 Project properties

658.6.1 Overview
658.6.2 Changing score properties
658.6.3 Adding new properties
658.6.4 Accessing project properties in your score

658.7 Score comparison
658.8 Publish to musescore.com

658.8.1 Overview
658.8.2 Creating a MuseScore account
658.8.3 Saving only to Musescore.com
658.8.4 Publish locally saved scores
658.8.5 Visibility in score manager

659 Customization
659.1 Language

659.1.1 Overview
659.2 Appearance

659.2.1 Overview
659.2.2 Theme and Colors
659.2.3 Fonts

659.3 Toolbars and windows
659.3.1 Overview
659.3.2 Toolbars
659.3.3 Windows and Panels

659.4 Templates and styles
659.4.1 Overview
659.4.2 Templates
659.4.3 Style files

659.5 Palettes
659.5.1 Adding palettes
659.5.2 Hiding and deleting palettes
659.5.3 Changing the order of palettes
659.5.4 Customizing palette contents
659.5.5 Saving and loading palettes
659.5.6 Palettes menu
659.5.7 Palette properties

659.6 Workspaces
659.6.1 Overview
659.6.2 Creating a new workspace
659.6.3 Deleting a workspace
659.6.4 Switching between workspaces
659.6.5 Changing workspace settings
659.6.6 Sharing workspaces

659.7 Keyboard shortcuts
659.7.1 Overview
659.7.2 Defining a shortcut
659.7.3 Resetting and clearing shortcuts
659.7.4 Importing and exporting shortcuts
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659.8 Preferences
659.8.1 General
659.8.2 Appearance
659.8.3 Canvas
659.8.4 Note input
659.8.5 MIDI device mapping
659.8.6 Score
659.8.7 I/O
659.8.8 Import
659.8.9 Shortcuts
659.8.10 Update
659.8.11 Advanced

659.9 Plugins
659.9.1 Overview
659.9.2 Managing plugins
659.9.3 Running a plugin
659.9.4 Pre-installed plugins

660 Support
660.1 Getting help

660.1.1 Overview
660.1.2 Learn
660.1.3 Forums
660.1.4 Issue tracker
660.1.5 GitHub
660.1.6 Mastering MuseScore

660.2 Revert to factory settings
660.2.1 Overview
660.2.2 Reverting to factory settings from the menu
660.2.3 Reverting to factory settings from the command line

660.3 Troubleshooting
660.3.1 Installation issues
660.3.2 Score issues
660.3.3 Display issues
660.3.4 Sound issues
660.3.5 Printing issues

660.4 Known incompatibilities
661 Appendix

661.1 Command line usage
661.2 All keyboard shortcuts

661.2.1 Keyboard Map
661.2.2 Navigation
661.2.3 Note input
661.2.4 Selecting
661.2.5 Editing
661.2.6 Text
661.2.7 Other score elements
661.2.8 Score setup and formatting
661.2.9 File Operations
661.2.10 User interface

661.3 Known incompatibilities
661.4 Upgrade from MuseScore 3.x
661.5 Upgrade from MuseScore 2.x or 1.x
661.6 Handbook for MuseScore 3.x
661.7 Handbook for MuseScore 2.x
661.8 Handbook for MuseScore 1.x
661.9 Glossary

Handbook for MuseScore 4
About the Handbook
This handbook is valid for MuseScore version 4.0 and above. If you are using a different version of the program, please consult the appropriate
handbook for your version:
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MuseScore 3 Handbook
MuseScore 2 Handbook
MuseScore 1 Handbook

This handbook is maintained and translated by the MuseScore community. Contributions and Help with translations  are welcome! In case of doubt,
please consult the English version of this handbook , or ask for help in the Support Forum .

If you are upgrading from MuseScore 3, you may find the following pages useful:

Upgrade from MuseScore 3.x (includes a list of keyboard shortcuts that have changed)
MuseScore 3 features not (yet) implemented in MuseScore 4

Exploring the Handbook
Use the chapter links below to explore content in each chapter of the handbook.

To search for information:

Try browsing the illustrated Glossary for notations you are incapable of naming.
Open "Full Table of Contents", use "Find in page (Ctrl/Cmd⌘ + F)" function of your web browser, or
Use this Google search syntax site:musescore.org your topic, e.g. site:musescore.org tempo , or
Use the search function as shown on the screenshot below

If you can't find the information you need in the Handbook, please ask for help in the Support Forum .

Download the handbook and create a PDF
Use this link to view a printer-friendly version of the handbook, then use your browser's Print facility to turn that page into a PDF for offline viewing.

Chapter links and table of contents
Full Table of Contents

Editing the Handbook

Guidelines for writing articles
So you'd like to contribute to the MuseScore 4 handbook – great! We're so happy you're here.

This page contains brief guidelines to get you started with writing articles. Please read this page carefully before editing anything in our handbook. This
information is intended to help, but if you're in doubt about anything or have any questions, please join the discussion on the Documentation  forum.

Structure - General principles
Each page should explain a single topic more or less completely. If a page feels like it is getting too long, try splitting it into separate pages.

Not every page is identical, but keeping the following in mind can help you structure your page content in a way that's easy to understand for the reader:

Start with an overview

Starting your page with an overview can help introduce a topic before launching into details. Overviews don't usually need a section heading.

Establish a hierarchy

Think about what most users will be trying to achieve, and why they might be coming to the handbook to look for information. Put solutions for the most
common tasks towards the top of the page; less commonly needed information can go towards the bottom.

Group information logically

Related concepts should be discussed together. This may sometimes require less-commonly-used features to be discussed alongside more-commonly
used ones, but that's okay.

https://musescore.org/en/node/278561
https://musescore.org/en/node/35711
https://musescore.org/en/node/51
https://musescore.org/en/node/49
https://musescore.org/en/handbook/4
https://musescore.org/en/forum/6
https://musescore.org/en/node/334701
https://www.google.com/search?q=site%3Amusescore.org+tempo
https://musescore.org/en/forum/6
https://musescore.org/en/print/book/export/html/329209?toc=1#undefined-undefined
https://musescore.org/en/forum/8
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Focus on user tasks, not just UI components

For instance, a section about "Creating custom key signatures" is better than a section called "Using the master palette".

Create a table of contents

Please be sure to enable the "Generate a table of contents" option for all Handbook pages.

Headings
In an effort to ensure consistency of style for community-written pages, we have already provided headings on many pages. Please organize your
content within this structure. For pages that lack headings, feel free to create your own in a style similar to that used elsewhere.

For accessibility reasons, headings should never be formatted in regular bold text. All headings need to be formatted as tags with semantic meaning.

All pages start by default with a Heading 1. The first section heading you will enter will therefore always be a Heading 2. Please also don’t skip heading
levels (By, for example, adding a heading 4 after a heading 2).

Heading level Usage and MarkDown syntax
Heading 1 Default for all page headings (Not editable by contributors)
Heading 2 Use for the start of every section. MarkDown syntax: ## Heading name

Heading 3
Use for the start of every sub-section, and to introduce single-step
instructions (I.e. where a list is not necessary). MarkDown syntax: ###
Heading name

Heading 4 Use sparingly if additional sub-sections are required. MarkDown syntax:
#### Heading name

Lastly, try to always start your headings with a verb. E.g. "Adding time signatures", rather than "Time signatures"

Content
The MuseScore handbook broadly contains two main types of information: descriptive material, and goal-oriented instructions.

Descriptive material

This is used to explain different areas of the program. For example,

A Palette is a folder containing musical symbols which can be applied to the score. MuseScore's default palettes contain collections of related symbols,
but you can customize palettes to display almost any kind of symbol, line or text.

Descriptive material tends to be longer and more “fleshed out” than goal-oriented instructions, but we still ask that you use simple, plain language
wherever you can.

Goal-oriented instructions

These explain how to perform a specific task. The instructions should be as short and direct as possible, generally taking the form of a numbered list. For
example,

To create a new palette

Open the palettes tab
Click Add palettes
Click Create custom palette
Name your new palette and click Create

Notice that we use bold text for named components of the user interface, including menus. Keyboard shortcuts, such as Ctrl+S, are rendered with <kbd>
tags (see Syntax).

When writing goal-oriented instructions, please:

Use only numbered lists (no dot points)
Begin each numbered instruction with a verb
Write only one task/direction per numbered item

For example, instead of writing this:

Open the palettes tab and click Add palettes

Please write this:

Open the palettes tab
Click Add palettes

Please be sure to include keyboard options for goal-oriented instructions, where such options exist. This is especially important for improving the
program's accessibility.

Use of non-written media

https://www.archives.gov/open/plain-writing/10-principles.html
https://musescore.org/en/print/book/export/html/329209?toc=1#undefined-syntax
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The use of non-written media is encouraged as a supplement to written descriptions. This includes:

Animated GIFs
Screenshots of relevant parts of the user interface

Creating animated GIFs

Animated GIFs offer many advantages over screenshots and videos in that they expose in the shortest amount of time the sequence of actions required
to achieve a particular task. There are lots of tools available for creating GIFs, however we recommend the following workflow to ensure crisp and clear
image quality while maintaining as small as possible file size (ideally <2MB per GIF).

Use only the MuseScore 4 interface, and set its appearance to dark mode with blue highlights (to achieve consistency across the entire handbook)
Plan and rehearse the mouse clicks and keyboard shortcuts you will use, aiming to demonstrate the required steps in as short as possible time
(ideally <10s)
Use a free tool like gifcap  to record the contents of your screen
Use a free tool like KeyCastr  to record keystrokes (where required)
Only show the amount of UI required demonstrate a particular task

Linking to other pages
It's really helpful to link to other pages in the handbook. You might do this wherever you mention a different part of the user interface, or even when
referring back to previous versions of the handbook.

There is a specific process for adding links to other handbook pages, which will allow accurate redirects regardless of the language version being read.

Use the right syntax

[node:######,title="Name of the page you want to link to"]

or, to link to a specific heading within the page:

[node:######,fragment="heading-slug",title="Name of the page you want to link to"]

Link to the page's node number, not the page's URL

To find a page's node number:

Open the desired page in your browser
Click the "three dots" icon in the top-right of the page
Click Edit in the context menu that appears
Click on your browser's search bar to read the URL

You will find the page's node number in the URL address visible in this edit screen (yes, it only appears in the edit screen). It will look something like this:

You can use this as a bookmarlet in your bookmarks

javascript:void function()
{prompt("",`[node:${drupalSettings.path.currentPath.replace("node/","")}${document.querySelector("meta[property=\"og:title\"]").content?`,title
`,fragment="${decodeURIComponent(window.location.hash).replace("#","")}"`:""}]`)}();

Taken from node,title,fragment bookmarklet

Syntax
The handbook is written in MarkDown with a few permitted HTML tags.

If you're not familiar with MarkDown, it doesn't take long to learn. Get started by reading this page first  (a MuseScore account is required to properly
view the content on that page, also note that you cannot use Filtered HTML anymore).

Some examples for stuff beyond MarkDown:

Keys
<kbd><kbd>A</kbd></kbd>, looks like A. (See Writing keyboard shortcuts below.)

Key combinations
<kbd><kbd>Shift</kbd>+<kbd>A</kbd></kbd>, looks like Shift+A. (See Writing keyboard shortcuts below.)

Buttons
<kbd><samp class="button">Advanced Style Properties…</samp></kbd>, looks like Advanced Style Properties…, but this particular form is not used
in the MuseScore 4 handbook (instead use bold for text that appears in the program).

Menu entries
__File&rarr;Open__, looks like File→Open

Images
<img src="image URL" alt="File name description" width="500px"/>, can be a useful alternative to inline images, where the image width needs
to be specified

Writing keyboard shortcuts

Use the <kbd> syntax described above and follow these guidelines:

https://gifcap.dev/
https://github.com/keycastr/keycastr
https://musescore.org/en/node/339996
https://musescore.org/en/filter/tips
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For accessibility reasons, always use words instead of symbols for the names of all whitespace keys, arrow keys, and modifier keys.

Good: Cmd+Space; Win+Return; Shift+Tab

Bad: ⌘+ ; ⊞+⏎; ⇧+↹

For keys that represent printable characters, the appropriate character should be used (e.g. write $ not Dollar).

Use common abbreviations like Ctrl, Cmd, Esc, Del, PgDn. Don't abbreviate key names that are not normally abbreviated.

Except where it matters, prefer Return instead of Enter, and Del instead of Backspace.

For combinations, write modifier keys in this order: Win+Ctrl+Alt+Shift+Fn+… (Mac: Ctrl+Cmd+Option+Shift+Fn+…).

When in doubt, consult Default keyboard shortcuts for the canonical way to write key names and combinations.

Leaving a revision log message
Finally, whenever you make a change to a page (however big or small!), please leave a concise message that briefly describes the changes you made.
For example,

Added content about xxx
Added images
Corrected content
Added keyboard tags

Leave this information in the Revision log message text field in the right panel of the Edit view for each page:

Introduction to MuseScore 4

Download and installation

Windows

macOS

Linux
AppImage

Install

The easiest way to install the program is by using an AppImage:

Go to the Download→Software  page at musescore.org
Under Linux→AppImage (recommended), click on the Download (64 bit) link
When the download is complete, right-click on the AppImage and select Properties
Switch to the Permissions tab
The next step varies depending on your file manager:

Nautilus-based (Nemo, Files, Caja) : Check the “Allow executing file as program” box.
Dolphin: Check the "Is executable" box.
Thunar: Check the “Allow this file to run as a program” box.
PCManFM: Change the “Execute” option in the drop down list to “Anyone”.

Exit the dialog.
Right-click inside the directory in which the AppImage is installed and select Open in Terminal
In the Terminal type, ./[file name] install (the dot and slash at the beginning are important!)

Steps 7–8 ensure that a MuseScore entry appears in the system’s menu and is linked to the new location of the AppImage (/home/[user name]/.local/bin).
The correct file associations are also automatically made.

Note: Instead of steps 7 and 8 (above) you can, of course, install using the absolute file path instead. That is:

Open the Terminal
Type [file path] install

https://musescore.org/en/download
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Tip: if you apply copy to the AppImage and press Ctrl+Shift+V in the terminal this will enter the absolute file path of the file that has just been “copied”.

Uninstall

No formal uninstall proceedure is needed to remove the installed AppImage. Just delete menu entries and any shortcuts manually, then delete the App
itself, and its links (which will be in ~/.local/bin).

Create your first score

We’ll start by creating a new score from a template (Alternatively, you can learn about creating a score from scratch in Setting up your score).

To create a score from a template:

Click New score in the Scores screen
In the New score dialog that appears, browse templates by Category, or use the search bar to look up a template directly
Click Next to enter additional score information (or skip this step and let MuseScore pre-fill your score with default information, which you can
always change later)
Click Done to create your new score

Entering score information
In the Additional score information screen, you can set:

The initial key signature (the default key signature contains no sharps or flats)
The initial time signature (the default time signature is 4/4)
The initial tempo (Click Tempo, then Show tempo marking on my score for this to appear)
A pickup measure (anacrusis or upbeat measure), and its duration
The initial number of measures in the score (the default is 32, but you can add/remove measures from the score edit window)

Entering notes
The simplest way to enter notes in MuseScore is to:

Hit N on your keyboard to enter note input mode
Start typing note names (A, B, C, D, E, F, G)

You’re now engraving in MuseScore! You’ll notice the blue note input highlight, which indicates that you are in note input mode. It shows you where in the
measure your next note will be entered.

You can specify the duration of each note you enter in the Note input toolbar. To change note duration:

Ensure you are in note input mode (See above)
Click on the desired note duration, or
Use shortcut keys 1 through 7 to select different note values

https://musescore.org/en/print/book/export/html/329209?toc=1#node-329757-pickup-measure
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Learn more about this topic in Entering notes and rests.

Adding items from the palettes
The Palettes panel contains almost every notational object you might need to add detail to your score. The simplest way to add palette items to your
notation is to:

Select an existing object (or range of objects) in your score (e.g. a notehead, clef, measure, etc.)
In the Palettes panel, open a palette by clicking the triangular arrow button
Click once on a palette object

Learn more about this topic in Palettes

Making adjustments in Properties
The Properties panel can be revealed by clicking on the Properties tab on the left side of the screen:

(Users of MuseScore prior to version 4 will know this as the Inspector).

The properties panel will show settings that are specific to the object being selected. These settings usually affect the visual appearance of the selected
object. Most of the time, changes you make in Properties will apply only to the object you have selected (e.g. you’ll change the selected hairpin, and not
every hairpin in your score).

As you add details to your score, click on any object to see what settings are available.

https://musescore.org/en/print/book/export/html/329209?toc=1#node-329660-entering-notes-and-rests
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329663-palettes
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Learn more about this topic in Properties.

Inserting and deleting measures
To insert a single measure:

Click on a measure to select it
In the Measure section of Properties, click Insert measures
Click the + button

This Measure section contains controls that allow you to insert multiple measures at once. Simply set the number of measures you wish to insert in the
text field. You can also use the dropdown menu to change the point where new measures will be inserted.

To delete a measure or group of measures:

Select the measure(s) you wish to delete
In the Measures section, click the trash can icon

More information on this topic can be found in Measures.

Exporting your score
Export allows you to create non-MuseScore files, such as PDF, MusicXML, MIDI, and various audio and image formats.

To export your score:

Select the Publish tab
Click Export
Select the parts you wish to export
Choose the file format for your exported file(s)
If exporting multiple parts, choose whether you want each part combined into one file or exported as a separate file
Click Export

You can also share scores online on musescore.com .

Saving your score

https://musescore.org/en/print/book/export/html/329209?toc=1#node-329664-properties
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329666-measures
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329679-share-scores-online
https://musescore.com/upload
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Scores can be saved locally or to your MuseScore cloud storage.

To save your score:

Go to File
Click Save

A dialog opens asking you “How would you like to save”, then offering you the options of “Save to the cloud” or “Save to computer”.

Save to computer

The Save to computer option triggers your operating system’s “Save” dialog, allowing you to save the score as a (compressed) MuseScore file, .mscz.

Save to the cloud

Scores saved online (to the cloud) appear in the program’s Home: Scores tab with a cloud symbol at the corner of the file icon. A copy is also
automatically saved on your computer in the Cloud scores folder in your user “MuseScore 4” folder.

Learn more about this topic in Opening and saving scores.

New features in MuseScore 4

If you’re coming to MuseScore 4 from earlier versions, you’ll notice changes not only to the user interface, but also to many familiar features and ways of
doing things. These changes have been designed to improve the user experience while providing much greater functionality. Here's a very quick
overview of some of the major changes.

New user interface
MuseScore 4 comes with a sleek new interface. Nearly every part of the application has been completely redesigned to be cleaner and easier to read.
You can choose between light, dark and high contrast themes, as well as pick your preferred accent color. Changes to the appearance of the app can be
made in Preferences.

Instruments and parts
A new instruments panel allows you to hide, rearrange and customize your instruments without having to leave the score view.

The instruments panel integrates tightly with the process of creating parts, making it much easier to produce custom parts with any combination of
available instruments. There’s now also a convenient button in the toolbar that allows you to quickly open any available part.

Inspector
The Inspector from earlier versions of MuseScore is now known as the Properties panel. Every option in this panel has been re-organized and the entire
experience has been streamlined. By default, the Properties panel displays multiple useful options, like the ability to show or hide empty staves and
various other types of score markings. Whereas previously you needed to select single element types before you could make changes to them,
MuseScore 4 always displays relevant settings, regardless of how many different elements you have selected.

New playback and VSTi support
Playback improvements are the single largest change to MuseScore 4. Apart from new sample libraries (Muse Sounds, available as a separate
download), there’s now support for VSTi plugins, which can be applied to instruments using the new mixer panel. The mixer also lets you easily switch
between VSTi, SoundFonts and the Muse Sounds libraries, while also supporting VST effects. Sounds will now always be saved on a per-score basis, so
there is no longer any need for the Synthesizer panel found in MuseScore 3 (this has been removed in MuseScore 4). If you previously used SFZ files for
playback in MuseScore 3, we now recommend that you use a free VST sampler, like Sfizz  or Sforzando , both of which support SFZ playback.

Engraving improvements
MuseScore 4 features many engraving improvements, some of which will have an effect on the appearance and layout of scores created in earlier
versions. The most significant changes affect the placement of beams, slurs and ties, horizontal spacing, and page layout. There are far too many
changes to list here, so those interested in learning more about the particularities may wish to read this dedicated document (link forthcoming) that
explains and illustrates everything in detail.

An unavoidable consequence of having made such significant engraving improvements is that it will not be possible to open a score in MuseScore 4 from
an earlier version of MuseScore and have it look identical.

Cloud storage
When you save a document for the first time, you’ll now be asked whether you want to save your file locally to your computer, or to the cloud. This new
option is part of an exciting expansion we are making to services on musescore.com. Learn more about this in Open/Save/Export/Print and Share Scores
Online.

Other changes
As you use the program, you’ll find lots of other small but significant changes that have been designed to make the process of composing and notating
music just that bit easier. These include:

https://musescore.org/en/print/book/export/html/329209?toc=1#node-329673-Save_to_the_cloud
https://sfz.tools/sfizz/
https://www.plogue.com/products/sforzando.html
https://musescore.org/en/print/book/export/html/329209?toc=1
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An expanded note input toolbar, with one-click access to frequently used elements like tuplets and articulation marks. There’s also a convenient “+”
menu where you can quickly add everything from notes and intervals, to frames and text elements.
Easy-access features in the Properties panel that let you quickly add and remove measures, and show and hide empty staves
A beautiful new mixer
Improvements to the time signature properties dialog
A streamlined experience for setting the language of the app
A new Learn center for instructional videos on how to get the most from the app

Viewing and navigation

Accessibility

Screen readers
MuseScore 4 supports the following screen readers on each operating system:

Windows 10 and 11: Narrator and NVDA
macOS: VoiceOver
Linux: Orca

Speech with JAWS is mostly working, but the output is not as complete as it is with Narrator or NVDA.

Speech on Windows

If screen reader speech output stops working for you at any time, try pressing Alt+F to focus the File menu, then press Esc twice to return to where you
were in the app, at which point speech should work again as normal. It can be necessary to do this if you start the screen reader after MuseScore is
already running, for example.

Speech on macOS

VoiceOver's Quick Nav mode  must be turned off while using MuseScore 4. You can toggle Quick Nav on or off by pressing the Left and Right arrow
keys simultaneously while VoiceOver is running, or you can disable Quick Nav from within VoiceOver Utility > Commanders.

MuseScore's interface is navigable with the tab cursor and with VoiceOver's own cursor. In general it's best to use the tab cursor because this matches
the interface on other platforms, and as such is the interface described in most documentation and tutorials. VoiceOver's cursor can be used to reach
areas of the application that are not yet accessible via the tab cursor. When using the tab cursor, remember to use the arrow keys as well as Tab for
navigation (see Navigating the UI).

Speech on Linux

On Linux it is necessary to start the screen reader running before you launch MuseScore, otherwise accessibility features will be disabled to save system
resources. If you forget to do this, simply exit MuseScore and launch it again. The same is true of all Linux applications built on the Qt framework.

Orca is the most feature-complete screen reader available for Linux. Orca is built into the GNOME desktop environment, so it is recommended that Linux
users with accessibility needs use a distribution based on GNOME or one of its derivatives.

Keyboard access
Navigating the UI

Keyboard navigation in MuseScore 4's user interface (UI) relies on the arrow keys in addition to the tab key. Press the tab key to cycle through each
control group, then use the arrow keys to navigate to individual controls within the group. This new system of navigation allows you to navigate to
anywhere in the interface with far fewer keypresses than if the tab key was used to access every individual control, as is commonly the case in other
applications, including previous versions of MuseScore. The new navigation system is still being refined, and feedback is welcome in the Development
Forum .

In addition to the arrow keys and tab, there is a new F6 shortcut that will take you between different panels within the program. Here is how the navigation
shortcuts work together to create a hierarchical system of navigation:

Up, Down, Left and Right arrow keys: Move focus from one control to the next within a control group (e.g. navigate between buttons in a toolbar).

Tab and Shift+Tab: Move focus out of one control group and into the next one (e.g. navigate between toolbars).

F6 and Shift+F6: Move focus between panels and large sections of the UI (e.g. navigate from toolbars to the Palettes or notation view).

By default, the grave accent key ` (sometimes called "backtick") can be used as an alternative to F6 for navigation between panels. Grave accent is found
above the Tab key on most QWERTY keyboards. If it's not there on your keyboard, consider changing this shortcut in Preferences to set it to whatever
key is above Tab on your keyboard, as it can be convenient to have the navigation keys located close to each other.

Once you have navigated to a button or control, in most cases it can be activated by pressing the Spacebar, Enter or Return key. Within lists and other
item views, Spacebar is often used to select items rather than to activate them. Once selected, certain items can be deleted by pressing the Delete key, or
modified by tabbing to other UI controls that become active once something has been selected. For example, this approach can be used within the
Instruments panel to remove instruments that you have previously added to the score.

Navigating the score

Navigation within the score (i.e. inside the "Notation view") is much the same as it was in MuseScore 3. Here are the shortcuts that are of particular value
to accessibility users:

https://support.apple.com/guide/voiceover/with-quick-nav-vo27943/mac
https://musescore.org/en/forum/687
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Shortcut Action

Alt+Right and Alt+Left Move to next or previous element. These shortcuts enable you to visit all
kinds of notation elements, not just notes and rests.

Alt+Up and Alt+Down
Move to note above or below. These shortcuts enable you to move
between individual notes in a chord, and also to reach notes and rests in
other voices and in other staves.

F2 or Alt+Shift+E

Edit selected element. This is the keyboard equivalent of double-clicking
on an element with the mouse. It enables you to edit text objects, including
lyrics, dynamics, and tempo markings. It also enables you to adjust the
length of line elements such as hairpins, slurs, and voltas (use the Tab key
to change which end of the line you are adjusting). When you are done
editing, press Esc to return to Normal mode.

Other aspects of keyboard navigation are described on pages throughout this handbook.

Video tutorials
The following accessibility tutorials are designed to get you up and running with MuseScore, using your keyboard and screen reader. They don't cover
every aspect of the program, but they should give you a solid foundation that will enable you can take full advantage of the rest of this Handbook.

Video Description

Installing MuseScore
This video covers the installation of MuseScore on Windows, including
Muse Hub and Muse Sounds. The process is similar on macOS and Linux,
although on Linux you need to install Muse Hub and MuseScore separately.

Score setup This video covers the initial setup of your score, including choosing
instruments and selecting the key and time signature and other settings.

Entering music This video covers basic note input.

Adding markings This video covers adding markings such as dynamics to your score, by
using the palettes.

The user interface
This video walks through the main window of the program, so you can
understand where all the different panels, toolbars, and controls are, and
how to reach them by keyboard.

The user interface

Menu bar

The Menu bar in MuseScore 4 contains the following menus:

File: Create a new file, open and save files, import and export various formats, create and edit instrument parts, and print
Edit: Undo and redo options, copy/cut/paste options, and Find / Go to function
View: Show or hide various palettes, dialogs, and other workspace elements
Add: Add different kinds of score elements; notes, text, measures etc.
Format: Adjust global and local formatting of the score. Also allows you to stretch or contract the score, load and save score styles, and much more
Tools: Many useful commands are available here including transpose, exchange voices, slash notation etc.
Plugins: Manage your plugins
Help: Access the online handbook, report bugs and give feedback, and restore factory settings

Keyboard users on Windows and Linux can access these menus by holding the Alt key and pressing a certain letter or number key, known as the
mnemonic access key, that is displayed with an underline in the name of the menu item you are looking for. For example, press Alt+F for File followed by
Alt+A for Save as. The letters 'F' and 'a' are underlined in the UI while the Alt key is held.

On macOS, MuseScore's menus are part of the system-wide menu bar, which you can navigate to by pressing Ctrl+F2.

Home tab

Beneath the main menu are three tabs, the first of which is the Home tab. This tab contains the following sections:

My account

Create a new MuseScore account, or login to your existing account. With an active account, you can get technical assistance and report bugs in the
forums at musescore.org . You can also save your files to the cloud on musescore.com .

Scores

This section allows you to set up a new score, or to open an existing one. Learn about creating new scores in Setting up your score.

Plugins

https://youtu.be/TFdhtLIXLPc
https://youtu.be/Fh45A6V3410
https://youtu.be/mkZPsGYZ3QQ
https://youtu.be/oRrT4WpE0PY
https://youtu.be/zxZ4OCBj00w
https://musescore.org/en
https://musescore.com/dashboard
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This window displays a list of available plugins. See the chapter on Plugins to learn about managing these useful add-ons.

Learn

This is where video tutorials are hosted. Clicking on any video tutorial opens it on the official MuseScore YouTube channel .

Score tab

This are is where you do most of your work in MuseScore, including adding music notation and listening to the playback of your score. The workspace
consist of several regions (numbered according to labels in the below diagram):

Parts: The button near the top center of the window opens the Parts dialog, where you can create, edit and delete instrument part scores.
Mixer: The button to the right of Parts opens and closes the Mixer panel.
Playback toolbar. Located to the right of the mixer icon.
Note input toolbar: Extending across the program window, this includes essential notation elements used in score writing. Use it to set the note input
duration, toggle accidentals, apply common articulations, enter tuplets, and change between voices.
Side bar: The area on the left-hand side of the program window contains various panels such as Palettes, Properties, and Instruments. These can
be hidden or displayed as desired.
Document/Score window: This area contains your score, and is where notation elements are added, edited, and deleted.
Status bar: This runs along the bottom of the window. The left-hand side displays useful information about the score when one or more elements
are selected. The right-hand side contains controls for switching between workspaces, selecting concert or written pitch views, and specifying the
page display and zoom factor (magnification).

Keyboard users can use the Tab key or F6 to navigate between these UI regions via the keyboard. Within each region, navigation is performed with the
arrow keys and Tab.

Almost all panels and toolbars can be un-docked and repositioned according to your project requirements and workflow preferences. Learn more about
this in Workspaces.

Publish tab

This tab allows you to view your score without the clutter of the note input toolbar or sidebar panels. There are options to print the score, and to export it
in a variety of image, audio and document formats. When your score is finished, you can also publish it to musescore.com .

Context menus
In certain parts of the application, primarily in the Score tab, context menus are available with additional functionality, such as options to copy, edit,
customise, delete, or view the properties of whatever item(s) were selected at the time you opened the menu.

Element context menus

Within the score, every element has a context menu. To open the context menu for a particular element, right-click on the element with the mouse, or
select the element via the keyboard and press Shift+F10 (some PC keyboards also have a dedicated Menu key near to the right Ctrl key). The exact
options available in the context menu can differ depending on the type of element you selected, so it is worth experimenting to find out what options are
available for different kinds of elements. For example, when you right-click on an empty region within a measure the resulting context menu contains

https://www.youtube.com/c/musescore
https://musescore.com/dashboard
https://musescore.org/en/print/book/export/html/329209?toc=1#undefined-score-tab
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options for Staff/Part properties and Measure properties. This is currently the only way to get to those options and the dialogs they lead to.

UI context menus

Outside of the score, the presence of a context menu is often indicated by a small button with three dots, or by a settings cog. Press the button to open
the menu. Sometimes the button is associated with another item in the vicinity, such as in the Palettes, where there is three-dots button for each palette.
In this case you can right-click on the palette name, or select it with the keyboard and press the Shift+F10 or Menu key shortcut, as an alternative to using
the three-dots button.

Navigating your score

Scrolling
Mouse wheel

Use the scroll wheel to move the view up and down.
Use Shift plus the scroll wheel to move the view left and right.

Scrollbars

Scrollbars appear at the right-hand and bottom edges of the score view. Click and drag them to quickly move the score view up and down, or left and
right. Scrollbars are usually hidden from view, but can be revealed by hovering over the edge of the score view with your mouse.

Keyboard

You can also scroll the score using the PgUp, PgDn, Home, and End keys on your keyboard. If your keyboard lacks dedicated keys for these functions, most
systems will also allow you to access these functions by holding Fn or a similar key, then pressing Up, Down, Left, or Right respectively.

By themselves, PgUp and PgDn scroll one screenful at a time. This may be less than an actual page of your score. If you hold Ctrl (Mac: Cmd) while
pressing PgUp or PgDn, it moves a full page at a time.

Element navigation
When a single element is selected in your score, it acts as a cursor. You can change the selection—and thus move the cursor—using common keyboard
shortcuts.

The Left and Right keys will move horizontally through your score one note or rest at a time. If you hold Ctrl (Mac: Cmd) while pressing Left or Right, you
can navigate a full measure at a time.

To move the cursor vertically through the various notes, voices, and staves in your score, use the shortcuts Alt+Up and Alt+Down (Mac: Option+Up and
Option+Down).

You can also use the shortcuts Alt+Left and Alt+Right (Mac: Option+Left and Option+Right) to select elements other than notes or rests. These
commands allow you select almost any elements—including articulations, barlines, hairpins, and more—using the keyboard alone.

In addition, Ctrl+Home (Mac: Cmd+Home) will select the first element in your score, and Ctrl+End (Mac: Cmd+End) will select the last element. Again, for
keyboards that lack dedicated Home and End keys, most systems provide the alternative of Fn+Left and Fn+Right respectively.

See Default keyboard shortcuts to learn more.

Navigator
The Navigator is a panel that displays thumbnails of score pages. To view or hide the Navigator, click View → Navigator.
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The blue bounding box represents the area of the score currently in focus in the score view. Click on the box and drag it to move around your score.

Timeline
A navigation aid that shows instruments and score structure. For details, see Timeline.

Views
You can switch between different views of the score using the pop-up in the right-hand side of the status bar.

Page view

The score is shown as it will appear when printed or exported as a PDF or image file: that is, page by page, with margins. MuseScore applies system
(line) and page breaks automatically, according to the settings made in Page settings and Style. In addition, you can apply your own system (line), page
or section breaks.

Continuous view (horizontal)

The score is shown as one unbroken system. Even if the starting point is not in view, measure numbers, instrument names, clefs, time and key signatures
will always be displayed on the left of the window.

Continuous view (vertical)

The score is shown as a single page with a header but no margins, and with an infinite page height. System (line) breaks are added automatically,
according to the settings made in Page settings and Style. In addition, you can apply your own system (line) or section breaks.



14/09/2023, 18:51Handbook for MuseScore 4

Page 47 of 270https://musescore.org/en/print/book/export/html/329209?toc=1

Zoom
There are several ways to zoom the score in or out:

Zoom in

Ctrl++ (Mac: Cmd++)
or scroll up with the mouse scroll wheel while holding Ctrl (Mac: Cmd).

Zoom out

Ctrl+- (Mac: Cmd+-)
or scroll down with the mouse scroll wheel while holding Ctrl (Mac: Cmd).

Status bar zoom controls

To zoom in and out of your score from the Status bar controls:

Click on the magnifying glass icons in the right-hand area of the status bar
Click the number field to the right of these icons, then type a custom zoom level
Choose from one of the preset zoom levels in the pop-up list on the extreme right

Restoring 100% zoom

This restores the zoom to the default (100%) level.

Ctrl+0 (Mac: Cmd+0)

Find/Go to
The Find/Go to panel allows you to speedily navigate to a specific measure, rehearsal mark or page number in the score.

To show the panel:

Go to Edit → Find, or
Press Ctrl+F (Mac: Cmd+F).

To hide the panel:

Click the X (close) button on the left side of the panel, or
Press Esc while the panel has focus.

Navigating to a numbered measure

Enter the measure number (counting every measure, starting with 1, irrespective of pickup measures, section breaks or manual changes to measure
number offsets).

Navigating to a numbered page

Enter the page number using the format pXX (where XX is the page number).

Navigating to a numerical rehearsal mark
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Enter the number using the format rXX (where XX is the number of the rehearsal mark).

Navigating to an alphabetic rehearsal mark

Enter the name of the rehearsal mark (the search is not case sensitive).

Pro tip! It is best to avoid naming rehearsal marks with the single letters “R", “r", “P”, “p", or one of these letters with an integer (e.g. “R1” or “p3”), as this
can confuse the search algorithm.

Timeline

Overview
Timeline is a navigation aid that displays at the bottom of the program window, giving you an overview of the instruments and main structural elements
measure-by-measure. You can easily move about the score by clicking on a measure or a structural element.

There are four parts to the timeline:

Meta labels

This is found in the top left corner of the timeline. These are the names of the meta rows.

Instrument labels

This is found in the bottom left corner of the timeline. These are the names of the rows in the main grid.

Meta rows

This is found in the top right corner of the timeline. These hold the meta values of the score.

Main grid

This is found in the bottom right corner of the timeline. This holds multiple 'cells' (a specific measure and staff in the score represented as a square)

Meta elements
Meta elements are those found in the score that are not notes, but are still important to the score—such as key signature, time signature, tempo,
rehearsal marks, bar lines, and jumps and markers.

Basic interactions
Selecting a measure

To select a measure in the timeline, press the mouse button on the cell. A blue box will appear around the selected cell and the respective measure in the
score will be selected. The score view will place the selected measure in view.

Selecting multiple measures

Drag selection

Holding Shift and holding the left mouse button and dragging the mouse over the main grid will create a selection box. Upon releasing the mouse button,
all the cells underneath the selection box will be selected, as well as all the measures in the score.

[Shift] selection

If a cell is already selected, holding Shift and selecting another cell in the timeline will stretch the selection to that new cell, similar to how the score does

[Ctrl] selection

If no cells are currently selected, holding Ctrl and selecting a cell will select the entire measure

Clearing a selection

To clear selection, holding Ctrl and clicking anywhere on the grid or the meta rows will clear any current selection.

Meta values selection

Selecting the meta values on the timeline will attempt to select the respective meta values in the score.
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Scrolling
Standard scrolling

Scrolling the mouse wheel up or down will move the grid and instrument labels down or up respectively. The meta labels and rows do not move.

[Shift] scrolling

Holding Shift and scrolling the mouse wheel up or down will move the grid and meta rows left or right respectively. The meta labels and instrument labels
do not move.

[Alt] scrolling

Holding Alt and scrolling the mouse wheel up or down will move the grid and meta rows left or right respectively, faster than Shift scrolling. The meta
labels and instrument labels do not move.

Dragging

To drag the contents of the timeline, hold the left mouse button and move it around.

Labels interaction
Rearranging meta labels

All meta labels besides the measures meta may be rearranged in any way. By moving the mouse cursor onto one of the meta labels, small up and down
arrows will appear. Click the left mouse button on the up arrow to swap the meta label with the one above it. Click the left mouse button on the down
arrow to swap the meta label with the one below it.

Collapsing the meta labels

In order to hide all the meta labels while keeping all the meta information on the timeline, click the left mouse button on the measures meta to collapse all
the currently visible meta rows into one row, where the meta values are staggered in that row. Click the left mouse button again on the measures meta to
expand the meta rows.

Hiding instruments

All instruments--hidden or not--will be displayed on the timeline. To start this interaction, the mouse cursor is moved over an instrument label. A small eye
will appear on the right side of the label that is open if the instrument is visible on the score, and closed if the instrument is hidden. Click the left mouse
button on the eye to toggle between the two options.

Zooming
To zoom in or out of the score, hold Ctrl and scroll the mouse wheel up or down respectively (Mac: Cmd + scroll).

Basics

Setting up your score

Overview
To create a new score, use one of the following options:

in the Home: Scores tab, select New score, or click New (bottom right).
From the menu, select File→New.
Use the keyboard shortcut, Ctrl+N (Mac: Cmd+N).

https://musescore.org/en/print/book/export/html/329209?toc=1#node-330533-home-tab
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This will open the New Score dialog (More instructions about this dialog are below). Once you've finished setting up your score, it will be visible in the
Score tab.

Instruments
When creating a new score, you can either choose the instruments yourself, or use a template that comes pre-configured with appropriate instruments
(these can always be changed later).

Choose instruments

In the New Score dialog, make sure the Choose instruments tab is selected.

MuseScore contains over 500 instruments, grouped according to the instrument family they belong to.

The dropdown menu under the Family heading on the left filters instruments by type/genre. "Common" is selected by default, which displays some of the
most common instruments or voices you are likely to need. if you want to display all available instruments, select All instruments.

If you know the instrument/voice you are looking for, you can simply type its name, or part name, in the search bar under the Instruments heading. Press
the clear button (X) to clear the selection.

Adding instruments

To add an instrument to your score:

Click on the instrument name to select it
Click the → button to add the instrument to your score (Pro tip: double-clicking an instrument name does the same thing).
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Instruments are automatically arranged according to the order shown in the dropdown menu under the Your Score heading on the right. From this menu,
you can choose from a range of standard score configurations or use a custom one.

Make soloist

To make an existing instrument the soloist:

Click on the instrument name (under the Your score heading on the right of the dialog)
Click the "Make soloist" button.

This reorders an existing instrument in the score to the soloist position. This position is defined in the Order … dropdown list under the Your Score
heading. For example, in an 'Orchestral' ordering system, soloists are above the strings. If required, you can designate multiple soloist instruments.

Changing order of instruments

To manually change the order of instruments:

Select an instrument in the Your Score panel
Click on ↑ or ↓ to change its position

Removing instruments

To delete an instrument from your score:

Select an instrument in the Your Score panel
Click the trash icon



14/09/2023, 18:51Handbook for MuseScore 4

Page 52 of 270https://musescore.org/en/print/book/export/html/329209?toc=1

You can also delete multiple instruments at once by first holding down Shift and selecting multiple instruments, then clicking the trash icon.

Create from template

Scores can also be created from pre-configured templates.

Templates are organized into categories based on musical style or ensemble configuration. Each template contains the instruments most commonly
required for a particular type of score. Instruments are ordered and styled according to conventional practice.

To create a score from a template:

Click Create from template
Select a group of templates from the Category panel
Choose your desired template from the center panel
Click Done

You can also search across all available templates in the search bar.

Visit Templates and styles to learn more templates, including how to create your own for future use.

Additional score information
Click Next in the New score dialog to specify additional information about your score.
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Key signature

By default, new scores are created with a key signature containing no sharps or flats (C major). Specify a different key signature by clicking the button
under Key signature. Major keys are shown first; minor keys can be displayed by selecting the Minor tab.

Time signature

New scores will be created in 4/4 by default. Change this by clicking the button under Time signature. Change the number of beats per bar using the
arrows in the spin box, and change the beat quality from the dropdown menu. You can also select common and cut-common (alla-breve) time signatures
in this popup.

Tempo

By default, new scores will play at a tempo of crotchet (quarter note) = 120 beats per minute (bpm). Metronome markings are not automatically included
in new scores.

To customize the starting playback tempo, and to show a metronome marking above the uppermost stave:

Click the button under Tempo
Tick Show tempo marking on my score
Select the desired beat value
Enter the desired number of beats per minute (20-400) in the text field or use the up and down arrows to scroll through the tempo range.

Learn more about tempo text indications, metronome markings, and playback speed in tempo markings.

Measures

New scores are created with 32 measures and no pickup (anacrusis). To change the starting number of measures in your new score:

Click the button under Measures
Enter the desired number of measures in the Initial number of measures field

Learn more about Adding and removing measures at any time after score creation.

To start your score with a pickup:

Click the button under Measures
Tick Create pickup measure
Enter the desired number of beats for the pickup in the text field
Select the metrical value of the pickup measure from the drop-down menu

You can always create a pickup later. Learn how to do this in Pickup and non-metered measures.

Title and other text

Enter text in the fields at the bottom of the New score dialog, and MuseScore will automatically place it in an appropriate format in your new score. You
can enter text labels for the score's:

Title
Composer
Subtitle
Lyricist
Copyright

This information also becomes data in the score's project properties (menu File), which you can change at any time.
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Once you've finished specifying additional score information, click Done to confirm your selections and create your score.

Changing instruments after score creation
There are three ways to change existing score instruments:

Use the keyboard shortcut I while in the Score tab
Click Add from the Instruments panel (If this panel is not yet visible, press F7, or select View → Instruments)
Click Replace instrument in the Staff/Part properties dialog

Entering notes and rests

Overview
inputting music via the computer keyboard is both quick and easy. To enter a note or rest, simply choose a duration, then type the pitch name (A-G) for a
note or a 0 (zero) for a rest. You can also input notation using a mouse, MIDI keyboard or MuseScore's own virtual piano keyboard (see below for
details).

MuseScore supports virtually unlimited undo, so you don't have to worry too much about making mistakes. Just click the undo button on the far right of
the toolbar, or use the standard keyboard shortcut Ctrl+Z (Mac: Cmd+Z).

Entering notes
The information in this page refers primarily to music notation on standard staves. See also tablature and percussion notation.

The most common input method (and the one assumed on this page) is step-time in which notes and rests are entered one at a time. For other modes of
entry see Alternative note input methods.

Selecting a start point

To add a note or rest to the score, start by selecting a location to begin entry. You can use the mouse or the keyboard navigation commands.

Entering note input mode

Next, enter note input mode by pressing the pen icon in the toolbar, or using the keyboard shortcut N. A note input cursor appears, indicating where the
next note will be added.

If you forget to select a starting location first, MuseScore will place the cursor at the last input position, or in some other logical place, so be sure the
cursor is where you intend.

Once in note input mode, you will enter notes left to right by first selecting a duration and then entering a pitch or rest. When you are done entering notes
in this location and are ready to do something else—for example, entering notes at a different location, adding other markings, or performing other
operations like copy and paste—you can leave note input mode by clicking the note input button or pressing N again. You can also press Esc to return to

https://musescore.org/en/print/book/export/html/329209?toc=1#node-329665-instruments-panel
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normal mode from note input or any other mode.

Selecting duration

While in note input mode, select a note value for the next note to be entered by:

Clicking a corresponding note icon in the Note Input toolbar (directly above the score window)

Entering the keyboard shortcut 1–9 corresponding to the desired duration

The keyboard shortcuts are designed to be efficient and easy to remember. The most common note values are eighth, quarter, and half (UK: quaver,
crochet, minim) and these are represented by the keys 4, 5, and 6 respectively (the middle row of a numeric keypad). Shorter note values are represented
by smaller numbers, longer values by larger numbers. The full list is as follows:

64th (hemidemisemiquaver): 1
32nd (demisemiquaver): 2
16th (semiquaver): 3
Eighth (quaver): 4
Quarter (crotchet): 5
Half (minim): 6
Whole (semibreve): 7
Double whole (breve): 8
Longa: 9
Dot: . (changes the selection into a dotted note/rest)

Other durations, including double dots and 128th notes, can be selected if you first customize your toolbar and/or define your own keyboard shortcuts.

Note: it is also possible to select duration using a MIDI keyboard, if you set up the keys you wish to use for this in advance.

Selecting pitch

Once you have selected a duration, you can enter pitches using the computer keyboard, mouse, MIDI keyboard, or virtual piano keyboard.

Selecting pitch using the computer keyboard

This is normally the most efficient way to enter notes in MuseScore.

To enter a note of a given pitch using the computer keyboard, simply press the corresponding letter (A–G) on your computer keyboard.

Notes entered in this way will replace any rests or notes that were already present at the cursor location. To add a note to an existing note or chord, press
Shift while entering the note. See the section on chords below for more information.

When entering notes by letter name, MuseScore will choose the octave that is closest to the previous note on that staff. This works well for passages that
move mostly by steps and small leaps. If you need to change the octave for a larger leap, use Ctrl+↑ and Ctrl+↓ (Mac: Cmd+↑ and Cmd+↓) to raise or lower
the pitch of the previously entered note by an octave.

Selecting pitch using the mouse

To enter a note using the mouse, position your mouse on the desired line or space in the staff, then click. The mouse cursor will show you a preview of
the note you are about to enter to help you place it accurately.

If any notes already exist at the location where you are entering a new note, the new note will be added above or below it. To replace existing notes
instead, press Shift while entering the new note.

It can be difficult to enter notes very far above or below a staff with this method, because MuseScore may interpret clicks far from the intended staff as an
attempt to enter notes onto the staff above or below. Instead, try entering the note an octave lower or higher, then raise or lower the pitch by an octave

https://musescore.org/en/print/book/export/html/329209?toc=1#node-329668-midi-device-mapping
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using Ctrl+↑ and Ctrl+↓ (Mac: Cmd+↑ and Cmd+↓).

Note: although one would normally enter notes left to right, the mouse entry method actually allows you to enter a note at any location where there is an
existing note or rest to replace.

Selecting pitch using a MIDI keyboard

If you have a MIDI keyboard connected, you can enter notes by simply pressing the corresponding keys.

When playing notes on a MIDI keyboard, they are entered consecutively so long as you release each key fully before pressing the next. If you press a
key before releasing the previous key, the new note is added above or below the previous note.

Notes entered via MIDI keyboard that are outside of the current key signature will have accidentals applied automatically, but the spelling of the
accidental may not be what you intend. To change the enharmonic spelling of a note, press J.

Selecting pitch using the virtual piano keyboard

You can also input notes using the on-screen Piano keyboard window. To display this, use View→Piano keyboard or press the shortcut P. The window
can be closed the same way.

To enter a note of a given pitch, simply click the appropriate piano key with your mouse.

As with the computer keyboard, notes entered in this way replace any existing notes or rests. To create chords instead, press and hold Shift while
entering notes.

Note: to resize the keyboard, position the mouse within the window and hold Ctrl (Mac: Cmd) while scrolling up or down.

Entering chords
For the purpose of this section, chords are any combinations of multiple notes all starting at the same time, all sharing the same duration, and all sharing
a single stem.

If you wish to enter notes that sound together but start at different times, have different durations, or have separate stems, see Voices. Text of the form
"Dm7" is a chord symbol, discussed in Chord symbols.

Just as for individual notes, chords can be entered by computer keyboard, mouse, MIDI keyboard, or virtual piano keyboard. Except for MIDI keyboard
(where you can play multiple notes at once), the notes are still entered one at a time, but in a way that tells MuseScore to combine them into a chord
rather than add them sequentially.

To add a note to a chord using the computer keyboard, press and hold Shift while entering the note
To add a note to a chord using the mouse, click the location where you wish to add the note
To add a note to a chord using a MIDI keyboard, either play all the notes at the same time, or play them one at a time but do not release one key
before pressing the next
To add a note to a chord using the virtual piano keyboard, press and hold Shift while entering the note

When using Shift+A–G to add a note to a chord, the note will be added above any notes already present at the cursor location. You can also specify the
note to be added based on the interval above or below the currently-selected note.

To add an interval above the selected note, use one of the following:
From the menu bar, select Add→Intervals and choose an interval from the list;
Press Alt+1-9.

For intervals below the selected note, you will need to apply a custom shortcut of your own (see Preferences).

Entering rests

https://musescore.org/en/print/book/export/html/329209?toc=1#node-329757-interval
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Rests can be entered using the computer keyboard or mouse. The duration is selected in the same way as for notes (e.g., using the toolbar or keyboard
shortcuts 1–9). Then instead of entering a pitch as you would for a note, choose one of the following options.

From the computer keyboard: press 0 (zero)
From the note input toolbar: click the rest icon, then click in the score

Using a mouse: right-click in the score

Accidentals

Standard accidentals (flat, natural, sharp, double flat, double sharp) can be entered either by selecting one before entering the pitch it applies to or by
adding them to a note already entered.

Selecting an accidental before entering a pitch

To specify an accidental to be applied to the next note entered, you can use the buttons on the Note input toolbar above the score or the corresponding
keyboard shortcuts. This can be done either before or after selecting the duration.

The default accidental shortcuts are:

Flat : -
Sharp : +
Natural : =

Unlike selecting duration—which applies to all subsequent notes until you change it—an accidental is applied only to the next note entered. But the usual
rules of music notation apply, so if you apply a flat to a given note, any subsequent notes you enter of that same pitch within the same measure will be
flatted as well, even though no explicit flat sign will be added in front of them.

Adding an accidental after entering a pitch

Appropriate accidentals are automatically added to a note when you increase or decrease its pitch:

↑: move pitch up a semitone (spells with sharps).
↓: move pitch down a semitone (spells with flats).

You can also apply an accidental to a note by clicking the appropriate icon in the Accidentals palette. This palette also contains a large number of
microtonal and other special accidentals.

Adding courtesy/cautionary accidentals

Although the rules of music notation say that a barline cancels an accidental, and that any note on the same staff line or space in the next measure
returns to the pitch indicated by the key signature, it is considered good practice to add a courtesy (also called cautionary) accidental anyhow. These do
not change the pitch of the note, so they cannot be added with the ↑ and ↓ keys. However, any of the other methods described above work.

While parentheses or brackets are not required for courtesy accidentals, some editors do choose to use them. To add parentheses or brackets around an
accidental, you will need to temporarily leave note input mode, select the accidental, then either use the Properties panel to select a bracket type, or
click the parentheses or brackets in the More section of the Accidentals palette.

Note: there are also a set of plugins pre-installed with MuseScore that can automatically add courtesy accidentals as needed.

Ties
A tie is a curved line between two notes of the same pitch, indicating that they are to be played as one combined note. Even though they look similar, ties
should not be confused with slurs, which join notes of different pitches and indicate legato articulation.

MuseScore makes it very easy to enter ties. Because ties are always between notes of the same pitch, you do not need to enter the pitch for the second
note—just select the duration and enter the tie; MuseScore will add the note automatically. After entering the first note, follow these steps to create the
tie:

Select the duration for the second note
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Click the tie button on the toolbar or use the shortcut T

The tie command adds the second note and ties it to the first in one step. If the first note you entered is part of a chord, then the tie command actually
creates an entire second chord with the same pitches as the first and ties all of the notes.

Note: ties normally connect adjacent notes in the same voice, but MuseScore also supports ties between non-adjacent notes and between notes in
different voices as described in the section on editing.

See also
Editing notes and rests
Voices
Tuplets
Alternate note input modes
Tablature
Drum notation
Slash notation
Noteheads

Working with multiple voices

Overview
A MuseScore voice is a line of music on a staff that has its own rhythm independent of other music on the same staff. Other notation programs may refer
to it as a "layer".

"Voice", in a different sense, may also refer to a pitch range in vocal music—soprano, alto, tenor, bass etc. It is important not to mix up the two meanings
by assuming, for example, that the four "voices" in an SATB choir are equivalent to MuseScore "voices" 1–4 (see below); that would be to confuse chalk
with cheese.

MuseScore allows up to four voices in one staff: Voice 1, Voice 2, Voice 3, and Voice 4. When writing music on a staff, one usually starts in voice 1
then moves on to voice 2. Voices 3 & 4 are less commonly used.

Two voices on the same staff are normally indicated using opposing stems—an upper voice with stems up and a lower voice with stems down:

In a four-part SATB arrangement on two staves, you would use voices 1 & 2 on the top staff for soprano and alto, and voices 1 & 2 on the bottom staff for
tenor and bass:

Entering notes and rests in multiple voices

https://musescore.org/en/print/book/export/html/329209?toc=1#node-330536-ties-normal
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The first step to enter multiple voices is to determine whether you need to write notes as voices in one staff, or spread voices among multiple staffs
such as four voices among two staffs of a piano, or among multiple instruments such as four voices on four string instruments. You should consider
the design of MuseScore's notation function and your production needs, do not base your decision merely on academic reasons:

MuseScore sets stem directions automatically based on the voice used and which voices are used in each measure. In measures where only Voice
1 is used, but no notes or rests are written on Voice 2, Voice 3 or Voice 4, stem directions of notes are determined by pitch—notes above the center
line have stems pointing down, notes below the center line have stems pointing up. Otherwise, the stem directions are determined according to the
voice—up for Voice 1 and Voice 3, down for Voice 2 and Voice 4.
To assign an overriding stem direction setting manually, use the Flip direction button on the toolbar, or the keyboard shortcut X, also see Stems
and flags.
Writing on voice 2 right away may seem correct academically, but musescore will create rest symbols in voice 1 automatically which might be
redundant in some cases. Popular options in this scenario are: manually hide rests afterwards (jump to how to); or simply use voice 1 instead of
voice 2.
It's not yet possible to assign different sounds to individual voices, so you may have to use multiple instruments. For example, you cannot assign a
Soprano VSTi to voice 1 and a Tenor VSTi to voice 2, only one or the other.
Sometimes you must use multiple voices in one staff to create certain visual notation result in Musescore, even if they aren't different voices
musically. For example, in MuseScore, inside one voice, a chord can only be created with notes of the same duration. If constituent notes of a chord
have varying durations, you must use separate voices to write them. A list of common similar scenarios can be found on the Handbook 3 Voices
page.

Using multiple instruments

If you decide you need to write different voices as notes on different instruments, start by creating multiple instruments using Setting up your score:
Changing instruments, then edit clef symbols as required, and then compose on Voice 1 in all of these staffs. A common example is to write four voice
SATB open score on four instruments' Voice 1.

To convert separate staffs into one staff containing multiple voices, or to do the opposite, see Implode and explode. A common example is SATB open
score <-> short score conversion,

Enter notes and rests in multiple voices in one staff

To enter new notes into a Voice:

Select your starting point in the score.
Click the pen icon on the toolbar or press N to enter note input mode.
Select the desired voice using the toolbar icons or press one of the keyboard shortcuts Ctrl+Alt+1–Ctrl+Alt+4
Enter notes and rests normally as described in Entering notes

You can repeat these steps to enter notes into other voices.

Note: to enter new notes, make sure you are in note input mode before selecting the desired voice, otherwise you will change the voice of any currently-
selected elements instead.

Note: the note toolbar only displays voice 1 and 2 icons by default. You can make all voice icons visible using the controls that appear when you click the
gear icon on the toolbar. For more information, see the section on customizing the note input toolbar.

Editing notes and rests in multiple voices
Adjusting rests

To make sense notation wise, rests should be used in each existing voice whenever necessary to complete beats of a measure, Musescore creates them
automatically. In measures containing multiple voices, rests are automatically added to voices of lower number whenever appropriate. MuseScore also
automatically positions rests to avoid overlapping other score elements.

To hide, delete, or adjust the position of these rests to create better layout, use one of the following methods:

Hiding or deleting rests

Rests may be hidden by selecting them and unchecking the Visible box in the Properties panel or using the keyboard shortcut V.

Rests in voices 2-4 may also be deleted by selecting them and pressing Delete. However, this leaves a "hole" in the voice that can be difficult to edit later.
To restore missing rests from a voice, you can use the commands in Tools→Voices to exchange the contents of the voice with those of voice 1, which
will fill the holes with rests again. You can then use the same command to move the contents of the voices back where they were.

Note: to ensure the correct duration of each measure, voice 1 rests can be hidden, but they cannot be deleted.

Positioning rests

While MuseScore will normally avoid collisions with other voices, it can sometimes be helpful to move rests up or down to create more space or to clarify
which voice they apply to.

To move a rest vertically, select it and press Up or Down to move it a staff space at a time.
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For more information on manual positioning, see Changing position of elements.

You can also change the default vertical offset between rests and elements in other voices from 1 space to 2 spaces in Format→Style…→Rests

Changing voice of existing notes

Notes originally entered into one voice can be moved into another voice, depending on the situation. For more information, see Changing voice in normal
mode.

Combining voices into chords

In cases where the rhythms match, notes originally entered as multiple voices can be combined into chords in a single voice. For more information, see
the Implode command.

Separate chords into Voices

To separate a chord written in one voice into separate notes of different voices:

Manually select the notes
Press the toolbar button to assign a Voice to selected notes, or use the Ctrl+Alt+1–Ctrl+Alt+4 Keyboard shortcuts.

Explode onto an empty stave, and then implode. See Implode and explode

See also
Instrument Parts (and see Part in the Glosary)
Editing notes and rests
Stems and flags
Positioning of elements
Implode and explode

Alternative note input methods

Accessing alternative note input methods
In addition to the default step-time note entry method, there are several other methods by which notation can be entered in MuseScore.

To enter these alternative note input methods:

Click and hold the Note input button in the Note input toolbar.
Select from one of the available note input methods.

Keyboard users can get to the Note input button by pressing Shift+Tab or Shift+F6 a few times from the score. Screen readers will say something like
"Note input toolbar: Default (step-time)". Press Space on this button to open a menu that contains all the available note input methods.

Each note input mode can also be activated directly using an assigned keyboard shortcut (See Keyboard shortcuts to learn how to assign these).

Note that the selected note input method remains in effect even when you leave note input mode and will be enabled the next time you enter note input
mode. So if you change to the Re-pitch method for a single passage, be sure to change back to the Step time method when you are done.
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Rhythm only
The Rhythm note input method allows you to enter durations with a single keypress. This is especially useful for unpitched percussion instruments that
use a single sound. In addition, you can combine Rhythm and Re-pitch methods for an efficient workflow in certain circumstances.

Select your starting point in the score.
Select the Rhythm note input method as described above.
Select a duration from the note input toolbar, or use the keyboard shortcuts 1-9, to add a note of the selected duration.
Add a dotted duration by pressing . and selecting/typing your desired duration. In this mode, the duration dot is toggled on/off for all subsequently
entered durations. It's worth noting that the duration dot needs to be activated prior to entering the note value, rather than afterwards.
Enter rests by clicking the rest icon in the note input toolbar and select/type your desired duration. When the desired duration already has been
selected (from the previous entered note), pressing 0 will enter the rest. Click the rest button to return to entering notes.
Continue pressing duration keys to enter notes with the chosen durations.

By default, notes are entered onto the middle staff line. You can use the cursor keys to change the pitch of the note just entered, and subsequent notes
will also be entered using that pitch. You can also use Re-pitch mode to quickly enter pitches for a passage after entering the rhythm.

Re-pitch
The Re-pitch note input method allows you to change the pitches of a sequence of notes while leaving their durations unaltered.

Select your starting point in the score.
Select the Re-pitch note input method as described above, or use the keyboard shortcut Ctrl+Shift+I (Mac: Cmd+Shift+I).
Enter pitches using the computer keyboard, MIDI keyboard or virtual piano keyboard. Note: you cannot use the mouse to input notes in the Re-
pitch method.

The Re-pitch method can be an extremely efficient way of entering notes in music with repeated rhythmic patterns. Simply copy and paste an existing
passage that uses the same rhythm as your new passage, then use re-pitch mode to alter the pitches. The same technique can be used to enter multiple
instrumental or vocal parts that share the same rhythm but different pitches.

Real-time
The real-time note input methods basically allow you to perform the piece on a MIDI keyboard (or MuseScore's virtual piano keyboard) and have the
notation added for you. However, you should be aware of the following limitations which currently apply:

You must pre-select the shortest duration you wish to use.
You cannot enter tuplets in Real-time note input.
You must enter notes onto a single staff and in a single voice, just as with other note input modes.
It is not possible to use a computer keyboard for Real-time note input.

These restrictions mean that MuseScore has very little guessing to do when working out how your input should be notated, which helps to keep these
methods accurate.

Real-time (metronome)

With the Real-time (metronome) note input method, you play at a fixed tempo indicated by a metronome click. You can adjust the tempo by changing
the delay between clicks from the menu: Edit→Preferences...→Note Input (Mac: MuseScore→Preferences...→Note Input).

Select your starting position in the score.
Select the Real-time (metronome) note input method as described above.
Select a duration from the note input toolbar to represent the metronome click.
Press and hold a MIDI key or virtual piano key to enter a note of the selected duration.
Listen for the metronome clicks—with each click the note grows by the selected duration.
Release the key when the note has reached the desired length.

The score stops advancing as soon as you release the key. If you want the score to continue advancing—necessary to enter rests—then you can use the
Real-time Advance shortcut to start the metronome. The same action will stop the metronome again.

Real-time (foot pedal)

With the Real-time (foot pedal) note input method, you indicate your input tempo by tapping on a key or pedal. You can play at any speed you like, and it
doesn't have to be constant. The default key for setting the tempo (called "Real-time Advance") is Enter on the numeric keypad (Mac: Fn+Return), but it is
highly recommended that you change this to a MIDI key or MIDI pedal (see below).

Select your starting position in the score.
Select the Real-time (foot pedal) note input method as described above.
Select a duration from the note input toolbar to represent the metronome click.
Press and hold a MIDI key or virtual piano key.
Press the "Real-time Advance" shortcut with each press, the note grows by the selected duration.
Release the note when it has reached the desired length.

Real-time Advance shortcut

The "Real-time Advance" shortcut is used to start the metronome with the Real-time (metronome) method or to tap beats with the Real-time (foot
pedal) method. It is called "Real-time Advance" because it causes the input position to move forward, or "advance", through the score.

The default key for Real-time Advance is Enter on the numeric keypad (Mac: Fn+Return), but it is highly recommended that you assign this to a MIDI key
or MIDI pedal via MuseScore's MIDI remote control. The MIDI remote control is available from the menu: Edit→Preferences...→MIDI mappings (Mac:
MuseScore→Preferences...→MIDI mappings).
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https://musescore.org/en/print/book/export/html/329209?toc=1#undefined-re-pitch
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329660-piano-keyboard-entry
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329660-mouse-entry
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329660-piano-keyboard-entry
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Alternatively, if you have a USB footswitch or computer pedal which can simulate keyboard keys, you could set it to simulate Enter on the numeric
keypad.

Insert
Insert note input method allows you to insert and delete notes and rests within measures, automatically shifting subsequent music forward and backward
within the measure. The measure duration is automatically updated as you go.

To insert a note:

Select your starting position in the score.
Select the Insert note input method as described above.
Enter a note or rest as you would in Step time mode. Each note is inserted before the current cursor position, and the measure duration is
increased to compensate.

When the notes are entered they will be placed just before the selected starting element, which will be highlighted with a square blue marker. The start
element and any subsequent notes or rests within the same measure will be shifted forward. You can move the insertion point forward and backward
using the arrow keys → or ←, and the new insertion point will then be highlighted.

Alternatively, if you have only one or two notes to insert, you can do this directly with the default Step time note input method. Press Ctrl+Shift (Mac:
Cmd+Shift) while adding the note by mouse or keyboard shortcut (A-G).

To insert a rest, first insert a note of the desired duration, then press Delete.

To delete a note or rest, use the shortcut Ctrl+Shift+Delete. The measure duration is decreased to compensate. The shortcut works with both the Step
time and Insert note input methods.

Because inserting and notes may cause the measure duration to increase or decrease beyond what is specified by the time signature, a small "+" or "-"
sign will be shown above the measure when this happens.

Adding and removing measures

Inserting measures
MuseScore allows you to insert or delete measures in the score using a variety of methods. Measures can be inserted:

After a selection
Before a selection
At the start of the score
At the end of the score

Measure context menu

To insert one or more measures:

Right-click on a blank area of a measure
From the context menu, choose Insert measures
From the options presented, choose the location where you want the measure(s) inserted
Complete the dialog box and press OK.

The Properties panel

To insert one or more measures:

Click on a measure
Go to the Properties panel
Click Insert measures in the Measure section
Type the number of measures you wish to insert (or leave it as “1” to insert a single measure)
Select where you want the measure(s) to be inserted from the dropdown menu (or leave it as is to insert the new measure(s) after the selection
point)
Click the + button

This popup remains open until you click another part of the user interface. As such, you can continue pressing the + button as many times as you need to
insert further measures.

https://musescore.org/en/print/book/export/html/329209?toc=1#node-330550-measure-duration
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In addition, you can insert measures from one of two menus:

Note input toolbar

Select something in your score (can be anything except line objects)
Click the + button in the Note input toolbar
Navigate to Measures
Choose where you want the new measure(s) to be inserted

Menu bar

Select something in your score (can be anything except line objects)
Click the Add in the Menu bar
Navigate to Measures
Choose where you want the new measure(s) to be inserted

Inserting measures with keyboard shortcuts

To quickly insert one measure before the selection point:

Select something in your score (can be anything except line objects)
Press Ins

Insert more measures before the selection point by repeatedly pressing Ins.

To quickly insert multiple measures before the selection point:

Select something in your score (can be anything except line objects)
Press Ctrl+Ins (Mac: ⌘+Ins)
Type the number of required measures in the dialog that appears
Click OK

To append to the end of your score, you can use the keyboard shortcut Ctrl+B (Mac: ⌘+B) for a single measure, or Alt+Shift+B (Mac: Option+Shift+B) for
multiple measures.

Add measures to a frame

It is also possible to add measures to a frame in the score:

Click on the frame
Use one of the methods shown under "Note input toolbar" or "Menu bar", or a keyboard shortcut (above).

Deleting measures
To delete one or more measures using keyboard shortcuts:

Select a measure (or hold Shift and select multiple measures)
Type Ctrl+Backspace or Ctrl+Del (Mac: ⌘+Backspace or ⌘+Del).

Alternatively,

Select a measure (or hold Shift and select multiple measures)
Right-click on any measure within the selection
Select Delete measures

You can also:
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Select a measure (or hold Shift and select multiple measures)
Go to Tools
Select Remove selected range

Remove empty trailing measures

To remove any empty measures at the end of your score:

Go to Tools
Select Remove empty trailing measures

See also
Other measure-related pages:

Measure numbering
Measure and multimeasure rests
Pickup and non-metered measures
Measure properties
Mensural notation and Mensurstrich

Selecting elements

You can select elements in MuseScore using the keyboard or mouse. Selections can consist of a single element, a list of individual elements that may
possibly be discontinuous, or a range of measures and staves that includes the elements within it. Certain commands work only on single elements or
lists; some work only on ranges; others work on any type of selection. The documentation for any given command should explain which types of selection
are allowed.

When selected, elements display in blue (or whatever color is defined for the voice the element belongs to).

For range selections, a blue rectangle appears around the entire range.

Selecting a single element
To select a single element with the mouse, simply click it.

To select a single element with the keyboard, use the cursor keys to navigate to the element. Note that there is no separate concept of a “cursor” in
MuseScore that is separate from the selection, except while in Note Input mode. In Normal mode, the left and right cursor keys select elements one by
one as you navigate, so even though there is technically not a cursor, the selection itself acts in a similar way.

By themselves, the cursor keys navigate through notes and rests only. When combined with Alt, they navigate through all elements, including
articulation, dynamics, and other markings.

Notes

A note normally consists of multiple elements: the notehead, stem, flag, dot, accidental, etc. Most commands that operate on a single note expect you to
select the notehead itself.

Chords

The notes of a chord share a single stem and flag. Even a single note can be considered a “chord” in the sense that it consists of these multiple
elements.

To select a complete chord (all noteheads plus the stem and other elements), first make sure nothing is currently selected (you can press Esc to be sure)
and then Shift+click the chord. This creates a range selection that encompasses the chord.

https://musescore.org/en/print/book/export/html/329209?toc=1#undefined-select-range
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Note that the selection may also include content in other voices if present, but see the section on excluding elements from range selections for
information on how to avoid that if necessary.

Overlapping elements

If multiple elements overlap, clicking selects the topmost element. To select the element underneath a currently-selected element, Ctrl+click it. This
deselects the currently-selected element and selects the next element beneath it, if any. Thus, repeated Ctrl+click operations cycle through a set of
overlapping elements.

Selecting a list of individual elements
You can select a list of elements manually by selecting each individually or automatically by using commands to select elements that are similar to a
given element.

Selecting multiple elements manually

To add an element to the list of selected elements, Ctrl+click it. If an element is already selected, Ctrl+click removes it from the list of selected elements.

You can also use Ctrl+click to add or remove individual elements from a range selection. In the process, this converts the selection into a list selection.

If the elements you wish to select are outside of the staff and clear of other elements, you may be able to create a list selection by using Shift+drag to
draw a selection box around the desired elements. If any notes or rests are included, however, a range selection is performed instead.

Selecting similar elements automatically

To select all elements of a given type in the entire score or in a given staff:

Right-click one such element
In the resulting menu, click Select→Similar or Select→Similar on this staff as appropriate

To select all elements of a given type within a range:

Click the first such element
Shift+click the last such element

—OR—

Perform the range selection using the techniques described below
Right-click one element within the range
In the resulting menu, click Select→Similar in this range

To create more complex selections of similar elements:

(Optional) Perform a range selection
Right-click an element
In the resulting menu, click Select→More
Check the desired boxes within the resulting dialog (see below)

The options available in the select dialog will depend on the type of element you right-clicked.

https://musescore.org/en/print/book/export/html/329209?toc=1#undefined-exclude-range
https://musescore.org/en/print/book/export/html/329209?toc=1#undefined-select-range
https://musescore.org/en/print/book/export/html/329209?toc=1#undefined-select-range
https://musescore.org/en/print/book/export/html/329209?toc=1#undefined-select-range
https://musescore.org/en/print/book/export/html/329209?toc=1#undefined-select-range
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The selection options specific to notes are:

Same notehead: notes with the same notehead group (normal, cross, slash, etc.)
Same pitch: notes with the same pitch name, accidental, and octave
Same string: notes with the on the same string (tablature only)
Same type: notes of the same type (normal, acciaccatura, appoggiatura)
Same note type: notes of the same duration, not considering presence of dots or tuplets
Same duration: notes of the same actual duration
Same note name: notes with the same pitch name and accidental, not considering octave
Same staff: notes in the same staff
Same voice: notes in the same voice
In selection: notes within the current selection
Same system: notes in the same system

In addition to the type-specific selection options, there are action options at the bottom of the dialog that are common to all element types. These control
what happens to the selected elements, and only one of these can be chosen at a time:

Replace selection: if checked, this action selection replaces an existing selection
Add to selection: if checked, this action adds elements to an existing selection
Subtract from selection: if checked, this action removes elements from an existing selection

Selecting a range of measures and staves
A range selection includes all elements from a given beginning and ending time position across a given set of staves. It is the usual starting point for
operations such as copy and paste.

Selecting a range by dragging

To select a range of measures and staves with the mouse alone, use Shift+drag to draw a rectangle around it. Note that this is only feasible for relatively
small selections that fit on screen at once.

Selecting a range by clicking

A more flexible method for making selections uses a combination of mouse and keyboard:

Click the first note or rest of the desired selection
Shift+click the last

In between the click and Shift+click, you can use [navigation commands to position the score. This allows you make selections that span several pages.

This method works just as well if you first click the last note/rest then Shift+click the first.

Selecting a range using the keyboard

You can also make range selections using the keyboard alone or primarily:

Select the first note or rest using keyboard navigation or by clicking
Hold Shift while using keyboard navigation to extend the selection as you navigate

The available commands include:

Shift+Left and Shift+Right to extend the selection one note or rest at a time
Shift+Ctrl+Left and Shift+Ctrl+Right to extend the selection one measure at a time (Mac: use Cmd instead of Ctrl)
Shift+Up and Shift+Down to extend the selection one staff at a time
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Shift+Home and Shift+End to extend to the beginning or end of the system
Shift+Ctrl+Home and Shift+Ctrl+End to extend to the beginning or end of the score (Mac: use Cmd instead of Ctrl)

Special range selections

MuseScore includes some special commands to make command selections:

Edit→Select all or Ctrl+A (Mac: Cmd+A) to select the entire score
Edit→Select section to select the current section of the score (everything between the previous and next section breaks)

Excluding elements from a range selection
For certain operations involving range selections, you might want to exclude elements of a given type from the selection. For example, you may wish to
copy the notes, rest, and most other markings in a phrase, but skip the lyrics. Or in a passage with multiple voices, you may wish to delete everything not
in voice 1. To exclude elements of a given type from a range selection:

Perform the range selection normally
Open the Selection Filter with View→Selection filter
Remove the checkmarks next to any element types you want excluded from the selection

Note that if you exclude voice 1, you will not be able to select any measures that lack content in other voices. So be sure to restore voice 1 after
performing the operation for which you are excluding voice 1. For example, if you wish to copy and paste only voice 2, make your range selection, use
the Selection Filter to exclude voice 1, use Edit→Copy or Ctrl+C, then restore the checkbox next to voice 1 before attempting to select the destination
to paste.

Editing notes and rests

Overview
After you have entered notes into your score, you may wish to change something about them - pitch, duration, time position, etc. MuseScore provides a
number of commands for this purpose. Many of the most powerful commands are only available after you leave note input mode and return to normal
mode, but there are a number of quick edits possible while still in note input mode.

Making changes in note input mode
Immediately after entering a note or rest, it is selected, and there are a handful of commands that operate on the selected note or rest while in note input
mode. These commands also work if you use the cursor keys to navigate to a previously-entered note or rest.

Changing duration in note input mode

There are two commands that alter the duration of an existing note or rest while in note input mode:

Shift+W increases the duration
Shift+Q decreases the duration
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Both commands will first add or remove a dot if appropriate, then will move to the next larger or smaller note value. So for instance, pressing Shift+W on a
quarter note changes it into a dotted quarter, and pressing Shift+W again changes it to a half note.

Changing pitch in note input mode

The commands for changing the pitch of a selected note while in note input mode are:

↑ - move pitch up a semitone (spells with sharps)
↓ - move pitch down a semitone (spells with flats)
Alt+Shift+↑ - move pitch up a step diatonically
Alt+Shift+↓ - move pitch down a step diatonically
Ctrl+↑ (Mac: Cmd+↑) - move pitch up an octave
Ctrl+↓ (Mac: Cmd+↓) - move pitch down an octave

Replacing notes and rests in note input mode

Most note input in MuseScore is in what a word processor might call "replace" or "overwrite" mode. This means that if you wish to replace a note with a
different one, you don't need to delete the old note first—just enter the new one directly, and it automatically overwrites what was there before.

Note: sometimes you may wish to add a new note and move some of the subsequent notes later to make room. In MuseScore, this is done by moving
the subsequent notes directly using cut and paste.

Deleting notes in note input mode

To delete a note and replace it with a rest, simply press Del.

Note: if you instead wish to move subsequent notes earlier to take the place of the deleted note, there is no need to first delete the original note - simply
move the subsequent notes directly using cut and paste.

Moving notes in note input mode

Although for the most part, moving notes to a different time position is done in normal mode, there is one pair of commands that can be used to change
the time position of a note or rest in certain cases while in note input. If you have two notes or rests of the same duration and you wish to exchange them
while in note input mode, you can use Shift+← or Shift+→ to exchange a note or rest with its neighbor of the same duration.

Making changes in normal mode
Most changes one might want to make to notes and rests already entered are more easily performed in normal mode—the mode you are in when you
leave note input or any other mode.

Except where noted, the methods described below work on either a single selected note or rest, a list selection consisting of multiple notes or rests, or
entire range selections. See the page on selections for more information.

Changing duration in normal mode

Changing selected notes to a specific note value

To change the duration of one or more selected notes in normal mode to a specific note value, simply click the appropriate duration icon or use the
keyboard shortcuts 1–9.

Increasing or decreasing the duration of a selected note

To increase the duration of a selected note, you can use the Shift+W command as described above. This adds an augmentation dot if one is not already
present, or changes to the next longer note value if the note is already dotted. For example, an eighth note will be changed into a dotted eight note, and a
dotted quarter will be changed into a half note. You can also use W to double the duration, thus changing an eighth note into a quarter note directly, or a
dotted eighth into a dotted quarter.

The commands Shift+Q and Q to perform the opposite operation, decreasing or halving the duration in the same way.

All of these commands work on only a single selected note.

Doubling or halving all note values in a range selection

If you have entered a passage using eighths and sixteenths but wish to double the durations of all notes and rests—thus doubling the duration of the
passage itself—see the section on the paste half/double duration commands.

Changing pitch in normal mode

The same commands that work to change pitch in note input also function in normal mode, including single, list, and range selections. These commands
are:

↑ - move pitch up a semitone (spells with sharps)
↓ - move pitch down a semitone (spells with flats)
Alt+Shift+↑ - move pitch up a step diatonically
Alt+Shift+↓ - move pitch down a step diatonically
Ctrl+↑ (Mac: Cmd+↑) - move pitch up an octave
Ctrl+↓ (Mac: Cmd+↓) - move pitch down an octave

https://musescore.org/en/print/book/export/html/329209?toc=1#node-329659-move
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329659-move
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In addition, when in normal mode, the accidental buttons on the Note input toolbar and corresponding keyboard shortcuts will toggle (add or remove)
accidentals on any selected notes, thus potentially changing their pitch. The Accidentals palette can also be used to add accidentals to selected notes.

Deleting notes and rests in normal mode

To delete a note and replace it with a rest, simply press Del.

If multiple notes are selected as a list, Del replaces them each by rests individually.

If you select a range, Del replaces the entire passage with the correct rests according to the meter.

Rests cannot normally be deleted, as removing them would leave a measure with fewer beats than it should have. However, see the remove selected
range command below for information on how to do this when required. Also, rests in voices 2–4 can be deleted without removing time from a measure.

Removing notes and rests and their associated time

To completely remove selected notes or rests—thus leaving the piece with fewer measures if entire measures are selected, or fewer beats within the
measure if a partial measure is selected—use Tools→Remove selected range or the keyboard shortcut Ctrl+Del (Mac: Cmd+Del).

Adding ties in normal mode

Ties can be added in normal mode, but unlike in note input mode where the tie command automatically adds a note and creates a tie, in normal mode,
both notes must already exist.

To add a tie in normal mode:

Select a note that you wish to tie to the next note of the same pitch
Click the tie button or use the shortcut T

This works even if the next note of the same pitch is in a different voice.

If you select multiple notes, MuseScore will start a tie at each of them. You can use the technique to tie entire chords at once.

This technique also allows you to tie notes that are not adjacent, such as to show an arpeggiate-and-hold pattern on piano.

Changing voice in normal mode

A note entered into a given voice may be moved into another voice if this is musically possible, or the contents of two voices may be exchanged.

Moving selected notes into another voice

To move a selection of one or more notes into another voice, either press one of the voice buttons on the toolbar or use the keyboard shortcuts
Ctrl+Alt+1–4 (Mac: Cmd+Option+1–4). Notes will be moved to the extent it is possible without compromising the current content of the destination voice.

A note can be moved into another voice if there is currently silence (rests, or nothing at all) in the destination voice at that time position for the duration of
the note to be moved. In that case, the note will simply be moved to the new voice.

A note can also be moved into another voice if there is already a note or chord of the same duration starting at that time position. In that case, the note
will be combined with the existing note or chord.

Exchanging the contents of two voices

MuseScore can also exchange the contents of any pair of voices. These commands work only on full measures (or multiple measures), not on individual
notes.

To exchange the contents of any two voices, use the corresponding command in Tools→Voices:

Exchange voice 1-2
Exchange voice 1-3
Exchange voice 1-4
Exchange voice 2-3
Exchange voice 2-4
Exchange voice 3-4

See also
Entering notes and rests

Copy and paste

The cut, copy, and paste commands are powerful tools in MuseScore. They can be used to reproduce entire passages of music, to move music earlier or
later, to copy text or other markings between staves, to exchange the content in different measures, and more.

Accessing the commands
In all cases, the first step is to select what you want to cut or copy.

As with other programs that support cut, copy, and paste, you can access these commands from the Edit menu, from a context menu that appears upon
right-click or related gesture (e.g., Ctrl+click, or two-finger tap), or via the standard keyboard shortcuts.
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Command Shortcut (Windows) Shortcut (Mac) Context menu Main menu
Cut Ctrl+X Cmd+X Cut Edit→Cut
Copy Ctrl+C Cmd+C Copy Edit→Copy
Paste Ctrl+V Cmd+V Paste Edit→Paste
Swap with clipboard Ctrl+Shift+X Cmd+Shift+X Swap with Clipboard Edit→Swap with clipboard
Paste half duration Ctrl+Shift+Q Cmd+Shift+Q N/A Edit→Paste half duration

Paste double duration Ctrl+Shift+W Cmd+Shift+W N/A Edit→Paste double
duration

Note: When using the context menu, take care to always right-click on a selected item; if you right-click on an empty space by mistake your selection will
be lost!

Copying a range
To copy a range—whether a single chord, a single measure, several measures on one staff, or multiple measures across multiple staves—do the
following:

Select the range you want to copy
Use the Copy command from the menu or press Ctrl+C (Mac: Cmd+C)
Select the first note or rest of the destination

Use the Paste command from the menu or press Ctrl+V (Mac: Cmd+V)

Copied music will replace the existing content of the destination. All elements in the selected range will be copied, with the exception of system-wide
elements such as tempo text, key and time signature changes, and repeats. You can use the Selection Filter to exclude other elements of a given type
from the operation.

Copying a single element or list of elements

https://musescore.org/en/print/book/export/html/329209?toc=1#node-329658-select-range
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329658-exclude-range
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MuseScore allows you to copy lyrics, chord symbols, dynamics, articulation, or other markings from one place to another while keeping the notes in the
destination intact. For chord symbols and dynamics, MuseScore will preserve the relative beat positions of the markings if possible. For lyrics and
articulations, MuseScore will copy note by note.

To copy a single element or list of elements to a new destination:

Select the elements you want to copy
Use the Copy command from the menu or press Ctrl+C (Mac: Cmd+C)
Select the first note or rest of the destination
Use the Paste command from the menu or press Ctrl+V (Mac: Cmd+V)

Moving elements
In MuseScore, cut and paste is way to move element from one location to another. This can be used to move a passage from a flute part to a clarinet
part, from one measure to another within a single part, or simply shift a passage earlier or later. The latter is especially useful as a way to “insert” or
“delete” a note or rest while shifting existing notes to the right or left. Simply cut and paste the notes you wish to shift to their new position.

To move a selection:

Select what you want to move
Use the Cut command from the menu or press Ctrl+X (Mac: Cmd+X)
Select the first note or rest of the destination
Use the Paste command from the menu or press Ctrl+V (Mac: Cmd+V)

Swapping a selection with the clipboard
The swap with clipboard command combines two operations into one: (1) First it overwrites a selected part of the score with the contents of the
clipboard, just like the paste command; (2) Second, it transfers the overwritten part of the score back to the clipboard, just like the copy command.

It can be used, for example, to swap two equal-length sections of a score, A and B:

Select section A
Apply the cut command
Select section B
Apply the swap with clipboard command to paste A over the contents of B while moving the contents of B to the clipboard
Select section A again (or just the first note, rest, or measure)
Apply the paste command

Like the other commands discussed here, you can access the swap with clipboard command from the menu or via a keyboard shortcut—in this case, it
is Ctrl+Shift+X (Mac: Cmd+Shift+X).

Repeating a selection
A common use for copy and paste is to duplicate a given passage immediately after the original. MuseScore provides a special repeat selection
command to simplify this process. To quickly repeat a note, chord, measure, or other passage to the location immediately following the selection:

Select the passage to be repeated
Press R

Unlike the other commands discussed here, repeat selection works in note input mode and it repeats the entire chord containing the selected note. This
is useful for creating a series of repeated chords.

Copying a selection to multiple staves
If you wish to copy a passage to multiple staves—for instance, to double a flute part in the oboes and clarinets—you can use the explode command:

Select the passage you wish to copy
Extend the selection to include the staves below (e.g., by pressing Shift+↓)
Use Tools→Explode

This copies the original selection, assuming it contains only single notes—no chords and no multiple voices. If there are chords or multiple voices, then
these are distributed among the remaining staves as described in the section on the explode command.

Paste half/double duration
If you have entered a passage using mostly eighth notes but wish to halve the entire passage to using mostly sixteenth notes, or double it to quarter
notes, MuseScore provides a pair of special commands to accomplish this. You can either modify the durations of a selection in place or create a
separate copy of the passage with the modified durations. To halve or double the duration of a passage:

Select a range to modify
Use the copy command
If you wish to create a separate copy of the passage with the modified durations, select the destination
Use the paste half duration or paste double duration command

Duplicating individual elements
Individual elements—even those that are not normally copied as part of a range select, like time signatures or voltas—can be duplicated using the
mouse:

https://musescore.org/en/print/book/export/html/329209?toc=1#node-329658-select-list
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While pressing Ctrl+Shift (Mac: Cmd+Shift), and click and hold on an element
Drag it anywhere in the score

When you release the mouse button, the selected element is copied to the new location

See also
Selecting elements
Implode and explode

Using the palettes

Overview
Musical symbols and text may be applied to your score using the Palettes panel. MuseScore comes with a set of preset palettes divided into categories
—such as Key Signatures and Articulations etc. A basic working set of palettes is visible by default, but more advanced or specialist palettes can also
be displayed if required.

You can add, delete, edit and rearrange items inside any palette, as well as create and customize your own palettes.

This chapter shows you how to display palettes, search for items, and how to apply palette symbols to your score. Customizing the palettes area is dealt
with later in Palettes (Customization).

Accessing the palettes panel
The Palettes panel is normally displayed on the left sidebar of the main window. There are three tabs displayed at the top of the sidebar: Palettes,
Instruments, and Properties. If one of the other tabs is currently being displayed in the sidebar, click the Palettes tab to display the palettes instead.

You can open and close the Palettes panel using View→Palettes or the keyboard shortcut F9. If all of the panels in the sidebar are closed, the sidebar
itself closes as well, allowing more room for the score display.

Like most other panels within MuseScore, the Palettes can also be undocked to function as a separate window.

Adding palette items to your score
To add a palette item to your score, first open the appropriate palette if it is not already open, by clicking its title or the arrow icon to the left. The items in
that palette will be displayed in a grid.

https://musescore.org/en/print/book/export/html/329209?toc=1#node-330541-dock-undock-panels
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in general, to apply palette items to your score, you can either select the target elements in the score and then click the palette item, or drag the item from
the palette to a target element. See the section on searching and navigating below for information on applying palette items via the keyboard.

Items applied to individual score elements

Many palette items—for example, articulations, dynamics, and most other text—can be applied to individual notes, rests, or other score elements. When
using drag and drop, be sure to drag the palette item onto a specific score element, and do not release until the target element highlights to indicate it can
accept the palette item.

It is usually more efficient, however, to select the target elements in your score first and then click the palette item. This is especially true if you wish to
apply the same palette item to multiple score elements, since this method allows you can apply the palette item to multiple score elements at once.

To apply a palette to one or more score elements:

Select the elements you wish to apply the palette item to (single, list, or range selection)
Click the palette item

The palette item will normally be added to each of the selected elements. Note that with a range selected, when clicking a palette item representing text
(including dynamics and tempo markings), the item will be added to the first element in the range only. System text (including tempo markings) will be
applied to the top staff only; other text will be applied to the first selected element of each selected staff.

Items applied to ranges

Palette items such as hairpins, slurs, ottavas, and pedal markings are applied to a range rather than a single note or rest. The process for adding them is
the same:

Select the range of elements you wish to apply the palette item to
Click the palette item

Items applied to full measures

Certain palette items such as barlines, time signatures, voltas, and layout breaks are normally applied to a measure as a whole—or a range of measures
—instead of a specific note or rest. The process for adding these to the score is the same as for other palette items:

Select the measure or range of measures you wish to apply the palette item to
Click the palette item

Expanding and collapsing palettes
A palette can be opened (expanded) or closed (collapsed) individually by clicking on the title bars or the icon to the left of the title. In addition, you can
expand or collapse all palettes at once, or let MuseScore close palettes automatically. To access these options, click the ... button at the top of the
palette window to popup the palettes menu.

https://musescore.org/en/print/book/export/html/329209?toc=1#undefined-search-navigate-palettes
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Single-click to open a Palette: controls whether palettes are opened by single or double click
Open only one Palette at a time: if checked, then whenever you open a palette, any already-open palettes are automatically closed
Collapse all Palettes: immediately close all open palettes
Expand all Palettes: immediately open all palettes

Searching and navigating the palettes
You can also search and navigate the palettes using your keyboard instead of a mouse.

Search

To search for palette elements by name, use the keyboard shortcut Ctrl+F9 (Mac: Cmd+F9), or click the magnifying glass icon at the top of the Palettes
panel.

This will display a search box. As you type characters into the box, MuseScore will display any matching palette items.

To close the search box, click the "X" icon.

Navigation

The palettes are completely accessible by keyboard. The search facility described above is one method you can use to start the process, but you can
also focus the keyboard on the Palettes panel by using Shift+F6 to move focus to the sidebar.

Once focus is on the palette panel, the ↑ and ↓ keys will move through the various individual palettes. You can then open and close a palette by pressing
Enter. To access the elements with a palette, press → to access the palette, then ↑ and ↓ to move through the elements on the palette. Pressing Enter will
apply element in the same way as clicking it.
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Accessing more palette items
Some palettes also contain additional elements that are not displayed by default. To access those, click the More button at the bottom right of the palette.

You can add any of these additional items to the main part of the palette by simply dragging. For more information, see Palettes under Customization.

Adding more palettes
The palettes that are shown by default are the ones most users will need often. But MuseScore provides additional palettes that you may also find useful.

To access these extra palettes:

Click the Add Palettes button at the top of the Palettes panel.

This will display a list of palettes you can add to your Palettes panel. To add any palette, click the + button next to the palette name.

Added palettes appear at the top of the panel. To reorder them simply drag them into position.

You can also create an empty custom palette that can be filled later with your own choice of elements.
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Clicking the Create custom palette button, see Palettes (Customization).

The Master palette
The Master palette is MuseScore’s repository of all musical symbols; it also provide an alternative pathway for creating custom key signatures and
custom time signatures.

To display the Master palette, use the keyboard shortcut Shift+F9, or from the menu select View→Master palette.

The Master palette window is divided into categories matching the names of the default palettes (whether displayed or hidden) in the Palettes panel; in
fact, the contents of each small palette are drawn from the corresponding section of the Master. The exception is the Symbols category of the Master
palette which contains items not found in the Palettes panel.

Items can be applied to the score from the Master palette in the same way as from the small palettes; however, aside from applying items from the
Symbols section, it is usually better to do so from the Palettes panel.

Items found in all sections of the Master palette window, except "Symbols", are functional in that they have an effect on the score: Key and Time
signatures, for example. However, items from the Symbols palette are non-functional—that is, they are for display only.

See also, the chapter on Other symbols.

See also
Palettes (Customization) for information about customizing the palettes panel.
Other symbols for information about the Symbols palette.
Working with images for information about how to add images to your score.

Properties panel

The Properties panel shows settings for objects you select in the score. It was known as the “Inspector” in MuseScore 2 and 3.

You can select one object (say, a dynamic mark) or multiple objects at a time (say, a dynamic mark, a notehead, and a hairpin). If any of the objects you
have selected contains editable settings, Properties will be the place to find them.

An important thing about Properties is that by default it affects only the object(s) you have selected, so changing how one hairpin looks won’t change all
of the hairpins in your score—only those you have selected. However, for most settings, you can also choose to save as the default style for the score.

Accessing the Properties panel
From the Score window, click on the Properties tab in the panel on the left side of the screen:

https://musescore.org/en/print/book/export/html/329209?toc=1#node-329687-custom-key-sig
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329680-custom
https://musescore.org/en/print/book/export/html/329209?toc=1#undefined-default
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Global settings
This is what the Properties panel looks like when you have nothing selected in your score. All these settings affect your entire score (not just individual
elements):

Show

Invisible hides/shows all invisible objects in your score
Frames hides/shows Frames
Formatting hides/shows formatting elements added from the layout palette
Page margins hides/shows the page margin

Score appearance

Empty staves hides/shows staves that contain no notated music within a system. This setting mirrors the Hide empty staves within systems
settings in the Style dialog.
Page settings triggers the Page settings dialog.
Style settings triggers the Style dialog.

General settings
These settings are visible whenever something is selected in your score.

Visible

Click this box to hide/unhide selected elements, or use the keyboard shortcut V.

Use this feature to hide elements so they don't appear in your exported or printed score. This can be useful when, for example, applying tempo marks or
dynamics solely to affect playback in MuseScore. Use the Invisible toggle in Properties (when nothing is selected) to show or hide these hidden
elements in the score view (hidden elements will be rendered in a lighter shade).

Auto-place

https://musescore.org/en/print/book/export/html/329209?toc=1#node-329734-Frames
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329663-layout-palette
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329732-page-settings
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Usually checked by default, this feature positions the selected object according to MuseScore's vertical and horizontal collision avoidance algorithms.
Uncheck Auto-place to have more control over the positioning of certain elements. Learn more about this feature in Positioning elements.

Cue size

This feature is used to create small cue notes: i.e. notes provided to assist the performer by indicating what another ensemble/orchestra member is
playing at the same time. Checking the box makes any selected notes smaller, including their stems and any attached beams.

Play

When checked, this property allows playback of the selected element. Uncheck Play to silence the element.

Playback settings
The Playback button displays the editable playback properties of the element (if none, it will be greyed out).

Appearance settings
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Leading space

This changes the leading space of selected elements: i.e. the space in front of the element. The leading space adjustment is applied across all staves, so
that notes at the same time position remain aligned.

Measure width

This changes the width of the measure as a proportion of the original width: e.g. 1.5 = one-and-a-half times the default width.

Minimum distance

This is used by the auto-place collision avoidance algorithm and applies only to elements that are applied above/below the staff by default, such as staff
text, dynamics, fingerings, lines etc. It sets the minimum distance (in sp.) of the selected objects from other elements that are closer to the staff, or the
staff itself.

Offset

When newly applied, elements assume a default position. The horizontal/vertical offsets give you a more precise way of positioning an element than
dragging it or moving with the keyboard arrows.

Snap to grid

This feature allows you to constrain drag operations to increments of a desired distance. First you need to check the Snap to grid box, then press
Configure grid and set the desired horizontal/vertical step distances.

You can switch Snap to grid on/off as required by checking/unchecking the box.

Arrange

The four buttons in this section control how overlapping elements are drawn. They work as follows:

Forwards moves the selected element in front of the next element
Backwards moves the selected element behind the next element
To front moves the selected element in front of all other elements.
To back moves the selected element behind all other elements, including the staff lines.

Color

Click on this button to change the color of selected element(s). Choose a preset or custom color, or create your own by clicking the + button. This is
stored for future reference in the list of custom colors to the right.

Saving and restoring default settings
After changing any given setting, you can click the "three dots" menu button adjacent to the setting to reveal a menu that allows you to either Reset the
setting to the default for the score, or Save as default style for this score. The latter option is only available for properties that correspond to style
settings, but this includes many of the properties in this panel.

https://musescore.org/en/print/book/export/html/329209?toc=1#node-329757-spatium
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Adjusting elements directly

Changing the position of elements
To reposition most score elements, use any of the following methods:

Click and drag the element with your mouse (see also Snap to grid).
Press the keyboard arrows, either on their own for small steps (0.1 sp), or in combination with Ctrl (Mac: ⌘) for larger steps (1 sp).
Adjust the horizontal and vertical offsets in the Properties panel.

Certain score elements, such as articulations, ornaments, symbols, and notes and rests, can only be moved with the keyboard arrow keys after placing
the element into "Edit mode". To move these elements with the arrow keys:

Right-click on the desired element
Select Edit element to place the object in "Edit mode", or use the keyboard shortcuts F2 or Alt+Shift+E (Mac: ⌥+Shift+E)
Use the ← → ↑ ↓ keys to move the object in increments of 0.5 sp, or click and drag it with the mouse

Changing the shape of elements
To change the shape of elements such as slurs and ties after adding them to the score:

Click on the slur or tie to be adjusted
Click and drag the adjustment handles that appear around the element (N.b. red letters in the below diagram are for reference only)

Note that:

Handles B, C, and D change the shape of the curve at that point
Handles A end E adjust the element's length (This can also be achieved by pressing Shift+←/→ to move the ends one chord/rest at a time)
Handle F repositions the whole line without changing its shape or length

If you wish to change the note to which a slur or tie is connected, the recommended method is to use the keyboard shortcuts described above (Shift+←/
→). This is the most efficient way of changing both the visual and playback range of notes encompassed by a slur or tie.

Working with lines
Changing the range of a line

To change the start and end points of a line:

Select the line to reveal its adjustment handles

Click either the start or end adjustment handle
Press Shift+←/→ to move the handle one step at a time (a step = one note/rest, or one measure—depending on the line type). Note: You can use
Tab to move the focus between handles when adjusting.
Fine-tune the position of handles using the keyboard arrows ←/→ if required. Note that this does not affect the playback range of the line.

As with slurs and ties, it is recommended to use Shift when adjusting line length with the arrow keys to ensure that the playback range also adjusts
accordingly.

Creating diagonal lines

Although lines are horizontal by default, they can be set at any angle simply by dragging the start or end adjustment handles; or by selecting a start/end
handle and using the Up/Down keyboard arrows.

Editing line text

To edit the text of text line elements such as "system text line", "staff text line", and "barré line":

Select a text line element in your score
Go to the Properties panel
Click the Text tab in the Text line section
Enter the desired text in the Beginning text field.

Note: If the text line spans more than one system, you may also wish to modify the contents of the Text when continuing to a new system field.

See also
Other lines: Line properties
Positioning of elements

Parts

https://musescore.org/en/print/book/export/html/329209?toc=1#node-329664-appearance
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329660-ties
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MuseScore in Minutes: Layouts & Parts

Opening a part
MuseScore 4 automatically creates a separate (default) part for every instrument in your score.

To open all parts at once:

Click Parts in the toolbar (This will open the Parts dialog)
Click Open all

To open an individual part:

Click Parts in the toolbar
Click a part to select it
Click Open selected

You can also select specific parts to open at once. Do this by holding Control (Mac: ⌘) while selecting the parts you’d like to open, then click Open
selected. You can also select a range of contiguous parts by clicking the first and holding Shift while clicking the last.

Closing a part
Click the X close button in a part tab to close a part.

Note that changes you make to a part will be saved with that part and retrievable the next time you open it from the Parts dialog.

Creating custom parts
The Parts dialog is tightly integrated with the new Instruments panel. This integration makes it easy for you to create parts with any combination of
instruments from your score.

There are two ways to customize parts in MuseScore 4: using the default (i.e. ready-made) parts to reveal other instruments, and creating entirely new

https://www.youtube.com/watch?v=owDxvIQK4mE


14/09/2023, 18:51Handbook for MuseScore 4

Page 82 of 270https://musescore.org/en/print/book/export/html/329209?toc=1

parts.

Reveal instruments in default parts

As we’ve already seen, MuseScore 4 automatically creates a new (default) part for every instrument in your score. All you have to do is open the part
from the Parts dialog.

In fact, each default part already contains all of the instruments in your score – they’re simply hidden from view (except, of course, the chosen part
instrument).

This means you can “reveal” other instruments within any of the default parts. To do this:

Open a part (as described above)
Select the Instruments panel
Click the eye icon next to another instrument

This instrument will now be visible in the chosen part.

This makes creating custom parts an incredibly flexible process. Revealing or hiding other instruments is completely non-destructive, meaning you can
customize every instrument in every part, and hide or show only what you want to reveal to different players (or for different musical projects) without
having to create entirely new parts each time.

Create a new part

MuseScore 4 does of course give you the option to create a completely "blank" part from scratch, allowing you complete customization control. To do this:

Click Parts in the toolbar to open the Parts dialog
Click Create new part
Give your new part a name
Click Open selected

Your new part will now be open in the Score tab, but it will appear to contain no instruments. To add instruments to this part:

Go to the Instruments panel
Click the "eye" icon next to each instrument you’d like to appear in your part

Choose which voices appear in each part

Sometimes it will be necessary to create individual parts from staves that contain multiple voices. You might, for example, want to extract separate parts
for orchestral players who share a staff in the main score (E.g. Flute I and Flute II). Or you might wish to create individual vocal parts from choral scores
where, for example, four voices are notated across two staves.

You'll need to first create (see above) or duplicate (see below) a part. To then select which voices will appear in a part:

Open a part (see above)
Go to the Instruments panel
Expand an instrument by clicking on the triangular dropdown icon
Click the settings icon next to the staff name
Select which voice(s) you want to appear in your part by ticking/un-ticking the checkboxes under Voices visible in the score

Applying styles to parts
Style settings for a wide range of engraving elements can be applied specifically to parts without affecting the main score.

To change style settings for a specific part:

Ensure a part has been opened and is currently selected in the Score tab
Go to Format → Style...
Make your desired style settings changes (applicable changes will be visible in the score in real time)
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Click OK to confirm your changes

Changes you make in this dialog will affect only the part selected in the Score tab. If you want changes to affect all parts (but not the main score), select
Apply to all parts before clicking OK.

Learn more about saving and loading default style settings in Templates and styles.

Renaming, duplicating and deleting parts
This all takes place in the Parts dialog (accessible from the Parts button in the toolbar).

Simply click the "three dots" menu icon next to a selected part to reveal its options. Note that only newly created parts (created by clicking the Create
new part button) can be deleted. All parts can be duplicated or renamed.

To duplicate any part:

Select a part in the Parts dialog
Click the "three dots" menu icon for the selected part
Select Duplicate from the context menu that appears
Enter a new name for the part (or leave the default name as is)
Hit Enter, or click anywhere in the Parts dialog

To rename any part:

Select a part in the Parts dialog
Click the "three dots" menu icon for the selected part
Select Rename from the context menu that appears
Type your new part name
Hit Enter to confirm the new name

Note you can also double click on any part in the Parts dialog to rename it.

To delete a newly created part:

Select a newly created part in the Parts dialog
Click the "three dots" menu icon for the selected part
Select Delete from the context menu that appears

When a part is deleted, its tab in the Score tab (if already opened) will be closed. Any customizations made to that part will also be lost. The part will also
no longer appear in the Parts dialog.

Exporting and printing parts
To export parts:

Click File → Export... (alternatively, select the Publish tab and click Export...)
Check the box next to the part(s) you want to export, or click Select all to choose all parts at once
Select whether to export all parts combined in one file, or leave the default export setting as each part to a separate file
Click Export...
Select your destination file and name your score in your operating system's Export dialog
Click Save

Parts will be exported in the PDF format by default. To change the export format, select your preferred format from the dropdown menu in Export
settings. You can export your parts in a range of image and audio formats, as well as the braille format for compatible printers. For more information, see
File Export.

To print parts:

Ensure the part you wish to print is selected in the Score tab
Click File → Print



14/09/2023, 18:51Handbook for MuseScore 4

Page 84 of 270https://musescore.org/en/print/book/export/html/329209?toc=1

Use your operating system's print dialog to print the selected part

Note that parts can currently only be printed one at a time.

Default keyboard shortcuts

On macOS, make the following substitutions:

Replace Ctrl with Cmd (or ⌘)
Replace Alt with Option (or ⌥)
Replace Home with Fn+Left
Replace End with Fn+Right
Replace PgUp with Fn+Up
Replace PgDn with Fn+Down
Add Fn with function keys

Navigation
Page navigation

Action Windows/Linux macOS
Zoom in Ctrl+= Cmd+=
Zoom out Ctrl+- Cmd+-
Zoom to 100% Ctrl+0 Cmd+0
Go to first element in score Ctrl+Home Cmd+Fn+Left
Go to last element in score Ctrl+End Cmd+Fn+Right
Jump to next screen PgDn Fn+Down
Jump to previous screen PgUp Fn+Up
Jump to top of first page Home Fn+Left
Jump to bottom of last page End Fn+Right
Jump to next page Ctrl+PgDn Cmd+Fn+Down
Jump to previous page Ctrl+PgUp Cmd+Fn+Up
Find / Go to Ctrl+F Cmd+F

Score navigation

Action Windows/Linux macOS
Select next chord Right Right
Select previous chord Left Left
Go to next measure Ctrl+Right Cmd+Right
Go to previous measure Ctrl+Left Cmd+Left
Select next element in score Alt+Right Option+Right
Select previous element in score Alt+Left Option+Left
Select note/rest above Alt+Up Option+Up
Select note/rest below Alt+Down Option+Down

Note input
General

Action Windows/Linux macOS
Note input: toggle note input mode N N
Show/hide piano keyboard P P
Use voice 1 Ctrl+Alt+1 Cmd+Option+1
Use voice 2 Ctrl+Alt+2 Cmd+Option+2

Duration

Action Windows/Linux macOS
Set duration 1 – 9 1 – 9
Set duration: 32nd note 2 2
Set duration: 16th note 3 3
Set duration: 8th note 4 4
Set duration: quarter note 5 5
Set duration: half note 6 6
Set duration: whole note 7 7
Toggle duration dot . .
Enter tuplet Ctrl+2 – Ctrl+9 Cmd+2 – Cmd+9
Enter tuplet: duplet Ctrl+2 Cmd+2
Enter tuplet: triplet Ctrl+3 Cmd+3
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Enter tuplet: quadruplet Ctrl+4 Cmd+4
Add tied note T T
Halve selected duration (includes dotted values) Shift+Q Shift+Q
Double select duration (includes dotted values) Shift+W Shift+W

Pitch

Action Windows/Linux macOS
Enter note A – G A – G
Add note to chord Shift+A – Shift+G Shift+A – Shift+G
Enter interval Alt+1 – Alt+9 Option+1 – Option+9
Toggle accidental: flat - -
Toggle accidental: natural = =
Toggle accidental: sharp + +
Enter rest 0 0
Add grace note: acciaccatura / /

Tablature

Action Windows/Linux macOS
Set duration (TAB) Shift+0 – Shift+9 Shift+0 – Shift+9
Set duration: 32nd note (TAB) Shift+2 Shift+2
Set duration: 16th note (TAB) Shift+3 Shift+3
Set duration: 8th note (TAB) Shift+4 Shift+4
Set duration: quarter note (TAB) Shift+5 Shift+5
Set duration: half note (TAB) Shift+6 Shift+6
Set duration: whole note (TAB) Shift+7 Shift+7
Enter TAB: fret 0 – 9 0 – 9
Enter TAB: fret A – K A – K
Go to string above (TAB) Up Up
Go to string below (TAB) Down Down
Toggle ghost note Shift+X Shift+X

Selecting
Action Windows/Linux macOS

Select all Ctrl+A Cmd+A
Add to selection: previous note/rest Shift+Left Shift+Left
Add to selection: next note/rest Shift+Right Shift+Right
Add to selection: staff above Shift+Up Shift+Up
Add to selection: staff below Shift+Down Shift+Down
Select to beginning of measure Ctrl+Shift+Left Cmd+Shift+Left
Select to end of measure Ctrl+Shift+Right Cmd+Shift+Right
Select to beginning of score Ctrl+Shift+Home Cmd+Shift+Fn+Left
Select to end of score Ctrl+Shift+End Cmd+Shift+Fn+Right

Editing
General

Action Windows/Linux macOS
Escape Esc Esc
Undo Ctrl+Z Cmd+Z
Redo Ctrl+Shift+Z Cmd+Shift+Z
Copy Ctrl+C Cmd+C
Cut Ctrl+X Cmd+X
Paste Ctrl+V Cmd+V
Repeat selection R R
Insert one measure before selection Ins Ins
Insert measures before selection Ctrl+Ins Cmd+Ins
Insert one measure at end of score Ctrl+B Cmd+B
Insert measures at end of score Alt+Shift+B Option+Shift+B
Delete Del Del
Delete selected measures Ctrl+Del Cmd+Del
Show/hide properties F8 Fn+F8

Edit element F2 Fn+F2
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Duration

Action Windows/Linux macOS
Set duration 1 – 9 1 – 9
Enter tuplet Ctrl+2 – Ctrl+9 Cmd+2 – Cmd+9
Add tied note T T

Pitch

Action Windows/Linux macOS
Toggle accidental: flat - -
Toggle accidental: natural = =
Toggle accidental: sharp + +
Move pitch/selection up Up Up
Move pitch/selection down Down Down
Move pitch up an octave Ctrl+Up Cmd+Up
Move pitch down an octave Ctrl+Down Cmd+Down
Change enharmonic spelling (concert and written
pitch) J J

Move note to higher string (TAB) Ctrl+Up Cmd+Up
Move note to lower string (TAB) Ctrl+Down Cmd+Down

Notation

Action Windows/Linux macOS
Flip direction X X
Use voice 1 Ctrl+Alt+1 Cmd+Option+1
Use voice 2 Ctrl+Alt+2 Cmd+Option+2

Manual adjustment

Action Windows/Linux macOS
Move text left Left Left
Move text right Right Right
Move text left quickly Ctrl+Left Cmd+Left
Move text right quickly Ctrl+Right Cmd+Right
Move selection up Up Up
Move selection down Down Down
Move selection up quickly Ctrl+Up Cmd+Up
Move selection down quickly Ctrl+Down Cmd+Down

Text
General

Action Windows/Linux macOS
Add text: staff text Ctrl+T Cmd+T
Add text: expression text Ctrl+E Cmd+E
Add text: system text Ctrl+Shift+T Cmd+Shift+T
Add text: tempo marking Alt+Shift+T Option+Shift+T
Add text: rehearsal mark Ctrl+M Cmd+M

Formatting

Action Windows/Linux macOS
Format text: bold face Ctrl+B Cmd+B
Format text: italic Ctrl+I Cmd+I
Format text: underline Ctrl+U Cmd+U

Lyrics

Action Windows/Linux macOS
Add text: lyrics Ctrl+L Cmd+L
Go to next syllable Space Space
Go to previous syllable Shift+Space Shift+Space
Lyrics: enter hyphen - -
Lyrics: enter melisma _ _
Add lyric verse Return Return
Go to next lyric verse Down Down
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Go to previous lyric verse Up Up

Chord symbols, Roman numeral analysis, Nashville numbers, figured bass

Action Windows/Linux macOS
Add text: chord symbol Ctrl+K Cmd+K
Next text element Space Space
Previous text element Shift+Space Shift+Space
Advance cursor: next beat ; ;
Advance cursor: previous beat Shift+; Shift+;
Advance cursor: duration Ctrl+1 – Ctrl+9 Cmd+1 – Cmd+9

Other score elements
Action Windows/Linux macOS

Show/hide palettes F9 Fn+F9
Search palettes Ctrl+F9 Cmd+Fn+F9
Add slur S S
Add articulation: accent Shift+V Shift+V
Add articulation: marcato Shift+O Shift+O
Add articulation: staccato Shift+S Shift+S
Add articulation: tenuto Shift+N Shift+N
Add hairpin: crescendo < <
Add hairpin: decrescendo > >

Score setup and formatting
Action Windows/Linux macOS

Add/remove instruments I I
Open instruments dialog F7 Fn+F7
Toggle visibility of elements V V
Decrease layout stretch { {
Increase layout stretch } }
Add/remove system break Return Return
Add/remove page break Ctrl+Return Cmd+Return
Reset shapes and positions Ctrl+R Cmd+R

File Operations
Action Windows/Linux macOS

New Ctrl+N Cmd+N
Open Ctrl+O Cmd+O
Close Ctrl+W Cmd+W
Save Ctrl+S Cmd+S
Print Ctrl+P Cmd+P
Quit Ctrl+Q Cmd+Q

User interface
Playback

Action Windows/Linux macOS
Play Space Space
Show/hide mixer F10 Fn+F10

Notation: Instruments, staves, and systems

Working with instruments

Overview
The Instruments panel is a new feature in MuseScore 4. It gives you control over your instruments and some basic staff properties without having to
leave the score view. All of the instruments in your score will appear in this panel.

Adding and ordering instruments
Accessing the Instruments panel
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Open the Instruments panel by clicking on the Instruments tab on the left side of the screen:

Adding instruments

Click Add. This will open the Instruments dialog (see Choose instruments for more information).

Deleting instruments

To delete an instrument from the score, select the instrument and click the trash can icon, or press Delete.

Changing the order of instruments

Select any instrument and use the ↑ or ↓ buttons to change its position in the score. Alternatively, you can drag the instrument up/down using the mouse.

Instrument settings
Hiding/showing instruments

The visibility of entire instrument staves can be toggled by clicking the eye icon next to an instrument label.

Hidden instruments aren't ever deleted — they are simply hidden. This means they won't be printed, but you can still generate and export parts for them.

This feature might be useful if you have alternative instruments or alternative versions of a part that you'd like to toggle between (e.g. for different
performers or instrumental configurations). You might also like to isolate different sections of a larger score (say, for orchestra) without actually deleting
anything or generating any new project files.

Renaming instruments

Click the cog icon to expose settings for renaming your instruments. Leaving any of these fields blank will ensure that no label appears on the score or in
the part for that instrument.

https://musescore.org/en/print/book/export/html/329209?toc=1#node-329655-choose-instruments
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Replacing instruments

To replace an instrument in the Instruments panel:

Click the cog icon to the right of the instrument name
In the popup that appears, click Replace instrument
Select your desired replacement instrument in the dialog that appears
Click OK

Adding and configuring staves
The Instruments panel can also be used to add staves to an existing instrument and configure some of their basic properties.

To add a staff to an existing instrument

If there are no staves visible under the instrument label, click the small black triangle to the left of the label to reveal them
Click Add staff
Click the cog icon of the newly-added staff, and adjust "Staff type", if required.

Added staves share the same instrument but their notation can be edited independently. Amongst other things, they can be used to create staff/tablature
for stringed-instrument players (e.g. guitar, banjo, ukulele etc.).

To add a linked staff to an existing instrument

Certain notational objects on one staff can be made to automatically appear on other staves if they are linked together. Linked staves can be used to
create staff/tablature for stringed-instrument players (guitar, banjo, ukulele etc.).

To create a linked staff:

If there are no staves visible under the instrument label, click the triangular "show more" icon next to the label
Click the cog icon next to the staff label (E.g. "Treble clef")
Click Create a linked staff
Click the cog icon of the newly-added staff, and adjust "Staff type", if required.

Configuring a staff

Each stave contains some independently configurable properties. By clicking on the cog icon alongside a staff label (E.g. "Treble clef"), you can:

Change its staff type (including the clef and number of staff lines)
Reduce the size of the staff (Small staff)
Hide any measures that do not contain notation
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Learn more about staff customization in Staff/part properties.

Deleting staves
The Instruments panel can also be used to delete extra staves from an instrument:

If there are no staves visible under the instrument label, click the small black triangle to the left of the label to reveal them
Click the staff you want to delete
Click the trash icon at the top of the instruments panel, or press Delete.

Note: Deleting a staff from an instrument will delete the staff in the main score as well as in any part that the instrument is used.

Showing staves only where needed

By default, a score will show all measures of all staves on all pages throughout the score, whether they contain notes or not. However, you may wish to
have certain staves appear only on systems where they are needed. You may even wish to have a staff appear or disappear mid-system. MuseScore
provides a number of controls for this purpose.

Hiding empty staves
Ensemble scores often typically omit the staves for instruments that are not playing on any given system.
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Hiding all empty staves

To automatically hide staves on systems where they are empty:

Ensure that nothing in your score is selected (press Esc if necessary).
Go to the Properties panel.
Click the icon next to Empty staves.

Alternatively, you can enable the Hide empty staves within systems option in Format→Style→Score.

MuseScore will normally continue to show all staves on the first system, in accordance with common convention. If you would like to force MuseScore to
hide empty staves on the first system as well, disable the Don't hide empty staves in first system option in the dialog. You can also control whether or
not brackets are shown if, for example, only a single instrument from a section is playing, via the Show brackets when spanning a single staff option.

Excluding specific staves from being hidden

You can specify that certain staves should not be hidden when empty:

Right-click a staff.
Click Staff/Part properties.
In the resulting dialog, set Hide when empty to Never.

For instruments that use two or more staves (like piano, organ, and harp), you may wish to specify that individual empty staves should be shown unless
all staves for the instrument are empty. To do this, set the Hide when empty option to Instrument for each of the staves.

Temporary staves
In scores where some empty staves are not hidden in general, there may nonetheless be special staves that you wish to only show where needed. For
example, this might be a solo part in an ensemble score, or a bass staff in a lead sheet. To set an individual staff to hide when empty without forcing all
staves to be hidden when empty:

Right-click a staff.
Click Staff/Part properties.
In the resulting dialog, set Hide when empty to Always.

Cutaway staves
Film scores and other contemporary scores often use a style of notation where individual measures are hidden when empty. These are sometimes called
cutaway scores.

To accomplish this in MuseScore:

Right-click a staff.
Select Staff/Part properties.
In the resulting dialog, set Hide when empty to Always.
Enable the Cutaway option.

If you wish all staves to be displayed in this manner, you can use the Properties panel or the Hide empty staves style setting to hide the staves.
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However, you will need to set the Cutaway option for each staff individually. You can speed up this process by using the arrow buttons in the Staff/Part
Properties dialog:

Set the Cutaway option for the top staff.
Press the Apply button.
Press the ↓ button to move to the next staff.
Repeat steps 1-3 until you have gone through all staves.

Ossia
An ossia is a special type of cutaway staff in which a given musical passage is notated using a small staff above the normal staff, such as to show an
alternate interpretation.

These can be created in MuseScore using a combination of features:

Add a staff as described in Adding and configuring staves.
Select and delete or otherwise adjust any automatically added bracket.
Enter the desired notation.
Right-click the staff.
Select Staff/Part properties.
In the resulting dialog, set Hide when empty to Always.
Enable the Cutaway and Small options.
Press OK.

If you wish to hear the ossia playback instead of the normal staff, select the corresponding measures on the normal staff and uncheck the Play setting on
the Properties panel. Do the same for the ossia staff if you would rather hear the normal staff playback.

Depending on the look you desire, you might also want to hide the initial or final barline for the passage. To do this, select the barline and press V or
uncheck the Visible option in the Properties panel.

You may also wish to decrease the distance between the ossia and the normal staff. To do this, use a Staff spacer fixed down from the Layout palette.

Other invisible measures
MuseScore also allows you to make individual measures invisible on any given staff, whether empty or not.

To set a measure to be invisible on a given staff:

Right-click the measure.
Select Measure properties.
Disable the Visible checkbox for the staff or staves in which you wish the measure to be set invisible.

Note: you cannot make a measure invisible on all staves—it must remain visible on at least one.

Implode and explode

Implode
The Implode command allows you to do either of the following:

Combine the notation of several voices in the same staff into one voice
Combine notation from several staves into separate voices in one staff.

Combine notes from multiple voices in a single staff into one voice

Select a range of measures in a single staff.
From the menu bar, select Tools→Implode.

All selected notes in the staff are now displayed in voice 1.

Combine notes from multiple staves into multiple voices on a single staff

Ensure that there is only one voice in each staff to be imploded;
Select a range of measures in the top staff and extend this selection downwards to include up to 4 staffs.
From the menu bar, select Tools→Implode.

The notation initially in the upper staff will now be in voice 1, that from the staff below in voice 2, and so on.

Explode

https://musescore.org/en/print/book/export/html/329209?toc=1#node-329665-add-staff
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329734-staff-spacer-fixed-down
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Explode allows you to do either of the following:

Copy a passage of single notes, in a single staff, into one or more staves below.
Transform the chords of a selected passage of music, in a single staff, into their constituent notes on one or more staves below.

Copy passage of single notes to multiple staves

Ensure that the passage is in voice 1 (there should be no notes or rests in other voices).
Select the desired range of measures
Extend the selection downwards through as many staves as you wish to copy to.
From the menu bar, select Tools→Explode.

The passage in the top staff is copied to each of the selected staves below.

Separate a passage of chords into its constituent notes

In this case the chords in a selected passage of music are separated into their constituent notes as follows:

If the passage is all in voice 1, the top note of the chord is retained on the top staff, while the lower notes are moved to subsequent staves.
If the passage contains multiple voices, voice 1 notes are retained on the top staff, while other voices are moved to subsequent staves.
All exploded notes end up in voice 1.

Ensure that there are enough staves underneath the source staff to receive the exploded notes. Create extra staves if necessary using the
Instruments panel.
Choose one of two options:

Select a range of measures in the source staff: this allows all notes to be exploded if there are enough staves available.
Select a range of measures that includes both the source staff and also extends downwards to include one or more destination staves: This
limits the number of exploded notes/voices to the number of selected staves.

From the menu bar, select Tools→Explode.

Notes: (1) If the selection is all in voice 1, MuseScore will discard the lowest note(s) of any chord that contains more notes than the number of staves in
the selection. (2) If the selection is all in voice 1, and If a given chord has fewer notes than the number of destination staves, then notes will be duplicated
as needed so that every staff receives a note. (3) Any existing music in the destination staves is overwritten. (4) If you select a partial measure, the
explode command will automatically expand it to a full measure.

Mid-score instrument changes

Adding an instrument change
When a musician is required to double on a different instrument for a section of a piece, the instruction to switch instruments is generally placed above
the staff at the beginning of that section. A return to the primary instrument is handled in the same manner.

In MuseScore, the instruction to change to a different instrument is handled by the Change Instrument text element, which is found in the Text Palette.
This text element is different from Staff and system text in that it is linked to playback, allowing for a change in sound to the new instrument.

To add an instrument change:

Click on a note or rest to select the start point for the change
Click on the Change instr. palette item in the Text Palette
Choose which instrument you wish to change to in the Select instrument dialog that appears
Click OK

The instruction to change to the new instrument will appear above the selected insertion point in the score.

Working with instrument changes
Removing an instrument change
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To remove an instrument change, click once on a Change instrument text element to select it, and press either Del or Backspace.

Re-labelling an instrument change

You can re-label any Change instrument text element in the score by double-clicking on it and entering new text. This will not affect the playback sound
of the new instrument.

Instrument changes in the mixer

Playback sounds for instrument changes are reflected in the Mixer as separate channel strips stacked to the right of the primary instrument channel strip.
These instruments are labelled in parentheses. You can change the assigned playback library, apply effects, adjust the volume, and mute, solo, and pan
these channel strips just as you would any other instrument channel strip. For more information, see the Mixer.

Changing staff type

Changing to a different instrument may necessitate the use of different key signatures, clefs, and even staff type. Learn more about changing staff type in
Staff type change.

Staff type change

You can change the appearance of a staff mid-score by adding a "Staff type change" element to a measure, and adjusting its properties in the Properties
panel. This can be used when changing between pitched and unpitched staves or for various experimental notation effects.

Adding a staff type change
Select a measure in the score and, in the Layout palette

Click the "Staff type change" symbol  to add it to your score

Alternatively, you can drag the symbol from the palette to a measure in your score.

Setting staff properties
When you alter a "Staff type change" property in the Properties panel, the new value takes precedence over the value shown in the global Staff/Part
properties dialog. Only those property values in Staff/Part properties that cannot be changed for the "Staff type change" will be valid throughout the
score.

The properties that can be altered for the "Staff type change" in the Properties panel are:

Cue size
Use the Small staff size that is defined for the score

Offset
Displace the staff vertically

Scale
Change the size of the staff using a custom percentage

Number of lines
Change the number of lines making up the staff

https://musescore.org/en/print/book/export/html/329209?toc=1#node-329698-staff-properties
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Line distance
Change the distance between two staff lines

Step offset
Offset the notes on the staff relative

Invisible staff lines
Toggle visibility of the staff lines

Staff line color
Set the color of the staff lines

Notehead scheme
Specify alternate noteheads such as pitch names or shape note

Stemless
Toggle display of note stems

Show barlines
Toggle display of barlines

Show ledger lines
Toggle display of ledger lines

Generate clefs
Toggle display of clefs

Generate time signatures
Toggle display of time signatures

Generate key signatures
Toggle display of key signatures

Staff/Part properties

Overview
The Staff / Part Properties dialog allows you to make changes to the display of a particular staff; and to adjust the name, tuning, transposition, and
instrument of the corresponding instrument part.

To open the dialog:

Right-click onto either an empty area in a staff, or the instrument name, and select Staff / Part Properties….

An instrument part often consists of only one staff (e.g. violin, trumpet, flute) but there are notable exceptions. For example, a piano requires two staves—
treble and bass; a guitar may need both an 8vb treble staff and a tablature staff, and so on.

Staff properties
The top section of the dialog allows you to adjust many aspects of the appearance of an individual staff. The following options are common to all types of
staves:

Lines: The number of lines making up the staff.
Line Distance: The distance between two staff lines—measured in spaces (sp.).
Note: It is not recommended to change this value from the default. If you need to make the staff larger or smaller, use the Page Settings dialog
instead.
Extra distance above staff: Increases or decreases the distance between the selected staff and the one above in all systems.
Note: (1) This setting does not apply to the top staff of a system, which is controlled by the minimum/maximum system distance (see Formatting).
(2) To adjust the spacing above just one staff line in a particular system, see Fitting systems on a page: Spacers.
Scale: Changes the size of the selected staff and all associated elements as a percentage (to adjust the overall score size, use "Scaling"
(Format→Page Settings…).
Hide when empty: Together with the “Hide empty staves” setting in Format→Style…→Score, this determines if the staff will be hidden when it is
empty:

Auto (default): The staff will be hidden if it is empty and “Hide empty staves” is set.
Always: The staff will be hidden when empty, even if “Hide empty staves” is not set.
Never: The staff will never be hidden when empty.
Instrument: For instruments containing multiple staves, the staff is hidden only if all staves for that instrument are empty.

Show clef: Whether the staff clef will be shown.
Show time signature: Whether the staff time signature(s) will be shown or not.
Show barlines: Whether the staff barlines will be shown.
Hide system barline: Show/hide barline at left-hand edge of the staff.
Merge matching rests: Check if you want matching rests in different voices to be merged rather than separate.
Do not hide if system is empty: Never hide this staff, even if the entire system is empty. This overrules any “Hide empty staves” setting in
Format→Style…→Score.
Small staff: Create a reduced-size staff. You can set the default from the menu in Format→Style…→Sizes.
Invisible staff lines: Make staff lines invisible.
Staff line color: Use a color picker to change the color of the staff lines.
Cutaway: Used to create a cutaway staff in which only measures containing notes are visible (e.g. Ossia  (Wikipedia); or cutaway scores). This
can be used independently of “Hide when empty” or “Hide empty staves”.
Advanced style properties: (see below)

https://musescore.org/en/print/book/export/html/329209?toc=1#node-329757-spatium
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329732-Page-settings
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329734-Spacers
https://en.wikipedia.org/wiki/Ossia
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Advanced style properties
Clicking on Advanced Style Properties… opens a dialog giving access to advanced display options for the staff. These options will vary depending on the
staff type chosen.

Template (all staves)

At the bottom of the Advanced Style Properties dialog there are a number of buttons which allow you to make changes to the staff display by selecting
a different template.

Note: The options available here depend on the type of staff—whether standard, plucked-string staff/tab, or percussion.

To change the template:

Make a selection from the drop-down list labeled “Template”;
Press < Reset to Template;
Press OK to accept the changes and exit the dialog (or Cancel to cancel the operation).

Standard and Percussion staff options only

Lines / Line distance:
Show clef / time signature / barlines / key signature / ledger lines: Set to give the desired display on the staff.
Stemless: If checked, staff notes will have no stem, hook or beam.
Notehead scheme: See Notehead scheme.

Tablature options only

Lines: This number usually matches the number of strings in the String Data dialog (exceptions being the Baroque Lute, Theorbo etc. which have
more strings than lines).
Line distance:
Show clef / time signature / barlines: Set to give the desired display on the staff.
Upside down: If not checked, the top tablature line will refer to the highest string, and the bottom tablature line to the lowest string (this is the most
common option). If checked, the top tablature line refers to the lowest string, and the bottom tablature line to the highest line (e.g. Italian-style lute
tablatures).
Preview: Displays a short section of a specimen score as it would look with the current properties applied.

Fret Marks tab

Fret marks are the numbers or letters used to indicate the location of notes on the fingerboard. The following group of properties define the appearance of
fret marks:

Font: The font used to draw fret marks. A selection of eight fonts are provided supporting all the necessary symbols in 8 different styles—both
modern and historic..
Size: Font size of fret marks in typographic points. Built-in fonts usually look good at a size of 9-10pt.
Vertical offset: MuseScore tries to place symbols in a sensible way and you do not usually need to alter this value (set to 0) for built-in fonts. If the
font has symbols not aligned on the base line (or in some other way MuseScore does not expect), this property allows you to move fret-marks up
(negative offsets) or down (positive offsets) for better vertical positioning. Values are in sp.
Marks are: Select from using Numbers (“1”, “2”…) or Letters (“a”, “b”…) as fret marks. When letters are used, the letter “j” is skipped and “k” is used
for the 9th fret.
Marks are drawn: Choice of placing fretmarks On lines or Above lines.
Lines are: Choice of Continuous (lines pass through fret marks) or Broken (a small space appears in the line where the fretmark is displayed).
Show back-tied fret marks: If unchecked, only the first note in a series of tied notes is displayed. If ticked, all notes in the tied series are displayed.
Show fingering in tablature: Check to allow the display of fingering symbols applied from a palette.

Note Values tab

This group of properties defines the appearance of the symbols indicating note values.

Font: The font used to draw the value symbols. Currently 5 fonts are provided supporting all the necessary symbols in 5 different styles (modern,
Italian tablature, French tablature, French baroque (headless), French baroque). Used only with the Note symbols option.
Size: Font size, in typographic points. Built-in fonts usually look good at a size of 15pt. Used only with the Note symbols option.
Vertical offset: Applies only when Note symbols is selected (see below). Use negative offset values to raise the note value symbols, positive
values to lower them.
Shown as:

None: No note value will be drawn (as in the examples above)
Note symbols: Symbols in the shape of notes will be drawn above the staff. When this option is selected, symbols are drawn only when the
note value changes, without being repeated (by default) for a sequence of notes all of the same value.
Stems and beams: Note stems and beams (or hooks) will be drawn. Values are indicated for each note, using the same typographic
mechanics as for a regular staff; all commands of the standard Beam Palette can be applied to these beams too.

Repeat: If several notes in sequence have the same duration, you can specify if and where to repeat the same note symbol. i.e. Never / At new
system / At new measure /Always.
Note: This option is only available if “Shown as: Note symbols” is selected (see above).
Stem style:

Beside staff: Stems are drawn as fixed height lines above/below the staff.
Through staff: Stems run through the staff to reach the fret marks.
Note: This option is only available when “Shown as: Stems and Beams” is selected (see above).

Stem position:
Above: Stems and beams are drawn above the staff.
Below: Stems and beams are drawn below the staff.

https://musescore.org/en/print/book/export/html/329209?toc=1#node-330562-Customizing-appearance-of-notes
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Note: This option is only available when “Shown as: Stems and Beams” and “Stem style: Beside staff” is selected (see above).
Half notes: None / As short stems / As slashed stems.
Note: This option is only available when “Shown as: Stems and Beams and “Stem style: Beside staff” is selected (see above).
Show rests; Whether note symbols should be used to indicate also the rests; when used for rests, note symbols are drawn at a slightly lower
position. Used only with the Note symbols option.

Part properties
Instrument

The name of the instrument is shown here. To change the instrument,

Click on Replace instrument and make a choice from the "Select Instrument" dialog.

Names

Long instrument name: Name displayed to the left of the staff in the first system of the score or section.
Short instrument name: Name displayed to the left of the staff in subsequent systems of the score.

Usable pitch range

Amateur: Notes outside the amateur range are colored olive green / dark yellow in the score.
Professional: Notes outside the professional range are colored red in the score.

Note: To disable out-of-range coloration of notes, from the menu, select Edit→Preferences… (Mac: MuseScore→Preferences…), click on the “Note Input”
tab, and uncheck “Color notes outside of usable pitch range.”

Transposition

Set the octave, and up/down interval to ensure that transposing instruments are notated correctly. This is automatically done by the program for most
instruments.

For transposing instruments an additional option is shown: "Prefer sharps or flats for transposed key signatures". There are three options:

Default: Let MuseScore decide
Flats: Prefer flats
Sharps: Prefer sharps

Strings and frets

Staves of fretted, plucked-string instruments have a few extra options in addition to those listed above,

Number of strings: Displays the number of instrument strings.
Edit String Data…: This button opens a dialog box which allows you to set the number and tuning of strings. See Change tuning.

Brackets

Various types of brackets and a curly brace are provided in the "Brackets" palette.

Brackets/braces are automatically applied when a score is created in the New Score dialog. You can easily change them if the default is not what you
want (see below)

Adding brackets
To add a bracket or brace to all systems:

Click on the first measure of the staff where you want the bracket/brace to start, hold Shift and click on the measure where you want the
bracket/brace to end.
Click the desired bracket icon in the "Brackets" palette.

Alternatively:

Select the start measure, and click the bracket into place from the "Brackets" palette.
Select the bracket, click on the adjustment handle and drag it down to the desired position. It will snap into place.

Nested brackets can also be applied using these methods, applying the innermost first and ending with the outermost. The order can be edited
subsequently using the "Column" property (see below)

Editing brackets
If you select a bracket/brace, you can edit its properties in the Properties panel (sidebar).

Column: Moves the bracket inwards/outwards.
Span: Extends or retracts the end of the bracket/brace.

Changing bracket type

Select the bracket/brace in the score to be changed, then click on a new bracket/brace from the "Brackets" palette.

https://musescore.org/en/print/book/export/html/329209?toc=1#node-330564-change-tuning
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Changing bracket span

Use one of the following methods:

Select the bracket, click on the adjustment handle, and drag it to the desired position.
Select the bracket, click on the adjustment handle, and press Shift+↑/↓ to move it from staff to staff.
Alter "Span" in the Properties panel.

Deleting brackets
To delete a bracket/brace, select it and press Del.

Customizing bracket appearance
Brackets/Braces also have a few global properties which can be adjusted from the Style menu:

Adjust thickness and distance from the staff in Format→Style→System.
Adjust distance above/below in Format→Style→Page→Enable vertical justification of staves.

Notation: Rhythm, meter, and measures

Time signatures

Overview
Time signatures are applied to the score from the "Time Signatures" palette.

Setting the initial time signature for your score
This is done from page 2 of the New Score dialog.

Adding a time signature change to your score
Use any of the following methods:

Select an existing time signature, measure, note or rest in the score, and click a time signature in a palette.
Drag and drop a time signature from a palette onto a space in a measure, or onto an existing time signature.

Deleting a time signature
To delete a time signature in the score, select it and press Del.

Controlling the visibility of time signatures
To hide/show time signatures on a particular staff:

Right-click on the staff and choose "Staff/Part properties";
Uncheck/Check "Show time signature".

To disable/enable all courtesy time signatures (at the end of systems):

From the menu bar, select Format→Style→Page.
Uncheck/Check "Create courtesy time signatures".

To hide or show an individual courtesy time signature:

Select the parent time signature;
In the Time signature section of the Properties panel, uncheck/check "Show courtesy time signature".

Creating a custom time signature
In the Time Signatures palette, click on More, then, in the supplementary palette, click on the “Create Time Signature” button;
In Value enter the Numerator, Denominator, and Text (the latter is optional, when you need the display to be different from the actual time
signature);
Adjust the default note beaming in the Beam Groups section (see Beam groups (below). To restore the default beaming pattern, press Reset;
Press Add to transfer the newly-created time signature to the Time Signatures palette.

https://musescore.org/en/print/book/export/html/329209?toc=1#node-329655-additional-score-information
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You can also do the same thing from the Master Palette (Shift+F9).

Adding a local time signature for a single staff
In certain cases a score may show staves with different time signatures running at the same time. For example, in the following (J. S. Bach’s Goldberg
Variation no. 26):

The global time signature is 3/4, but the time signature of the upper staff has been set independently to 18/16.

To set a local time signature for just one staff:

Hold down Ctrl (Mac: Cmd) and drag and drop a time signature from a palette onto an empty measure.

Resizing a time signature
Select a time signature
In the Time signature section of the Properties panel, adjust the horizontal and vertical Scale values.

Time signature properties
To open the Time signature properties dialog use one of the following:

Right-click on a time signature and from the context menu select "Time signature properties".
Select a time signature, then click on Time signature properties in the "Time signature" section of the Properties panel.

Appearance

This part of the dialog allows you to adjust the nominal appearance of the signature without affecting its underlying rhythmic value.

Text: Insert the nominal numerator and denominator that you wish to appear on the score.

Alternatively, you can make a selection from a range of time signature symbols below.

Beam Groups
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This section allows you to adjust the default beaming patterns of notes occurring in the section controlled by the time signature.

Click on a note to break the beam in front of it. Click again to reform the beam.
Alternatively you can drag and drop a "beam selector" icon to the note after the beam you want to make or break.
Click Reset to restore the default beaming pattern.

Check the "Also change shorter notes" box if you want changes to apply to beam groups below as well.
For more information on beams, see Beams.

Time signature style
There are a few global style properties for time signatures (see Format→Style).

Create courtesy time signatures: Found in the Page section. Check or uncheck to turn on or off.
Clef to time signature / Key signature to time signature / Barline to time signature / Time signature to barline / Time signature to first note:
Found in the Measure section. Allows you to set spacing for various aspects of time signature layout.

Stems and flags

Stem direction
Default stem direction

MuseScore aligns the stems of voice 1 notes according to the conventions of music theory. By contrast, voice 2 and voice 4 stems point downwards by
default, while voice 3 stems point upwards. Voice 1 stems automatically flip upwards in the presence of voice 2 or 4 notes.

Flipping stem direction

Select either the notehead, stem or attached beam (if any)
Use any of the following methods:

Press X
Click on the "Flip direction" icon in the Note input toolbar
Select a stem direction from the Stem tab in the Properties panel

This action will flip any attached beam as well.

Changing stem length
Select the stem
Use one of the following methods:

Press ↑/↓ to extend or shorten the stem
Change Length in the Properties panel

Creating stemless notes
To hide the stems of individual notes:

Select one or more noteheads
Go to the Properties panel
Select the Stem tab
Select the checkbox next to Stemless

To hide all stems in an instrument part:

Right-click on the staff and select Staff/Part properties
Click on Advanced style properties
Select the checkbox next to Stemless

Stem and flag properties
Properties specific to stems and flags can be edited from the Stem tab in the Note section of the Properties panel:

Stemless removes the stem (and associated beams) from the selected note(s)
Stem direction:

Auto determines the direction of the stem according to the voice of the selected note(s)
Up and Down override the default stem direction

Flag style sets the appearance of flags for the entire score to either traditional (default) or straight
Thickness determines the stem's width
Length determines the stem's length
Stem offset can be used to move the stem in a horizontal and/or vertical direction

Stem and flag style
Global settings for Stem thickness and Flag style may also be set in Format→Style→Notes.

See also



14/09/2023, 18:51Handbook for MuseScore 4

Page 101 of 270https://musescore.org/en/print/book/export/html/329209?toc=1

Beams

Beams

Controlling which notes are beamed
Setting the default beaming for a time signature

By default, MuseScore beams notes according to settings in the Time signature properties dialog. To change this automatic pattern of note-beaming, see
Beam groups.

Changing the beaming for selected notes

You can override the default beaming of any individual note, using beam symbols in the Beam Properties palette, or in the Beam tab of the Properties
toolbar. Hover over the icons for more info on what each one does.

To change one or more note beams use one of the following methods:

Select one or more notes and/or rests in the score and click the desired symbol in the Beam Properties palette.
Select one or more notes and/or rests in the score and click on a symbol under "Beam types" (Beam tab of the Properties panel).
Drag and drop a beam symbol from the Beam Properties palette onto a note or rest in the score.

The following table describes the effect of each beam symbol:

Icon Name Description

Auto Beam Apply default beaming as determined by the
current time signature (see above).

No beam Break beams before and after the selected note.

Break beam left If the note is beamed to a previous note, break the
beam.

Break inner beams (eighth) Start a second level beam at this note.

Break inner beams (sixteenth) Start a third level beam at this note.

Join beams Join beams on both sides of the note.

Add feathered beam: decelerate Start feathered beam to indicate gradually slower
tempo.

Add feathered beam: accelerate Start feathered beam to indicate gradually faster
tempo.

Note: The beam between two notes/rests is determined by both of the note/rests. For example: Two consecutive notes with a status of start beam here
will not have a beam between them. If the two consecutive notes are set up to connect to each other they will beam, if one of them is not set up for this,
the two notes will not beam.

Controlling the appearance of beams
Changing the angle of a selected beam

Click on the beam you wish to adjust;
Click on the left/right adjustment handle and adjust the height using one of the following methods:

Drag the handle.
Move the handle using ↑/↓.
In the Beam section of the Properties panel, adjust the "Beam height" properties.

Use the center adjustment handle to set the overall height of the beam.

Creating a feathered beam

To create feathered beams use one of the following methods:

Select one or more beams, notes or rests in the score and click the desired symbol in the Beam Properties palette.
Select one or more beams, notes or rests in the score and click on a symbol under "Beam types" (Beam tab of the Properties panel).
Drag and drop a beam symbol from the Beam Properties palette onto a beams in the score.

Please note that only beams with two or more components (i.e. 16th notes or shorter) can become feathered.
See the table above for a description of the beam symbol effects.

Beam properties
Properties specific to beams can be edited from the Beam tab of the Note section in the Properties panel:

https://musescore.org/en/print/book/export/html/329209?toc=1#node-329680-time-sig-properties
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329680-properties-beams
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Beam types: Alter the beaming pattern at selected notes.
Feather beams: Ditto.
Force horizontal: Make beams of selected notes horizontal.
Beam height: Adjust height and angle of beams.

Editing of these properties is covered in the sections above.

Beam style
A few global properties of beams can be set from Format→Style→Beams:

Beam distance: The vertical distance from one beam to the next.
Beam thickness
Broken beam minimum length
Flatten all beams: Check to make all note beams horizontal, regardless of context.

Regroup rhythms

Overview
Standard music notation normally follows a set of conventions designed to facilitate the reading of rhythm. The basic idea is to group notes in ways that
clarify which notes belong to which beat. Rules include:

sixteenth notes should be beamed in a way that clarifies each beat
eighth notes should be beamed in a way that clarifies each group of two beats
longer notes that start off the beat should be broken up with ties to clarify each beat or group of two beats

A full discussion of this topic is beyond the scope of this Handbook, but for more information, see this handout .

Here is an example of a rhythm written incorrectly and then correctly:

MuseScore can correct many of these cases automatically.

Regrouping rhythms
To regroup rhythms according to the common conventions of standard music notation:

Select the passage you wish to regroup.
From the main menu, select Tools→Regroup rhythms.

The rhythm itself is not changed—only the notation of it.

See also
Notation Rules: Rhythm

Tuplets

Creating tuplets
A tuplet is any group of notes that divide the beat in a way other than what is normally permitted by the time signature. Triplets consisting of three eighth
notes in one beat are the most familiar type of tuplet.

Simple tuplets

A simple tuplet such as the triplet shown above can be entered in note input mode or in normal mode.

In note input mode

Navigate to the note/rest (or blank measure) where you want the tuplet to start.
Select a final duration for the whole tuplet group (e.g. for an eighth note triplet, this will be a quarter note—keyboard shortcut 5).
Use one of the following commands:

https://musescore.com/user/2975/scores/5711373
https://musescore.com/user/2975/scores/5711373
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329660-selecting-duration
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Press the keyboard shortcut for the required tuplet: i.e. Ctrl+3 for a triplet; Ctrl+4 for quadruplet … and so on, up to Ctrl+9 for a nonuplet.
(Mac: Cmd+3 … Cmd+9);
From the menu, choose Add→Tuplets…, then select the required tuplet.
From the note input toolbar, click on the Tuplet icon and select from the dropdown.

The note or rest is automatically divided for you and an appropriate annotation is applied.

Enter the desired series of notes/rests.

In normal mode

Select a note or rest that specifies the full duration of the desired tuplet group. You may need to create this in the score beforehand. Thus, if you
want an eighth note triplet you need to select a quarter note/rest.
Use one of the following commands:

Press the keyboard shortcut for the required tuplet: i.e. Ctrl+3 for a triplet; Ctrl+4for quadruplet … and so on, up to Ctrl+9 for a nonuplet.
(Mac: Cmd+3 … Cmd+9).
From the menu, choose Add→Tuplets…, then select the required tuplet.
From the note input toolbar, click on the Tuplet icon, and select from the dropdown.

The note or rest is automatically divided for you and an appropriate annotation is applied.

Enter the desired series of notes/rests.

Consecutive tuplets

If you need to input a series of tuplets, and don't want to continually repeat the tuplet command, you can select the notes of the first tuplet and press R
(Repeat) as many times as needed; then move subsequent notes into position using keyboard arrows, retyping or re-pitch mode.

Custom tuplets

More complex tuplets can be created as follows:

In note input mode, select a note duration equaling the total duration of the tuplet; or, if in normal mode, select a note or rest of the desired overall
duration.
Open the Create Tuplet dialog from either the menu (Add→Tuplets…→ Other…), or by clicking on the tuplet icon (note input toolbar).

In the Ratio field, specify the desired number ratio of the tuplet.
Set Number and Bracket to get the required tuplet display.
Press OK to close the dialog.
Enter the desired series of notes and rests.

Nested tuplets

Tuplets can be nested within other tuplets.

To create a nested tuplet:

Create the outer tuplet as described above.
While entering the individual notes, create inner tuplets in the way (select the total notated duration for the inner tuplet, then use one of the tuplet
commands to divide it appropriately).

Changing the display of tuplets
You can choose to display or hide a tuplet number or bracket, change its orientation, or adjust line thickness. See Tuplet properties (below) for details.

https://musescore.org/en/print/book/export/html/329209?toc=1#node-329660-selecting-duration
https://musescore.org/en/print/book/export/html/329209?toc=1#node-330535-re-pitch
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329660-selecting-duration
https://musescore.org/en/print/book/export/html/329209?toc=1#undefined-tuplet-properties
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Tuplet properties
The display of selected tuplets can be changed in the Tuplet section of the Properties panel.

Direction: Whether the tuplet indication appears above or below the staff. Available settings are "Auto", "above" (↑) or "below" (↓).
Number type: Affects the numerical display. Choice of "Number", "Ratio" or "None".
Bracket type: Sets bracket display. Settings are "Auto", "bracket", or "no bracket".
Line thickness: The thickness of the tuplet bracket, if displayed.

Tuplet style
You can set the global properties of tuplets in the score from Format→Style→Tuplets. These settings provide fine control over the default display of
tuplets.

The settings include:

Properties
Direction
Number type
Bracket type

Brackets
Bracket thickness
Bracket hook height

Vertical distance from notes
Maximum slope
Vertical distance from stem
Vertical distance from notehead
Avoid staves

Horizontal distance from notes
Distance before stem of first note
Distance before head of first note
Distance after stem of last note
Distance after head of last note

Barlines

A full range of common barlines is contained in the Barlines palette.

Adding double and other special barlines
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Changing barline type for all staves

Select one or more barlines in a staff ;
Click on the desired barline in the palette.

Alternatively, you can drag a barline from the palette onto a barline in the score.

Changes are applied automatically to all barlines at the same point in the score.

Changing barline type for a single staff

Select one or more barlines in the score;
Hold Ctrl then click on the desired barline in the palette.

Alternatively, you can hold Ctrl and drag a barline from the palette onto a barline in the score.

Only barlines in the one staff are affected.

Adding mid-measure barlines

Select one or more notes.
Click on a barline in the palette.

This will add a "barline" in front of each selected note. The barline is for visual purposes and does not factor into any measure operations.

If you wish to divide a measure, inserting a real barline in the process, see Splitting a measure.

Changing barline length
Here we are concerned with the vertical extension of barlines in order to link staves together, or their reduction to create partial barlines.

Extending all barlines in a staff

Select a barline on the "start" staff;
Use either of the following:

Drag the end handle downwards until it meets the destination staff. This method is the best for extending barlines through multiple staves.
Select the edit handle and press ↓.
Check the "Span to next staff" in the Barlines section of the Properties panel; then click Set as staff default

Repeat if required for subsequent staves.

The barline snaps into place, and all other barlines in that staff follow.

Extending selected barlines in a staff

Select one or more barlines (and their counterparts in the staves below if there are more than two staffs to join).
Check the "Span to next staff" in the Barlines section of the Properties panel.

Creating partial barlines

Partial barlines can be easily created by adjusting "Span from" and "Span to" in the Barlines section of the Properties panel.

Creating barlines between staves only (Mensurstrich)

See Working with Mensurstrich.

Barline properties
You can edit properties specific to barlines in the Barlines section of the Properties panel:

Style: Used to change selected barlines to one in the dropdown list.
Span to next staff: Check this to make selected barlines extend to the staff beneath.
Span from/to: used to set the vertical start and end points of one or more selected barlines.
Set as staff default: Applies the changes made in Span to next staff and Span from/to to all barlines in the staff.
Span presets: Applies the selected preset to one or more selected barlines in the score.

Barline style

https://musescore.org/en/print/book/export/html/329209?toc=1#node-330549-split-measure
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329714-mensurstrich
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Selected properties for all barlines in the score can be changed in Format→Style→Barlines:

See also
Fixed Measure Widths  for a workaround to ensure barlines are aligned vertically between systems.
Repeat signs

Measure numbering

Showing and hiding measure numbers
Showing measure numbers automatically

By default, MuseScore shows measure numbers at the start of each system except the first one in a section. Numbering starts at the first complete
measure in a section.

if you wish to change measure numbering:

From the menu bar, select Format→Style→Measure numbers.
Edit the following properties as required:

Measure numbers: This is ON by default. Uncheck to turn off measure numbering.
Show first: Check to show measure number on the first system of a section.
All staves: Check to show measure numbers on every staff.
Every system / Interval: If "Every system" is selected, measure numbers are shown at the start of each system. If "Interval" is selected, you
can choose a measure interval at which to display measures.

Make changes to positioning using the controls on the right.
Edit the display of multimeasure numbers in the section below:

Show measure number range at multimeasure rests. If checked, you can also customize the appearance and position of the numbering.
Unchecked (the default setting), only the count of multimeasure rests is displayed.

Showing measure numbers manually

To always show the number of a particular measure, regardless of style settings, open Measure properties and select "Always show" from the Measure
number mode dropdown.

Hiding measure numbers

To hide all measure numbers, uncheck "Measure numbers" in Format→Style→Measure numbers.

To hide the number of a particular measure, regardless of style settings, open Measure properties and select "Always hide" from the Measure number
mode dropdown.

Changing the measure number sequence
Excluding a measure from the count

In Measure properties, check "Exclude from measure count" (in the Other pane).

Altering the numbering of a measure

In Measure properties, edit "Add to measure number". Both positive and negative numbers are accepted.

Resetting measure numbering for a new section

https://musescore.org/en/node/313555#comment-1169175
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329757-system
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329757-section
https://musescore.org/en/print/book/export/html/329209?toc=1#node-330550-Open
https://musescore.org/en/print/book/export/html/329209?toc=1#node-330550-Open
https://musescore.org/en/print/book/export/html/329209?toc=1#node-330550-Open
https://musescore.org/en/print/book/export/html/329209?toc=1#node-330550-Open


14/09/2023, 18:51Handbook for MuseScore 4

Page 107 of 270https://musescore.org/en/print/book/export/html/329209?toc=1

By default, numbering of measures always restarts at the beginning of a new section. To prevent this, and make numbering continuous, select the break
and in the Properties panel uncheck "Reset measure numbers for new section".

Changing the position of measure numbers
To adjust the position of all measure numbers, edit the X and Y offsets of "Position above" and "Position below" in Format→Style→Measure numbers.

Measure number properties
Note that any changes made to a measure number in the Properties panel may be lost if the layout changes.

Measure number style
Various properties for all measure numbers in the score can be adjusted in Format→Style→Measure numbers. Most are dealt with in the sections above.

See also
Other measure-related pages:

Measure rests and multimeasure rests
Pickup and non-metered measures
Measure properties
Adding and removing measures
Mensural notation and Mensurstrich

Measure rests and multimeasure rests

Measure rest
A measure rest looks like a whole rest, but is centered within a measure and indicates that the entire measure (or a voice within it) is silent:

It is commonly used in all meters (except 4/2 and 8/4).

Multimeasure rest
A multimeasure rest is used to indicate a run of empty measures, the number of measures being shown by a figure above/below the staff.

Enabling and disabling multimeasure rests

Multimeasure rests can be turned on/off with the shortcut M, or by checking "Multimeasure Rests" in Format→Style…→Rests.
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By default, if multimeasure rests are enabled, any sequence of two or more empty measures is automatically converted to multimeasure rests.

To change the minimum number of empty measures needed to trigger multimeasure rests:

From the menu, choose Format→Style…→Rests.
Check "Multimeasure rests" (if the option is not already enabled).
Edit "Minimum number of empty measures".

Multimeasure rests can be turned on/off independently in the score and instrument parts.

Breaking multimeasure rests

Multimeasure rests are automatically broken at important points, such as double barlines, rehearsal marks, key signature or time signature changes,
section breaks etc.

However, you can opt to break a multimeasure rest elsewhere as follows.

Disable multimeasure rests;
Right-click on the measure at which you want the multimeasure rest to break, and select Measure properties.
In the dialog, check "Break multimeasure rest".
Click OK.
Re-enable multimeasure rests.

Multimeasure rest properties

You can edit properties specific to multimeasure rests in the Multimeasure rest section of the Properties panel:

Show number: This box is checked by default. Uncheck it to hide the multimeasure number.
Number position: Adjust the vertical position of the multimeasure number, above or below the rest.

Multimeasure rest style

Some global properties of multimeasure rests can be set from Format→Style…→Measure numbers:

Others from Format→Style…→Rests:

See also
Other measure-related pages:

Measure numbering
Pickup and non-metered measures
Measure properties
Adding and removing measures
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Mensural notation and Mensurstrich

Pickup and non-metered measures

Creating a pickup measure
A pickup measure, also known as an upbeat or anacrusis, is a partial, or incomplete, measure at the beginning of a score or section.

Note: By convention, measure numbering starts at the first complete measure.

Specifying the pickup duration during score creation

Click on Measures in the "Additional score information" page (page 2) of the New Score dialog;
Check "Create pickup measure";
Choose an underlying time signature using the spin controls below.

Converting a measure into a pickup

Right-click on the measure and choose Measure properties;
In the Measure duration section, next to "Actual", choose an underlying "time signature";
Click OK; or click Apply and then ← or → if you want to configure an adjacent partial measure.

It is accepted musical practice to omit the same duration as the pickup from the final measure of the piece or of the same repeat section. The same
method of shortening the measure applies here.

Creating non-metered measures
A non-metered measure is one which is less or greater in duration than the indicated time signature.

A measures of less duration than the indicated signature may be created in exactly the same way as a pickup measure (see above).

Other ways of creating non-metered measures are described below:

Inserting notes and rests

Extra notes/rests can be inserted in a measure with the help of either a keyboard shortcut, or by using a special mode of entry called Insert mode:

Using a keyboard shortcut

Select the note or rest in the score before which you want to insert notes/rests;
Enter note-input mode;
Select a duration;
Press Ctrl+Shift (Mac: Cmd+Shift) while adding the note/rest from the keyboard or mouse.

Using Insert mode

Make sure you have the element selected where you want to start inserting notes/rests;
Click and hold the Note input icon, and select Insert (or if Insert is the current default, just press N);
Enter a note or rest as you would in step-time mode. Each note is inserted before the current cursor position;
Move the cursor forward and backward if required (using the arrow keys), to change the insertion point.

If, at any time, the total duration of the notes and rests within the measure does not match the time signature, a small + or - sign will be shown above the
measure.

Joining measures

This command joins selected measures into one measure.

Method A. To join two measures only:

Select the barline between the two measures;
Press Ctrl+Del; or select Tools→Remove selected range.

Method B. To join any number of measures:

Select the measures you want to join;
From the menu bar, select Tools→Measures→Join selected measures.

Notes: (1) If you select measures on only one staff in a score with multiple staves, the same measures will be joined in each staff of the system. (2)
Beaming may be automatically modified.

Splitting a measure

This command inserts a barline before a selected note, splitting the measure into two.

Use one of the following methods:

Select a note; then hold Ctrl and click a barline in a palette.

https://musescore.org/en/print/book/export/html/329209?toc=1#node-329655-measures
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329660-selecting-duration
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Hold Ctrl and drag a barline (from a palette) to a note.
Select a note; then, from the menu bar, select Tools→Measures→Split Measure Before Selected Note/Rest.

See also
Working with non-metered music.

Other measure-related pages:

Measure numbering
Measure and multimeasure rests
Measure properties
Adding and removing measures
Mensural notation and Mensurstrich

Measure properties

Opening and using the dialog
The Measure properties dialog allows you to adjust various properties of an individual measure—such as visibility, duration, numbering and width
("Stretch").

To open Measure properties, right-click on a measure and select "Measure properties".

If you only want to adjust one measure, click OK to make the changes permanent. However, if you also want to adjust adjacent measures there is no need
to close the dialog; simply click Apply, then use the arrows on the bottom left of the window to move the dialog to the new measure. The new measure
number appears both at the top of the dialog and in the status bar.

Staves
Visible : Uncheck/check the boxes to hide/show the selected measure.
Stemless: Check/uncheck the box to hide/show stems.

Measure duration
Nominal: This is the time signature set in the score.
Actual: Adjust these figures to increase or decrease the duration of a measure.

Other
Exclude from measure count: Check to make the count skip the selected measure.
Break multimeasure rest: See Measure rests and multimeasure rests.
Measure number mode: Allows you to display/hide measure number for the selected measure irrespective of style settings.
Add to measure number: Changes numbering from this measure onwards in the score.
Layout stretch: This property is normally adjusted first with a shortcut (see Stretch); use "Measure properties" for fine adjustment.
Play count: This only appears if the measure is before an end repeat barline. It indicates the number of times the repeat section is played.

The play count of the measure with the end repeat barline must be set one higher than the number of times you want the measure to play (this is usually
equal to the number of entries in that volta repeat list + 1).

Take the following score:

https://musescore.org/en/print/book/export/html/329209?toc=1#node-329714-non-metered
https://musescore.org/en/print/book/export/html/329209?toc=1#node-330533-scores
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329694-break-rests
https://musescore.org/en/print/book/export/html/329209?toc=1#node-330548-measure-number-style
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329733-Stretch
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Measure 4 should have play count set to 4
Measure 6 should have play count set to 3

See also
Fixed Measure Widths  for a workaround to ensure barlines are aligned vertically between systems.

Other measure-related pages:

Measure numbering
Measure and multimeasure rests
Pickup and non-metered measures
Adding and removing measures
Mensural notation and Mensurstrich

Notation: Pitch

Clefs

Clefs are applied to the score from the "Clefs" palette.

Setting the initial clef for a staff
MuseScore automatically applies the most appropriate clef(s) for the instrument when creating a new score. You can easily change this from the score
window if needed.

Adding or changing a clef
Add/Change a start clef

To change a clef at the start of a system, use one of the following:

Select the first measure in the system and click a clef symbol in the palette.
Drag a clef from the palette onto the first system measure.
Select the clef and click a clef in the palette.
Drag a new clef from the palette onto the clef.

Add/Change a mid-measure clef

To add/change a mid-measure clef before a note, use one of the following:

Click on the note, then click a clef in the palette.
Drag a clef from a palette onto the note

To add/change a mid-measure clef in front of a barline, use one of the following:

Select the following measure and click a palette clef.
Drag a clef from a palette onto the following measure.

Notes: (1) “Mid-staff” clefs are always smaller than the main system clef. (2) Notes after a clef change are automatically repositioned so that they
continue to sound at the original pitch.

Delete
To delete a clef, just select it and press Del. Note that clefs at the beginning of systems cannot be deleted.

Controlling the visibility of clefs
Standard clefs

To hide/show clefs at the beginning of all systems except the first:

From the menu bar, select Format→Style→Page;
Uncheck/check Create clef for all systems.

Mid-measure clefs are unaffected.

To hide/show all clefs on a selected staff:

Right-click on a measure;
Choose "Staff/Part properties";
In the dialog, uncheck "Show clef".

https://musescore.org/en/node/313555#comment-1169175
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329698-staff-properties
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This affects clefs at the start of a system and mid-measure.

Courtesy clefs

To hide/show courtesy clefs:

From the menu bar, select Format→Style→Page;
Uncheck/Check the Create courtesy clefs.

If courtesy clefs are enabled, you can still hide an individual courtesy clef as follows:

Select the relevant standard clef;
In the Properties panel, uncheck/check Show courtesy clef on previous system.

Clefs and transposition
Using octave clefs

[To be added]

Using different clefs for transposed and concert pitch

[To be added]

Clef properties
See Courtesy clefs (above).

Clefs applied to an entire measure or the first note in a measure are shown before the barline.

To move the clef after the barline:
1. Select the clef
2. Open the Properties panel
3. Under Position relative to barline, choose After

To replace the first clef in a score, see Add/Change a start clef.

Clef style
Tablature users can select the type of TAB clef displayed:

From the menu, select Format→Style→Clefs
Set the default TAB clef to "Standard" or "Serif" as required.

Other style properties are available in Format→Style→Page, namely:

Create clef for all systems
Create courtesy clefs

For details, see Controlling the visibility of clefs (above).

Key signatures

Overview
Key signatures are applied to the score from the "Key signatures" palette.

Setting the initial key signature for your score
The initial key signature is set from page 2 of the New Score dialog.

Adding a key signature change to your score
Use one of the following methods:

Select a measure and click a key signature in the palette.
Drag a key signature from the palette onto an empty part of a measure.

Note: It is also possible, though uncommon, to add a key-signature mid measure by selecting a note then clicking a palette key signature, or dragging the
key signature to a note.

Adding a local key signature for a single staff
If you wish to add a key signature to only one staff, leaving others unchanged, apply one of the following methods:

Select the measure from which you want the new key signature to apply, then press and hold Ctrl (Mac: Cmd) and click on a key signature in the

https://musescore.org/en/print/book/export/html/329209?toc=1#node-329757-courtesy-clef
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329655-additional-score-information
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(Key signatures) palette.
Press and hold Ctrl (Mac: Cmd), then drag a key signature from a palette on to a measure.

Selecting a key signature for a single staff
If you wish to select a key signature for a single staff only, press and hold Ctrl (Mac: Cmd), then click on the key signature.

Replacing an existing key signature
Use any of the following methods:

Select the key signature to be replaced, and click a new key signature in a palette.
Drag a key signature from the palette onto the key signature to be replaced (or onto the measure containing the key signature).

To replace the key signature on a single staff only, press and hold Ctrl (Mac: Cmd) before carrying out the above operations.

Deleting a key signature
To delete a key signature in the score, select it and press Del.
To delete a key signature from single staff only, hold Ctrl (Mac: Cmd) while selecting it, then press Del.

Controlling the visibility of key signatures
To show key signatures only at the beginning of a score, and at a key change:

From the menu bar, select Format→Style→Page;
Uncheck/Check "Create key signature for all systems".

To hide/show all courtesy key signatures (at the end of systems):

From the menu bar, elect Format→Style→Page;
Uncheck/Check "Create courtesy key signatures".

To hide/show a particular courtesy key signature:

Select the parent key signature;
In the Properties panel, uncheck/check "Show courtesy key signature on previous system".

Key signatures and transposing instruments
Care needs to be taken when working in written pitch and applying a key signature directly to a transposing instrument. For example, a Bb clarinet is
written a tone higher than it sounds; so, to get the clarinet to display in G major, you need to apply a key signature of F major from the palette. And so
on.

Open/Atonal key signature

Some instruments (e.g. French horn) are conventionally written with no key signature. To achieve this, you need to add an open/atonal local key
signature to the staff (this is already done in scores created from templates).

An open/atonal key signature looks similar to a 'C major/A minor' key signature. However, unlike standard key signatures, an open key signature always
remains the same, regardless of key changes to the rest of the score.

Creating a custom key signature
To create a custom signature:

In the "Key signatures" palette, click More, then Create key signature

https://musescore.org/en/print/book/export/html/329209?toc=1#node-329687-add-local-key-sig
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Drag accidentals onto the staff image as required. Note: Accidentals are horizontally aligned by default. If you want to an accidental in a custom
position, hold Ctrl (Mac: Cmd) while dragging it.

To remove an accidental select it and press Del. Note: The Clear button deletes all added accidentals.

To add the completed signature to the main palette, click Add.

Note: Custom key signatures are adapted to transposing instruments automatically. If You want transposing instrument to use custom key signature
exactly the same, as it is in palette, You need to transpose it back. Select measure where key signature is placed and use Tools→Transpose.

Key signature properties
You can edit properties specific to key signatures in the Key signature section of the Properties panel:

Show courtesy key signature on previous system: See Controlling the visibility of key signatures (above).
Mode: You can select a mode for the key signature if required—major, minor, dorian etc. The default is "unknown".

Key signature style
Various style properties affect key signature display.

Format→Style→Page

Create key signature for all systems

https://musescore.org/en/print/book/export/html/329209?toc=1#undefined-control-visibility
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Create courtesy signatures

The use of these properties is discussed in Controlling the visibility of key signatures (above).

Format→Style→Accidentals

Here you can change the way accidentals are displayed in key signature changes in the score.

Format→Style→Measure

Clef to key signature
Key signature to time signature
Barline to key signature
Key signature to barline
Key signature to first note

These properties control the various distances before and after key signatures in the score.

See also
Transposition

Transposition

Overview
Transposition is the act of raising or lowering the pitch of a selection of notes by the same interval.

In MuseScore, you can transpose your music using keyboard shortcuts, or via the Transpose dialog.

Transposing with keyboard shortcuts
To transpose with keyboard shortcuts, first select a range of notes (See Selecting elements). Then use one of the following options, depending on how
you need to transpose your music:

Transpose chromatically

Press ↑ or ↓ to move the selection up/down in semitone steps

Transpose diatonically

Press Alt+Shift+↑/↓ to move the selection up/down in scale degrees (Mac: ⌥+Shift+↑/↓).

Transpose by an octave

Press Ctrl+↑/↓ to move the selection up/down in octave steps (Mac: ⌘+↑/↓).

Using the transpose dialog
The Transpose dialog gives you more control over transposition, with options to transpose to selected keys or by specific intervals.

First select a range of notes you wish to transpose. (See Selecting elements). If no selection is made, the whole score is automatically selected for
transposition.

Then open the dialog by selecting Tools → Transpose...

https://musescore.org/en/print/book/export/html/329209?toc=1#undefined-control-visibility
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Transpose Chromatically

When this is selected, you can choose to transpose to a specific key, or by specified interval.

To transpose chromatically to a specific key:

Select To key
Select whether to transpose to the Closest key (relative to the current key signature of the selection), or Up or Down to the destination key
signature
Choose your destination key signature from the drop down menu
Leave Transpose key signatures selected to transpose any existing key signatures in your selection (deselecting this will leave any existing key
signatures unchanged)
Leave Transpose chord symbols selected to transpose any existing chord symbols in your selection (deselecting this will leave any existing chord
symbols unchanged)
Click OK

To transpose chromatically by interval

To transpose selected notes up or down in semitone increments:

Select By interval
Select whether to transpose your selection Up or Down by the specified interval
Select the transposition interval from the drop down menu
Select options for Transpose key signatures and Transpose chord symbols as required (see above)
Click OK

Transpose Diatonically

Select this to transpose the selection by a specified interval without changing the existing key signature(s). Note: the intervallic relationships between
pitches in your selection will change as a result!

Select Transpose Diatonically
Select whether to transpose your selection Up or Down by the specified interval
Leave Keep degree alterations selected to retain any accidentals in the selection (Note: accidentals will be modified relative to the existing key
signature. Note also: Deselecting this will remove any existing accidentals upon transposition)
Leave Transpose chord symbols selected to transpose any existing chord symbols in your selection (see above)
Click OK

Working with transposing instruments
Transposed and concert pitch

Transposing instruments (such as the clarinet, French horn, trumpet etc.) are notated at a different pitch (and key signature) to how they sound. The
notated pitch is called the written pitch, while the actual pitch is called concert or sounding pitch.

By default the program is displayed with all the staves at written pitch. However, if you wish to view the score at concert pitch just check the "Concert
pitch" box (to the left of the tuning fork icon) in the status bar.
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Setting the interval of transposition

When you set up a score in the New Score, or Add or remove instruments dialogs, transposed key signatures are automatically applied to any
transposing instruments. However if for any reason you need to set up the staff transposition manually, this is how to do it.

Right-click on the instrument staff and select Staff/Part properties;
Next to "Transpose" in the lower part of the dialog, select the interval that the instrument sounds above/below concert pitch. (Music for the Bb
clarinet, for example, is written a tone above its sounding pitch and the transpose setting is therefore a major second down.)

Click OK.

The correct transposed key signature will now appear on the staff.

Controlling enharmonic spelling

The enharmonic spelling of the transposed key signature, whether in sharps or flats, is set in Staff/Part properties (see Setting the interval of transposition
).

To change the enharmonic spelling of pitches in the score, see Change spelling.

Octave lines

Overview
Octave (Ottava) lines are used to indicate that a section of music is to be played one or more octaves above or below written pitch; the line may be
dotted or solid:

8--------┐or 8va--------┐: Play one octave above written pitch.
8--------┘or 8va--------┘: Play one octave below written pitch.

8va alta/bassa lines are particularly common in piano scores, though they are sometimes used in other instrumental music. 15ma alta (2 octaves above)
and 15ma bassa (2 octaves below) are also occasionally used.

MuseScore automatically adjusts playback of the score under the ottava to the correct pitch.

Ottava lines may be found in the Lines palette.

Adding an octave line to your score
See Adding a line to your score.

To adjust the range and vertical position of the line, see Adjusting elements directly.

Octave line properties
Properties specific to the selected ottava(s) can be adjusted in the Ottava section of the Properties panel, namely:

Style tab

Type: Specifies whether the Ottava line is 8va, 8vb etc.
Show number only: Hides any text (such as “va”).
Show line: Makes the line visible / invisible. Text is unaffected.
Allow diagonal: Allow line to slope if required.

For other properties in this tab, see Line properties.

Text tab

This has a similar user interface to general lines (see Line properties), but uses special code to specify the ottava text.

Octave line style
Default properties for ottavas can be adjusted in Format→Style→Ottava.

https://musescore.org/en/print/book/export/html/329209?toc=1#node-330553-apply-line
https://musescore.org/en/print/book/export/html/329209?toc=1#node-330553-line-properties
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Noteheads

You can choose from an extensive range of alternative noteheads including diamond, crosshead, and many others.

A number of alternative notehead systems are also available allowing you, for example, to write music with pitch names in noteheads, solfege, or shape-
note music. e.g.

Changing notehead direction
To flip a notehead horizontally (left to right of stem or vice-versa), use one of the following:

Press Shift+X.
Set Note direction in Properties: Note.

This also works for a selection of notes.

(Note: Contrast this command with X which flips the stem and beam vertically (top to bottom or vice versa)

Changing notehead shape
Select one or more noteheads;
Use one of the following:

Select a notehead from Notehead type in Properties: Note.
Click on a notehead in the Noteheads palette.

Alternatively, you can drag a notehead symbol from a palette onto a notehead in the score.

Sharing noteheads between voices
When two notes in different voices coincide on the same beat, they can either share a single notehead, or else be offset to allow the display of both
noteheads. This is done automatically by MuseScore according to certain rules (see below).

To force two offset noteheads in different voices to share a single notehead, use one of the following methods:

Make the smaller-value notehead invisible. This works for the majority of cases.
Select the smaller value notehead and in the Note section of the Properties toolbar change "Head type (visual only)" to that of the higher value
note.

Rules for automatically sharing or offsetting noteheads:

https://musescore.org/en/print/book/export/html/329209?toc=1#node-329664-visibility
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Notes with stems in the same direction do not share noteheads.
Dotted notes do not share noteheads with undotted notes.
Black notes do not share noteheads with white notes.
Whole notes never share noteheads.

Remove duplicate fretmarks in tablature

If you are using paired standard and tablature staves you will come across situations where a shared notehead in the standard staff generates two
fretmarks in tablature. In this case simply hide one of the fretmarks by making it invisible.

Alternative notehead schemes
To apply an alternative notehead scheme to all notes on a staff:

Right click on an empty part of the desired staff and select Staff/Part properties
Click on the Advanced style properties button
Make a selection from the Notehead scheme dropdown.
Click OK twice to exit the dialog.

To apply an alternative notehead scheme to only selected notes on a staff:

Select the notes to be changed
In the Properties panel, select the desired option from the Notehead system dropdown in the Note section (you may need to click "Show more" at
the bottom of the panel to reveal it).

There is a choice of normal noteheads, noteheads enclosing pitch names, solfege or various shape-note styles.

Adding pitch and velocity information to notes
To edit the playback velocity of a note:

In the Playback: General section of the Properties panel, edit "Velocity". This adds or subtracts the displayed value to/from the absolute velocity of
the note indicated in the score.

To modify the playback pitch of a note (without altering notation):

In the Playback: General section of the Properties panel, edit "Tuning (cents)". This adds/subtracts the displayed value to/from the note pitch
shown in the score.

Notehead properties
After selecting a notehead, the following properties can be edited in the Note section of the Properties panel:

Notehead parentheses: Add or remove parentheses.
Notehead type: See Changing notehead shape (above).
Hide notehead: Makes notehead invisible (see also, Properties: visibility).
Small notehead:
Duration dot position: This provides an alternative vertical offset for the duration dot.
Notehead system: See Alternative notehead systems (above).
Notehead type (visual only): See Change offset noteheads to a shared notehead (above).
Note direction: See Changing notehead direction (above).
Notehead offset: This changes the offset of the notehead only (to change the offset of the complete note, use "Offset" in Properties: Appearance
instead).

Ambitus

An ambitus indicates the range of notes included within a stave. It is used to indicate the appropriate voice for a particular part. See Wikipedia:
Ambitus .

Adding an ambitus to your score
To create an ambitus choose one of the following methods:

Select the desired start clef and click on the ambitus symbol in either the Pitch or Lines palette.
Drag the ambitus symbol from either the Pitch or Lines palette and drop it onto the desired start clef.

Changing the range of an ambitus
The top and bottom notes of the range can be manually adjusted via Properties.

Ambitus properties
Four different properties of the ambitus can be manually altered:
1. style: vertical or diagonal
2. notehead type
3. notehead duration
4. line thickness of the line joining the two noteheads

https://musescore.org/en/print/book/export/html/329209?toc=1#node-329664-visibility
https://musescore.org/en/print/book/export/html/329209?toc=1#undefined-change-shape
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329664-visibility
https://musescore.org/en/print/book/export/html/329209?toc=1#undefined-change-systems
https://musescore.org/en/print/book/export/html/329209?toc=1#undefined-offset-to-shared
https://musescore.org/en/print/book/export/html/329209?toc=1#undefined-change-direction
https://en.wikipedia.org/wiki/Ambitus_(music)
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Respell pitches

Manually changing the enharmonic spelling of notes
To change the enharmonic spelling of a note, or notes, in both written and concert pitch views:

Select a note, or group of notes;
Press J;
Continue pressing J to cycle through the enharmonic equivalents.

To change the enharmonic spelling in the written pitch view, without affecting the concert pitch view, or vice versa:

Select a note, or group of notes;
Press Ctrl+J (Mac: Cmd+J);
Continue pressing the same combination of keys to cycle through the enharmonic equivalents.

Note: If the pitches of selected notes are not all the same, the effect may be unpredictable.

Automatically respelling all notes in a selection
Respell pitches

From the menu, select Tools→Respell Pitches.

Notation: Expressive markings

Articulations

Articulations can be found in the Articulations palette.

These include all kinds of accents, staccato and vibrato markings.

Adding articulations to your score
Articulations can be added to your score in any of three ways:

Toolbar

Certain articulations (accent, marcato, staccato, and tenuto) can be added from the note input toolbar (above the document pane).

Select one or more notes;
Click on the desired icon in the articulations toolbar area.

Articulations palette

To add any articulation:

Select one or more notes;
Click on the desired articulation in the Articulations palette;

Alternatively, drag and drop an articulation symbol from the palette to a notehead.

Keyboard shortcuts

To add an articulation with a keyboard shortcut (i.e. accent, marcato, staccato, or tenuto):

Select one or more notes;
Apply the relevant shortcut from the list below:

Accent: Shift+V
Marcato: Shift+O
Staccato: Shift+S
Tenuto: Shift+N

Articulations playback
Certain articulations affect note playback—such as staccato, staccatissimo, louré (tenuto + staccato), and accents. This is handled automatically by the
program.
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Articulation properties
For a selected articulation any editable properties will be shown in the Properties panel.

Use the placement controls to either let MuseScore automatically choose the standard placement, or manually select above or below.

Placement: This alters the position of the symbol above or below the note.

Articulation style
Certain default properties for articulations can be edited in Format→Style→Articulations, Ornaments.

Alignment options

Align with stem

Align with notehead

Center between stem and notehead

Combined articulation options

Always keep together

Prefer closeness to notehead (combined articulations may become separated)
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Dynamics

Dynamics are symbols indicating the relative loudness or softness of a note or phrase of music. They can be found in the Dynamics palette.

There are two types of dynamics: standard ones, such as p and ff etc., which apply to the score from the point where the dynamic appears; and single-
note dynamics, such as sfz, which apply only to the note to which the dynamic is attached

Dynamics can be edited just like other text objects.

They have playback effect depending on each instrument's Sound setting selected in the Mixer, see MuseScore 3 features not implemented in
MuseScore 4: Velocity controls .

Adding dynamics to your score
Dynamics palette

To apply a dynamic to the score, use one of the following methods:

Select one or more notes and click a dynamic symbol in a palette.
Drag a dynamic symbol from a palette onto a note.

Combining dynamics with expression text

If the dynamic you want is not available in the palette, like poco f, you can do one of the following:

To snap expression text to a dynamic

Select a dynamic or a note with a dynamic
Add an Expression text element from the Text palette and it will snap to the right of the dynamic

Snap to dynamic can be turned off in the Properties panel.

To add text to a dynamic

Select a dynamic
Enter edit mode (double click)
Type text before or after the dynamic text

Dynamic text and expression text can be styled independently in the Properties panel.

Adding text to a dynamic marking does not affect playback.

Keyboard shortcuts for adding dynamics

Dynamic Windows & Linux Shortcut Mac Shortcut
Piano p Ctrl+Shift+P Cmd+Shift+P
Forte f Ctrl+Shift+F Cmd+Shift+F
Mezzo m Ctrl+Shift+M Cmd+Shift+M
Rinforzando r Ctrl+Shift+R Cmd+Shift+R
Sforzando s Ctrl+Shift+S Cmd+Shift+S
Niente n Ctrl+Shift+N Cmd+Shift+N
Z z Ctrl+Shift+Z Cmd+Shift+Z

Dynamics properties
Select a dynamic marking and open the Properties panel to adjust its properties individually. To edit default dynamics styles in the score, see Dynamics
style (below).

Scale: Control the size of the dynamic marking.
Avoid barlines: By default, dynamic markings avoid colliding with barlines, but this can be turned off..
Position: Choose whether a dynamic sits above or below the stave

https://musescore.org/en/node/334701#Velocity_controls
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329723-edit-mode
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329701-dynamics-style
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Alignment with notehead: For dynamic markings with custom text added, choose whether the dynamics symbol or the entire string of text centers
to its attached note (under Show more)
Frame: Add a square or circular frame to the dynamic marking and customize its styling (under Show more)

Dynamics style
The default positioning of all dynamics in the score can be adjusted from Format→Style…→Dynamics.

Hairpins

Types of hairpin
Hairpins are symbols used to indicate gradual changes of volume in the score. There are two kinds: crescendo (getting louder) and decrescendo (getting
quieter).

There are also crescendo and diminuendo lines which do the same thing:

All can be found in the Lines or Dynamics palettes.

Adding a hairpin to your score
Lines palette

To enter a hairpin from a palette use one of the following options:

Select a range of notes or measures, then click on a hairpin in the palette.
Drag and drop a hairpin onto a notehead. The hairpin will extend to the end of the measure.

Keyboard shortcuts

To enter a hairpin using a keyboard shortcut:

Select a range of notes or measures;
Use one of the following options:

For a crescendo hairpin press < ("less than" sign).
For a diminuendo hairpin press > ("greater than" sign).

Changing appearance of hairpins
Range

To extend or contract the range of a hairpin, see Changing range of a line.

Height

To change the height, select the height adjustment handle (shaded in the image below) …

… then use keyboard arrows, offsets (Properties panel), or dragging, to move the handle into the desired position. (See Basics: Adjusting elements

https://musescore.org/en/print/book/export/html/329209?toc=1#node-329658-select-range
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329658-select-range
https://musescore.org/en/print/book/export/html/329209?toc=1#node-331419-change-range
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directly.)

Alternatively you can adjust the "Height" in the Hairpin: Style section of the Properties panel.

Set at angle

To allow the hairpin to slope at a diagonal, check the "Allow diagonal" box in Hairpin: Style in the Properties panel. Then move the start/end adjustment
handles to get the desired slope.

Other adjustments

See Hairpin properties.

Changing playback of hairpins
[To be added]

Hairpin properties
You can edit properties specific to hairpins in the Hairpins section of the Properties panel.

Style tab

Niente circle: Places a small circle at the point of the hairpin.
Allow diagonal: Allows the hairpin to be set at an angle; see Changing appearance of hairpins (above).
Line style: Choose solid, dashed or dotted lines.
Thickness / Height:
Height (new system): Specify the height of subsequent hairpins if the first one spans a system.
Position: Above or Below.

Text tab

Properties here allow you to specify beginning, end, and continuation texts and their vertical offsets.

Hairpin style
Default properties for all hairpins in the score can be adjusted from Format→Style→Hairpins:

Slurs

A slur is a curved line between notes of different pitches indicating legato phrasing; exact interpretation depends on the instrument.

Slurs should not be confused with (note) ties which connect notes of the same pitch and extend the duration of the first note to encompass the connected
notes.

Adding a slur to your score
After selecting a note, a slur can be created using any of the following:

A keyboard shortcut, S. This option is both convenient and fast.
The menu option, Add→Line→Slur
A slur from the lines palette.

The exact method of applications depends on whether you are in note input or normal modes of operation. The keyboard shortcut method will be used as
an example.

https://musescore.org/en/print/book/export/html/329209?toc=1#undefined-properties
https://musescore.org/en/print/book/export/html/329209?toc=1#undefined-change-appearance
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329660-ties
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329757-note-input-mode
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329757-normal-mode
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Adding slurs in normal mode

Method 1

Select the note where you want the slur to start:

Press S to add a slur extending to the next note:

To extend the slur to the next note, hold Shift and press → (right arrow). Repeat as required:

To flip the slur direction, press X:

Press Esc to exit edit mode:

Method 2

Select the note where you want the slur to start;
Choose one of the following options:

To add a single slur: Hold down Ctrl (Mac: Cmd) and select the last note that you want the slur to cover.
To add slurs to all voices: Hold down Shift and select the last note that you want the slurs to cover.

Press S.

Adding slurs in note input mode

Enter the first note in the slurred section;
Press S to begin the slurred section;
Type in the remaining notes in the slurred section;
Press S again to end the slurred section.

Multi-voice and cross-staff slurs
Using method 2 (above) you can create a slur between notes in the same or different voices. Cross staff slurs can be created in exactly the same way.
e.g.

You can also adjust the start/end handles of an existing slur to move the start or end to a note of a different voice:

Click on the start/end handle of the slur.;
Press Shift+↑/↓ to move the start/end between voices, and from staff to staff.

Changing appearance of slurs
To adjust the shape of a slur or its range, see Adjusting elements directly.

Slur properties
The following properties specific to slurs can be adjusted in the Properties panel.

Style: Solid, dashed or dotted line.
Position: Above or below.

Slur style
Some default properties for all slurs in the score can be adjusted in Format→Style→Slurs/Ties:
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Breaths and pauses

Breaths and pause symbols may be found in the Breaths & pauses palette.

These symbols also have an adjustable playback effect.

Types of pauses
Fermata

A fermata, or pause appears above/below a note, and extends its written duration, indicating a pause in the music.

It may also be written above a rest, or a barline, indicating the end of a piece or section of music.

Breath mark

A breath mark is placed just above the staff, and tells a wind instrument performer or singer to take a breath here, or other instruments to pause slightly.
It may occur between two notes or at the end of a measure.

Caesura

The caesura also indicates a pause, slightly longer than a breath mark but less so than a fermata. It may occur between two notes or at the end of a
measure.

Adding a pause to your score
To add a fermata:

Select a note, rest or barline;
Click on a fermata symbol in the Breaths & pauses palette

Alternatively drag a fermata symbol onto a note.

To add a breath mark or caesura:

Select a note;
Click on a breath mark/pause symbol in the Breaths & pauses palette.

Alternatively drag a breath mark/caesura symbol onto a note.

MuseScore automatically places the breath mark/caesura in the correct position, just above the staff and after the selected note.

Changing pause playback
Pause symbols have a playback effect in the score. To adjust the pause length, click on Playback in the Properties panel and adjust "Time stretch".
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Pause properties
The position of selected pauses can be altered by clicking on Appearance in the Properties panel and adjusting the offsets. Alternatively you can drag a
symbol, or enter Edit mode and use the keyboard arrows to move it.

In addition you can position a fermata above or below the staff by selecting the desired option in "Placement on staff" in the Fermata section of the
Properties panel.

Pause style
You can specify default positional properties for all fermatas in Format→Style→Fermatas.

Ornaments

Ornaments and ornament lines can be applied from the Ornaments palette. This includes turns, trills, mordents and so on:

If the Ornaments palette is not already displayed in the palettes area, see Adding more palettes.

Adding an ornament to your score
Add an ornament

To add an ornament to the score:

Select one or more notes;
Click on the desired ornament in the Ornaments palette;

For a trill only, it is possible to use a custom shortcut instead at step 2.

Add an ornament line

The procedure for applying ornament lines is just like any other line, i.e.

Select a start note;
Press Shift and click on an end note;
Click on an ornament line in the Ornaments palette

If you subsequently need to adjust the ornament's length, see Changing the range of a line.

Changing ornament intervals (adding accidentals)
Ornaments are aware of the key signature and of other accidentals in the bar. By default, trills, turns, mordents and other ornaments will display and play
diatonic intervals. Use the Properties panel to change the interval, displaying the appropriate accidentals in the score and changing playback.

To change the interval of an ornament:

Select an ornament
Open the Properties panel
Use the interval selectors to choose the desired interval. The score will display the appropriate accidentals for the chosen interval.

Trills can be customized by quality (major, minor, augmented, etc.) and interval number from unison to octave. The appropriate accidental or upper
auxiliary note will display in the score above or below the ornament. For intervals larger than a second, consider using a tremolo.

https://musescore.org/en/print/book/export/html/329209?toc=1#node-329757-edit-mode
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329663-adding-more-palettes
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329668-shortcuts
https://musescore.org/en/print/book/export/html/329209?toc=1#node-331419-change-range
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Both the upper and lower interval can be set for turns.

Short trill and mordent intervals can be set to the minor or major second.

Any accidentals introduced only by an ornament must be confirmed or cancelled later in the measure for clarity, meaning it is not possible to delete
accidentals where the note:

is after AND in the same measure as an ornament with accidentals
as the same pitch class as a note with an accidental specified by the ornament (excluding the base note)

For example, in a measure starting with a chromatic turn on A as seen below, all Gs and Bs later in the measure will have an accidental, even if it is the
same as what appears in the ornament.

While these accidentals cannot be deleted, their visibility can be turned off. To do so:

Select the accidental
Open the Properties panel
Uncheck Visible

Ornament properties
The following properties of selected ornaments can be edited from the Ornament section of the Properties panel:

Accidental visibility

Default only shows accidentals that have not shown up yet in the measure.
Show any alteration shows accidentals again even if they appear earlier in the measure.
Always display an accidental shows accidentals even for diatonic notes.

Placement
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Use the placement controls to either let MuseScore automatically choose the standard placement, or manually select above or below.

Accidental properties

When selected, accidentals, including those linked to ornaments, have the following options in the Properties panel:

Add parentheses or brackets
Toggle small accidental

Ornament style
Default sizing and spacing properties for ornaments can be edited in Format→Style…→Articulations, Ornaments.

Ornaments can be individually repositioned by clicking and dragging in the score or via the Appearance dialog in the Properties panel.

Arpeggios and glissandi

Arpeggios, glissandi (slides) and strum arrows can be applied from the Arpeggios & Glissandi palette:

Many have an adjustable playback effect (see below).

Arpeggios
Adding an arpeggio/strum to your score

To add an arpeggio/strum to a score:

Click on any note in a chord (multiple selection is possible)';
Click on an arpeggio/strum symbol in the palette.

Alternatively you can drag an arpeggio/strum symbol from a palette onto a notehead.

Adjusting the height of an arpeggio/strum

Click on an arpeggio and two adjustment handles will appear at the top and bottom of the symbol. You can move either up or down by dragging, or by
selecting a handle and using the up/down keyboard arrows.

Creating multi-voice or cross-staff arpeggios

Multi-voice arpeggios

By default arpeggio symbols only span notes of the same voice. If you have a chord consisting of more than one voice, just extend the arpeggio as
shown above.

Cross-staff arpeggios

To create an arpeggio that crosses two staves:

First add an arpeggio to the chord component in the top staff;
Click on the bottom edit handle of the arpeggio and press Shift+↓.

The arpeggio should now extend to cover the chord in both staves. For it to stay that way, disable autoplace in its properties.

Changing playback of arpeggios
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To change the speed of a selected arpeggio, press Playback in the Properties panel, and adjust "Spread delay".

If you want to turn off playback altogether, untick the "Play" box in the General section of the Properties panel.

Arpeggio style

Default properties for all arpeggios in the score can be adjusted from the style menu at Format→Style→Arpeggios:

Glissandi
Note: Guitar slides are covered in Guitar techniques.

Adding a glissando to your score

Select one or more start notes;
Click on the desired glissando icon in the palette. A glissando is created extending to the next note in the same voice:

Alternatively you can drag a glissando symbol from the palette onto a notehead.

Glissandi can cross staves if needs be:

Editing range of a glissando

If required, you can change the start or end position of a glissando as follows:

Select the edit handle whose position you want to change;
Press Shift+↑/↓/←/→, to move the handle in the specified direction, one note at a time.

This method can also be used to move the edit handle between voices and across staves.

Changing appearance of glissandi

The line type of a selected glissando—whether straight or wavy—and any text associated with it, can be changed in the Glissando section of the
Properties panel. You can also turn off text by unchecking the "Show text" box.

Changing playback of glissandi

To change the playback effect, click on Playback and select an option from the dropdown list: chromatic, white keys, black keys, diatonic, portamento.

You can also choose to turn off the playback effect by unchecking "Play" in the General section of the Properties panel.

Glissando properties

The following properties are available in the Glissando section of the Properties panel.

Glissando line: Choose from "Straight" or "wavy".
Show text: Uncheck/Check this box to turn off/on the display of the glissando text.
Text: Specify any text to appear with the glissando.

The default style of all glissando text is determined by the settings of "Glissando" in Format→Style→Text styles.

Bends
Note: For guitar bends, see Guitar techniques.

The Arpeggios & glissandi palette also contains bend symbols for brass instruments such as the trumpet:

https://musescore.org/en/print/book/export/html/329209?toc=1#node-330563-adding-guitar-slide
https://musescore.org/en/print/book/export/html/329209?toc=1#node-330563-add-bend
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These have a playback effect on the score.

Types of bends

Fall:
Doit:
Plop:
Scoop:

if you are not sure what's what, mousing over the palette icon will display the name of the symbol in a tooltip.

Adding a bend to your score

Select a notehead;
Click on the desired bend symbol in the palette.

Alternatively, drag a bend symbol onto a notehead in the score;

Changing appearance of bends

To change the shape of the bend, click on it and four adjustment handles become visible. Drag the handles, or click on them and press the keyboard
arrows, until you get the shape you want.

Grace notes

Grace notes can be applied to the score from the Grace notes palette.

For bagpipe players there is a comprehensive range of grace notes in the Bagpipe embellishments palette.

Types of grace notes
Grace notes are small (cue-size) notes which ornament a previous or following note. They take their value from this parent note but do not themselves
count towards the measure duration.

There are several kinds:

Acciaccatura():  Usually written with an oblique stroke through the note flag, or through the beam, if there is a beamed series.

Appoggiatura:  A stressed note which takes half the value from the parent note.

Grace note after (trill endings):

Adding a grace note to your score
Note: For standard staves and tablature, the following instructions for adding grace notes work in both note input and normal modes.

Add grace note with keyboard shortcut

Ensure that the "parent" note is selected (multiple selection is possible in normal mode).
To apply an acciaccatura, press / (slash). For other grace notes use a custom shortcut (see Preferences: Shortcuts).

Add grace note from palette

Ensure that the "parent" note is selected (multiple selection is possible in normal mode).
Click on the desired symbol in the Grace notes palette.

Alternatively, you can drag and drop a grace note from the palette onto a note in the score.

Multiple grace notes
Sequential grace notes

You can add a run of grace notes to a selected note by repeatedly applying any of the following:

https://musescore.org/en/print/book/export/html/329209?toc=1#node-329668-shortcuts
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pressing the relevant keyboard shortcut (see above).
clicking on a grace note icon in a palette.
dragging and dropping a grace note from a palette onto a note.

Grace note chords

To apply a chord of grace notes:

Add a single grace note (as described above).
For standard staves use one of the following methods:

Press Shift and a note letter, A to G. This will add the corresponding note above.
Press Alt+1–9; or from the menu bar, select Add→Intervals and choose an interval from the list. This will add a note at the indicated interval
above the selected note.
You can add intervals below in the same way, but using a custom shortcut (see Preferences: Shortcuts).

For tablature, select the grace note in normal mode, then add further chord notes using the method of adding intervals in step 2.

Editing grace notes
Change duration

To edit the visual duration, click on the grace note in normal mode, and select a duration from the note input toolbar or by using a keyboard shortcut (see
Selecting duration).

Change pitch

Standard staves. To change the pitch of grace notes, use one of the methods described in Editing notes and rests.

Tablature. To change the pitch of grace notes, use one of the methods described in Changing the pitch in normal mode (tablature).

Changing playback of grace notes
[to be added?]

Grace note style
You can adjust the default size for all grace notes in Format→Styles→Sizes.

Tremolo and rolls

Types of tremolo and rolls
A Tremolo is the rapid repetition of one note or chord, or a rapid alternation between two notes or chords. The placement of tremolos is handled
automatically by the program.

Single note tremolo

For stemmed notes, the rhythmic value of the tremolo is indicated by the number of diagonal strokes through the stem. One stroke indicates that the
original note is divided into eighth notes. e.g.

Two strokes divides the note into sixteenth notes, and three strokes into thirty-second notes. On whole notes the tremolo symbol is placed above the
note.

Tremolo between notes

In traditional two-note or two-chord tremolos, incomplete beams are drawn between the notes to indicate the rhythmic value of the tremolo (to change the
style see below). One beam indicates eight notes, two beams sixteenth notes, and three beams thirty-second notes. e.g.

Buzz roll

A buzz roll symbol is also available from the Tremolos palette. However, it is notational only and currently has no playback properties.

Adding a tremolo to a single note
Click on a notehead in the score.
Click on the desired tremolo symbol in the Tremolos palette.

Adding a tremolo between notes/chords

https://musescore.org/en/print/book/export/html/329209?toc=1#node-329668-shortcuts
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329660-selecting-duration
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Enter the notes at half the desired final duration of the tremolo.
Select a note in the first chord.
Click on the desired tremolo symbol in the Tremolos palette.

Tremolo beams appear between the notes/chords and the appearance of the noteheads is adjusted accordingly.

Example: To enter a two-note tremolo with the duration of a half note (minim), enter two normal quarter notes (crotchets). After applying a tremolo symbol
to the first note, the note values automatically double to half notes.

Changing appearance of tremolos
Three styles of tremolos between notes/chords are supported in MuseScore; the default is traditional. To change the style:

Click on the (between notes) tremolo symbol.
In the Tremolos section of the Properties panel, click on the desired style icon under “Style (between notes)”.

Other lines

Overview
Note: The following page applies mostly to special-purpose lines such as guitar barre lines, fingering/string number lines, ornamentation lines, vibrato
lines, palm mute lines etc.

Information on more general-purpose lines can be found at:

Voltas
Hairpins
Slurs
Pedal lines
Octave lines

Lines often have text associated with them, and may feature a playback effect appropriate to the line type.

Adding a line to your score
Lines are applied to the score from a palette like any other element. By default, most can be found in the Lines palette; other specialist lines in the Guitar
palette.

To apply a line to a selected range:

Select a range of notes;
Click on a line in a palette;

Alternatively you can drag a line from a palette to the start note, then use the end adjustment handle to extend it (see Changing range of a line).

To apply a line to a single note:

Select a note and click on the desired palette line.
Drag a palette line to the desired start note.

Adjusting a line
To adjust the range of a line, see Changing range of a line.

Types of lines
Guitar-related lines

Barre lines: Used to indicate fret positions. For further details, see Adding a barre line to your score.
Fingering/String number: Apply the fingering first, then a plain line (LInes palette), and adjust the length as required.
Vibrato : Apply from the Guitar palette. You can change the shape of the line in the Vibrato section of the Properties panel.

The following also have playback effects:

Palm mute: Apply from the Guitar palette. This changes the sound to that of a clean muted electric guitar.
Let ring: Apply from the Guitar palette. Acts like the sustain pedal on a keyboard.

Tempo lines

See Tempo markings.

Staff and System Text lines

A staff text line, like staff text, is affixed to one staff in a system, and is indicative only for that staff. It appears only in the part featuring that staff.

A system text line, like system text, is affixed to one staff but is indicative for all the staffs in the system. It appears in all instrument parts.

https://musescore.org/en/print/book/export/html/329209?toc=1#node-329663-add-palette-item
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Trill lines

A variety of trill lines are available from the Lines palette.

Standard lines

Plain lines are applied from the Lines palette. They can be purposed to anything you like; their use in fingering/string number lines is discussed briefly
above.

Line properties
The Properties panel allows you to view and edit General, Appearance, and Playback settings.

The name of the section below varies depending on the type of line. But it will have two tabs marked Style and Text:

Style tab

Clicking on the Style tab allows you to set the properties of the line itself:

Line type: A choice of straight, hooked, angle-hooked, or double-hooked.
Thickness / Hook height:
Style: Choice of solid, dashed or dotted line.
Dash / Gap: Adjust the appearance if "Dashed" is selected.

Text tab

Clicking on the Text tab allows you to apply and position any text associated with the line:

Beginning text: Enter the text, if any, to appear at the beginning of the line.
Vertical offset: Allows you to move the text vertically in relation to the line (in sp.).
Text when continuing to a new system: If the line spans a system, this is the text that will appear before the line in the next system.
Vertical offset: As above.

Line style
A few properties of all lines in the score can be set in Format→Style→Text Line; and in Format→Style→System Text Line:

Other symbols

The Symbols palette is a category within the Master palette and houses all symbols and text from all built-in music fonts.

https://musescore.org/en/print/book/export/html/329209?toc=1#node-329664-general
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Unlike other categories in the Master palette, items in the Symbols palette are non-functional: they are for display purposes only and have no other
effect on the score.

You should find most symbols and text items you need for scoring in the Palettes panel—use of the Symbols palette should be reserved for specialist
items not available in the small palettes, or on those occasions when you really do need a non-functional element.

The Symbols palette
View

To view the Symbols palette, select View→Master Palette, or use the shortcut Shift+F9.

Selecting “Symbols” in the list of headings reveals all symbols under all subcategories. Selecting one subcategory to focus on a specific set.

Search

You can search for a symbol by entering a term in the Search box at the top of the Symbols section. Specify the musical font you want in the dropdown
at the bottom right.

Adding symbols to your score
Symbols added from the Symbols palette scale in line with the score (see Staff size), but their font-size is fixed.

If you need a symbol with an adjustable font-size, you should consider adding it instead from the Special characters palette as staff text.

https://musescore.org/en/print/book/export/html/329209?toc=1#node-329663-master-palette
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Add a symbol

Use one of the following methods:

Select one or more score elements (notes, rests, barlines) then click on the desired symbol in the Symbols palette.
Drag the desired symbol from the Symbols palette onto a score element (note, rest, barline).

Add to other symbols

After adding a symbol, you can, if required, add an additional symbol to the existing one. Use one of the following:

Select a symbol (previously added to the score from the Symbols palette), then click on the desired symbol in the Symbols palette.
Drag the desired symbol onto the existing symbol in the score.

Reposition symbols

To reposition, you can drag the symbol, or edit the offsets in the Apprearance section of the Properties panel. You can also move the symbol using the
keyboard arrows—after selecting it and entering edit mode by pressing Alt+Shift+E or F2.

If two symbols have been joined together (see Add to other symbols, above), moving the first-added symbol moves both. However you can still move the
second symbol in relation to the first.

See also

Using the palettes for information about how to search for and apply palette items to the score.
Working with images for how to apply images to your score.

Notation: Repeats

Repeat signs

A repeat sign looks like a double barline with a dot above and below the center line of the staff (see image below). It is used to enclose repeated
sections of the score.

Adding repeat signs to your score
Simple repeats

Place a start repeat barline at the beginning of the repeated section and an end repeat barline at the end.

If the start of the repeat section coincides with the beginning of the piece there is no need for a start repeat barline.

Multiple ending repeats

See Voltas, for repeat sections with multiple endings.

Changing playback of repeat signs
To change the number of times the repeat section is played, adjust the Play count of the final measure in the Measure properties dialog.

Changing appearance of repeat signs
In the Properties panel, you can specify repeat barlines with winged tips in "Barlines: repeat style".

Repeat properties
See Changing appearance of repeat signs (above).

Repeat style
You can specify repeat barlines with winged tips, and change the distance from the barline to dots for all repeat barlines in Format→Style→Barlines.

Voltas

Volta brackets are lines above the staff used to mark different endings for a repeat section. Score playback automatically follows the repeat indications.
For example:

https://musescore.org/en/print/book/export/html/329209?toc=1#node-329695-change-all-staves
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Here the repeat section is played once through with the ending marked "1", then a second time with the ending marked "2".

Adding voltas to your score
Make sure that any repeat barlines are in the correct position;
To apply the volta bracket use one of the following:

Select a measure and click on the desired line in the Lines palette
Drag a line from a palette onto a measure

If required, edit the beginning and continuing text in the "Text" tab of the "Volta" section of the Properties panel.
If required, specify the playback sequence by editing the "Repeats list" In the "Style" of the "Volta" section of the Properties panel. Enter a series of
numbers, separated by commas;
If required, ensure that the correct Play count is indicated in Measure properties.

Changing appearance of voltas
After selection, the general appearance of a volta line can be adjusted in the "Volta: Line type" section of the Properties panel. Line type, thickness, hook
type, and line style (solid/dashed/dotted) can be specified.

The beginning and continuing text (and their vertical offsets) can be edited in the "Text" tab of the "Volta" section. This is an indication only and does not
affect playback of the volta.

To change the range of a volta see Changing range of a line.

Changing playback of voltas
The actual playback is affected by the entry in the "Repeat list" (Volta: Style). This consists of a series of numbers each followed by a comma (the last
comma is omitted). This can be freely edited, but remember to ensure that Play count is also amended accordingly.

Example of a complex Volta setting

A correct volta setting is not always straightforward—as in the following example:

Volta properties
If a volta is selected in the score you can edit its properties in the Voltas section of the Properties panel. These are covered in the sections above.

Voltas style
Properties for all voltas in the score can be edited from Format→Style→Volta.

The "Volta" text style can be edited from Format→Style→Text Styles.

Jumps and markers

Jumps and markers are used to create repeated sections in a score.

Types of jumps and markers
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Jumps include:

D.C. (Da Capo): Jump back to the start of the score.
D.S. (Dal segno): Jump back to the segno (see below).
To Coda; Jump to the coda.

Markers include:

Segno: .
Fine: The end of the piece.

Coda:  The final section of the score.

Adding a jump or marker to your score
Use one of the following methods

Select a measure, then click the desired repeat symbol in the Repeats and jumps palette.
Drag and drop a repeat symbol from the palette onto the desired measure.

Changing appearance of jumps and markers
Jumps and markers are text objects and can be edited as such in the "Text" section of the Properties panel. You can also edit and style the wording as
required.

Changing playback of jumps and markers
If you select a jump or marker its playback properties can be viewed in the "Jump" or "Marker" section of the Properties panel.

In the case of jumps, you can see the titles of the markers that playback subsequently jumps to. These default settings should work for most users, but
you can change the destination markers if desired, as long as the named objects exist in the score.

You can also specify whether repeats are taken or not in the section jumped to, by checking/unchecking "Play repeats"

For markers, you can view and edit the title of the marker only.

Jump and marker properties
Properties specific to jumps and markers can be edited in the Jump and Marker sections of the Properties panel. See Changing playback of jumps and
markers (above).

See also, Text properties.

Jump and marker style
You can change the default text properties of all repeat signs of a particular text style (either "Repeat text left" or "Repeat text right") in
Format→Style→Text Styles.

Measure and multi-measure repeats

A measure repeat symbol indicates that the previous measure is to be repeated. Two- and four-measure repeat symbols indicate the repetition of the
previous two or four measures.

Adding a measure or multi-measure repeat to your score
To apply a measure repeat symbol, select a measure in the score and click on the measure repeat icon in the Repeats & Jumps palette. Or drag the
symbol on to a measure.

https://musescore.org/en/print/book/export/html/329209?toc=1#undefined-change-playback
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To apply a two- or four-measure repeat symbol, select the first blank measure following the section you want repeated, then click on the applicable
measure repeat icon in the Repeats & Jumps palette. Alternatively, drag the repeat icon from the palette onto the same blank measure instead.

Note: You may need to click the More icon in the palette to reveal the two- and four-measure repeat symbols.

In the case of multiple-measure repeats a "Group measures" symbol appears above and between measures. This keeps the measures together on the
same system, where possible, in case of any automatic layout changes in the score. This symbol can be deleted if desired.

Measure repeat properties
Number position in the Measure repeat section of the Properties panel, allows you to edit the vertical offset of the number above the measure.

Measure repeat style
Properties of all measure repeats in the score can be set from Format→Style…→Measure repeats:

Repeat playback

Turning repeat playback on and off
By default, repeats are always played. If you want to turn off repeat playback,

Click on the Cog button in the Play toolbar

Uncheck "Play repeats".

Idiomatic notation: Keyboard

Pedal

Types of pedal markings

Adding pedal markings to your score

Creating pedal changes

Pedal properties

Pedal style

Cross-staff notation

Creating cross-staff notation
First of all, enter the notation on one staff only.

Select a note in the voice that you wish to move up or down to the other staff. e.g.
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Press Ctrl+Shift+↓/↑ (Mac: Cmd+Shift+↓/↑), to move the voice up or down to the other staff. Alternatively, you can click on the cross-staff icon in
the note input toolbar and choose the same options from the context menu.

Note: This operation works on a voice basis, rather than on individual notes. It follows that if you want to ensure that notes remain on the same staff
during the operation, they should be in a different voice to the one selected above.

Changing appearance of cross-staff notation
To adjust the beam angle and height, click on the beam, then click on an adjustment handle and use the keyboard arrows, or drag the handle with a
mouse. e.g.

Alternatively you can make more precise adjustments from the beam section of the Properties panel.

See also

How to span a chord or stem over two staves  

Accordion notation

these symbols are literally just symbol from the Symbols, but there is a dedicated palette for them
we could consider eliminating this page
we could also consider adding one for harp

Adding accordion symbols to your score

Idiomatic notation: Guitar

Fretboard diagrams

Fretboard (or Chord) diagrams usually appear above the staff on lead sheets and piano scores:

They are commonly used for guitar chords, but MuseScore allows you to create diagrams for any stringed instrument.

A library of common guitar chord diagrams (major, minor and 7th) is provided in the Fretboard Diagrams palette.

To reveal the chord name of any diagram in the palette, hover the cursor over it.

Adding a fretboard diagram to your score
Use one of the following methods:

https://musescore.org/en/print/book/export/html/329209?toc=1#node-329681-beam-properties
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Select one or more notes, then click a fretboard diagram in the palette.
Drag and drop a fretboard diagram from a palette on to a note.

Chord symbols linked to fretboard diagrams

When any of the preset diagrams is applied to the score, a chord symbol is automatically placed above it. This linked chord symbol has the same
properties as a stand-alone chord symbol and can be edited and moved as such.

The default placement of a chord symbol in relation to its parent diagram is controlled by the “Distance to Fretboard Diagram” property (set in
Format→Style…→Chord Symbols→Positioning). This value interacts with the chord symbol Minimum distance (to view, press Appearance in the
Properties panel). Adjust the diagram’s position manually if you need to override this.

A linked chord symbol can be deleted independently of its parent diagram. You can also add a new linked chord symbol to a fretboard diagram: see
Entering a chord symbol.

Note: Neither fretboard diagrams nor their linked chord symbols are affected by transposition commands.

Creating a custom fretboard diagram
Select an existing fretboard diagram in the score; or add one from the Fretboard diagrams palette.
Ensure that the Properties panel is open (toggle F8).
Edit the properties in the Settings tab as required.
In the General tab, apply the following instructions to the fretboard image, as required:

Remove all dots: Click the Clear button above the diagram.
Add a finger dot: Click on a fret. The shape of the dot is determined by the Marker type setting. If Multiple dots is checked you can add
more than one dot per string.
Delete dot: Click on an existing dot.
Add barre / partial barre: If "Barre" is unchecked, press Shift and click on the string fret where you want the barre to begin. If Barre is
checked simply click on the fret. e.g.

Add partial barre ending before first string: Create a standard barre first (see previous instruction). Then shorten it by Shift clicking (if
Barre is disabled); or clicking (if Barre is enabled) the fret where you want the barre to end. e.g.

Delete a barre: With Barre disabled, Shift click on the "top" of the barre. With Barre enabled, just click on the "top".
Create multiple barres: Repeat the above steps at different fret positions.
Open / Mute strings: Click just above the diagram to toggle a string between:

No symbol
Open (o)
Mute/Unplayed (X)

Note: See also Fretboard diagram properties (below).

Finger markers

The default finger marker is a round black dot, which suffices for standard chord (and scale) diagrams. However a number of other shapes are provided
—cross, square and triangle—to enable other notation styles.

Alternative notation styles

Some arrangers and educators have extended the basic form of the fretboard diagram, incorporating finger dots of various shapes, and allowing multiple
dots per string. Jazz guitarist Ted Greene and his successors are notable examples.

Multi-dot notation style. With this approach, the chord signified by round dots on the fretboard diagram is played first (see image below). Then, on
successive beats marked by chord symbols, the chord fingering is modified to incorporate other shapes on the same diagram; the usual playing order is:
dot → X → square → delta, but this can vary.

Optional-note notation style. Another use of multiple dots per string allows other symbols to show optional notes, rather than delayed notes:

https://musescore.org/en/print/book/export/html/329209?toc=1#node-329728-enter-chord-symbol
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Fretboard diagram appearance
Select a chord diagram and click on Appearance in the Properties sidebar.

Edit the following properties as desired:

Leading: The leading space.
Measure width:
Min distance: Minimum distance from the staff.
Offset: Move the diagram horizontally or vertically.
Snap to grid:
Arrange: Backward or forward.
Color: Click on this button to change the color of a selected chord diagram.

Fretboard diagram properties

When a fretboard diagram is selected, its properties are viewable in the Properties tab of the sidebar as follows:

General (tab)

Barre: Check if you want to add or delete finger barres with one click on the fretboard image below. If unchecked, barres are added by Shift
clicking instead.
Multiple dots: If unchecked you can only add one finger dot per string. If checked you can add multiple dots per string.
Marker type: When you click on the fretboard image the shape of the dot added is determined by this property. This allows you to add a variety of
shapes if desired.
Clear: Clears everything leaving an empty fretboard.

Settings (tab)

Scale: Allows you to make the fingerboard larger or smaller.
Strings: The number of strings to be displayed.
Visible frets: Specifies the number of displayed frets: these are added, or removed, from the bottom of the diagram.
Fret number: Specifies the fret number to be displayed at the top left/right of the diagram.
Placement on staff: Positions the diagram above or below the staff.
Show nut: Check the box to embolden the nut. Applies to first position diagrams only.

At the bottom of the Fretboard diagram section of the sidebar is an image of the selected fretboard diagram. Any changes made to this image are
automatically applied to the fretboard diagram in the score as well.

Fretboard diagram style
Global fretboard diagram properties can be set in Format→Style…→Fretboard Diagrams:
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See also
Customizing palette contents

Guitar techniques

Adding a bend symbol to your score
Bends are created with the Bend Tool located in the Guitar palette.

Apply a bend

To apply one or more bends to the score, use one of the following options:

Select one or more notes and click the bend symbol in the palette.
Drag the bend symbol from the palette on to a note.

A default bend is created in the score. You can modify this bend or choose from a range of alternatives using “Bend type” in the Bends section of the
Properties panel.

Edit a bend

Bend shape and length can be edited in the graphical display in the Bends section of the Properties panel:

Each red line segment between blue nodes represents one step in the bend, and each step extends horizontally for 1 sp. in the score. The slope of any
line shows whether it is an up-bend, a down-bend or a hold. So the above graph describes an up bend, then a hold—total length 2sp.

The vertical axis of the graph represents the amount by which the pitch is bent up or down: one unit (the side of a small square) equals a quarter-tone, 2
units a semitone, 4 units a whole-tone, and so on.

To add another step to a bend

add another node by clicking on the appropriate line intersection.

To delete a bend step

click on the relevant node to remove it.

Adjust bend height

The height of the bend is automatically adjusted so that any text appears just above the staff. This height can be adjusted, if necessary, with a
workaround:

https://musescore.org/en/print/book/export/html/329209?toc=1#node-330542-Customizing_palette_contents
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329757-spatium


14/09/2023, 18:51Handbook for MuseScore 4

Page 144 of 270https://musescore.org/en/print/book/export/html/329209?toc=1

Create another note vertically above the note (shortening the height) or below the note (extending the height) at which you want the bend to start.
Apply the bend to the new note.
To adjust the height of the bend move this created note vertically so that the bend symbol gets the desired height.
Drag the bend symbol to the correct position (to the original note).
Mark the created note invisible and silent (using the Properties panel).

Reposition bend

Bends can be freely repositioned using the methods shown in Changing position of elements.

Adding a tremolo bar symbol to your score
Tremolo bar symbols are available from the Guitar palette (look for the oversized "V") and are applied and adjusted in a similar way to bend symbols
(above)—with a similar graphical interface in the "Tremolo" bar section of Properties.

You can choose from a range of presets in "Tremolo bar type", or create your own custom one.

Adding a slide to your score
Slides can be found in the Arpeggios and glissandi palette. They are of two types:

Glissando-type slides: these run from one note or chord to the next.

In / Out slides: played before or after a note; these can be slide-up or slide down.

By default, slides have a playback effect on the score. You can turn this off by unchecking "Play" in the General section of the Properties panel.

Add a slide

Use one of the following methods:

Select one or more notes as start points, then click the desired slide icon in the palette.
Drag the desired slide from the palette onto a note.

In the case of in-between slides going from one chord to the next, the program will attempt to link the correct notes where possible. If further adjustment
is required, see below.

Edit properties

For in-between slides, the following properties can be adjusted in the Glissando section of the Properties panel.

Type: Choose between Straight or Wavy.
Show text: Tick this box to display text. Note: If there isn't enough room between notes, the text is not displayed.
Text: The wording displayed above the slide (if any).

Adjust start and end points of a slide

In-between slides:

To move an end handle vertically or horizontally, from one note to the next:

Select the slide.
Click on the start or end handle:

Use Shift+↑↓ to move the handle up or down, from note to note.
Use Shift+←→ moves the handle horizontally, from note to note.

Slides in/out:

To adjust the position of the end handle:

Select the slide.
Click on the adjustment handle.
Drag the handle, or use the keyboard arrows.

Adding a barre line to your score
A Barre lines is a text-line drawn above a guitar staff to indicate that the passage requires a full or half barre. Symbols such as the following are
commonly found in guitar music:

Full bar (2nd fret):

Half barre (2nd fret):

https://musescore.org/en/print/book/export/html/329209?toc=1#node-331419-change-position
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The C before the roman numerals can be omitted and other variations in line style and text are possible—according to the publisher.

To apply a barre:

Click on the start note for the barre, then shift click on the end note to establish the range.
Click on the "Capo Line" symbol in the Guitar palette.
Customize the line and text as required. See Line properties (Other lines).

To adjust the length of a line, see Changing range of a line.

Adding hammer-on and pull-off symbols to your score
Hammer-ons and pull-offs are notated by slurs. If you need text annotations as well, create them using staff text; they can be saved to a palette for future
use (see Adding elements from your score).

Notating harmonics
Standard staff

A natural harmonic can be notated in one of three ways:

At the pitch of the open string on which it is produced. For example, harmonics on the third string appear as:

At the pitch of the string fret at which it is produced. The same harmonics now appear as:

At concert pitch. The same harmonics now appear as:

An annotation, such as "Nat. Har.", "N.H.", "Har.", is usually attached, as well as string and fret numbers; the notehead may be standard or diamond-
shaped, and rendered clear rather than black; fret numbers may be Arabic or Roman, and so on.

Fixing Playback: If harmonics do not play back at the correct pitch, mute them and create a hidden voice containing the harmonics at concert pitch.

See also, How to Read Harmonic Notation on the Classical Guitar  (douglasniedt.com).

Tablature

A natural harmonic in tablature may be rendered simply as a fretmark, or may be followed by a dot, or enclosed in a diamond, or a pair of angled
brackets. e.g.

To create a pair of angled brackets:

Select a harmonic and add staff text.
Enter a "single left-pointing angle quotation mark" (U2039), then a space, then a "single right-pointing angle quotation mark" (U203A).
Move the text so it sits over the fretmark;
Adjust the font size of the staff text and the space inside it to just enclose the harmonic.
Save it to a palette for future use.

Staff/Tablature pairs

You should ensure that the staff/tab pairs are not linked, since you need to be able to edit each staff independently of the other.

Notating guitar fingering
The types of guitar fingering and how to apply them are explained in Fingering.

Creating a tablature staff

Overview
Music for fretted, stringed instruments is commonly notated using tablature (often abbreviated as tab); this gives a visual representation of the strings
and fret numbers. Tablature is frequently found in combination with traditional staff notation.
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Types of tablature staves
A variety of tablature templates for common instruments are supplied. If this isn't quite what you're looking for, you can easily change the template (see
Changing tablature staff type), and/or customize the staff (see Tablature: customization).

Adding a tablature staff to your score
There are three possibilities:

Create tablature as part of a new score.
Add tablature to an existing score.
Change an existing staff from standard to tablature.

Add tablature using the New Score dialog

To create tablature as part of a new score:

Open the New Score dialog.
Select the required tablature from either the Choose Instruments or Create from template tabs.
Complete the rest of the New Score dialog.

Add tablature using the "Add or remove Instruments" dialog

To create a tablature staff in an existing score:

In the Instruments panel, click on the Add button; or press the shortcut key, I. This brings up the Add or remove instruments dialog.
Click on the Strings – Plucked family and choose the desired tablature from the Instruments column.
Press OK.

Change an existing staff from standard to tablature

Make sure that the standard staff contains a plucked string instrument;
Use one of the methods described under Changing tablature staff type.

Creating paired standard and tablature staves
Music for the guitar (and other plucked-string instruments) is often notated using paired standard and tablature staves. In MuseScore, the staves can be
either linked or unlinked.

Linked: Any change you make to the notation in one staff automatically updates the other.

Unlinked: Each staff is edited independently. To update the other staff, copy and paste the relevant music notation.

Note : In both cases, the staff/tablature pair shares the same instrument.

Create paired standard/tab staves using the New Score Wizard

There are two ways to do this when creating a new score (A or B):

A. For linked staves only:

Open the New Score Wizard.
In the "Create from template" tab, click on the "Solo" category and choose the "Guitar + Tablature" .
Complete the rest of the New Score wizard.
Change the instrument type, if required, in Staff / Part properties.
Change the tablature type, if required (see Changing tablature staff type).

B. For linked or unlinked staves:

Open the New Score Wizard.
In the "Choose instruments" tab, click on the "Strings – Plucked" family, and select a staff option from the "Instruments" column.
Complete the rest of the wizard.
Add the desired staff using the Instruments panel.

Create paired standard/tab staves using the Instruments dialog

Use this method when you want to add to an existing score:
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Open the Add or remove instruments dialog: press I; or, alternatively, the Add button in the Instruments sidebar
Click on the Strings – Plucked family and choose the desired staff from the Instruments column.
Press OK.
Add the desired tablature from the Instruments panel.

Note: If you already have one staff of a standard/tab pair in your score, you can simply add the missing staff from the Instruments panel. See Adding
and configuring staves.

Entering and editing tablature notation

Computer keyboard entry
In normal mode, select a measure, or note/rest.
Switch to note input mode: the cursor appears as a small “blue rectangle” on the currently "active" string.
Select the duration (see below) of the note or rest to be entered.
Press the up/down arrow keys to move the cursor between strings. Use the left/right arrow keys to navigate through the score.
Press a number from 0 to 9 to enter a fret mark from 0 to 9. To enter double digit numbers press each digit in sequence (Note: You cannot enter a
number higher than the “Number of frets” value set in the Edit String Data dialog).
Press ; (semicolon) to enter a rest of the selected duration.
To enter grace notes, see Grace notes.
You can enter notes in different voices if required—just as you would in a standard staff.

Note for period instrument tablature: A to K (skipping I) can also be used to enter numbers 0 to 9. In French tablature the corresponding letters appear
instead; for L, M, N, you need to type respectively 10, 11, 12.

See also, Editing notes and rests" (below).

Mouse entry
Enter note input mode and select the note or rest duration (see below).
Click on a string and MuseScore will enter a 0 which means "open string." (For French tablatures MuseScore enters an a. )
You can immediately type a single or double digit number to replace the 0. (Note: You cannot enter a number higher than the “Number of frets”
value set in the Edit String Data dialog).
You can also increase/decrease the fret mark using Alt+Shift+↑; or, Alt+Shift+↓.
You can enter notes in different voices if required—just as you would in a standard staff.

See also, Editing notes and rests" (below).

Selecting note duration
Whether you are using a keyboard or mouse, you can set note duration using one of the following:

Press Shift+0 up to Shift+9: to set duration from a 128th note to a longa (availability of these shortcuts may depend on the platform and/or
keyboard layout);
Press NumPad 0 to 9: to set duration from a 128th note to a longa (if a numeric keypad exists and NumLock is on);
Click on the desired note duration icon in the Note Input toolbar above the document window;
Press Q to decrease the selected duration and W to increase it.

Note: This applies to note input mode only. If you want to change the duration of a selected note in normal mode see Changing duration in normal
mode.

Period tablature notation
MuseScore also supports tablature notation for period instruments such as the renaissance and baroque lutes, Theorbo etc. There are a number of
notation systems in use (French, Italian, German, Spanish), but the most common is French.

French tablature features 6 lines representing the top 6 courses. Instead of numbers, fretmarks are indicated by letters—as explained above. Any notes
on bass courses below the 6th string (fretted or unfretted) are represented by symbols in the space underneath the 6th line of tablature.

To enter symbols below the 6th course:

In note input mode, move the cursor until it is in the space below the 6th line. Press ↓ to move the cursor to the next lowest course and so on. As
you do so a "cue mark" appears at the left side of the cursor to show you which course is active:

Cue mark Number of course Fretmark entered automatically for unstopped course
no cue 7 a
/ 8 /a
// 9 //a
/// 10 ///a
4 11 4
5 12 5
6 13 6
7 14 7

Conversely you can return to a higher course by pressing ↑, and the cue mark changes accordingly.
2. If the selected course is fretted simply enter a fretmark in note input mode (as shown above). If the selected course is unstopped press any note key in
note input mode and MuseScore will automatically enter the correct zero fretmark (see table above).
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Editing tablature notation
Changing the pitch

In note input mode:

Position the cursor over the fret mark and type the desired number.
Increment or decrement the fret mark using Alt+Shift+↑; or, Alt+Shift+↓ (The fret mark automatically changes strings, if necessary, to achieve the
lowest possible fret position).

In normal mode:

Select one or more fret marks.
Use any of the following commands:

To increment or decrement, without changing the string: Press ↑/↓.
To increment or decrement, changing strings, when possible, to minimize the fret number: Press Alt+Shift+↑/↓.

Note: The fret mark cannot be higher than the “Number of frets” value set in the Edit String Data dialog.

Moving the fretmark to a different string

To move the fret mark to an adjacent string without changing the pitch:

In note input mode:

Position the cursor over a fret mark, and press Ctrl+↑/↓ (Mac: Cmd+↑/↓).

In normal mode:

Use one of the following methods:

Select one or more fret marks, and press Ctrl+↑/↓ (Mac: Cmd+↑/↓).
Drag a fret mark up or down to an adjacent string.

Note: This operation can only proceed if the relevant string is free and can produce that note.

Changing the duration

See Changing duration in normal mode.

Crosshead/Ghost notes

To change a fret mark to a crosshead/ghost note:

Select one or more fret marks (in normal mode).
Press Shift+X to toggles ghost noteheads on/off.

Customizing a tablature staff

Changing tuning
Right-click on the staff and select Staff/Part Properties…
Press the Edit String Data… button at the bottom of the dialog box. This opens the String Data dialog:

Under Strings tuning, click on a string pitch and select Edit String…; Alternatively, just double-click the string pitch.
Select a new pitch in the Note Selection box and click OK. Alternatively, just double-click the new pitch.
Click OK to close the “String Data” dialog box.
Click OK to close the Staff/Part Properties dialog.

Notes: (1) If the tuning is changed on a tab staff that already contains some notes, fret marks will be adjusted automatically (if possible); (2) Any change
of tuning to a particular instrument applies only to the score at hand, and does not change any program default settings.

https://musescore.org/en/print/book/export/html/329209?toc=1#node-330536-duration-normal
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Adding or removing strings
Add a string

Right-click on the staff and select Staff/Part Properties…
Click on Edit String Data…
Click on a string pitch and select New String…
Select the new pitch and press OK; alternatively, just double-click the new pitch.

The new string is inserted below the selected string. You will also need to adjust the number of lines in Staff/Part properties→Advanced style properties.

Delete a string

Right-click on the staff, select Staff/Part Properties…
Click on Edit String Data…
Click on a string pitch and press Delete String.

Note: After deleting a tablature string you will also need to adjust the number of lines in Staff/Part properties→Advanced style properties.

Mark unfretted string “open”
For an instrument such as the Baroque lute, this feature is used to mark a bass course as unstopped—i.e. always played open like a harp string. This
means that only a fret mark indicating a zero fret can be displayed.

To mark a bass course as unstopped:

Right-click on the staff, and select Staff/Part Properties...
Click on Edit String Data…
Check the required boxes in the Open column.

See also Period tablature notation.

Change number of instrument frets
This property defines the maximum fret number which can be entered on a tablature staff.

Right-click on the staff, and select Staff/Part Properties…
Click on Edit String Data…
Select or enter a new number using the “Number of frets” spinner.

Changing tablature staff type
MuseScore provides a range of common tablature types. If you want to change the tablature type, choose one of two options:

Change staff type from Instruments panel

Ensure that the Instruments panel is visible (toggle F7).

Click on the arrow next to the instrument name to reveal the staves.
Click on the edit cog next to the desired staff and choose an option from the "Staff type" dropdown.
To close, press Esc, or click outside the dialog.

Change staff type from Staff/Part properties

Right-click onto an empty area of the staff and select Staff/Part Properties….
Click on Advanced Style properties, select the desired option from "Template", then press < Reset to Template. You can fine tune the display if
necessary using the "Fret Marks" and "Note Values" tabs.
Click OK twice to exit.

Note: For customization options in detail, see Customizing appearance of tablature (below).

You will find the terms "simple", "common" and "full" in the tablature type names:

Simple: Displays just fretmarks.
Common: Displays fretmarks, rests, stems and beams.
Full: Displays fretmarks; rests, stems and beams, half-note stems.

Customizing appearance of tablature

https://musescore.org/en/print/book/export/html/329209?toc=1#node-329698-advanced-style
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Right click on the staff and select Staff/Part Properties…
Click on Advanced Style Properties….

This gives you access to a full range of tablature customization options. See Staff properties: Tablature options.

Applying capos

Overview
A capo is a device clamped onto a fretted stringed instrument so that it can be played at a higher pitch. MuseScore allows you to emulate this effect by
adding Capo text to an instrument staff (or staves). This automatically transposes playback to the desired pitch while keeping the notes, or fretmarks,
unchanged. Partial capoes are also possible (see below).

Applying a capo to your score
The capo element is available in the Guitar palette, which is hidden by default. To reveal this palette:

Click Add palettes
Click the Add button next to Guitar

To apply a capo to a staff:

Click on the note, or rest, where you want to add a capo marking.
Click the Capo element in the Guitar palette. “Capo 1” is shown by default.
Adjust the settings in the popup dialog (see below).

Adjusting capo settings
Turning capo on or off

Select On at the top of the dialog to indicate that a capo should be added to the instrument.
Select Off to indicate that the capo should be removed from the instrument and return playback to the original key.

Setting capo position

The number in the Fret spinner refers to the fret where the capo should be applied. For example, fret 1 transposes the key up by a semitone, fret 2
by a whole tone, and so on. The text label in the score will update automatically.

Specifying partial capo placement

The switches in the Apply to section let you specify that a capo should be applied only on certain strings. When at least one is turned off, the text in
the score will change to indicate a partial capo.

Customizing capo text appearance

To change the wording of the Capo text:

Check the Manually specify instruction text box in the popup dialog.
Type the text you want to appear in the score.

To place the capo text beneath the staff:

Under Position, select Below.

https://musescore.org/en/print/book/export/html/329209?toc=1#node-329698-tab-options
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Changing capo setting mid-score
Using the steps above, you can, if desired, vary the capo setting at different points in the score. Each capo instance will affect the transposition of all
music that follows it, up until the next capo mark.

Note: it is not possible to apply more than one capo at the same time. This feature is planned for a later release.

Idiomatic notation: Harp

Overview
Harps typically have seven strings per octave, with one string per pitch-class from C to B. Modern harps also have seven pedals, each of which has three
positions: middle (natural), highest (flattened), and lowest (sharpened). Raising the pedal from middle position loosens the tension of one pitch-class of
strings in every octave, lowering the notes by a half step, and lowering the pedal results in notes a half step higher. For example, moving the C pedal to
the lowest position will make all C strings play C#.

In notated music for pedal harps, diagrams or text markings in the score indicate when to change pedal positions to change playable notes.

Adding a harp pedal diagram to your score
As of MuseScore 4.1 the harp pedal diagram element is available in the Harp notation palette.

To apply a harp pedal diagram to a staff:

Click in the score where you want to add a harp pedal diagram.
Click the Harp pedal diagram element in the Harp notation palette.
Choose the tuning in the popup dialog.

Notes that cannot be played with the selected pedal configuration will turn red.

The diagram view shows every pedal, while the text view shows only the notes that need to change since the last pedal marking.

By default, diagrams appear above the staves and text markings appear between them.

To change a diagram, select it in the score to reopen the popup dialog.
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Reading harp pedal diagrams
Visual diagram

The diagram corresponds visually to the seven harp pedals. The three to the left of the vertical line are the left foot pedals; the four on the right
correspond to the right foot. From left to right, the notes the pedals control are:

Left foot: D, C, B
Right foot: E, F, G, A

A bar on the line indicates the middle position, which plays a natural note. A bar above the line tells the player to raise the pedal, flattening the note, and a
bar below indicates lowering the pedal, sharpening the note.

For example, the playable notes indicated by the diagram below are C#, D, E, F#, G#, A, and B.

Text diagram

The upper line of notes refers to the pedals controlled by the right foot, and the bottom line to the left foot pedals.

The first instance of a harp pedal text diagram in the score will always show the positions of all seven pedals. The text view shows only the notes that
need to change since the last pedal marking.

Text diagrams appear between the staves by default, but can be manually repositioned.

Idiomatic notation: Percussion

Entering and editing percussion notation

Overview
In percussion notation, the lines and spaces of the music staff are allocated to different instruments—rather than different pitches—and a range of
different notehead shapes is used.

The example below shows a simple drumkit beat on a five-line music staff. By convention, the bass drum rhythm is written on the lowest space of the
staff, the snare drum on the third space, and the closed hihat, using crosshead notes, on the space above the staff.

Drumkit scores are often written using two voices: voice 1 (with stems up) for instruments played by the hands, such as drums and cymbals; and voice 2
(with stems down) for instruments played by the feet, such as the bass drum and hi-hat pedal.

Types of percussion staves

Percussion music is usually written on a 5-line, 3-line, or 1-line staff—depending on the instrument. When a percussion instrument is created using the
New Score dialog, MuseScore automatically chooses the most appropriate staff type. This can be changed later, if necessary, using the "Staff type"
column in the Instruments panel.

Adding a percussion staff to your score

See Setting up your score and/or Instruments panel.

Entering notes and rests in percussion staves
There are several ways of entering music on a percussion staff:
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Using a Mouse (and the Drum Input Palette).
Via keyboard shortcuts.
Using an external MIDI keyboard.
Using the virtual piano.

After each note or rest is entered, the cursor automatically advances so that it is in the correct position for subsequent entry.

Mouse entry using the Drum input palette

Select a start location in the percussion staff.
Enter note Input mode (shortcut N). The Drum input palette (DIP) appears at the bottom of the window:

This displays a range of percussion instruments and how they will appear on the staff. If any instrument has a keyboard shortcut this is shown
above the staff.
Click on an instrument in the DIP, and its name appears on the left-hand side of the palette. The color of the note shows the voice pre-allocated to
that instrument: blue for voice 1, green for voice 2 etc.
Use one of the following methods:

Click on an instrument in the DIP; select the desired note duration, then, click on the staff at the desired location.
Select a note duration, then double-click the desired instrument in the DIP. The note is entered at the cursor position.
Note: Any existing notes in that voice are overwritten.

To enter another instrument in the same voice at a location, press Shift, then double-click the instrument in the DIP.
To enter a rest of the selected duration, press 0 (zero).

Using keyboard shortcuts

This method is suitable for adding instruments which have a keyboard shortcut displayed in the Drum Input palette.

Select a note, rest or measure in the percussion staff as a start point.
Enter note Input mode (shortcut N). The Drum input palette (DIP) appears at the bottom of the window (as above).
Choose a note duration.
Type the keyboard shortcut for the desired instrument; this is shown above the staff in the DIP. The note is entered at the cursor position.
Note: Any existing notes in that voice are overwritten.
To enter another instrument in the same voice, hold Shift, while entering the shortcut.
To enter a rest of the selected duration, press 0 (zero).

Note: Shortcuts can be changed in the Edit drumset dialog.

Using a MIDI controller

To add notes to a percussion staff from a MIDI keyboard:

Ensure that the MIDI keyboard is connected to your computer before launching MuseScore. Check that it is functioning correctly.
Note: If you click on the percussion staff in normal mode, you can "preview" the sound of the percussion instruments from the MIDI keyboard.
Click on the note or rest where you want to start.
Enter note input mode.
Select the voice in which you wish to enter notes.
Select a note duration.
Press an instrument key to add a note to the score. To add another instrument in the same voice, keep the first key held down while pressing the
second key.
To enter a rest of the selected duration, press 0 (zero).

Note: Refer to a GM2 drum map for details about which MIDI keyboard key corresponds to which percussion instrument.

Using the on-screen piano keyboard

To add notes to a percussion staff from the virtual Piano Keyboard:

Ensure that the Piano keyboard is displayed. Press P (or select it from the menu, View → Piano keyboard).
Note: If you click on the percussion staff without entering note input mode, you can demo the percussion instruments from the Piano keyboard.
Click on the note or rest where you want to start.
Enter note input mode.
Select the voice in which you wish to enter notes.
Select a note duration.
Click on a (virtual piano) key to add a note to the score. To add another note to an existing one, press Shift and hold it while pressing the new note.
To enter a rest of the selected duration, press 0 (zero).

Note: Refer to a GM2 drum map for details about which piano key corresponds to which percussion instrument.

Drumset customization

Introduction
You can customize the drumset using the Edit drumset dialog. This can be opened in note input mode from the Drum input palette by clicking on the
Edit drumset button (bottom left of the program window). Alternatively, in normal mode, right-click on the percussion staff and select Edit drumset...

https://musescore.org/en/print/book/export/html/329209?toc=1#node-329660-note-input-mode
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329660-selecting-duration
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On the left is a list of available percussion instruments. You can put these in MIDI number order by clicking on the "No." heading; this automatically shows
them in note order as well. Clicking again puts the list in reverse order.

The right of the dialog shows you how the selected instrument is displayed on the percussion staff: its name, position, notehead type and note-stem
direction.

Any changes made here are automatically saved in the parent MuseScore file (after pressing OK). You can also save the drumset independently as a
drumset file.

Customizing a drumset definition
Selecting a sound

info on GM drum sounds
how much of this is relevant for VST?

Defining the note

Name

Noteheads

Other properties

Saving and loading drumset definitions

Other percussion notation

Diddles
Diddles can be added by using an eighth-note Tremolo.

Pedal lines
To add a vibraphone pedal line, see Pedal.

Rolls
To add a drumroll to your score, see Tremolo.
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Sticking
To enter sticking symbols (R, L):

Select a start note;
From the menu, select Add→Text→Sticking (alternatively, set up a keyboard shortcut to do the same
thing). The cursor positions itself ready to accept your keyboard input;
Input the letter just as you would normal text. To move forward or backwards to the next note, see Keyboard commands (chord symbols).
To exit, press Esc, or click on a blank section of the score.

Alternative notation

Mensural notation and Mensurstrich

Adding a mensural time signature to your score
To apply mensural signs to a score you need to add a conventional time signature first, then modify its display by substituting with the appropriate
mensural symbol in the Time signature properties dialog. Note that these signs are for show only; it is not possible to modify the duration ratio between
different note values, and the actual underlying time signature remains unchanged.

Using mensural note symbols
[to be added]

add from symbols palette, hide

Working with non-metered music
Early music, such as renaissance choral music, may be written without barlines or a time signature. This can be achieved in MuseScore as follows:

Set up the instruments or voices of the score in the usual way (See Setting up your score);
Hide the time signature;
in Format→Style→Score, check the box titled "Display note values across measure boundaries";
Right-click on a measure in the top staff and select Staff/Part properties;
Uncheck "Show barlines"; repeat this for each applicable staff (see note);
Click OK.

Note: In step 4 you can make the barlines invisible instead by selecting all and pressing V.

Note that the score still behaves as if measures are present. Measure properties can be applied if required.

Working with Mensurstrich
Mensurstrich is a form of modern notation of early music in which barlines are drawn between staves rather than across them:

Adding barlines between staves

Right click on the bottom staff of the intended mensurstrich system, and select Staff/Part properties. Uncheck "Show barlines".
Select the first (not the start!) barline for each of the remaining staves;
Check the "Span to next staff" box in the Barline section of the Properties panel;
Adjust "Span from" to set the position of the top of each barline;
Press Set as staff default;

https://musescore.org/en/print/book/export/html/329209?toc=1#node-329668-shortcuts
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329728-commands
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329680-time-sig-properties
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Displaying note values across measure boundaries
From the menu bar, select Format→Style→Score;
Check "Display note values across measure boundaries".

See also

Slash notation

Filling a range with beat slashes
To indicate that a range of measures is to be strummed—but without indicating the exact rhythm:

Select the desired range of blank measures
From the menu, select Tools→Fill with slashes

Apply chord symbols in the usual way to the slashes.

Using beat slashes is a quick and convenient way of indicating strumming. The exact rhythm is left to the player and only the chord symbols play back.

To notate the chord slashes with the correct duration:

Fill the applicable measures with beat slashes, as shown in steps 1 and 2 (above)
Select the slashes and in the Properties panel, uncheck “Stemless” in the Note: Stem section.
Change the duration of slashes, as required
To change a rest to a slash, copy and paste a slash to it of the same duration
To indicate a mute strum, select the slash and click the cross notehead in the Noteheads palette (or in the Note: Notehead section of the
Properties panel).
To ensure the correct note beaming pattern, select the range of measures and apply “Auto” from the Beam properties palette.
Apply chord symbols in the usual way to the slashes.

Creating rhythmic slash notation
To notate the strum rhythm, with the option to include correct playback, you need to use rhythmic slash notation.

Accompaniment rhythms on the staff

Add the chords, in full, in standard notation on the staff
Select the range of chords
From the menu bar, select Tools→Toggle rhythmic slash notation
To unmute the slash notation, select the applicable range of chords and check “Play” in the Properties: General panel.

Accent rhythms above or below the staff

Custom staff types

Customizing appearance of staff lines
Number
Color
Visibility
Line distance

Customizing appearance of generated elements
Clef
Key signature
Time signature
Barlines

Customizing appearance of notes
Ledger lines
Stems
Notehead scheme

Changing staff type mid-score
Most of the above plus line & step offset

https://musescore.org/en/print/book/export/html/329209?toc=1#node-329658-select-range
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Text

Entering and editing text

Overview
Many score objects are text-based. For example

Title, Subtitle, Composer, Lyricist
Tempo marks
Dynamics, such as p or mf
Expressions such as Andante or Allegro
Fingering numbers
Lyrics
Chord symbols

And so on …

Text, of whatever type, always has an object to which it is attached.

Some types of text (Title, Subtitle etc.) are associated with frames;
Staff and System text are attached to a music staff;
Jumps and markers are attached to measures;
Fingering is attached to a particular musical note;
Header and Footer text appear at the head and foot of the score respectively.

And so on …

See the table below, under "Types of text", for links to handbook pages for specific types of text.

Adding text to your score
A text object may get entered from a palette, the Add menu, or using a keyboard shortcut.

Note: Adding text to a frame is dealt with elsewhere; see Text blocks.

Add text from a palette

To add a text element to your score from a palette, either select one or more notes/rests and click on the desired palette item; or drag the text from the
palette onto a note/rest. e.g.

https://musescore.org/en/print/book/export/html/329209?toc=1#undefined-text-types
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329663-add-palette-item
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Add text from a menu

If the text object is associated with a staff you can add it by selecting a note, then choosing a text option from Add→Text.

Add text using a shortcut

Many text types can be entered using keyboard shortcuts. You can view a list of shortcuts next to the items in Add→Text.

To create a text object, select a note, then enter the required shortcut.

Deleting text objects from your score
To delete one or more text objects, select the objects then press Delete.

Editing text
To enter text edit mode use one of the following methods:

Double click on the text object.
Select the text object and press Return.
Select the text object and press F2 or Alt+Shift+E.
Right-click on the text object and select "Edit element."

You can now add, edit and format the text within the text object.

To leave text edit mode either press Escape or click on a part of the score outside the edit area.

Keyboard shortcuts

The following keyboard shortcuts are available in text edit mode:

Function Windows & Linux Mac
Bold (toggle) Ctrl+B Cmd+B
Italic (toggle) Ctrl+I Cmd+I
Underline (toggle) Ctrl+U Cmd+U
Move cursor Home, End, ←, →, ↑, ↓ (Alt+) ←, →, ↑, ↓
Remove character to the left of the cursor Backspace Delete
Remove character to the right of the cursor Del → Delete or Fn+Del
Start new line ↵ return
Insert special characters (see below) Shift+F2 Fn+F2

Special characters

Characters not available from the standard keyboard may be accessed using the Special Characters window.

To open Special Characters In text edit mode, press Shift+F2; or click on Insert special characters in the Text section of the Properties panel.

The dialog is divided into 3 tabs: Common symbols, musical symbols and unicode symbols. The musical and unicode tabs are further subdivided into
alphabetically-arranged categories.

Clicking an item in the Special Characters dialog immediately adds it to the text where the cursor is positioned. Multiple items can be applied without
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closing the dialog box, and the user can even continue to type normally, delete characters, enter numerical character codes etc., with it open.

A few special characters can also be created using shortcuts—see below.

Special character shortcuts

Character Windows & Linux Mac Note

Sharp ♯ Ctrl+Shift+# Cmd+Shift+# May not work on some keyboard
layouts

Flat ♭ Ctrl+Shift+B Cmd+Shift+B

Natural ♮ Ctrl+Shift+H Cmd+Shift+H

Piano p Ctrl+Shift+P Cmd+Shift+P
Forte f Ctrl+Shift+F Cmd+Shift+F
Mezzo m Ctrl+Shift+M Cmd+Shift+M
Rinforzando r Ctrl+Shift+R Cmd+Shift+R
Sforzando s Ctrl+Shift+S Cmd+Shift+S
Niente n Ctrl+Shift+N Cmd+Shift+N
Z z Ctrl+Shift+Z Cmd+Shift+Z
Elision ‿ Ctrl+Alt+- Cmd+Alt+-

Types of text
Text type Uses

Staff text General purpose text attached to a single staff:
appearing only in that instrument part.

System text General purpose text attached to a single staff:
appearing in all instrument parts.

Chord symbols Display the chords associated with a melody:
usually above the staff.

Fingering Numbers or letters attached to notes showing
which fingers to use.

Lyrics Create lyrics attached to a melody.

Rehearsal marks Facilitate rehearsals, divide score into sections,
bookmark passages etc.

Dynamics Indicate the loudness of a note or phrase.
Figured bass Period notation for keyboarders.

Frame text Title/composer/lyricist details at the start of a
score; song sheet lyrics etc.

Headers/Footers Page numbers, copyright info etc. at the
top/bottom of a page.

Instrument text Apply mid-staff instrument changes.
Repeats and jumps (voltas) Da Capo, Dal segno, Fine etc.
Roman Numeral Analysis (RNA) A chord analysis system.

Sticking Letters (L and R) attached to (drum) notes
showing which hand or foot to use.

Swing text Change from straight to swing time, and vice
versa.

Tempo marks Apply metronome and/or expression marks.
Text-lines Voltas, ottavas, pedal lines, guitar barre lines etc.

Formatting text

Overview—levels of formatting
There are three levels of text formatting in MuseScore:

Text style
Text object
Character

Text style

When you create a text object in the score it automatically assumes a style appropriate to its class. For example, a tempo mark will have the “Tempo”
style; a fingering number, the "Fingering" style and so on.

A style consists of a group of text properties (font-size, align, offset etc.) with specific values. You can view the full range of text styles in
Format→Style→Text Styles.

To check the style of a selected text object, click the More button in the Text section of the Properties panel. The style name will be visible under "Text
style".

Text style is the top level of formatting.
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Text object properties

The text properties of a particular, selected text object can be viewed and edited in the Text section of the Properties panel.

This is the second-level of formatting—the text object level.

Character formatting

Individual characters within a text object may themselves be formatted independently.

This is the third level of formatting—the character level.

Formatting hierarchy

Character formatting overrides Text object formatting, which, in turn, overrides Style.

Applying text properties
Apply to a text object

After clicking on a text object you can edit its text properties in the Text section of the Properties panel.

Click More to see:

Apply to characters

In order to edit the characters within a text object you need to enter text edit mode using one of the following methods:

Double-click on the text object.
Select the object and press F2 or Alt+Shift+E
Right-click on the element and select Edit element

Then you can apply formatting to highlighted characters using the Text section of the Properties panel, and/or keyboard shortcuts (see Editing text).

Note that certain properties in the Properties panel are not applicable to characters—such as "Alignment", "Frame", "Text style" and so on. If you attempt
to apply them, they are added to the text object instead.

Setting style defaults
If you want to change the default style properties of a particular class of objects, you can do so in the Style menu: From the menu bar, select
Format→Style→Text Styles.

However, it is often better to do this from the Properties panel itself:

Select a score object of the style in question;
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Edit a property;
Click on the ellipsis (…) above the property and select "Save as default style for this score".
Repeat for other properties as required.

Selecting different text styles
If you wish to change the text style associated with a text object:

Click on the text object.
Click the More in the Text section of the Properties panel.
Select a new style from the dropdown list under "Text style".

Position
For text objects applied to the staff, the default position may be above or below the staff. This may be changed at the style or text object level with the
Position property (Above/Below).

Staff and system text

Overview
Staff text and System text is general purpose text attached to a staff. It can be used for a variety of purposes not covered by other more specific types
of text, e.g.

Musical expressions.
Performance indications.
Applying titles to movements.
Capo playback for guitarists (staff text only).
Applying swing and straight time (staff or system text).

and so on.

Staff text appears on only one staff in a system, applies only to that staff, and is present in its instrument part.

System text appears above the top staff of a system, applies to all staves, and is present in all the instrument parts.

Staff and system text can also be found incorporated into lines.

Adding staff text to your score
Select a note
Use one of the following methods:

Press Ctrl+T.
From the menu, select Add→Text→Staff text.
Click on the "Staff text" icon in the Text palette

Enter the desired text in the bounding box.

Alternatively, drag the "Staff text" icon onto a note in the score before entering the desired text.

Adding expression text to your score
Select a note
Use one of the following methods:

Press Ctrl+E.
From the menu, select Add→Text→Expression text.
Click on the "Expression text" icon in the Text palette

Enter the desired text in the bounding box.

Alternatively, drag the "Expression text" icon onto a note in the score before entering the desired text.

Adding system text to your score
Select a note
Use one of the following methods:

Press Ctrl+Shift+T.
From the menu, select Add→Text→System text.
Click on the "System text" icon in the Text palette

Enter the desired text in the bounding box.

Alternatively, drag the "System text" icon onto a note in the score before entering the desired text.

Repeating system text on other staves
System text automatically appears above the top staff of the system. If you need a similar indication on a lower staff, add it to that staff using staff text.

[Adding automatically via a template? – to be added]
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Staff and system text properties
Staff text properties, for swing and capo settings, can be accessed as follows:

Right-click on the text object
Select Staff text properties
Choose one of the following tabs:

Swing settings
Capo settings

System text only has one property, swing, and this is applied using a similar context menu.

Staff and system text style
Some default properties for all staff text in the score can be set from Format→Style→Staff text.

And for system text lines, from Format→Style→System text line.

Tempo markings

Overview
A variety of tempo markings/marks may be found in the Tempo palette. These include

Metronome marks: 
Text indications: Andante, Allegro etc.
Metric modulations: 
Tempo change lines: rall., accel. etc.

Metronome marks, text, and metric modulations modify the tempo of score playback once from the point at which they are applied. Tempo change lines
work with the existing tempo and vary it over a range of notes.

If required, you can override the written tempo temporarily using the Playback panel.

A tempo mark is a form of system text; it appears above the top stave but applies to all staves in the system.

Adding a tempo mark to your score
To add a metronome mark, tempo text or metric modulation to the score, use one of the following methods:

Select one or more notes/rests and click on a tempo symbol in a palette.
Drag a tempo symbol from a palette onto a note/rest.
From the menu bar, select Add→Text, and click on Tempo marking.

To add a tempo change line, use the same method as for lines.

Using metronome markings

A metronome mark consists of a musical note indicating the duration of the beat, an equals sign, then a number showing the beats per minute (bpm). So
the following mark

indicates a tempo of 80 quarter notes (crotchets) per minute, and so on.

Using text markings

The Tempo palette also contains text markings, such as Andante, Allegro etc. The background tempo can be read off in the Tempo section of the
Properties palette.

Changing appearance of tempo markings
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Tempo markings can be edited just like any other text object: see Entering and editing text.

To edit the appearance of Tempo change lines, see line properties.

Changing playback of tempo markings
Metronome marks

You are free to change the tempo number as required.

Tempo text

You can override the written tempo by unchecking "Follow written tempo" in the Tempo section of the Properties panel, and setting a new tempo in the
"Override written tempo" box.

Metric modulations

If the note value relationship you require is not part of an existing metric modulation, you can customise the note values as follows:

Add a metric modulation to the score from the Tempo palette
Highlight the note in the metric modulation that you wish to change
Open the Special characters palette
Click on the note/dot in the "Common symbols" tab that you wish to insert.

Tempo change lines

You can set the Tempo "Change amount" and "Easing method" in the Playback: General section of the Properties panel.

Repeating tempo markings on other staves
Tempo text always appears on the top staff of the system. If you need to see it on lower staves as well, use staff text and insert the beat note as a special
character.

Tempo properties
See above—Changing playback of tempo markings.

Tempo style
Default positioning properties of tempo markings can be set in Format→Style→Tempo text.

Lyrics

Overview
Lyrics are a form of text associated with melody lines on staves. e.g.
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As you can see in the example above, lyrics are entered syllable by syllable, those within words being connected by hyphens. Underscore lines or
hyphens (depending on the context) are used to indicate melismas, where a syllable extends over several notes (see below).

Lyrics are organized into verses, with verse 1 at the top and subsequent verses in order below.

Adding lyrics to your score
In order to enter new lyrics, or to edit/format existing ones, you need to be in lyrics mode.

There are two ways to enter lyrics mode:

Start from a selected note—see Entering syllables (below).
Start from an existing lyric syllable—see Editing existing lyrics.

Entering syllables

Select the desired start note, and enter lyrics mode by pressing the keyboard shortcut Ctrl+L (Mac & Linux: Cmd+L). This will create a bounding box
ready for text input.
Type the syllable;
To enter a connected syllable, press - (hyphen), then enter the new syllable.
To move forward to a new word (from any point in a syllable), press Space, Alternatively, and only if you are at the end of a word, press → (right
arrow).
To enter a non-breaking space, type Ctrl+Space.
To enter a melisma, see below.
To move forward or backwards one character at a time, jumping between syllables, press →/← (right/left arrows).
To move backwards one syllable, press Shift+Space.

Entering a melisma

A melisma is a syllable that extends over more than one note.

If the melisma is at the end of a word it should be notated by an underscore line:

Starting from the end of the previous syllable, press _ (underscore) for as many notes as the melisma extends.

If a melisma occurs in the middle of a word it may be notated by hyphens instead:

Starting from the end of the previous syllable press - (hyphen) for as many notes as the melisma extends.
For long melismata, instead of repeated typing of hyphens, select the last note in the melisma and press - (hyphen). The intermediate hyphens will
automatically be inserted between the previous typed syllable and that final note.

Entering multiple verses

To enter subsequent verses, simply repeat the steps shown under Entering syllables. Lyrics entry automatically starts in the space beneath the last
entered verse.

In lyrics mode you can move up and down between verses using the keyboard arrows, ↑ and ↓.

Entering lyrics onto rests

By default, the cursor skips over rests in lyrics mode. However, It is possible to enter a syllable on a rest by selecting the rest, (re-)entering lyrics mode
and typing the syllable. Then you can continue entering lyrics as above.

Special characters within lyrics

Characters not available from the computer keyboard may be entered in lyrics mode using the Special characters palette. A special case is highlighted
below:

Elision slur

An Elision slur (lyric slur or synalepha) is a symbol used to join two syllables together under one note.
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For example, to create the lyrics text below, starting with the syllable text "te":

Type te;
Open the Special Characters palette;
Click one of the elision slurs in the "Common Symbols" tab
Type A.

Escaping characters (that cannot be normally typed while entering Lyrics)

In most cases, lyrics can be edited just like normal text. However, special keyboard shortcuts are required to enter the following characters:

Space character: Ctrl+Space (Mac & Linux: Alt+Space).

- (hyphen): Ctrl+- (Mac & Linux: Alt+-).

_ (underscore): Ctrl+Shift+_ (Mac & Linux: Alt+Shift_).

Line feed: Ctrl+↵ (Mac & Linux: Alt+Return) or Enter (from the numeric keypad).

Editing existing lyrics
To make additions or changes to existing lyrics, click on a syllable and use a text edit mode shortcut to enter lyrics mode.

Delete lyrics
Lyrics are automatically deleted with their parent notes. You can also delete lyrics while leaving the notes intact, by selecting the lyrics and pressing
Delete.

Entering lyrics above the staff
If you wish to position all lyrics above, instead of below, the staff:

From the menu bar, select Format→Style→Lyrics;
Set Placement to "Above".

You can of course do the same thing by selecting all lyrics in the score and changing Position to "Above" in the text section of the Properties panel.

Changing verse number of lyrics
Each verse attached to the staff is allocated a verse number—with the lowest positioned at the top and highest at the bottom. (You can of course
prepend a number to the beginning of each verse, but this is a visual indication only.)

To change the verse number, select the verse and adjust "Set to verse" in the Lyrics section of the Properties panel.

Copying lyrics
Copying lyrics within MuseScore

Lyrics are automatically copied with their parent notes, but you can also copy lyrics on their own without the notes.

Copy to the same verse

Select a range or list of lyrics syllables;
Apply cut/copy;
Select a destination note in the same verse
Paste the lyrics.

Note that the destination range should be clear of existing lyrics, otherwise the clipboard contents will be pasted on top of them.

Copy to a different verse

Select a range or list of lyrics syllables;
Apply Copy;
Assign the selected lyrics a new verse number (see above);
Click on the first note of the lyrics selection;
Paste. This will replace the missing lyrics.

Note: Lyrics always paste into the same verse they were copied from.

Copying lyrics to other programs

https://musescore.org/en/print/book/export/html/329209?toc=1#node-329723-special-characters
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329723-editing-text
https://musescore.org/en/print/book/export/html/329209?toc=1#undefined-change-verse-number


14/09/2023, 18:51Handbook for MuseScore 4

Page 166 of 270https://musescore.org/en/print/book/export/html/329209?toc=1

All lyrics attached to staves can be copied to the clipboard from the menu using Tools→Copy lyrics to clipboard.

Lyrics properties
See Changing verse number of lyrics.

Lyrics style
You can adjust global lyrics properties from Format→Style→Lyrics.

Lyrics text

Placement / Position above / Position below: Sets the default positioning of lyrics in relation to the music staff.
Line height: The space between verse lines.
Min top/bottom margin: The distance above and below the lyrics block to the staves above and below.
Min. distance: The minimum distance allowed between syllables. Increase this if the lyrics are too squashed.
Align verse number:

Lyrics dash

Here you will find a number pf properties which allow you to control how hyphens between syllables are displayed:

Min./Max. dash length: Sets the minimum and maximum length of inter-syllable dashes.
Max. dash distance: Maximum distance allowed between dashes. Reducing this value allows more dashes to form between syllables where
possible—and vice versa.
Dash thickness: The (vertical) thickness of the dash.
Dash pad: The distance between the - and the syllable
Dash Y position ratio: Affects the vertical placement of the dash.
Always force dash: Tick to ensure that a dash is always visible between syllables.

Lyrics melisma

Melisma thickness: The (vertical) thickness of the melisma.
Melisma pad: The distance between the melisma and the syllable
Align:

Fingering

Types of fingering
Fingering symbols for various instruments are found in the Fingerings palette; some of these are duplicated in the Guitar palette.

https://musescore.org/en/print/book/export/html/329209?toc=1#undefined-change-verse-number


14/09/2023, 18:51Handbook for MuseScore 4

Page 167 of 270https://musescore.org/en/print/book/export/html/329209?toc=1

Mouse over the palette icons to reveal the names of the symbols.

The different types of fingerings are as follows:

Fingering; In keyboard notation, used to indicate left and right hand fingering. Also used in guitar music for left hand fingering.
LH guitar fingering: In guitar notation, 1–4, indicates the left-hand fingers. 0 (zero), an open string. T, the left hand thumb. Can also be used in
keyboard music.
RH guitar fingering: In guitar notation, used to indicate the right hand fingers, namely: p = thumb, i = index, m = middle, a = ring/annular, c = little.
String number (circled): In guitar notation, used to indicate the strings (1–6, top to bottom). 0 (zero) is used for the open string.
Other fingering: Lute fingerings may be found by clicking "More" in the Fingerings palette.

Adding fingering to your score
Note: If you want fingering to be displayed in tablature, right-click on the TAB, and select Staff/Part Properties…→Advanced Style Properties; then
check the box labelled "Show fingering in tablature"

Adding fingering from a palette

To add fingering to a selection of notes:

Select one or more notes;
Click on the desired fingering symbol in a palette.

Alternatively, you can drag and drop a fingering symbol from a palette onto a single note.

When fingering is added to a note, the focus immediately shifts to the symbol, so you can adjust it right away.

Adding fingering using a keyboard shortcut

Select a start note;
Choose one of the following options:

(for any fingering) Add the desired fingering symbol from a palette (as shown above);
(for Fingering only) Enter the custom keyboard shortcut for "Add Fingering," then type the desired number.
(Note: you can create this shortcut from the menu Edit→Preferences→Shortcuts

Choose one of the following options:
To move the cursor to the next note: Press Space, or Alt+→;
To move the cursor to the previous note: Shift+Space, or Alt+←;

Type the desired number; a fingering is added of the same type as the initial one .
Repeat steps 3 and 4 as required;
Press Esc, or click on an empty space in the document window, to exit.
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Adding fingering using the menu

Select the start note;
From the menu bar, select Add→Text→Fingering;
Type the fingering number of the first note;
Press space to move to the next note; and so on.

Adjusting position
To edit fingering position, see Changing position of elements.

Some fingerings can be flipped to the other side of the staff using the X shortcut, or the Flip direction icon on the note input toolbar.

Changing the appearance of fingering
The text formatting of fingering elements can be adjusted in the Text section of the Properties panel. See Formatting text for details.

Fingering properties
General and text properties for fingering can be edited from the Properties panel.

For General properties see General settings.

For Text properties, see Formatting text.

Fingering style
Each of the different classes of fingering have their own text style. These can be viewed and edited from the menu: Format→Style→Text styles.

See also
Drum sticking

Chord symbols

Overview
A chord symbol is an abbreviated way of representing a musical chord and its harmony.

MuseScore supports the following notations:

Chord symbol: Alphabetical chord name plus chord quality. e.g. Am,
Nashville Number System (NNS): Arabic numeral plus chord quality. e.g. 6m,
Roman Numeral Analysis (RNA): Roman numeral plus chord quality. e.g. vi.

Adding chord symbols to your score
Entering a chord symbol

Select a start note, note slash, or rest;
Press Ctrl+K (Mac: Cmd+K). The cursor is now positioned above the staff ready for input.
Enter the chord symbol using the following characters:

Root note: a, b, c, d, e, f, g. (the lower case will automatically change to upper-case when you exit the chord symbol)
Sharp: # (hash).
Flat: b (small letter "b").
Double sharp: x (small letter "x") or ## (two hash symbols).
Double flat: bb (small letter "b" twice).
Natural: Ctrl+Shift+H.
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Space: Ctrl+Space (Mac: Alt+Space);
For other symbols, see Chord symbol syntax (below).

To move the cursor forward to the next chord/rest/beat, press Space. For other ways of moving the cursor, see navigation commands (below);
Exit chord symbol mode by pressing Esc.

Chord names and accidentals

When you exit a chord symbol, any characters entered are automatically converted to the correct format. A root note typed in lower case turns into upper
case (for alternative options, see Automatic Capitalization). And characters entered for accidentals are automatically converted into professional glyphs.
For example, a "#" (hash character) automatically becomes a sharp sign (♯). Don't input, or copy and paste, unicode characters, such as U+266F (sharp
sign, ♯), or U+266D (flat sign, ♭) etc, as MuseScore will not render them correctly in chord notation.

Navigation commands

The following is a summary of keyboard shortcuts used to move the cursor in chord symbol entry mode:

Action Command (Windows) Command (macOS)
Move cursor to next note, rest, or beat Space Space
Move cursor to next beat ; (semicolon) ;
Move cursor to previous note, rest, or beat Shift+Space
Move cursor to previous beat : (colon) :
Move cursor to next measure Ctrl+→ Cmd+→
Move cursor to previous measure Ctrl+← Cmd+←
Move cursor by duration number Ctrl+1-9 Cmd+1-9
Exit chord symbol entry Esc Esc

Chord symbol syntax

MuseScore understands most of the abbreviations used in chord symbols:

Major: M, Ma, Maj, ma, maj, Δ (type t or ˆ for the triangle)
Minor: m, mi, min, -
Diminished: dim, ° (entered with lowercase letter o, shows as ° if using the Jazz style, as o, the Greek omicron, otherwise)
Half-diminished: ø (entered with 0, number zero, shows as ø if using the Jazz style, as 0 (zero) otherwise). Alternatively, you can, of course,
choose abbreviations such as mi7b5 etc.
Augmented: aug, +
The following abbreviations are also valid: extensions and alterations like b9 or #5, sus, alt, and no3; inversions and slash chords, such as C7/E;
commas; parentheses, which can enclose part, or even all, of a chord symbol.

Editing a chord symbol

An existing chord symbol can be edited in a similar way to ordinary text: See Text editing for details.

Entering Roman numeral analysis

Not to be confused with Figured bass.

The Roman Numeral Analysis (RNA) system is a type of musical analysis where chords are represented by upper- and lower-case Roman numerals (I,
ii, III, iv etc.), superscripts, subscripts and other modifying symbols. It is used to notate and analyze the harmony of a composition independent of its key.

Note: MuseScore uses a specialist font, Campania , to provide the correct formatting for RNA. This is free and open source.

Enter RNA

Select a start note;
From the menu, select Add→Text→Roman Numeral Analysis. Alternatively, set up a keyboard shortcut to do the same thing in Preferences ;
Input the RNA symbols for the chord just like normal text, as follows;

Major chord: Upper case roman numerals
Minor chord: Lower case roman numerals
Diminished chord: o (lower case)
Half-diminished chord: 0 (zero)
Augmented chord: +
Chord inversions: Enter up to 3 single-digit numbers, top note first
Accidentals: enter # for a sharp, b for a flat or h for natural. These turn into a proper (and superscripted) ♯ , ♭ or ♮ right away, see entering
accidentals above.
To prevent any character from being interpreted or superscripted, prefix the character with a backslash, "\". This could be used, for example,
to add a literal letter "b", "h", a hash symbol "#", or a non-superscripted number etc.
Inversion notation using alphabet a,b,c,d can be created with the method described above.
Inversion notation using vertically aligned arabic numerals without accidentals such as 64 can be created with the method described below.
[ TO DO: This is from MS3, pls check if this is correct for MS4] Inversion notation using vertically aligned arabic numerals with accidentals
such as 6#3, ie altered chord, is unsupported, workaround : create Figured bass text instead; or create separate text objects and manually
nudge them into place.
For other symbols, see the images below.

Move the cursor forward or backwards to continue entering or editing symbols for other chords;
When RNA is completed, exit by pressing Esc, or by clicking on a blank section of the score.

RNA input offers the same keyboard shortcuts for navigation as in chord symbols (see above ).
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Examples of RNA

Type this:

To get:

Entering a Nashville number

The Nashville Number System (NNS), is a shorthand way of representing chords based on scale degrees rather than chord letters. This allows an
accompaniment to be played in any key from the same chord chart.

To start entering Nashville notation:

Select a start note;
From the menu, select Add→Text→Nashville Number.

Just as with standard chord symbols, you can type Nashville notation normally and MuseScore will do its best to recognize and format the symbols
appropriately. The same shortcuts used for navigation when entering standard chord symbols (e.g. Space, see above) are available for Nashville notation
as well.

Aligning chord symbols
Using the Style menu

The default vertical alignment of all Chord Symbols can be set from the style menu, Format→ Style→Text styles→Chord Symbol.

Or you can do the same thing from the Appearance section of the Properties panel (refer to Saving and restoring default settings).

If this results in an irregular line of chord symbols, try varying Max shift above/below (Format→ Style→Chord symbols) to bring the symbols into line.

Using the Properties panel

You can align a selection of chord symbols by pressing Appearance, and changing the "Offset" values; and/or by changing the "Alignment" or "Position"
properties in the Text section of the Properties panel.

Transposition of chord symbols
Transposing instruments

Chord symbols copied to a transposing instrument staff are automatically transposed in equal measure. For example, an A7 chord copied from a Flute
part (non-transposing) to a B♭ Clarinet part (sounds a tone lower than written) will be transposed to a B7 chord.

Note that chords associated with guitar fretboard diagrams are not transposed automatically.

Transpose dialog

Chord symbols are automatically transposed by default when using the Transpose dialog. If this is not required, you can untick the "Transpose chord
symbols" option in the same dialog.

Capo fret position

The Capo fret position property automatically transposes chord symbols in the score (without affecting playback) and puts them in brackets after the
existing chord symbols. The aim is to provide an alternative accompaniment on a capoed instrument.

To apply, select Format→Style→Chord symbols, and enter a number in the Capo fret position spin box.

Changing Spelling of Chord Symbols
By default, MuseScore uses letter names for chord symbols. For users in regions where other note naming schemes are used, all chord symbols in the
score can be changed.
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Chord Spelling Systems

From the main menu, choose Format→ Style→Chord symbols. Then choose one of the following radio buttons in the spelling section:

Standard: A, B♭, B, C, C♯,…
German: A, B♭, H, C, C♯,…
Full German: A, B, H, C, Cis,…
Solfeggio: Do, Do♯, Re♭, Re,…
French: Do, Do♯, Ré♭, Ré,...

Automatic Capitalization

By default, MuseScore automatically capitalizes all note names on exit, regardless of whether you entered them in upper or lower case. From the main
menu, choose Format→ Style→Chord symbols. Then choose from of the following options:

Lower case minor chords: c, cm, cm7,...
Lower case bass notes: C/e,...
All caps note names: DO, RE, MI,...

You can also turn off the automatic capitalization completely, in which case note names are simply rendered the way you type them.

Changing appearance of chord symbols
[To do]

Font settings
Style settings for appearance, scaling/offset

Changing Playback of Chord Symbols
Enabling and disabling playback

You can disable/enable playback of all chord symbols in the score by clicking on the cog icon to the right of the playback controls and
deselecting/selecting Play chord symbols.

You can also disable/enable playback of a selection of chord symbols, by unchecking/checking Play in the General section of the Properties panel .

Customizing playback

Default playback settings for all chord symbols in a score are available in the Playback section of Format→ Style→Chord symbols.

You can also customize the playback of selected chord symbols in the Chord symbol section of the properties panel.

Interpretation: Literal or Jazz.
Voicing: Automatic, Root Only, Close, Drop two, Six note, Four note, three note
Duration: Until next chord symbol, Until end of measure, Chord/rest duration

Generating chord voicings onto a staff

MuseScore allows you to generate chords on the staff from selected chord symbols. The voicing of these chords depends on the playback settings
(above) for these chords.

To realize a selection of chord symbols:

Make a selection of chord symbols;
Right click on any chord in the selection;
Click Realize chord symbols;
Optional. Check "Override with custom options" and set the options as required;
Click OK.

Chord symbol properties
Properties specific to chord symbols (i.e. playback) are covered in Changing Playback of Chord Symbols (above)

Other non-specific properties are detailed in Properties.

https://musescore.org/en/print/book/export/html/329209?toc=1#undefined-change-playback
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Chord symbol style
Default properties for all chord symbols in a score can be edited from Format→Style→Chord symbols.

The Chord symbols style menu contains the following headings:

Appearance

Style: Three options are available— Standard, Jazz or Custom.

In the Standard style, chords are rendered simply, with the font determined by your chord symbol text style.

In the Jazz style, the MuseJazz font is used for a handwritten look, with distinctive superscript and other formatting characteristics. The Jazz style is
selected by default if you use any of the Jazz templates.

The Custom style option allows you to use your own customized chord symbols style file (advanced users only).

Extension/Modifier scaling: This affects the size of the chord extension or of the modifier.
Extension/Modified vertical offset: This affects the vertical position of the chord symbol extension or of the modifier.

Spelling

See Changing Spelling of Chord Symbols (above).

Positioning

Distance to fretboard diagram: Affects the distance between fretboard diagrams and any chord symbols above.
Minimum chord spacing: The minimum distance allowed between chords.
Maximum barline distance:
Maximum shift above/below: This is used to line up chord symbols whose vertical alignment is irregular. Experiment until you get the apperance you
want.

Playback

See Customizing playback (above).

Figured bass

Overview
Figured bass is a shorthand notation for representing chords on a continuo instrument (such as a keyboard), using a series of numbers and other
symbols written underneath the notes of the bass line.

Adding figured bass to your score
Entering a figure

Select the note to which the figured bass applies;
Press the Figured Bass shortcut. The default is Ctrl+G (Mac: Cmd+G); this can be changed in Preferences: Shortcuts if desired;
Enter the text in the "edit box" which appears.

Text format

For the relevant substitutions and shape combinations to take effect and for proper alignment, the figured bass mechanism expects input texts to follow
some rules (which are in any case, the rules for a syntactical figured bass indication):

There can be only one accidental (before or after), or only one combining suffix per figure;
There cannot be both an accidental and a combining suffix;
There can be an accidental without a digit (altered third), but not a combining suffix without a digit.
Any other character not listed above is not expected.

If a text entered does not follow these rules, it will not be processed: it will be stored and displayed as it is, without any layout.

Digits

https://musescore.org/en/print/book/export/html/329209?toc=1#undefined-change-appearance
https://musescore.org/en/print/book/export/html/329209?toc=1#undefined-note-spelling
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329657-shortcuts
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Digits are entered directly. Groups of several digits stacked one above the other are also entered directly in a single text, stacking them with Enter:

Accidentals

Accidentals can be entered using regular keys:

To enter: type:
double flat bb
flat b
natural h
sharp #
double sharp ##

These characters will automatically turn into the proper signs when you leave the editor. Accidentals can be entered before, or after a digit (and of course,
in place of a digit, for altered thirds), according to the required style; both styles are properly aligned, with the accidental 'hanging' at the left, or the right.

Combined shapes

Slashed digits or digits with a cross can be entered by adding \, / or + after the digit (combining suffixes); the proper combined shape will be substituted
when leaving the editor:

The built-in font can manage combination equivalence, favoring the more common substitution:

1+, 2+, 3+, 4+ result in  (or )

and 5\, 6\, 7\, 8\, 9\ result in  (or )

Please remember that / can only by combined with 5; any other 'slashed' figure is rendered with a question mark.

+ can also be used before a digit; in this case it is not combined, but it is properly aligned ('+' hanging at the left side).

Parentheses

Open and closed parentheses, both round: '(', ')' and square: '[', ']', can be inserted before and after accidentals, before and after a digit, before and after
a continuation line; added parentheses will not disturb the proper alignment of the main character.

Notes: (1) The editor does not check that parentheses, open and closed, round or square, are properly balanced. (2) Several parentheses in a row are
non-syntactical and prevent proper recognition of the entered text. (3) A parenthesis between a digit and a combining suffix ('+', '\', '/') is accepted, but
prevents shape combination.

Editing existing figured basses

To edit a figured bass indication already entered use one of the following options:

Select it, or the note it belongs to and press the same Figured Bass shortcut used to create a new one.
Double-click it.

The usual text editor box will open with the text converted back to plain characters ('b', '#' and 'h' for accidentals, separate combining suffixes,
underscores, etc.) for simpler editing.

Once done, press Space to move to a next note, or click outside the editor box to exit it, as for newly created figured basses.
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Navigating by note, beat, or measure

The duration of a Figured Bass indication often lasts until the next bass note or the end of a bar. Such Figured Bass can be entered consecutively using
the keyboard. (To move to a point in between, or to extend a figured bass group for a longer duration, see Duration).

Press Space to move to the next note ready for another figured bass indication (or click outside the editor box to exit it). The editor advances to the
next note, or to the rest of the staff to which figured bass is being added.

Shift+Space moves the editing box to the previous staff note or rest.
Tab advances the editing box to the beginning of the next measure.
Shift+Tab moves the editing box to the beginning of the previous measure.

Duration

Each figured bass group has a duration, which is indicated by a light gray line above it (of course, this line is for information only and it is not printed or
exported to PDF).

Initially, a group has the same duration of the note to which it is attached. A different duration may be required to fit several groups under a single note or
to extend a group to span several notes.

To achieve this, each key combination in the table below can be used to (1) advance the editing box by the indicated duration, and (2) set the duration of
the previous group up to the new editing box position.

Pressing several of them in sequence without entering any figured bass text repeatedly extends the previous group.

Type: to get:
Ctrl+1 1/64
Ctrl+2 1/32
Ctrl+3 1/16
Ctrl+4 1/8 (quaver)
Ctrl+5 1/4 (crochet)
Ctrl+6 half note (minim)
Ctrl+7 whole note (semibreve)
Ctrl+8 2 whole notes (breve)

(The digits are the same as are used to set the note durations)

Setting the exact figured bass group duration is only mandatory in two cases:

When several groups are fit under a single staff note (there is no other way).
When continuation lines are used, as line length depends on the group duration.

However, it is a good practice to always set the duration to the intended value for the purposes of plugins and MusicXML.

Entering continuation lines

Continuation lines are input by adding an '_' (underscore) at the end of the line. Each digit of a group can have its own continuation line:

Continuation lines are drawn for the whole duration of the figured bass group.

'Extended' continuation lines

Occasionally, a continuation line has to connect with the continuation line of a following group, when a chord degree has to be kept across two groups.
Examples (both from J. Boismortier, Pièces de viole, op. 31, Paris 1730):
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In the# first case, each group has its own continuation line; in the second, the continuation line of the first group is carried 'into' the second.

This can be obtained by entering several (two or more) underscores "__" at the end of the text line of the first group.

Figured bass properties
The text formatting of figured bass symbols is handled automatically by the program, based on style settings (see below). Only General and Appearance
properties can be adjusted from the Properties panel..

Figured bass style
Properties of all figured bass symbols in the score can be set from Format→Style…→Figured Bass.

Font: This is the preset "MuseScore Figured Bass," which is specially designed to realize figured bass notation.
Size: Select a font-size in points.
Vertical Position: The distance (in spaces) from the top of the staff to the top margin of the figured bass text. Negative values go up (figured bass
above the staff) and positive values go down (figured bass below the staff: a value greater than 4 is needed to step over the staff itself).

Line Height: The distance between the base line of each figured bass line, as a percentage of font size.

The following picture visualizes each numeric parameter:

Alignment: Select the vertical alignment: with Top, the top line of each group is aligned with the main vertical position and the group 'hangs' from it
(this is normally used with figured bass notation and is the default); with Bottom, the bottom line is aligned with the main vertical position and the
group 'sits' on it (this is sometimes used in some kinds of harmonic analysis notations):

Style: Choose between "Modern" or "Historic." The difference between the two styles is shown below:

Figured bass keyboard shortcuts
Type: to get:

Ctrl+G Adds a new figured bass group to the selected note.
Space Advances the editing box to the next note.
Shift+Space Moves the editing box to the previous note.
Tab Advances the editing box to the next measure.
Shift+Tab Moves the editing box to the previous measure.

Advances the editing box by 1/64, setting the duration of the previous

https://musescore.org/en/print/book/export/html/329209?toc=1#node-329757-spatium
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Ctrl+1 group.

Ctrl+2 Advances the editing box by 1/32, setting the duration of the previous
group.

Ctrl+3 Advances the editing box by 1/16, setting the duration of the previous
group.

Ctrl+4 Advances the editing box by 1/8 (quaver), setting the duration of the
previous group.

Ctrl+5 Advances the editing box by 1/4 (crochet), setting the duration of the
previous group.

Ctrl+6 Advances the editing box by a half note (minim), setting the duration of the
previous group.

Ctrl+7 Advances the editing box by a whole note (semibreve), setting the duration
of the previous group.

Ctrl+8 Advances the editing box by two whole notes (breve), setting the duration of
the previous group.

Ctrl+Space Enters an actual space; useful when figure appears "on the second line"
(e.g., 5 4 -> 3).

BB Enters a double flat.
B Enters a flat.
H Enters a natural.
# Enters a sharp.
## Enters a double sharp.
_ Enters a continuation line.
__ Enters an extended continuation line.

Note: For Mac commands, Ctrl is replaced with Cmd.

Rehearsal marks

Overview
Rehearsal marks (sometimes called Rehearsal Letters) can be used in a number of ways. e.g.

To identify specific points in a score to facilitate rehearsing.
As bookmarks in the score to which you can instantly navigate—using the Find/Search command.
To mark the various sections in the score.

Rehearsal marks are a type of system text. In a full score they show only above the top staff of a system, but appear in all instrument parts.

Rehearsal marks can be added to the score in two ways: (1) manually, allowing you to name them as you wish, or (2) automatically, which ensures that
they are named in sequence

Adding a rehearsal mark to your score
Manual placement and naming

To create a rehearsal mark manually and give it a name of your own choosing:

Click on a note (or rest) at the desired location;
Select one of the following options:

Press Ctrl+M (Mac: Cmd+M);
From the menu, choose Add→Text →Rehearsal Mark;

Enter the desired text.

Automatic placement and naming

MuseScore can name the Rehearsal Marks automatically. Do either:

Click on a note (or rest) at the desired location, then click the [B1] rehearsal mark icon in the "Text" palette
Drag and drop the rehearsal mark from the "Text" palette onto the score.

Notes: (1) By default, marks are added in the sequence, A, B, C etc. (2) To change the format of subsequently-added marks (to lower case letters, or
numbers), edit the previous rehearsal mark accordingly. (3) Marks added between existing rehearsal marks append a number or letter to the previous
mark: it is a good idea to apply the Resequence command afterwards (see below).

Using measure numbers in rehearsal marks
If you want the rehearsal marks to be displayed as measure numbers:

Add the first rehearsal mark, then edit it to read the same as the number of the measure it is attached to;
Add subsequent marks as shown in Automatic placement and naming (above). They will automatically adopt the measure-number format.

Resequencing rehearsal marks

https://musescore.org/en/print/book/export/html/329209?toc=1#node-329730-system
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MuseScore allows the user to automatically re-order a series of rehearsal marks if they have got out of sequence for any reason. Use the following
method:

Before making a selection, you can, if desired, establish a new format for the rehearsal marks (lower/upper case, number, or measure number) by
manually altering the first mark in the range accordingly.
Select the range of measures you wish to apply the Resequence command to (if there is no selection then the program assumes you wish to
resequence all measures).
From the menu, select Tools→Resequence Rehearsal Marks.

MuseScore automatically detects the sequence based on the first rehearsal mark in the selection—all rehearsal marks in the selection are then altered
accordingly. The following sequences are possible:

A, B, C etc.
a, b, c etc.
Numerical: 1, 2, 3 etc.
Numerical: according to measure numbers.

Finding rehearsal marks
See Find / Go to (Navigating your score).

Repeating rehearsal marks on other staves
In most full scores any Rehearsal marks are shown only above the topmost staff of a system, but appear in all the generated instrument parts. If
duplicate marks are required on lower staves they should be added as staff text.

However, some templates (e.g. Symphony Orchestra or Classical Orchestra), have an additional feature; when you create a rehearsal mark above the
top staff, an identical one is automatically added just above the string section. If either instance of the mark is edited the content of both is updated.

Changing appearance of rehearsal marks
By default, rehearsal marks appear in a large bold font, enclosed in frames, and aligned to the center of the start barline of the measure. You can edit the
default text properties from Format→Style→Text style .

Rehearsal mark properties
The properties of selected rehearsal marks can be changed in the Properties Panel.

Rehearsal mark style
Default positional properties for all rehearsal marks in the score can be edited from Format→Style… →Rehearsal Marks.

External links
Rehearsal letter  (Wikipedia article)

Header and footer

Overview
The header and footer areas are at the top and bottom of a page respectively. They often display useful information about the score such as the title, file
name, page number, copyright details etc.

Adding a header or footer to your score
From the main menu, select Format→Style→Header, Footer:

https://musescore.org/en/print/book/export/html/329209?toc=1#node-330537-find
https://musescore.org/en/node/278581
https://en.wikipedia.org/wiki/Rehearsal_letter
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 :

The top half of the dialog is where you define Header text;
The bottom half of the dialog is where you define Footer text.
Both Header and Footer subsections are divided into two rows, labelled Odd, and Even. This allows you to define odd and even pages
separately if required.
The whole dialog is divided into three columns, labelled Left, Middle, and Right, representing the corresponding areas of the header or
footer.

To turn off/on the display of headers/footers, uncheck/check the "Header text" and/or "Footer text" boxes as required.

Hover the cursor over the control area in which you wish to specify text. A popup box appears displaying a list of text options, and which codes to
enter to realize them.

Enter the code for the desired text in the control area. A new line should be used for each code snippet.

To create a header or footer for an instrument part, that part should be the active tab.

Note: When you create a new score, any copyright details entered on the Additional score information page of the New score dialog will appear in the
footer area of the the first page. Page numbers are also displayed on subsequent pages of newly-created scores. These are default settings only, and
can be changed later from the Header, Footer style dialog (above).

Using metadata
Metadata is information about your score file—such as the title, copyright info, file name, number of pages and so on. Each of these snippets is called a
metadata tag.

Headers and footers can display metadata tags such as page number, file name etc., as well as tags whose content is shown in Project properties.

If you hover the cursor over any control area in the Header, Footer dialog (see image above) you will see a list of the metadata tags available for entry,
and the (two-letter) codes to enter them.

You will notice that code entry for tags is case-sensitive. For example,

$p enters a page number, but skips page 1.
$P enters a page number on all pages.
$C enters the copyright info on the first page only.
$c enters the copyright info on all pages.
$i enters the Part name, except on first page.
$I enters the Part name, on all pages.

If you want to display content from the Project properties window not covered by a two-letter code, you need to enter it in the relevant control area using
the format:

Enter the tag name in lower-case letters, unless the name of the meta tag in Project properties consists of two words, in which case the second word
should start with an upper-case letter, and there should be no spaces between words.

Changing how headers and footers are displayed
In the header, footer dialog there are two check boxes for both header and footer:

Show on first page: When checked, header/footer text is enabled for page 1.
Different odd/even pages: When checked, the header/footer text of odd pages may be different in content from that of even ones. If unchecked,
the content of both is identical in form.

To fine tune the placement of all header and footer text:

Click on an instance of a header/footer in the score
Click on the Appearance button in the Properties panel
Edit the horizontal and vertical Offsets.
Click on the ellipsis symbol (three dots) for Offset and select “Save as default style for this score”.

https://musescore.org/en/print/book/export/html/329209?toc=1#node-329655-additional-score-information
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In the same way you can adjust other text properties (font, font-size etc.) from the Text section of the Properties panel.

The same adjustment can be made directly in the "Header" and "Footer" entries at Format→Style→Text styles.

Header and footer properties
Unlike other types of text, you cannot change the text properties of a single header or footer element wthout affecting all the elements in the score of the
same style. This makes sense as you usually want all footer/header elements to have the same text properties.

Header and footer style
Style properties of headers and footers are covered in Adding a header or footer to your score (above).

Text style properties are covered in Changing how headers and footers are displayed (above).

Text blocks

Overview
A text block is a text object entered within a frame.

Text blocks in frames have numerous uses:

Display the title, subtitle composer, arranger, lyricist etc at the beginning of a score.
Display details of individual pieces within a suite.
Display lyrics at the end of a song/hymn.

and so on.

Adding text blocks to your score
To add a text block to a frame:

Add the appropriate frame to the desired location in the score if needed (see Using frames for additional content)
Right-click on the frame and select Add; alternatively, from the menu bar select Add→Text
Choose from the text types offered: Text, Title, Subtitle, Composer, Lyricist, Part name
In the bounding box that appears, enter the desired text.

Note: When you enter details of a new score (such as Title, Composer etc) on the Additional score information page of the New score dialog, these
appear automatically as text blocks in a frame at the top of the first page.

Changing the appearance of text blocks
The general and text properties of a selected text block can be changed in the Properties panel. In particular, you may want to

change default horizontal/vertical alignment in the Text section.
adjust position by dragging, using the keyboard arrows, or adjusting the horizontal/vertical offsets in the Appearance section.
check “Match staff size” in the Text section, to ensure that the text block scales up and down with the Scaling set in Page Settings.

Remember to make the new setting the style default (where appropriate) by clicking on the relevant ellipsis (three dots) icon and selecting “”Save as
default style for this score”.

Text block text properties
The text properties of a selected text block can be changed in the Text section of the Properties panel.

Alternatively you may wish to choose a different text style altogether from the dropdown list under “Text style” (in Properties: Text→More)

Text block text style
The default properties of any text block can be edited from Format→Styles→Text Styles. Alternatively you can make changes to individual style
properties from the Properties panel; see Saving and restoring default settings.

See also
Using frames for additional content

Formatting

Page layout concepts

MuseScore generally does an excellent job of arranging music and text on the page, but there are situations where you may need to adjust things—to
make music larger or smaller, to add space between staves, to change the number of measures on a page, to move text closer to or further away from
the staff, etc. In order to make these types of changes, it helps to understand how MuseScore works with respect to page layout.

https://musescore.org/en/print/book/export/html/329209?toc=1#undefined-add-header-footer
https://musescore.org/en/print/book/export/html/329209?toc=1#undefined-header-footer-display
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329655-additional-score-information
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329664-default
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Definitions
There are a number of terms used throughout this chapter that you will need to be familiar with.

Staff

A staff is the set of lines and spaces on which notes are written. When the term is used in MuseScore, it refers to that set of lines and spaces for a given
instrument throughout an entire score. In the following score for voice and piano, everything marked in yellow constitutes a single staff—the staff for the
voice:

Grand staff

In music for piano and certain other instruments, two staves are used—one primarily for the right hand, the other for the left. This set of two staves is
normally connected by curly braces and is referred to as a grand staff. In the following excerpt, the portion marked in yellow is a grand staff:

System

Like text, music is read left to right, top to bottom. Each line of music read across the page is called a system, and it contains the staves and grand
staves for all instruments. In the following example, the yellow highlighted region represents a single system:
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Even if a score has only a single staff for a single instrument, we still refer to a line of music read across the page as a system. In the following lead
sheet, there is only a single staff but three systems:

Frame

Most text in notated music is associated with specific notes or measures. However, you may also need to place text that is not associated with a specific
note or measure—the title at the beginning of a score, lyric verses placed at the end of a score, explanatory information placed between systems or even
between measures. MuseScore uses elements called frames for this. There are vertical, text, and horizontal frames—each optimized for a particular type
of use. Horizontal frames can also be used to create separation between measures on a system, with or without associated text.
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Margin

A margin is an area in which MuseScore will not normally place music or other elements. The page margin is the area around all four edges of the page
where no elements are placed. The music margin is the area between the top and bottom margin and the first and last staff. The staves themselves will
not be placed in those margins, but notes and other markings above or below the staves may be.

Positioning of elements

MuseScore places elements in your score automatically according to a set of rules and style settings. These are designed to produce excellent results by
default in most cases&dash;elements positioned according to standard engraving practices while avoiding collisions between elements. MuseScore also
provides the ability to customize these defaults and also to override the defaults for any given element.

Default position
Most elements in MuseScore have a default position that is determined by a style setting that can be customized via the Properties panel or the
Format→Style dialog. For elements that are placed above the staff, the position is specified as an offset from the top line of the staff; for elements that
are placed below the staff, the position is specified as an offset from the bottom line of the staff. These offsets, like most measurements in MuseScore,
are expressed in staff spaces—abbreviated sp. For many element types, you can specify an offset to be used when placed above as well as a separate
offset to be used when placed below, and also which of these placements should be applied by default.

For example, for dynamics, the default placement is below the staff, and the default offset below the bottom staff line is 2.5 sp. If you flip a dynamic
marking above the staff, it defaults to 1.5 sp above the top staff line staff (expressed as a negative offset: -1.5 sp). These settings are all found in
Format→Style→Dynamics.
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Note that the default offset is larger for dynamics placed below the staff than above only because the offset is measured from the baseline of the text.

Auto-place
Auto-place is the term MuseScore uses for a set of algorithms used to avoid collisions as well as to align certain elements automatically. A basic
understanding of how auto-place works can be useful when making adjustments.

Vertical collision avoidance

For most elements placed above or below the staff, collision avoidance works vertically. When an element is being positioned, MuseScore first tries to
place it according to the default offset for that element type. If that would result in a collision with another element, then one of the two elements will be
moved further from the staff to avoid the overlap. MuseScore follows standard engraving rules in determining which elements to move. For example,
tempo markings will be moved further above the staff to trill lines, rather than vice versa.

The Minimum distance style setting found determines how much distance MuseScore places between elements when avoiding collisions in this manner.
The corresponding setting in the Properties panel allows you to override this for individual elements where necessary. But MuseScore adjusts this value
automatically when positioning elements manually, as seen below in the section on manual adjustment.

Horizontal collision avoidance

For certain elements such as lyrics or chord symbols, MuseScore will widen measures to avoid collisions rather than displace these elements vertically.

Vertical alignment

MuseScore will also try to align certain elements vertically, so that if one element of that type needs to be adjusted vertically to avoid a collision, other
elements of that same type on the same system will automatically be adjusted as well. Elements that are always aligned vertically include lyrics and pedal
markings. Dynamics and hairpins will be aligned if they are directly adjacent, as will pedal markings.

Chord symbols can also be aligned vertically if you enable this in the chord symbol style settings, by setting a Maximum shift value. See Chord symbols
for more information.
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Disabling auto-place

Auto-place normally does a good job of avoiding collisions and of aligning elements. And in cases where you wish to position an element manually, you
can normally do so directly, without the need to disable auto-place (see manual adjustment below). However, there can be some situations in which you
may still wish to disable auto-place. For example, rehearsal markings default to displaying above voltas, but you may wish to reverse this for some
specific case where the volta was already displaced higher and there is then room for the rehearsal mark underneath.

In this case, disabling auto-place for the rehearsal mark allows it to display underneath the volta, while still allowing the volta to automatically avoid
collisions with the notes.

To disable auto-place for an element, select it and then disable the Auto-place setting in the Properties panel.

The element will be returned to its default position (as determined by its style settings) and it will not be included in the detection of collisions with other
elements. Disabling auto-place for an element also causes it to be excluded from any vertical alignment that would otherwise have applied.

Manual adjustment
Whether auto-place has displayed an element from its default or not, the position of elements can be adjusted manually, such as by dragging, using the
cursor keys, or the Offset fields in the Properties panel. See Adjusting elements directly for more information.

MuseScore even allows you to perform manual adjustments that would result in collisions. In the example above, if you drag the rehearsal letter below
the volta, MuseScore will allow this and will automatically set the Minimum distance for that element to a negative value, thus effectively allowing the
collision without disabling auto-place.

Manual alignment
Elements of the same type will normally be aligned by default simply because they have the same style settings and therefore the same offset. However,
auto-place can result in some of the elements being moved further from the staff than others. As described above under Vertical alignment, MuseScore
will automatically align some types of elements. For other elements types, you can align them manually by assigning them the same vertical offset.

To do this, simply select the elements you wish to align (e.g., click the first, Shift+click the last), then gradually increase or decrease the vertical offset in
the Properties panel. For example, to align a series of tempo markings above the staff, you will need to set their vertical offsets to the same value. To
make sure they are aligned and also avoid the collisions that cause auto-place to display one or more of them to begin with, you will need to set the offset
to a sufficiently large negative value.

Score size and spacing

MuseScore provides a number of score-wide settings to control the overall size and spacing of your music, and below we will cover these settings.
There are also a variety of ways to override these defaults to change the horizontal or vertical spacing of individual systems pages, and these are
covered in Systems and horizontal spacing and Pages and vertical spacing.

Page settings
The settings that control the overall size of your music are found in Format→Page Settings.

https://musescore.org/en/print/book/export/html/329209?toc=1#undefined-vertical-alignment
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Note that units in this dialog default to millimeters, but you can change to inches using the control provided.

Page and margin sizes

Page Size: select from predefined pages sizes
Width: set a custom width
Height: set a custom height
Portrait / Landscape: set the page orientation
Two sided: determines whether margins as well as Header and footer can be set independently for odd and even pages

The default page size is Letter in North and Central America, and A4 in most of the rest of the world.

Odd Page Margins: set the top, bottom, left, and right page margins for odd-numbered pages
Even Page Margins: set the top, bottom, left, and right page margins for even-numbered pages

The margins default to 15 mm regardless of the page size. If Two sided is not enabled, then only the Odd Page Margins settings are applicable.

Staff size

Staff space: set the distance between two adjacent staff lines

The staff size is determined by the size of the staff space—a five-line staff is four staff spaces high. Almost all measurements elsewhere in MuseScore
are expressed in units of staff spaces (abbreviated sp), so this setting affects the scaling of your entire score.

The default sp value of 1.75 mm results in a staff height of 7 mm, which is a good staff height for most solo music, choral music, small ensemble
scores, and individual parts. Lead sheets and children's music may benefit from a larger staff size. Large ensemble scores may often require a smaller
staff size in order to fit all instruments on the page. MuseScore will adjust the staff space automatically when creating a score for many instruments,
so that the staves all fit on the page initially. You may need to adjust this value further as you add music, if auto-place results in additional space being
added between staves in order to avoid collisions.

Other settings

First page number: Set the number on which page numbering starts (useful if your score has a title page, for example)
Unit: select between inches and millimeters for values in this dialog

Actions

In addition to the standard OK and Cancel buttons, this dialog also contains:

Reset All Page Settings to Default: reset all settings in this dialog to their default values
Apply to all Parts: apply the current page settings to all individual parts

Note that in large ensemble scores where MuseScore has automatically reduced the staff size in order to fit all instruments on a single page, resetting
page settings will revert to the standard staff space default of 1.75 mm.

Style settings
The horizontal spacing of notes and the vertical spacing of staves and systems are controlled by style settings.

Horizontal spacing

MuseScore determines an initial width for each measure based on the music it contains, then calculates how many measures can fit on each system,
and then stretches those measures out so that all systems (except possibly the last) are filled to the right margin. The initial width for a measure is
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determined by the music within it as well as a group of style settings that control the spacing between notes and other symbols. Most of the settings
affecting the horizontal spacing for a score are found in Format→Style→Measure. The most important are:

Minimum measure width: set the minimum width for a measure
Spacing ratio: set the ratio of space allocated for one note value compared to the next shorter value
Minimum note distance: set the minimum distance between two notes

The default spacing ratio value of 1.5 means that each note value takes 1.5 times as much space as the next shorter value. So, a half note takes 1.5
times as much space as a quarter note, etc. The minimum note distance specifies the smallest distance MuseScore will allow between two notes, and
this sets the initial distance for the shortest note values. Longer note values will always receive more space as per the spacing ratio, and by the time
measures are stretched to fill the page width, it is likely that even the shortest notes will not actually be as close as the minimum. The minimum note
distance and spacing ratio settings together determine how tight or loose the spacing is.

Note: a value of 1.0 for Spacing ratio will result in all notes taking equal space. A ratio of 2.0 will result in direct proportional spacing, where a half
note takes twice as much space as a quarter. Either of these extreme values can be useful in certain types of scores, but values closer to the default
of 1.5 are best for most cases. To achieve tighter spacing, a slightly smaller value such as 1.4 can be used, or 1.6 for looser spacing. Decreasing or
increasing the minimum note distance will also result in tighter or looser spacing.

If the spacing calculation results in some measures (those containing relatively few notes) working out to less than the minimum measure width, extra
space is added to enforce the minimum.

There are also many individual settings in this same dialog to control specific details such as the padding from Clef to time signature or Barline to
grace note. More such settings are added over time, and these are meant to be self-explanatory.

Additional relevant style settings can be found in :

Format→Style→Score
Enable indentation on first system: set to indent the first system of the score
First system indentation: set the amount of indentation

Format→Style→Page
Last system fill threshold: determines whether to fill the last system of the score to the right margin

These settings are discussed further under Systems and horizontal spacing.

Vertical spacing

MuseScore provides a choice of two different vertical spacing algorithms.

In both algorithms, MuseScore fills pages with systems in a similar manner to how it fills systems with measures. First, it determines an initial size for
each system, then it determines how many systems can fit on each page, and then it spreads those systems out so that all pages are filled well.
Depending on your style settings, MuseScore may literally fill each page to the bottom margin, or it may leave additional space on the bottom of some
pages if trying to fill the page completely would spread things out too widely.

The difference between the two algorithms has to do with how the spreading to fill the page occurs.

If you select Disable vertical justification of staves, the distance between the staves within a system is fixed, unless that would result in collisions.
In this algorithm, if MuseScore needs to spread systems to fill a page, it will always do so by adding space between systems rather than within
systems. This yields consistent spacing between staves from one system to the next, but it can result in spacing between systems being much larger
than spacing within them, and it will usually result in ragged bottom margins on pages with only a single system (since the staves within the system
won't be spread to fill the page).

The default, however, is to Enable vertical justification of staves. With this method selected, the distance between staves within systems is also
subject to spreading. This results in more even spacing overall—the spacing between systems will still be larger than the spacing within them but not
to the same extreme—and it mostly avoids ragged bottom margins on pages with only a single system (since the staves within the system can be
spread to fill the page).

Most of the settings controlling the vertical spacing for a score are found in Format→Style→Page. There is, however, one relevant setting in
Format→Style→Score.

Minimum vertical distance: set the minimum amount of space that MuseScore will allow between symbols below one staff or system and
symbols above the next staff or system below

Music margins

Regardless of whether vertical justification is enabled or disabled, MuseScore will add space above the top staff and below the bottom staff of each
page:

Music top margin: set the minimum amount of space between the page top margin and the top staff
Music bottom margin: set the minimum amount of space between the page bottom margin and the bottom staff

Distance between staves within systems

If you select DIsable vertical justification of staves, then there are two settings that control spacing within systems:

Staff distance: set the distance between the staves of adjacent instruments
Grand staff distance: set the distance between the staves of a grand staff (e.g., for piano)

Note: even with DIsable vertical justification of staves selected, MuseScore will still add more space between staves as necessary to avoid
collisions. To force a completely consistent distance between staves (and accept the resulting collisions), set the Minimum vertical distance to a
large negative number.

If you select Enable vertical justification within staves, then there is not a single setting for staff or grand staff distance. Instead, you select a range
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of acceptable distances and values that control how much of the available space MuseScore will fill by spreading systems versus spreading staves
(and how much extra space to add between bracketed and braced groups of staves). The relevant settings include:

Minimum staff distance: set the minimum distance between adjacent staves
Maximum staff distance: set the maximum distance between adjacent staves
Maximum grand staff distance: set the maximum distance between adjacent staves of a grand staff
Factor for distance above/below bracket: set the extra amount to spread between bracketed staff groups
Factor for distance above/below brace: set the extra amount to spread between braced staff groups

Distance between systems

Whether vertical justifications of staves is enabled or disabled, you specify the distance between systems as a range:

Minimum system distance: set the minimum distance between adjacent systems
Maximum system distance: set the maximum distance between adjacent systems

In addition, if you select Enable vertical justification of staves, there are two more settings:

Factor for distance between systems: set the extra amount to spread between systems
Maximum page fill distance: the total maximum amount of spread

Staff/part properties
There are also a couple of staff-specific settings that affect size and spacing. To access these, right-click (Ctrl+click) a staff and then select Staff/Part
properties. The relevant settings are:

Small staff: set staff size to percentage specified in Format→Style→Sizes
Scaling: set staff size to a custom percentage
Extra distance above staff: set an extra distance between this staff and the staff above

Systems and horizontal spacing

The horizontal spacing algorithm in MuseScore determines the width of each measure, which in turn determines how many measures will fit on each
system. While this will produce good results in many cases, there are also situations where you may wish to override this and have fewer or more
measures on a system, or to have them spaced differently within the system.

Features
The main tools used to control systems and horizontal spacing are described below.

System breaks

A system break causes MuseScore to end a system after a specific measure or horizontal frame, even if more measures would fit. To add a system
break, select a measure (or any element within it) or a frame, and then click the System break icon in the Layout palette:

You can also use the keyboard shortcut Enter. Both methods of adding breaks also work while in note input mode.

After adding a break, the icon will appear above the measure you added it to:

As with other formatting elements, system breaks appear in gray and will not print, and their on-screen display can be disabled via the Properties panel.

Layout stretch

You can increase or decrease the width of measures, and their contents will stretch accordingly. The calculated width of a measure is multiplied by a
layout stretch factor that you can set numerically for selected measures, but you can also use commands to increase or decrease the stretch of selected
measures directly without needing to set a specific number.

https://musescore.org/en/print/book/export/html/329209?toc=1#node-329732-horizontal-spacing
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To change the layout stretch directly, you can select one or more measures, then use one of the commands in Format→Stretch:

Increase layout stretch: increase the width of the measure (shortcut })
Decrease layout stretch: decrease the width of the measure (shortcut {)
Reset layout stretch: reset the width of the measure

To set the layout stretch value numerically, you can select one or more measures and then set the Measure width in the Appearance section of the
Properties panel.

As you can see if you watch this setting, each press of } or { increments or decrements this value by 0.1.

You can also set this value for a single measure by right-clicking it, selecting Measure properties, and setting Layout stretch in the resulting dialog.

Horizontal frames

A horizontal frame is a container for empty space, text, or images, that can be placed between measures in a score. Although you can place text or
images within horizontal frames (see Using frames for additional content), one of their main purposes is to create empty space within systems, as shown
below.

To add a horizontal frame to your score, select a measure and then click the Insert horizontal frame icon in the Layout palette:

The frame will be inserted in front of the selected measure. If the measure is at the beginning of a system, the frame may actually appear at the end of
the previous system, if there is room.

You can also use the commands in the Add→Frames menu.

You can then change the width of the frame using the Width setting in the Properties panel, or by selecting the frame and dragging its handle or using
the Left and Right cursor keys to change the width. Keyboard adjustment occurs in steps of 0.5 sp, or 1.0 sp if you hold Ctrl (Cmd on Mac).

Insert horizontal frame: insert a horizontal frame before the selected measure
Append horizontal frame: append a horizontal frame to the end of the score

Keep measures on the same system

To keep measures together for the purpose of determining if they fit on a given system or not, you can select them and then click the Keep measures on
the same system icon on the Layout palette:

When MuseScore is deciding how measures to place on a given system, and it encounters such a group and determines that they do not all fit,
MuseScore will move the entire group to the next system.

Tasks
These features can be used in a variety of ways, but there are a handful of tasks that are especially common.

Placing fewer measures on a system
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It is always possible to get fewer measures on a system than what MuseScore places by default. To end a system on a particular measure or horizontal
frame, select it and add a system break.

Placing more measures on a system

While it is not always physically possible to fit more measures onto a given system at the current page and staff size and spacing settings—there may
simply be “too many notes” to fit without overlapping—you can reduce the widths of selected measures.

To place more measures on a system:

Select and delete any system break that might be present already
Select the measures you wish to combine onto one system
Reduce stretch for the selected measures until they fit (e.g., by pressing {)

Depending on how close it was to fitting before, it might take multiple Decrease layout stretch operations before the stretch is reduced enough for them
all to fit. But it may also be the case that it just is not possible without reducing your overall page or staff size, or spacing settings. See Score size and
spacing for more information.

Changing the relative spacing of measures within a system

The default spacing is designed to make sure that all notes of a given duration on the same system take the same amount of space, unless more space
is required to make room for markings between specific notes. But there can be cases where it might make sense to increase the spacing in one or more
measures, thus correspondingly decreasing the spacing in the others (or vice versa).

To change the spacing in one or more measure, simply select them and increase or decrease the layout stretch as described above.

Creating space between measures

To create space between two measures, select the second measure, then insert and adjust a horizontal frame as described above.

Creating space at the beginning or end of a system

To add space at the beginning of a system, select the first measure of the system then insert and adjust a horizontal frame as described above. You may
also need to place a system break on the last measure of the previous system to ensure that the horizontal frame does not appear there instead.

Note that for the first system of a score, the First system indent style setting (in Format→Style→Score) automatically creates space. See Score size
and spacing for more information.

To add space at the end of a system, first make sure there is no system break on the last measure, then select the next measure and insert a horizontal
frame. Then add a system break to the horizontal frame itself if needed.

Adjusting the width of the final system

The last system of a score will normally be right-justified (stretched to fill the width of the page) if its default width exceeds the Last system fill threshold
as set in Format→Style→Score. See Score size and spacing for more information. This normally produces good results, but there may be cases where
the last system is filled but would look better if it were not, or vice versa.

For cases where the system is filled but you would prefer it not to be, you can increase the threshold. A value of 100% will mean the last system is never
filled (since its width will never exceed that threshold). Conversely, if the last system is not filled but you want it to be, then decrease the threshold. A
value of 0% will mean the last system will always stretch (because its width will always exceed that threshold).

Normally, however, you should select a threshold value that will accommodate future changes to the score that might result in more or fewer measures
ending up on the last system. For instance, if your last system currently has several measures and you force it to be filled by setting the threshold to 0%,
this might look bad if the layout changes in the future and the last system has only one measure. Or if the last system has only one measure and you
force it not to be filled by setting the threshold to 100%, this might look bad if the layout changes in the future and the last system ends up with several
measures. This is why a more middle-of-the-road value usually makes sense.

It is usually even better, however, to plan system breaks to avoid having the last system being less full than others.

Grouping measures

As discussed in Score size and spacing, MuseScore normally fits as many measures as it can on each system. This can sometimes result in two or more
musically-related measures being split across a system break, when it might be easier to read if they were kept together on the next system. While you
could add a system break to the measure before the group, this could easily turn out to be counterproductive if the layout changes later and all the
measures could have fitted on that system. What you really want is to be able to specify that a group of measures should be kept together if possible,
whether that means keeping them on the original system or moving them all together to the next.

In a word processor, a “non-breaking space” character can be used to keep two words together. If the words both fit on the current line, then the non-
breaking space acts like a regular space. But if the two words cannot both fit on a line, word wrap will move them both together to the next line rather than
split them apart at the non-breaking space.

In MuseScore, you can use the Keep measures on the same system icon in the Layout palette to group selected measures in the same way. These
measures will be treated as a single block for the purpose of deciding whether to place them on one system or the next.

Note that this will not allow you to fit more measures on a system than your current settings would normally allow. It simply tells MuseScore that it should
keep them all together if possible.

Pages and vertical spacing
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Features
As described in Vertical spacing, MuseScore fills each page with as many systems as can fit given the current score settings, and then adjusts the
spacing within each page according to one of two different algorithms. You can also adjust the number of systems on a page, or the spacing between
specific staves or systems, manually.

Page breaks

A page break causes MuseScore to end a page after a given system, even if more systems would fit. To add a page break, select a measure or frame
and then either press Ctrl+Enter (Cmd+Enter on Mac) or click the Page break icon in the Layout palette:

Spacers

A spacer is a formatting element you can add to a measure to control the amount of space above or below that particular staff. Spacers can work to either
add or remove space, and they can operate either within or between systems.

To add a spacer to your score, select a measure and then click the appropriate icon in the Layout palette:

You can also drag and drop a spacer from the palette to a measure in your score.

Once you have added a spacer, you can adjust its height by selecting it and dragging its handle, or by using the Height setting in the Properties panel.
There are three different types of spacers, and the height setting affects the score differently according to the spacer type:

Staff spacer down: ensure there is at least the specified given amount of space below this staff
Staff spacer up: ensure there is at least the specified amount of space above this staff
Staff spacer fixed down: ensure there is exactly the specified amount of space below this staff

In all cases, the spacer works within a system when added between staves of a system. In addition, a Staff spacer down or Staff spacer fixed down
works between systems when added to the bottom staff of a system, and a Staff spacer up works between systems when added to the top staff of a
system.

Vertical frames

A vertical frame is a container for empty space, text, or images, that can be placed between systems in a score. Although vertical frames can be left
empty and thus function in a manner similar to spacers, the primary purpose of vertical frames is to add text or images. For more information, see Using
frames for additional content.

https://musescore.org/en/print/book/export/html/329209?toc=1#node-329732-vertical-spacing
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System dividers

In ensemble music in which multiple systems fit on a single page of music, it is common to use a pair of diagonal strokes to help clarify the division
between the systems.

MuseScore can add these automatically via the settings in Format→Style→System. You can enable Left and Right dividers independently. For each,
you can customize a number of settings:

Symbol: select between System divider, Long system divider, or Extra long system divider
Horizontal offset: distance from default position (aligned with the page margin)
Vertical offset: distance from default position (midway between systems)

Tasks
The feature listed above can be used to achieve a number of common tasks.

Placing fewer systems on a page

To place fewer systems on a page, simply add a page break to the system or frame you wish to appear last on the page.

Placing more systems on a page

As with horizontal spacing, in some cases it might not be possible to fit more systems onto a page than your current settings permit. So you may also
want to consider a smaller staff size, or reducing the minimum system distance score-wide, or other style changes. However, in some cases you may be
able to fit more systems on a page by manually reducing the distance between specific systems.

To reduce the distance between two specific systems, add a Staff spacer fixed down to the bottom staff of the upper system, then set its height as
desired. If this reduction allows another system to fit on the page, then it will happen automatically.

Adjusting the spacing on sparse pages

MuseScore normally spreads systems and staves out to fill a page (see Vertical spacing for more information). Whether you enable or disable vertical
justification, however, pages that are especially sparse may still look awkward. This is especially common for the last page of a score, where it is possible
more systems could have fit.

In many cases, the best results would be obtained by planning the system and/or page breaks throughout the score to avoid these overly sparse pages.
But in cases where this is unavoidable, you will need to decide where you want the extra space—all at the bottom of the page, equally divided between
the top and bottom, dispersed between systems, or dispersed between staves within systems as well as between systems.

To force all extra space to the bottom of the page, once solution is to add a Staff spacer down below the last system, and adjust its height as appropriate

https://musescore.org/en/print/book/export/html/329209?toc=1#node-329732-staff-size
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to take the space you wish to leave below. Another is to reduce either the Maximum system distance or Maximum page fill distance (see Vertical
spacing). These settings may affect other pages as well, but in most cases, they will only be relevant for especially sparse pages.

To force some space at the top of the page, you can add a Staff spacer up above the first system.

To change the distribution of space between systems and staves within systems, be sure Enable vertical justification of staves is enabled in
Format→Style→Page, then adjust Factor for distance between systems. A value of 1.0 means that space is equally distributed within and between
systems. Larger values mean that more of the available space will be allocated between systems as opposed to within them.

Adjusting space between specific systems

To add space between two specific systems, add a Staff spacer down to the bottom staff of the upper system, or a Staff spacer up to the top staff of the
lower system.

Adjusting space between specific staves

To add space between specific staves within a single system, add a Staff spacer down to the upper staff, or a Staff spacer up to the lower staff.

To add space between specific staves across all systems—such as to separate piano accompaniment from the vocal staves in a choral score—right-click
the lower staff, select Staff/Part properties, and increase the Extra distance above staff setting.

Using frames for additional content

Overview
A frame is a rectangular space in the score into which one or more text objects or images may be inserted. In the score window the sides of the frame
are marked by dotted lines (these do not show up in the printed score).

A frame may be one of three types:

Vertical frame: A full-width rectangle inserted before the first system, after the last system, or between systems. It may contain several text objects
and/or images.
Text frame: A full-width rectangle inserted before the first system, after the last system, or between systems. It may contain one text object only.
Horizontal frame: A rectangle between two measures which may contain several text objects and/or images.

Note: Although you can use frames to create extra space between systems, it is best to use spacers for this purpose.

Uses of frames
Frames may be used to

Display the title, subtitle, composer, arranger, lyricist etc., at the top of a score. This is done automatically for new scores if you have completed the
relevant details on page 2 of the New Score dialog.
Display details of movements within a score.
Display lyrics at the end of a song.
Create a blank space before a coda

and so on.

Adding frames between or before/after systems
Text frames

A text frame is a full-width rectangle placed either before the first system or after the last one, or between systems. One text block (only) may be added
to the frame. The height of the frame is automatically adjusted to the height of any text block contained within it.

Adding a text frame

Select a measure, or a frame
Apply one of the following methods:

From the menu bar select Add→Frames→Insert text frame
In the Layout palette click on the “Insert text frame” icon
Use an “Insert text frame” custom keyboard shortcut (you can set this up in the Preferences: Shortcuts dialog).

If the measure selected is the first one in the system, the frame will simply be inserted above the system. If the selected measure is any one but the first,
it will start a new system and the frame will appear above it.

Adding text

To add a text block to the text frame:

Double-click the frame; or right-click on the frame and choose Edit element; or select the frame and use the shortcut F2, or Alt+Shift+E.
Type the desired text.

The text has the “Frame” style by default but you can change this using “Text style” in the Text tab of the Properties panel. You can also apply character
formatting in the usual way.

Vertical frames

https://musescore.org/en/print/book/export/html/329209?toc=1#node-329732-vertical-spacing
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A vertical frame is a full-width rectangle placed either before the first system or after the last one, or between systems. Several text blocks and/or images
may be added to the frame.

Adding a vertical frame

Select a measure, or a frame
Apply one of the following methods:

From the menu bar select Add→Frames→Insert vertical frame
In the Layout palette click on the “Insert vertical frame” icon
Use an “Insert vertical frame” custom keyboard shortcut (you can set this up in the Preferences: Shortcuts dialog).

If the measure selected is the first one in the system, the frame will simply be inserted above the system. If the selected measure is any one but the first,
it will start a new system and the frame will appear above it.

Adding text

To add a text block to the vertical frame apply one of the following methods:

Right-click on the frame, select Add, then choose one of the options (Text, Title, Subtitle, Composer, Lyricist, Part name).
Select the frame, and from the menu bar choose Add→Text. Then choose one of the first five options (Title, Subtitle, Composer, Lyricist, Part
name).
Select the frame and use keyboard shortcuts to add applicable text blocks (you can set these up in the Preferences: Shortcuts dialog).

Adding an image

Right-click on the vertical frame
Select Add→Image
Search for and add the image from the “Insert image” window.

Size

The height of the vertical frame is automatically adjusted to the height of any text block contained within it. But you can override this using “Height” in the
Vertical frame tab of the Properties toolbar.

Position and alignment of content

The position of a text object which abuts directly onto the border of a vertical/text frame can be altered by adjusting the relevant margin
(Top/Bottom/Left/Right) in the Vertical frame tab of the Properties panel.

For example, a left- and top-aligned text object will be pushed away from the respective border by increasing the “Left margin” and/or “Top margin”, and
so on.

Spacing

In the Vertical frame or Text frame tab of the Properties panel, adjust “Gap above” and “Gap below” to create extra space above/below the frame.

Adding frames between measures
Horizontal frames

A horizontal frame is used to create space between the measures of a particular system with optional text and/or image content.

Adding a horizontal frame

Select a measure.
Apply one of the following methods:

From the menu bar select Add→Frames→Insert horizontal frame
In the Layout palette click on the “Insert horizontal frame” icon
Use an “Insert horizontal frame” keyboard shortcut (you can set this up in the Preferences: Shortcuts dialog).

The frame is inserted between the selected measure and the following one.

Adding text

To add a text block to a horizontal frame, right-click on the frame and select Add→Text.

Adding an image

Right-click on the horizontal frame
Select Add→Image
Search for and add the image from the “Insert image” window.

Size

You can adjust the width of the frame in the Horizontal frame tab of the Properties panel.

Spacing

https://musescore.org/en/print/book/export/html/329209?toc=1#node-329668-shortcuts
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329668-shortcuts
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You can adjust the space on either side of the horizontal frame using “Left gap” and “Right gap” in the Horizontal frame tab of the Properties panel.

Other horizontal frame properties

Display brackets, clefs and key signatures in the next measure

See also
Add measures to a frame

Working with images

Adding images
supported formats

Frames

Other elements

Image properties

Using sections for multiple movements or songs

Overview
A section break is used to divide a score into separate sections, such as might be required in a musical suite, for example.

In the following score example, there is a section break at the end of the first system, followed by a text frame providing the title of the next movement.

Features

A section break has the following features:

The measure after the point of application is forced to start a new system (like a system break)
An adjustable playback pause between movements
An option to restart measure numbering
An option to display long instrument names (as you might at the start of a piece).

These options are detailed in Section break properties (below).

Time and key signatures

If the beginning of a new section is accompanied by a change of time or key signatures, there will be no courtesy signature at the end of the previous
section.

Adding section breaks
To add a section break, select a measure, barline (or any element within the measure), then click the Section break icon in the Layout palette. You can
substitute the latter action with a custom shortcut if desired (see Preferences: Shortcuts).

Section break properties
The following properties of section breaks are adjustable from the Section break part of the Properties panel:

Pause

To adjust the playback pause after a section break: select the break and edit “Pause before new section starts”.

Instrument names

https://musescore.org/en/print/book/export/html/329209?toc=1#node-329666-add-to-frame
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329733-system-break
https://musescore.org/en/print/book/export/html/329209?toc=1#undefined-break-properties
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329668-shortcuts
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To display the long intrument names on the first system after a section break: select the break and make sure that “Start new section with long
instrument names” is checked.

Bar numbers

To restart measure numbering after a section break: select the break and make sure that “Reset bar numbers for new section” is checked.

Additional settings for measure number display are available in the Measure properties dialog.

Sound and playback

Playback controls

Overview
Basic playback functions are accessed from the Play toolbar at the top right of the program window:

From left to right, the icons are:

Rewind to start position: Playback returns to the beginning of the score, or to the start of the loop (if one is set).
Start or stop playback: See Start/stop playback.
Toggle loop playback: See Loop playback.
Play metronome: Toggles metronome ON and OFF.
Playback settings: Opens the playback settings dialog (see below).

To the right of the playback controls are counters showing

Time elapsed from the start of score to the cursor position.
Bar number and beat at the cursor position.
Tempo in 1/4 notes (crotchets) per min.

This panel can also be undocked giving you access to additional controls—see play position and tempo, (below). To redock the Playback Panel: click and
hold down the "6 dots", then drag the Playback Panel to the top right of the MuseScore screen and release.

Playback commands
Start/stop

To play back all the instrument parts

Click on a note or rest to establish the starting point.
Press the Play button, or press Space.

To play back selected instrument parts only

Select a measure that you want to start from (by clicking on a blank space within that measure);
To play back more than one instrument part, extend the selection up or down as required.
Press the Play button, or press Space.

Notes: (1) If no selection is made before activating Play, playback returns to the place it stopped at previously; or, if no previous playback, to the start of
the score. (2) The Play button changes to a "stop" icon while music is playing.

To stop playback

Press the Play button; or press Space.

Rewind

To rewind playback click on the Rewind icon on the Play toolbar. Rewind returns the playback to the beginning of the score or, if a loop is set, to the
beginning of the loop.

Loop

To loop playback over a section of music:

Stop playback (if it is on);
Ensure that the loop playback button is "off" (i.e. not colored blue);
Select a range in the score, encompassing the instrument staves you want to play back;
Click on the loop playback button in the Play toolbar. Flags will appear around the selection and the button change color.
Click on the Play button.

In the example below, playback will cycle over the selected two bars of Violin 2 and Viola, the region marked by the blue flags. Use the "Loop playback"
button to toggle the loop on or off.

https://musescore.org/en/print/book/export/html/329209?toc=1#undefined-other-commands
https://musescore.org/en/print/book/export/html/329209?toc=1#node-330541-dock-undock-panels
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329658-select-range
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329658-select-range
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Metronome

If you want to hear a metronome tick during the performance, click on the metronome button. Click again to turn it off.

Play position and tempo

The current playback position is shown by counters to the right of the playback controls. One shows the position in terms of time elapsed, the other in
measures and beats (see image in overview).

The numbers in the time and measure counters can be edited after clicking on them; playback will be resumed from the edited position.

When the Play toolbar is undocked from the toolbar area, it automatically expands to include two slider controls. By dragging the sliders you can adjust
the playback position and tempo of playback. Note that tempo overrides are only temporary, and do not affect the actual written tempo(s); returning the
slider to "100%" restores normal playback.

In the following example the position of playback is about one third of the way through the score, and the playback tempo slider is set to 78 quarter note
beats per minute (bpm); or 130% of the nominal metronome mark, 60 bpm, displayed in the score.

Other commands
Click the settings button (cogged gear) on the Play toolbar to show the following controls:

You can uncheck or check these options as desired.

Enable MIDI input

Enable MIDI input to write music to your score with a linked MIDI device (such as a keyboard or drum machine) during playback. See Working with Midi
for details.

Play repeats

Uncheck this option if you want playback to ignore any repeat indications in the score.

Play chord symbols

Uncheck this option if you want playback to ignore chord symbols in the score.

Pan score automatically

When checked, this option pans the score during playback; uncheck if you want the view to remain stationary.

https://musescore.org/en/print/book/export/html/329209?toc=1#undefined-overview
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Mixer

Overview
The mixer allows you to

change instrument sounds (without affecting the staff notation).
load virtual instruments and effects.

adjust volume and panning, and make other adjustments to the playback for each stave.

The mixer is divided into a number of color-coded channel strips:

Instrument: Each staff instrument in the score has its own channel, with the name of the instrument, labelled blue, at the bottom. An instrument
channel is also created for each mid-score instrument change applied to a staff.
Metronome: This channel, also labelled blue, allows control of metronome volume and panning.
Aux 1/Aux 2: These are the auxiliary channels, labelled green, and may be used to house VST effects units. Aux 1 by default contains Muse
Reverb (see below).
Master: The master fader, labelled red.

Opening the mixer
You can display/hide the mixer by:

Clicking on the Mixer button in the Note input toolbar.
Clicking View→Mixer.
Using the shortcut F10.

Note: If the instrument channel strips are not in the same order as the instruments in the score, try closing and reopening the Mixer again.

Mixer controls
A channel strip contains the following controls (from top to bottom):

Sound: See below.
Audio FX: See below.
Aux sends: See below.
Pan: Click and drag on the Pan knob to move the audio track to the left or right in the stereo sound field. Double click on the knob to return Pan to
the center position.
Volume: Click and drag the fader to increase or decrease playback volume. Double click on the fader to return it to the default level, 0 dB.

https://musescore.org/en/print/book/export/html/329209?toc=1#undefined-aux-channels
https://musescore.org/en/print/book/export/html/329209?toc=1#undefined-sound
https://musescore.org/en/print/book/export/html/329209?toc=1#undefined-aux-sends
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Mute and Solo: Click on the Mute button to silence the track; click again to unmute it—and so on. The Solo button silences all other tracks allowing
you to hear only the soloed track. Multiple selection of Solo and Mute buttons is possible, allowing you to conveniently isolate any combination of
instruments.
Name: Note that this name is not affected by any changes made to the instrument name in the score.

Click the three dot icon in the upper right corner of the Mixer panel to show / hide a control. For example, you can hide the Volume faders to save up
vertical screen space for score viewing.

Sound
The row labelled Sound shows the virtual instrument set used in each track. This can be either a SoundFont (.sf2,.sf3), VST instruments (VSTi) or
MuseSounds.

To change the instrument of a channel:

Mouse over the name of the virtual instrument set (in the row marked “Sound”)
Click the dropdown button that appears
Locate and click on an item from the dropdown menu.

Note: This changes the staff instrument, but has no effect on staff notation. If you want the staff to be updated as well, say, with correct transposition and
clef changes, see Choose instruments.

MS4 does not yet support bank selection of sounds from a single SoundFont file (as MS3 did). This is planned for a future version, but for now, use the
workaround detailed in SoundFonts.

SFZ files are supported but only by using a VST sampler; see SoundFonts.

Audio FX
Each row (slot) under the Audio FX allows you to add an extra VST effect or Muse Reverb (a native effect). Audio is processed through the Audio FX
from top to bottom.

Find VSTi inside Sound drop-downs, and find VST effects inside Audio FX drop-downs.
To apply Audio FX(s) to one instrument, add Audio FX to the corresponding instrument strip.
To easily apply the same Audio FX(s) to multiple instruments, use Aux sends.

To add an Audio FX plugin

Hover over an empty Audio FX slot
Click the dropdown button that appears
Locate and click on a plugin from the dropdown menu .
The plugin will load as a separate window on top of the Musescore window.
When you add one effect, a new empty row (slot) is created automatically to allow adding further effect. Repeat these steps to add more effect.

To disable an Audio FX plugin

Hover over an Audio FX slot
Click on the power icon that appears.

This deactivates the plugin without removing it from the mixer.

https://musescore.org/en/print/book/export/html/329209?toc=1#node-329655-choose-instruments
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To remove an Audio FX plugin

Hover over an Audio FX slot
Click the dropdown button that appears
Click No effect.

Muse Reverb

Muse Reverb is MuseScore’s native reverb unit. A fixed amount of reverb is added by default to each instrument—you can adjust the amount for each
channel using the Aux send knobs next to the blue buttons labelled "Reverb". The effect can be toggled on/off for each channel by clicking on the same
buttons. You can also adjust the Muse Reverb output volume using the Aux 1 fader.

Aux sends
Each row (slot) under the Aux sends adjusts how much of a corresponding Aux channel effect(s) is added to the audio created for an instrument.

There are two Aux sends, corresponding to the two aux channels:

The first row adjusts how much of Aux channel 1 Aux 1 is added onto the current instrument, it is shown as Reverb by default, because Aux 1
contains Muse Reverb by default.
The second row adjusts how much of Aux channel 2 Aux 2 is added onto the current instrument, Aux 2 does not contain any Audio FX by default.
Both of the two aux sends are enabled by default for each instrument, and can be disabled individually. Audio is processed with Aux 1 then Aux 2.
You can also apply audio effect(s) to one instrument only by adding Audio FX.

To show/hide an Aux send row (slot)

Click the three dot icon in the upper right corner of the Mixer panel
Hover over View
Click Aux send 1 and/or Aux send 2.

To disable an Aux send row (slot)

https://musescore.org/en/print/book/export/html/329209?toc=1#undefined-aux-channels
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Make sure the Aux send is visible
Click Reverb to turn off Aux send 1 OR Click Aux 2 to turn off Aux send 2.

Aux channels
Aux channels are special channels to simplify audio FX application. You can set up audio FX(s) in one Aux channel and then apply them to multiple
instruments.

There are up to two Aux channels in each score:

Aux 1: contains the Muse Reverb by default, but you can remove this and replace it with any Audio FX(s) you like.
Aux 2: is empty by default.

To show/hide Aux channels

By default, aux channels are hidden. To show/hide a aux channel:

Click the three dot icon in the upper right corner of the Mixer panel
Hover over View
Click Aux channel 1 and/or Aux channel 2.

To add Audio FX to an Aux channel

The process is the same as adding Audio FX(s) to an instrument channel, see To add an Audio FX.

If there is only one Audio FXin an Aux Channel, the channel strip and its corresponding aux send are labelled by the name of the Audio FX. If there is
more than one, they are labelled Aux 1 and Aux 2. You may need to save and reopen the score to see the labels update.

To adjust an Aux channel's level

Aux channel strips have volume faders. This changes the volume of the effect across all channel strips with the corresponding aux send turned on. Think
of this as setting the maximum volume of the effect(s) that an instrument channel can receive.

To apply the effect(s) of an Aux channel to an instrument

To adjust how much effect of an Aux channel come through on each instrument, use the knob in the corresponding Aux sends row (slot) on that
instrument channel strip, see Aux Sends.

See also

Installing Muse Sounds

SoundFonts

MuseScore uses virtual instruments to create audio for playback. SoundFont files (.sf2, .sf3) are one of the supported formats . An sf2 or sf3 file contains
all the audio data for one or more virtual instruments.

MuseScore comes packaged with its own native SoundFont, MS Basic, which contains most of the instrument sounds you need for score playback.

You can also add and use custom SoundFonts—many are available free online. See also the list in SoundFonts and SFZ files  (MS3 handbook).

Install a SoundFont
Once you’ve downloaded a SoundFont to your computer, there are two ways to install a SoundFont in MuseScore 4:

https://musescore.org/en/print/book/export/html/329209?toc=1#undefined-show-hide-aux
https://musescore.org/en/print/book/export/html/329209?toc=1#undefined-aux-sends
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Drag and drop the SoundFont file into MuseScore 4.
Place the SoundFont file in the MS4 user directory named "SoundFonts".

Drag and drop installation

[Content on its way]

File directory installation

By default, MuseScore looks for SoundFonts at the location [MuseScore4 Installation Folder]\SoundFonts. So, by OS, the default locations are as
follows:

Windows: C:\Users*username*\Documents\MuseScore4\SoundFonts.
macOS:
Linux: ~/Documents/MuseScore4/SoundFonts.

You can also specify in which folder(s) on your computer MuseScore looks to find SoundFonts. If a SoundFont is installed in a recognized folder/directory,
it will automatically be available in MuseScore.

First, specify the SoundFont directory in MuseScore 4:

Open Preferences (Mac: MuseScore > Preferences or shortcut Cmd+;. Windows: Edit > Preferences)
Select Folders (under General)
Click the SoundFonts folder icon
Click Add directory in the dialog that appears
Choose and Open the folder location where you want MuseScore to look for SoundFont files
Repeat steps 1-5 to add further directories (optional)
Click OK to finish. The specified directory (or directories) will appear in the SoundFonts text field.
Click OK in the Preferences dialog to confirm your selection.

Once a SoundFont is installed, all you’ll need to do is choose the SoundFont you want for each instrument in your score. To do this:

Open the Mixer
Hover over the plugin slot next to Sound
Click the dropdown arrow that appears
Hover over SoundFonts
Select the SoundFont you wish to assign to that particular instrument

Repeat this process for each instrument. In most cases, MuseScore will automatically map instruments to their correct sounds in the specified
SoundFont, as long as that SoundFont is using the correct MIDI instrument definitions.
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Uninstall a SoundFont
To uninstall a SoundFont, simply open the folder where its file is installed and delete it.

Selecting sounds with a SoundFont
When you select a SoundFont for a given instrument, MuseScore uses the General MIDI  standard to automatically select the corresponding sound
from within the SoundFont. However, this may not always be sufficient. The SoundFont in question might not be GM-compatible, or there might be
multiple variants of a sound you wish to choose between, like fingered versus picked for electric bass.

When you select a SoundFont with only a single sound or only a single drum kit, MuseScore will use that. But for SoundFonts that represent collections
of sounds, manual selection of individual sounds within a given SoundFont is currently not supported (as of Musescore 4.0 ). Therefore, if you need to
select a sound for an instrument other than the one specified by General MIDI, you will need to employ a workaround:

You can use this special version of MS Basic  that provides all of the individual sounds and drum kits as separate soundfont files.

For other soundfonts, you can split them into individual sound files using a free tool such as sf2-split  or SF2 Splitter . You can edit the individual
files as needed—see Editing, below.

You can use a a VST sampler such as Sforzando , FluidSynthVST , or juicysfplugin

Editing Soundfonts
This is possible using 3rd party software such as Polyphone . For more information, see also Soundfont, MIDI velocity and instruments.xml
(Developer’s Handbook).

A note on the Zerberus player and SFZs
Users of MuseScore 3.6 and earlier may be accustomed to using the Zerberus player, which supports the .sfz file format. In building a new system that
now supports VST instruments, changes were required that necessitated the removal of the Zerberus player, as well as the Synthesizer  found in
previous versions of MuseScore. Consequently, some functionality has been lost in this process, including the ability to map specific instrument sounds
like pizzicato and tremolo to specific MIDI channels. Our highest priority in future releases of MuseScore 4 is to again support this functionality for VST,
SoundFont and the Muse Sounds libraries. Users who rely extensively on mapping .sfz sounds to specific performance directions are advised to continue
using earlier versions of MuseScore until we re-enable this capability in MuseScore 4. It is worth mentioning that the new systems we are planning will be
much more flexible, easy to use and powerful than those found in MuseScore 3.

For those who wish to still use SFZ sounds in MuseScore 4, good alternatives would be the open source VST samplers, Sfizz  (Windows, Mac & Linux)
or Sforzando  (Windows & Mac), both of which support SFZ playback.

See also
SoundFonts and SFZ files  (MS3 handbook)

Alternatives to soundfonts:

Muse Sounds
VSTi

Installing Muse Sounds

MuseScore 4 - Installing Our FREE Orchestral Plugin: Muse …

Installation via Muse Hub
Muse Sounds is a library of sophisticated plugins that provide realistic playback for MuseScore.

Muse Sounds are installed using the Muse Hub application, which can be downloaded here on musescore.org .

Once installed, Muse Hub can be opened by clicking the application icon in the menu bar (macOS) or system tray (Windows). Click Get under any sound
you’d like to have in your library, and it will begin downloading and installing right away.

https://www.youtube.com/watch?v=n7UgN69e2Y8
https://en.wikipedia.org/wiki/General_MIDI
https://musescore.org/en/node/334701
https://community.masteringmusescore.com/c/resources/ms-basic-individual-sounds
https://github.com/schnitzeltony/soundfont-cmdline-tools
https://www.softpedia.com/get/Multimedia/Audio/Other-AUDIO-Tools/SF2-Splitter.shtml
https://musescore.org/en/print/book/export/html/329209?toc=1#undefined-edit
https://www.plogue.com/products/sforzando.html
https://github.com/AZSlow3/FluidSynthVST/tree/master/bin
https://github.com/Birch-san/juicysfplugin/releases
https://www.polyphone-soundfonts.com/
https://musescore.org/en/handbook/developers-handbook/references/instrumentsxml-documentation
https://musescore.org/en/node/278660
https://sfz.tools/sfizz/
https://www.plogue.com/products/sforzando.html
https://musescore.org/en/node/278624#list
https://musescore.org/en/download
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Muse Hub also contains a range of effects plugins. Download and install these from the Effects tab.

Once a plugin is fully downloaded, it will appear in the Mixer the next time you launch MuseScore.

Using Muse Sounds in MuseScore
Any Muse Sounds plugins you’ve downloaded will be automatically assigned to the appropriate instruments in your score.

You can tell MuseScore to always use available Muse Sounds plugins via the Playback Setup dialog.

Go to view → Playback setup
Select Muse Sounds in the Profiles section
Leave Set as default for new scores checked if you want all future scores to also use Muse Sounds
Click OK

The Muse Sounds playback profile will ensure that all Muse Sounds plugins will be assigned to every available instrument in your score. You can also
manually assign a Muse Sounds plugin to a single instrument via the Mixer. This can be helpful for scores with more than one instrument, where you may
wish to combine Muse Sounds plugins with other VSTs or Soundfonts.

Go to View → Mixer to show the Mixer (Shortcut: F10)
Hover over a plugin slot next to Sound
Click the dropdown button that appears
Navigate to Muse Sounds and select a sound from the desired library

Available sounds in Muse Sounds
Muse Sounds currently supports the following instruments:

Choir

Sopranos
Altos
Tenors
Basses

Strings

Violins 1
Violin 1 (Solo)
Violins 2
Violin 2 (Solo)
Violas
Viola (Solo)
Violoncellos
Violoncello (Solo)
Contrabasses

Woodwinds

Alto Flute
Alto Sax
Baritone Sax
Bass Clarinet
Bass Flute
Bassoon
Clarinet in Bb
Clarinet in Eb
Contrabass Flute
Contrabassoon
English Horn
Flute 1
Flute 2
Oboe
Piccolo
Soprano Sax
Tenor Sax

Brass

French Horns a6
French Horn
Trumpets a4
Trumpet
Trombones a3
Trombone
Bass Trombone
Cimbasso
Tuba
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Percussion

Bass Drum
Bell Tree
Bongos
Cabasa
Castanets
Claves
Cowbell
Crotales
Field Drum
Glockenspiel
Gong
Marimba
Mark Tree
Piatti
Shaker
Sleigh Bells
Snare Drum
Suspended Cymbal
Taikos
Tam-Tam
Tambourine
Timbales
Timpani
Toms
Triangle
Tubular Bells
Vibraphone
Wood Blocks
Xylophone
Metronome

Keys

Celesta
Grand Piano
Harpsichord
Soft Piano
Upright Piano
Hammond Organ
Suitcase Piano
Wurly 200A
Dream Piano

Harp

Harp

Any instruments not supported by Muse Sounds will remain assigned to MS Basic by default.

Capo playback (MS 4.0.2 and before)

This page shows you how to apply Capo markings in MuseScore versions prior to MuseScore 4.1. See Applying capos for the new method of applying
capos in MuseScore 4.1 and above.

Adding a capo marking to your score (before MuseScore 4.1)
MuseScore allows you to transpose the playback of a staff without changing the music notation (written pitch). This simulates the effect of a capo on a
guitar (or other stringed instrument).

Adding a capo to a single staff

Add staff text to the note/rest from which you want capo playback to start;
Open the Staff text properties dialog.
Click on the Capo Settings tab;
Check the “Capo Settings” checkbox, and set "Capo fret" to the fret number you wish to apply the capo at (each fret increases the pitch by a
semitone);
Click OK to apply your changes;
Edit the wording of the text as desired.

Adding a capo to a staff / tablature pair

Use one of the following:

If linked, add the capo to the standard staff—not the tablature.
If unlinked, add the capo to both staves.

Note: Any capo playback settings apply until overridden by a subsequent Staff text with “Capo Settings” enabled.

https://musescore.org/en/print/book/export/html/329209?toc=1#node-329724-staff-system-text-properties
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See also
Chord symbols: Capo fret position

Swing playback

Overview
Music in “straight” time is performed strictly as written in the score. By contrast, music in swing time interpets straight eigth and sixteenth notes as triplet
pairs, with the first of the pair being roughly twice as long as the second. This gives the rhythm a characteristic bouncy feel—often asssociated with Jazz
music. e.g.

Swung eighths:

Swung sixteenths:

Rather than notate swung music exactly as performed, it is accepted convention to write it in straight time and simply provide the written indications
“Swing and “Straight” at appropriate points in the score.

Swing markings have a playback effect on the score. The default swing ratio is 60% (3:2) but you can vary this to suit the feel of the piece if required.

Adding a swing or straight marking to your score
To add a swing marking

Click on the destination note or rest
Click on the Swing text in the Tempo palette.

Alternatively, you can drag and drop the Swing text from the palette onto the note or rest in question.

You can, if desired, add a visual swing marking  as well.

To add a straight marking

Click on the destination note or rest
Click on the Straight text in the Tempo palette.

Note that the above markings are a form of System text and therefore the playback effect is applied to all staves in the system. If you want swing to apply
to only one staff you can use Staff text instead: see below.

Changing swing playback
Adjust the type and degree of swing

Right-click on the Swing text in the score and select System text properties.

In the Swing settings tab edit the “Swing” and “Swing ratio” as required.

Note: Swing settings are found in both system and staff text.

Apply swing to one staff only

If you want swing to apply to only one staff in the system, use staff text instead:

https://musescore.org/en/print/book/export/html/329209?toc=1#node-329728-capo
https://musescore.org/en/node/266325
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Select the destination note or rest.
Click on the Staff text indication in the Text palette.
Edit the text to create the desired performance indication
Right-click on the text and select Staff text properties. Alternatively select the text object and in the Properties panel, click on the Staff text
properties button.
In the Swing settings tab edit the “Swing” and “Swing ratio” as required.

Working with MIDI

This section needs to be organized / written by someone with an understanding of how to use MIDI input/output in MuseScore 4. If JACK is still
supported, it could be discussed here too, or in a new page.

Working with VST and VSTi

Introduction to VST
Virtual Studio Technology (VST) is an audio plug-in software interface licensed under Steinberg that integrates software synthesizers and effects units
into digital audio workstations. Most VST plugins are either instruments (VSTi) or effects (VSTfx); VSTi includes software simulation emulations of well-
known hardware synthesizers and samplers.

Installing VSTs
In MuseScore 4, any compatible VST plugins installed on a Windows or MacOS computer will automatically be made available in the Mixer, where you
can easily configure playback settings for all instruments in a score. Note that Linux is not yet supported (but see Linux VST3 ).

After installing new VSTs on your computer, you may to restart Musescore 4 to make them visible in the mixer. If this doesn't work, you can force a re-
scan of VSTs by deleting previous cache settings before restarting. On Windows 10 the relevant file can be found at

C:\Users\ [your user] \AppData\Local\MuseScore\MuseScore4\known_audio_plugins.json

MuseScore 4 directly supports VST3 plugins only (not VST1 or VST2) because of licensing restrictions. If you are using VST1 or VST2, see How to use
older, non-VST3 plugins in MuseScore 4 .

Note: Sound settings in the Mixer are saved with the score, but not to the program.

Enabling, disabling, removing and replacing VST plugins
See Mixer: Audio FX and Sounds.

See also

Alternatives to VST instruments:

Muse Sounds
SoundFonts

File management

Opening and saving scores

MuseScore in Minutes: Publishing and Saving to the Cloud

Overview
You can store your files either locally on your computer, or online (“in the cloud”) to your musescore.com account. If you don’t have an account yet, you
can create one for free here .

In the case of scores saved online, MuseScore also keeps local copies on your computer (in a folder called Cloud Scores in your user “MuseScore 4”
folder), so you can work on them even without an active internet connection. Every time you save a score that was opened from the Cloud Scores folder,
the online copy at musescore.com is also updated. This system protects both the integrity of your local cloud scores while offering all the advantages of

https://www.youtube.com/watch?v=6LP4U_BF23w
https://musescore.org/en/node/351813
https://musescore.org/en/node/352231
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329739-audiofx
https://musescore.com/user/register
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online storage, including backup, viewing and playback across multiple devices, ease of sharing, commenting, and much more.

Please note that, if you download one of your cloud scores from musescore.com and open it in MuseScore, the file you download and open will be a new,
locally-stored file, separate from the file in the cloud.

Opening a score
There are a few ways to open a score in MuseScore 4.

File → Open

This triggers your file browser, allowing you to select and open scores stored on your computer or storage device (dialog will vary according to operating
system).
Windows/Linux: Ctrl+O. MacOS: Cmd+O

File → Open recent

This option allows you to choose from a list of recently-opened scores.

Home tab → Scores

This window displays your most recently modified scores. Double-click on any score thumbnail to open it. You can also click Open other… to access
locally-stored scores from your file browser.

Scores that have been saved to the cloud are indicated with a cloud icon. Unlike local scores, it is not possible to rename or otherwise modify a cloud file
from your computer’s file browser. You can, however, do this from the score manager on musescore.com. Go directly to your score manager by clicking
the Score manager (online) button in the Scores window.

It is possible to open multiple scores simultaneously. In this case, MuseScore opens each score in a separate window.

Import file formats
Apart from its native format files  (*.mscz and *.mscx), MuseScore can also open MusicXML , compressed MusicXML  and MIDI  files, as well as
a variety of files in other formats . You can customize various import settings by going to Preferences → Import.

Saving a score
To save a score:

1. Go to File
2. Choose any of the following options:

Option What it does Shortcut

Save Saves current score to new file, or saves changes
to a previously saved file Windows/Linux: Ctrl+S, MacOS: Cmd+S

Save As... Saves current score to new file Windows/Linux: Shift+Ctrl+S, MacOS:
Shift+Cmd+S

Save a copy... Saves current score to new file, but allows you to
continue editing the original file None

Save selection... Saves selected measures to new file None
Save to cloud... Saves score as a new file on musescore.com None

The first time you use any of the above save options, a dialog opens asking you “How would you like to save”, then offering you the options of “Save to
the cloud” or “Save to computer”.

To disable this window, click Don't show again to ensure you only see your operating system's native save dialog for future saves.

Save to computer

The Save to computer option triggers your operating system’s “Save” dialog, allowing you to save the score as a (compressed) MuseScore file, .mscx.

There is also an option in your “Save” dialog to save files in an uncompressed format (“Uncompressed MuseScore folder”). This option creates a new
folder on your computer that contains a MuseScore (.mscx) file, as well as a thumbnail image file (.png) and any relevant .json, .mss, and .xml files.

Save to the cloud

Scores saved online (to the cloud) appear in the program’s Home: Scores tab with a cloud symbol at the corner of the file icon. A copy is also
automatically saved on your computer in the Cloud scores folder in your user “MuseScore 4” folder.

To save a score to the cloud, choose Save to the cloud. This triggers a dialog with the following options:

Name

This is the name under which your score will be identifiable on musescore.com

Visibility

https://musescore.org/en/handbook/3/file-formats#musescore-native-format
https://musescore.org/en/handbook/3/file-formats#musicxml
https://musescore.org/en/handbook/3/file-formats#compressed-musicxml
https://musescore.org/en/handbook/3/file-formats#midi
https://musescore.org/en/handbook/3/file-formats#share-with-other-software
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Private allows you to save changes to your score without others seeing your work online.
Public makes your score visible to everyone on musescore.com.

When you’re ready, click Save. The first time you do this, MuseScore will ask whether you also want to upload your audio to musescore.com. You can
choose from the following options:

Never

Each time you press Save, only the score itself will be uploaded to musescore.com. Online playback will use the MS Basic soundfont.

Always

Each time you press Save, MuseScore will generate an .mp3 file to upload together with your score. Score playback on musescore.com will sound the
same as it does in your desktop app (including audio from the Muse Sounds library, if installed, or any VST instruments and effects you’ve added)

Every x saves

MuseScore will only generate and upload an .mp3 file at a save interval you specify.

These settings only affect your private cloud scores. You will only be asked to specify this setting once, however you can change this setting at any time
by going to Preferences → Cloud. Once you click OK, MuseScore will confirm your score has been saved. Your file will be accessible from both the
Home tab as well as the score manager on musescore.com.

File export

Overview
This chapter covers the saving of MuseScore scores in formats other than the native ones (*.mscz and *.mscx), such as MusicXML, MIDI, MP3, PDF,
PNG etc.

Exporting your score
To export a score:

Select File→Export
Choose a Format from the dropdown list
Select the parts to export by checking/unchecking the appropriate boxes on the left of the dialog
If you want to combine all parts in one file click on the radio button titiled All parts combined in one file
Click Export...

File formats
Graphical formats

PDF is a universal format for text, pictures, music and so on. Virtually every computer will have a dedicated PDF reader; if not a PDF can also be opened
using web browsers such as Firefox etc.

Use this format when you want to generate music scores for other musicians to read from. PDF scores can also be printed to hard copy if desired.

PNG is a compressed graphical format suitable for embedding in all kinds of documents. SVG enables you to preserve a higher graphical resolution and
allows you to resize in situ.

Audio formats

MuseScore enables you to export audio files in a number of compressed formats: MP3 is the most well-known, but OGG and FLAC also have their
advantages. These formats combine the benefit of relatively small size with high audio quality.

If you want uncompressed audio go for the WAV option. File size will be considerably larger than the uncompressed audio options.

MIDI format

MIDI (Musical Instrument Digital Interface), a well-established music industry standard, encodes the notes and instrumentation of the original score and
can be played back using a PC’s media player, or other suitable computer app, as long as the right software (or hardware) instruments are available to
realize it.

You should be aware that the sound generated by a MIDI file is dependent on the virtual instruments used to play it back, so it is likely to differ in sound
quality from the original. Also it does not preserve score formatting, voicing etc.

Score formats

MusicXML is a universal standard which aims to preserve as much of the original score formatting as possible. It can be opened in any modern score
writer. MuseScore 4 uses MusicXML 4.0.

Braille is a plain text format used by musicians who are blind, either on a electronic braille display, or embossed onto paper as raised dots. MuseScore's
braille files are bar-over-bar format, conforming to the North American Music Braille Code 2015. The files use ASCII rather than Unicode characters,
meaning that sighted users who open these files in a text editor will just see ordinary font symbols; you would need to install a braille font in order to see
the braille as dots.
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Customizing export settings

{To be added]

MIDI import

MIDI import panel not currently implemented, making this section largely moot

Working with MusicXML files

Overview

Cleaning up an imported score
resetting stems
removing breaks
resetting text
import settings

Preparing a score for export
gotchas - manual adjustments, misuse of element types, images, ...
export settings

Backup and recovered files

TBD

Project properties

Overview
The Project Properties dialog contains meta tags. Meta tags are snippets of descriptive text that can be used by Musescore, such as "Work title,"
"Composer," "Copyright" etc.

Changing score properties
To change a score property

From the menu, choose File→Project Properties...
Click in the required field
Enter text or edit existing text

When you create a score, a title block is generated on the first page, and the value of some metatags is genearted automatically (see Setting up your
score). After the score is created, the text in the title block is no longer linked to the value of the metatags in Project Properties.

Every score is created with the following predefined metatags. The third column shows the code to use the meta tag in Headers and Footers.

Property Value when Score is created Code to access from headers and footers

Work title Same text as "Title" on the first page of the score
(see Setting up your score). $:workTitle:

Arranger $:arranger:

Composer Same text as "Composer" on the first page of the
score(see Setting up your score). $:composer:

Copyright
Same text as "Copyright" on the first page of the
score(see Setting up your score). (if you need a
copyright symbols, copy/paste this: ©).

$C

Creation Date
Date of the score creation. This could be empty, if
the score was saved in test mode (see Command
line usage). Edit manually if you are Beethoven's
ghost.

$D

Lyricist
Same text as "Lyricist" on the first page of the
score(see Setting up your
score).fragment="title"]).

$:lyricist:

Translator Empty $:translator:

Platform
The computing platform the score was created on.
This might be empty if the score was saved in test
mode.

Source May contain a URL if the score was downloaded
from or Publish to MuseScore.com.

Musescore Version The version of MuseScore the score was last
saved with

File Path The score file's location on your Computer.

https://musescore.org/en/print/book/export/html/329209?toc=1#node-329655-title
https://musescore.org/en/print/book/export/html/329209?toc=1#undefined-access-properties
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329655-title
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329655-title
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329655-title
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329655-title
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Adding new properties
To add another metatag, click on the New button. Fill in the "New tag name" field and press OK;

Any tag name can be used. For example, the following metatags were used in previous versions of Musescore:

movementNumber:
movementTitle:
originalFormat:
poet:
workNumber:

To delete a tag click on the trashcan symbol. The predefined meta tags cannot be deleted.

Accessing project properties in your score
To show the content of one or more metatags in a header or footer for your score or part:

Make sure that the correct score or instrument part is the active tab;
From the menu, select Format→Style...→Header, Footer
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If you hover with your mouse over the Header or Footer text region, a list of macros will appear, showing their meaning, as well as the existing meta
tags and their content.

Add tags (e.g. $:workTitle:, note the leading and trailing colons) and macros (e.g. $M, no colons) to the appropriate boxes, as required;
Changes are directly visible in the score window. Make corrections to the dialog if required;
If an instrument part is in the active tab, click Apply to all parts, if you want to apply these settings to all the score parts;
Click OK to assign the header or footer and exit the dialog.

In this list $I and $i are only available in parts, because the partName score property is only defined there, unless, as described above, it got manually
added to the main score properties. Not shown in this tooltip, but available likewise, is the $:partName: meta tag.

Metatags for parts
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Every part additionally has the following meta tag, generated and filled on Parts:

partName: The name of the part as given on part creation (which is also used to fill the corresponding part name text in the top vertical frame—be
aware that later changes to one are not reflected in the other). It can be accessed for use in Headers and Footers using $I, $i, or S:partName:.

To change a part name:

click on parts
double click on the part name or click on the "..." menu to the right of the part and choose Rename
edit the part name

This meta tag is not present in the main score and thus is not available for use in its header/footer or in an added part name box in the top vertical frame,
unless manually added as a new tag to its score properties.

Score comparison

not currently implemented

Publish to musescore.com

Overview
Scores can be saved online using a free or subscription account with Musescore.com. This allows you to access your scores from anywhere; you also
have the option of whether to keep them private or allow them to be shared. You can choose to save scores only online, or publish any of your locally
saved files online.

When saving online Musescore creates an MP3 file of the audio of your score which may take a long time. To modify this behaviour see Managing
publishing preferences.

Creating a MuseScore account
Go to www.musescore.com
Click "Log in" - it's at the top right of the window
On the dialog that pops up click "Create an account" - it's at the bottom right of the dialog that popped up
If your browser is already logged in to a Google, Facebook or Apple account you can sign up with any of those services by clicking on the
appropriate button
If you prefer to sign in with your email address, fill in the remaining fields, check "I'm not a robot"
Click "Create new account"

Saving only to Musescore.com
The first time you save a score you will be asked if you want to publish the score to Musescore.com.

If you are not already logged in to Musescore.com, or you do not have an account, you will need to login.

https://musescore.org/en/print/book/export/html/329209?toc=1#undefined-publish-preferences
http://www.musescore.com/
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You will be asked if the score should be Public, Unlisted, or Private.
* Public scores are visible to everyone on the internet.
* Unlisted scores are visible to everyone on the internet, but do not show up in search results. Only people with the link will be able to find an unlisted
score.
* Private scores are visible only to you. You must be logged in to your musescore.com account to view.

If you’re publishing a score that you’ve already published at least once, you can choose to replace the existing online score or to publish as a new online
score.

You will be asked whether you also want to upload your audio to musescore.com. See Managing publishing preferences

Musescore will tell you when it is ready. Large scores may take some time to generate the MP3 file.

https://musescore.org/en/print/book/export/html/329209?toc=1#undefined-publish-preferences
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Publish locally saved scores
Scores saved on your computer can also be published at Musescore.com but are not automatically updated.

To publish a score at Musescore.com
* Click the Publish Tab (below the menu bar)
* Click Publish to Musescore.com

Visibility in score manager
Scores published only at Musescore.com are marked with a "cloud" symbol in the Musescore score manager.
MuseScore also keeps local copies on your computer (in a folder called Cloud Scores in your user “MuseScore 4” folder), so you can work on them even
without an active internet connection.

Manage generation of mp3 during upload
When saving online Musescore creates an MP3 file of the audio of your score. Depending on the score length, and number of instruments in the score,
this might take a long time. To control when this happens:

From the menu, choose Edit→Preferences...→Cloud

Under "Generate MP3 audio for private cloud scores" choose Never, Always, or Every (X saves)
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Never

Each time you press Save, only the score itself will be uploaded to musescore.com. Online playback will use the MS Basic soundfont.

Always

Each time you press Save, MuseScore will generate an .mp3 file to upload together with your score. Score playback on musescore.com will sound
the same as it does in your desktop app (including audio from the Muse Sounds library, if installed, or any VST instruments and effects you’ve
added)

Every x saves

MuseScore will only generate and upload an .mp3 file at a save interval you specify.

If you chose "Every X saves" choose the number of saves

Share on Audio.com

Overview
As of MuseScore 4.1 in addition to publishing your score on musescore.com , you can share the MP3 audio generated by MuseScore to audio.com ,
a free service from Muse Group. On audio.com, you can keep your uploads private, share them publicly, and make your tracks available to download.

To share audio from your score on Audio.com:

In MuseScore, click the Publish tab
Click the Share on Audio.com… button in the toolbar
You will be prompted to sign in to your audio.com account or create one if you’re not already signed in
Enter a title, choose whether the score should be Public or Unlisted, then click Share

The audio will export and audio.com will open in your browser.
From here, you can change the title, URL, category, tags, description, sharing permissions, and downloading permissions of your track.

https://musescore.com/
https://audio.com/
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Customization

Language

Overview
MuseScore works with your "System" language (the one used for most programs, and generally depending on your country and the language settings of
the PC, or account).

Change language

From the menu, select Edit→Preferences... (Mac: MuseScore→Preferences...);

In the General tab, select the desired language from the drop-down list in the Language section:

Update translations

To update translation(s):

From the menu, select Edit→Preferences... (Mac: MuseScore→Preferences...);
In the General tab, click on the Check for language updates button;

A message which displayed if the version of your language is already up to date, if not then the update will be downloaded.

To complete this step, a restart of the application is required.

See also

Helping with translations

Appearance

Overview
To change the appearance of MuseScore

From the menu, select Edit→Preferences... (Mac: MuseScore→Preferences...);

In the Appearance tab, select the desired option described below.

https://musescore.org/en/node/49
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Theme and Colors
The following options are available to change the colors of MuseScore. The display changes immediately so options can be tested without closing the
dialog. The changes apply to all open instances of MuseScore (see Windows)

Light or Dark Theme
Select "Follow system theme" if you want MuseScore to change themes from light to dark, or dark to light, when the system theme changes
Enable high-contrast
Accent color options
Background - the color behind the score (not the color of palettes and other program items) can be changed to a solid color or a Wallpaper image.
Paper - the color of the score itself can be changed to a solid color or a Wallpaper image.
Invert Score - swaps the color of score elements with the Paper color

Fonts
To change the font face and text size for Menu and Palette elements:

From the menu, select Edit→Preferences... (Mac: MuseScore→Preferences...);
In the Appearance tab, select the font options.

This does not affect and text elements in the score.

Toolbars and windows

Overview
Windows, toolbars and panels within MuseScore can be repositioned, and you can choose which elements you want to see displayed in them.

The default appearance of MuseScore is shown below:

https://musescore.org/en/print/book/export/html/329209?toc=1#node-330541-toolbarsandwindows-windows
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The Menu bar
Toolbars
Palette, Property and Instrument Panels
The Score Window
The Status Bar

Toolbars
Showing and hiding toolbars

To show or hide the playback controls, note input toolbar, or the status bar:

Select View→Toolbars... and check/uncheck the applicable element.

Rearranging toolbars

To change the position of either the note input or playback toolbars, click on and hold the six dots at the left of the toolbar, then drag and drop it to the
desired location. The toolbar can be left free floating, but in the case of the note input toolbar, you can also drag and drop it either to the left or the
bottom edge of the program window—a blue rectange then appears to show you that you can drop the toolbar at that location to redock it. The playback
toolbar can only be redocked in its default position.

Customizing contents of toolbars

To select the icons that you want on view in the note input or playback toolbars, click on the gear icon to the right of the toolbar:

In the case of the note input toolbar, this reveals a dropdown list from which you can hide or display the various icons by clicking on the eye symbol to
the left of each one (closed=hidden, open=displayed).

In the case of the playback toolbar, uncheck or check the various options in the gear menu to hide or display the corresponding elements.

Windows and Panels
Docking and undocking panels

To undock and move one of the side panels (Palette, Instruments, Properties, or Selection filter), click on the three dots on the tab, select the Undock
option, then drag the undocked panel to the desired position.

You can leave the panel free-standing but there are also dock positions at the top and right hand edges of the document window—a blue rectangle
appears to show that you can drop the panel to redock it at that location.

In a similar way, you can redock the free panel back to the sidebar:

To display half-length at the top of the sidebar, drag and drop the free panel to the top left of the sidebar.
To display half-length at the bottom of the sidebar, drag and drop the free panel to the bottom left of the sidebar.
To display full-length in the sidebar, drag and drop the free panel to the center left of the side.

You can also redock the free panel in its original position by clicking on the three dots on the tab, and selecting Dock.

Panels such as the Mixer or virtual Piano can be undocked if desired, by dragging them into position or clicking on the three dots icon and selecting
Undock. To redock, click on the three dots icon and select Dock.

https://musescore.org/en/print/book/export/html/329209?toc=1#node-329660-piano-keyboard-entry
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The undocked mixer can be resized by dragging the edges inwards or outwards.

Customizing contents of panels

To choose which elements to display within the mixer or the virtual Piano, click on the three dots, select View and uncheck or check the applicable
options.

To customize the palettes area, see Customization: Palettes.

Templates and styles

Overview
Templates

A template is simply a standard MuseScore file (*.mscz) stored in a dedicated “Templates” folder.

There are two kinds of templates:

System templates. These are supplied with the installed version of MuseScore and cover a wide variety of solo instruments and ensembles of all
genres. When you open the New Score dialog, these template files appear under various categories in the Create from Template tab.

User templates. These are created by the user and stored in the folder marked Templates in the MuseScore4 folder of your Documents
directory. When you open the New score dialog, user templates are displayed in the My Templates section of the Create from template tab.

Style files

A style file is a file containing customized style settings for all musical and text objects in a score. You can save an existing set of styles or import one
using the Format menu (see below).

Templates
Saving your score as a template

Create a specimen score containing the style settings, workspace, and title text that you wish to use in the template.
Make sure that the Title text of the score describes the template accurately, as this is the wording that will appear in the My templates section of
the New score dialog.
Save the score in the "Template" folder of your MuseScore 4 user directory.

Creating a score from your template

Open the New Score dialog
Choose a template file in the “My templates” section of the Create from template tab.
Complete the rest of the New Score dialog and exit.

Style files
Saving style settings for your score to a file

Create a score with the style settings that you wish to save and reuse in future scores
Select Format→Save style, and save the Style file in the “Styles” folder of your MuseScore 4 user directory.

Loading style settings into your score from a file

Open the score to which you want to apply the saved style settings
Select Format→Load style, and select the applicable style file.

Setting a default style for your score

[to be added]

Palettes

This chapter shows you how to customize the palettes and their contents; the application of palette items is already covered in Using the palettes
(Basics).

Adding palettes
To add a preset or a custom palette, see Using the palettes: Adding more palettes.

Hiding and deleting palettes
To hide a preset palette, right click on it and select Hide palette. The palette is returned to the Add Palettes list (see above). Note that preset palettes
cannot be deleted.

https://musescore.org/en/print/book/export/html/329209?toc=1#node-329660-piano-keyboard-entry
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329663-adding-more-palettes
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To hide or delete a custom palette you have created earlier, right click on it and select Hide/Delete palette. Then follow the instructions in the dialog.

Changing the order of palettes
To change the order of a palette simply drag it up or down and drop it onto the desired position in the palettes list.

Customizing palette contents
Palettes can be populated with items from the Master Palette (Shift+F9 or View→Master palette), or from an opened score.

Score items, when added to a palette, are saved with their custom properties.

To enable/disable editing for a particular palette:

Right-click on the palette name; or click on the ellipsis symbol (three dots) to the right of the palette name
Check/uncheck Enable editing.

Adding elements from the Master Palette window

To add a symbol from the Master Palette to a palette in the Palettes panel:

Open the desired palette, make sure editing is enabled (see Customizing palette contents).
Open the Master Palette (Shift+F9 or View→Master palette)
Drag and drop symbols from the relevant section(s) of the Master palette to the ordinary palette as required.

If you have created a custom palette, there is another way to access the Master Palette:

Open the custom palette
Click on the More button
Use the arrow buttons to navigate through the various sections of the Master Palette window
Select on a symbol
Press Add to my custom to add it to the custom palette
To exit the dialog, click once more on the More button, or press Escape, or click outside the More section.

Adding elements from an opened score

To add score elements to a palette:

Open the desired palette
Press Ctrl+Shift, then drag and drop the score element to the open palette.

Moving elements between palettes

Symbols can be moved from one open palette to another simply by dragging and dropping them.

Deleting elements from palettes

To delete an element in a palette, right-click on it and select Delete. In the case of preset palettes, the element will be moved to the More section. For
custom palettes you are offered a choice of Hide (send element to the More section) or Delete permanently.

Resetting a palette

To reset a palette to its default state, right-click on the palette name, or click on the ellipsis symbol (three dots) to the right of the palette name; then select
Reset palette.

Note: A custom palette will be reset to an empty palette when this function is applied.

Saving and loading palettes
To save a palette, right-click on the palette name, or click on the ellipsis symbol (three dots) to the right of the palette name; then select Save palette.

To load a previously-saved palette, right-click on a palette name, or click on the ellipsis symbol (three dots) to the right of the palette name; then navigate
to the desired palette, select it and click Open.

Palettes menu
To access display options for the palettes area, click on the ellipsis symbol (three dots) to the right of the Palettes title at the top of the palettes area.

https://musescore.org/en/print/book/export/html/329209?toc=1#undefined-customize-contents
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Single-click to open a Palette: Uncheck this if you want to open a palette by double-clicking.
Open only one Palette at a time: if this option is checked, when you open a palette other palettes automatically close.
Collapse all Palettes: Closes all open palettes.
Expand all Palettes: Opens all palettes.
Close: Palettes panel closes.
Undock: Undocks the palettes panel. See also Windows and panels.

Palette properties
To access Palette properties for individual palettes, right-click on the palette name, or click on the ellipsis symbol (three dots) to the right of the palette
name; then select Palette properties.

This allows you to rename the palette, create a visible grid to separate elements, adjust width and height of cells, and change the scale and offset of the
symbols.

See also
Using the palettes for info about how to apply palette items.
Other symbols for more info about the Symbols palette.

Workspaces

Overview
A workspace includes the visible palettes, toolbars and assorted open panels. You can customize the appearance of all aspects of a workspace, and
create new ones.

Creating a new workspace
To create a new workspace:

Click on the current workspace name in the status bar below the document window. Alternatively, select View→Workspaces→Configure
workspace
Click on Create new workspace
Fill in the name of the workspace, and uncheck any elements in the list below whose present arrangement you do not wish to be remembered.
Click Select to close the dialog.

To customize the palettes display and contents, see palettes.
To customize the display of toolbars and panels, see Toolbars and panels.

Deleting a workspace
Click on the current workspace name in the status bar below the document window. Alternatively, select View→Workspaces→Configure
workspace
Select the workspace to be deleted
Click on the trash icon at the top of the dialog.

Switching between workspaces
Click on the current workspace name in the status bar below the document window.
In the resulting dialog box, click on the desired workspace
Press Select.

Alternatively

Select View→Workspaces→Configure workspace
Click on the desired workspace in the menu.

Keyboard shortcuts

Overview

https://musescore.org/en/print/book/export/html/329209?toc=1#node-330541-windows-panels
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MuseScore commands can be accessed via the main menus, toolbars, Properties panel or context menus, or by using keyboard shortcuts.

Pre-existing keyboard shortcut are shown alongside the commands in the main menus or context (right-click) menus, or by hovering the mouse pointer
over an icon in a toolbar.

Alternatively, you can view a list of commands and their shortcuts in Edit→Preferences→Shortcuts. This is also the place where you can create a
shortcut or change an existing one. To locate a command in the list either scroll down the alphabetical order, or enter an appropriate keyword in the
“Search shortcut” box.

Defining a shortcut
To define a new shortcut, or change an existing one:

From the menu bar, select Edit→Preferences→Shortcuts
Find the relevant command in the alphabetical list; use the Search box if needed.
Either double-click the relevant entry, or select the entry and click Define…
With the Enter shortcut sequence dialog open, press and hold the sequence of keys on your keyboard to use as the new shortcut.
Press Save (or Cancel to exit the dialog without changing anything).

Resetting and clearing shortcuts
To reset a shortcut to its default:

From the menu bar, select Edit→Preferences→Shortcuts
Find the relevant command in the alphabetical list; use the Search box if needed.
Select the entry and press Reset to default.

To clear (i.e. delete) a shortcut:

From the menu bar, select Edit→Preferences→Shortcuts
Find the relevant command in the alphabetical list; use the Search box if needed.
Select the entry and press Clear.

Note: You can select more than one shortcut if needed. Press the Shift key to establish a continuous range, or the Ctrl key for a list.

Importing and exporting shortcuts
To save the existing shortcuts or import a list of your own:

From the menu bar, select Edit→Preferences→Shortcuts
Press Export to save the list; or Import to load a new shortcut list.

Preferences

To edit Preferences (the appearance and general behavior of MuseScore), go to Edit→Preferences.

These are divided logically into sections (see below); notice also the three buttons at the bottom of the window:

Reset preferences: Click on this to reset all preferences to their default values.
Cancel: Exit preferences without changing anything.
OK: Exit preferences and apply any user changes.

General
You can specify your language, and autosave interval in “General”. See also Language.

“Program start” allow you to choose what, if any, score you want displayed in the edit window after launching.

“Folders” allows you to customize locations for any user folders (though it’s a good idea to leave them at default to start with if you are a new user).

Appearance
Choose between light and dark options, and specify the accent color; there is also a high contrast option for visually impaired users.

The system font is also the default for the MuseScore UI, but you can alter this if desired—and the font-size.

You can set the score paper/color option and the background. For visually impaired there is an “Invert score” option which inverts the score colors (white
to black and vice versa)

Canvas
Specify the default zoom level of the score, and the mouse zoom precision. Also how you want your score pages to scroll, and the degree of precision of
mouse selection.

Note input
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Here you can choose how MuseScore sounds when you click on or advance to a note. And whether you want notes outside the playback range of an
instrument to be colored.

MIDI device mapping
Here you can map certain keys of your external MIDI keyboard to certain actions. For example to start or stops score playback, set note-entry duration,
and so on.

Score
Customize the default order of instruments in your score.

I/O
Specify your audio and MIDI input devices.

Import
Specify the way that MuseScore handles the import of MusicXML and MIDI files. You can supply a style file covering every aspect of the score.

Shortcuts
See Keyboard shortcuts for more information.

Update
By default MuseScore automatically checks for updates when online. You can turn this off by unchecking the box.

Advanced
A number of specialized options can be accessed here, such as voice color, and palette behavior.

Plugins

Overview
A MuseScore plugin is a small piece of software that adds extra functionality to the program. A range of plugins is installed automatically with the
program: you can view these in the Home: Plugins tab.

Additional plugins can be downloaded from the MuseScore website at musescore.org→Download→Plugins . See Installing a plugin (below) for further
details.

N. B.: No warranty of any kind is provided for plugins. Either download from a trusted author or double-check the code yourself.

(How to create a plugin - to be added)

Installing a new plugin

Download the necessary plugin files and move them to MuseScore's plugins folder.
Open MuseScore and go to Home/Plugins
Find the name of the plugin, select it, and click 'Enable'

Updating existing plugins

Updating works the same way as installing, but remember to remove the files from the previous version to avoid duplicate plugins!

Enabling and disabling plugins

In order to not overcrowd the plugins tab, you can enable/disable specific plugins as you please.

Running a plugin
You can run enabled plugins in the Score tab, from the 'Plugins menu. You can also set shortcuts to run specific plugins, in the Home: Plugins tab.

Pre-installed plugins
brief info on each

See also
Plugins
MuseScore 3 features not implemented in MuseScore 4

https://musescore.org/plugins?category=All&compatibility=4496
https://musescore.org/plugins?category=All&compatibility=4496
https://musescore.org/en/node/334701#Plugin_API
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Plugins for 4.x  (porting a Musescore 3 plugin to MuseScore 4)

Support

Getting help

See https://musescore.org/support

Overview
documentation
support questions
bug reports
See https://github.com/musescore/MuseScore/issues
feature requests

Learn
tutorials
classes

Forums

Issue tracker
?

GitHub
?

Mastering MuseScore

Revert to factory settings

Overview
why to do this
what it does
disclaimers

Reverting to factory settings from the menu

Reverting to factory settings from the command line
Windows

macOS

Linux

Troubleshooting

Installation issues

Score issues

Display issues

Sound issues

Printing issues

Known incompatibilities

Appendix

Command line usage

https://musescore.org/en/node/337468
https://musescore.org/support
https://github.com/musescore/MuseScore/issues
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PLEASE NOTE: This page was copied from the equivalent page  in the MuseScore 3 Handbook. If you find an option that no longer works in
MuseScore 4, please report it on GitHub and add a note next to that option on this page. If the option was intentionally removed from MuseScore 4 then
please delete it from this page.

MSCORE(1) — General Commands Manual Page

NAME

mscore, MuseScore4 — MuseScore 4 sheet music editor

SYNOPSIS

You can launch MuseScore from the command line by typing

mscore [options] [filename …] (Mac and Linux/BSD/Unix)
musescore [options] [filename …] (Linux/BSD/Unix)
mscore4portable [options] [filename …] (Linux AppImage)
MuseScore4.exe [options] [filename …] (Windows)

[options] and [filename] are optional. For this to work the MuseScore executable must be in %PATH% (Windows) resp. $PATH (Mac and Linux). If it is not,
see Revert to factory settings  for detailed instructions on how and where to find and execute the MuseScore executable from the command line on the
various supported platforms.

A more detailed synopsis follows:

mscore [-deFfhIiLmnOPRstvw]
[-a | --use-audio driver]
[-b | --bitrate bitrate]
[-c | --config-folder pathname]
[-D | --monitor-resolution DPI]
[-d | --debug]
[-E | --install-extension extension file]
[-e | --experimental]
[-F | --factory-settings]
[-f | --force]
[-h | -? | --help]
[-I | --dump-midi-in]
[-i | --load-icons]
[-j | --job file.json]
[-L | --layout-debug]
[-M | --midi-operations file]
[-m | --no-midi]
[-n | --new-score]
[-O | --dump-midi-out]
[-o | --export-to file]
[-P | --export-score-parts]
[-p | --plugin name]
[-R | --revert-settings]
[-r | --image-resolution DPI]
[-S | --style style]
[-s | --no-synthesizer]
[-T | --trim-image margin]
[-t | --test-mode]
[-v | --version]
[-w | --no-webview]
[-x | --gui-scaling factor]
[--diff]
[--long-version]
[--no-fallback-font]
[--raw-diff]
[--run-test-script]
[--score-media]
[--score-meta]
[--highlight-config]
[--score-parts]
[--score-parts-pdf]
[--score-transpose]
[--source-update]
[--template-mode]
[file ...]

DESCRIPTION

MuseScore is a Free and Open Source WYSIWYG cross-platform multi-lingual music composition and notation software, released under the GNU
General Public Licence (GPLv3).

Running mscore without any extra options launches the full graphical MuseScore program and opens any files specified on the command line.

The options are as follows:

-a | --use-audio driver

https://musescore.org/en/node/278640
https://musescore.org/en/node/278582#Via-command-line
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Use audio driver: one of jack, alsa, portaudio, pulse

-b | --bitrate bitrate

Set MP3 output bitrate in kbit/s

-c | --config-folder pathname

Override configuration and settings directory

-D | --monitor-resolution DPI

Specify monitor resolution (override autodetection)

-d | --debug

Start MuseScore in debug mode

-E | --install-extension extension file

Install an extension file; soundfonts are loaded by default unless -e is also specified

-e | --experimental

Enable experimental features, such as layers

-F | --factory-settings

Use only the standard built-in presets (“factory settings”) and delete user preferences; compare with the -R option (see also Revert to factory
settings )

-f | --force

Ignore score corruption and version mismatch warnings in “converter mode”

-h | -? | --help

Display an overview of invocation instructions (doesn’t work on Windows)

-I | --dump-midi-in

Display all MIDI input on the console

-i | --load-icons

Load icons from the filesystem; useful if you want to edit the MuseScore icons and preview the changes

-j | --job file.json

Process a conversion job (see EXAMPLES below)

-L | --layout-debug

Start MuseScore in layout debug mode

-M | --midi-operations file

Specify MIDI import operations file (see EXAMPLES below)

-m | --no-midi

Disable MIDI input

-n | --new-score

Start with the New Score wizard regardless whether it’s enabled or disabled in the user preferences

-O | --dump-midi-out

Display all MIDI output on the console

-o | --export-to file

Export the given (or currently opened) file to the specified output file. The file type depends on the extension of the filename given. This option
switches to “converter mode” and avoids the graphical user interface.

-P | --export-score-parts

When converting to PDF with the -o option, append each part’s pages to the created PDF file. If the score has no parts, all default parts will
temporarily be generated automatically.

-p | --plugin name

Execute the named plugin

-R | --revert-settings

https://musescore.org/en/node/301598
https://musescore.org/en/node/278582
https://musescore.org/en/print/book/export/html/329209?toc=1#undefined-EXAMPLES
https://musescore.org/en/print/book/export/html/329209?toc=1#undefined-EXAMPLES
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Use only the standard built-in presets (“factory settings”) but do not delete user preferences; compare with the -F option

-r | --image-resolution DPI

Set image resolution for conversion to PNG files. Default: 300 DPI (actually, the value of “Resolution” of the PNG option group in the Export tab of
the preferences )

-S | --style style

Load a style file first; useful for use with the -o option

-s | --no-synthesizer

Disable the integrated software synthesizer

-T | --trim-image margin

Trim exported PNG and SVG images to remove whitespace surrounding the score. The specified margin, in pixels, will be retained (use 0 for a
tightly cropped image). When exporting to SVG, this option only works with single-page scores.

-t | --test-mode

Set test mode flag for all files, includes --template-mode

-v | --version

Display the name and version of the application without starting the graphical user interface (doesn’t work on Windows)

-w | --no-webview

Disable the web view component in the Start Center

-x | --gui-scaling factor

Scale the score display and other GUI elements by the specified factor; intended for use with high-resolution displays

--diff

Print a conditioned diff between the given scores

--long-version

Display the full name, version and git revision of the application without starting the graphical user interface (doesn’t work on Windows)

--no-fallback-font

Don’t use Bravura as fallback musical font

--raw-diff

Print a raw diff between the given scores

--run-test-script

Run script tests listed in the command line arguments

--score-media

Export all media (except MP3) for a given score as a single JSON document to stdout

--highlight-config

Set highlight to svg, generated from a given score

--score-meta

Export score metadata to JSON document and print it to stdout

--score-parts

Generate parts data for the given score and save them to separate mscz files

--score-parts-pdf

Generate parts data for the given score and export it as a single JSON document to stdout

--score-transpose

Transpose the given score and export the data to a single JSON file, print it to stdout

--source-update

Update the source in the given score

--template-mode

https://musescore.org/en/node/278648#export
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Save files in template mode (e.g. without page sizes)

MuseScore also supports the automatic Qt command line options .

Batch conversion job JSON format

The argument to the -j option must be the pathname of a file comprised of a valid JSON document honoring the following specification:

The top-level element must be a JSONArray, which may be empty.

Each array element must be a JSONObject with the following keys:

in: Value is the name of the input file (score to convert), as JSONString.
plugin: Value is the filename of a plugin (with the .qml extension), which will be read from either the global or per-user plugin path and
executed before the conversion output happens, as JSONString. Optional, but at least one of plugin and out must be given.
out: Value is the conversion output target, as defined below. Optional, but at least one of plugin and out must be given.

The conversion output target may be a filename (with extension, which decided the format to convert to), as JSONString.

The conversion output target may be a JSONArray of filenames as JSONString, as above, which will cause the score to be written to multiple output
files (in multiple output formats) sequentially, without being closed, re-opened and re-processed in between.

If the conversion output target is a JSONArray, one or more of its elements may also be, each, a JSONArray of two JSONStrings (called first and
second half in the following description). This will cause part extraction: for each such two-tuple, all extant parts of the score will be saved
individually, with filenames being composed by concatenating the first half, the name (title) of the part, and the second half. The resulting string
must be a valid filename (with extension, determining the output format). If a score has no parts (excerpts) defined, this will be silently ignored
without error.

Valid file extensions for output are:

flac
Free Lossless Audio Codec (compressed audio)

metajson
various score metadata (JSON)

mid
standard MIDI file

midi
standard MIDI file

mlog
internal file sanity check log (JSON)

mp3
MPEG Layer III (lossy compressed audio)

mpos
measure positions (XML)

mscx
uncompressed MuseScore file

mscz
compressed MuseScore file

musicxml
uncompressed MusicXML file

mxl
compressed MusicXML file

ogg
OGG Vorbis (lossy compressed audio)

pdf
portable document file (print)

png
portable network graphics (image) — Individual files, one per score page, with a hyphen-minus followed by the page number placed before the
file extension, will be generated.

spos
segment positions (XML)

svg
scalable vector graphics (image)

wav
RIFF Waveform (uncompressed audio)

xml
uncompressed MusicXML file

See below for an example.

ENVIRONMENT

SKIP_LIBJACK
Set this (the value does not matter) to skip initialization of the JACK Audio Connection Kit library, in case it causes trouble.

XDG_CONFIG_HOME
User configuration location; defaults to ~/.config if unset.

XDG_DATA_HOME
User data location; defaults to ~/.local/share if unset.

Note that MuseScore also supports the normal Qt environment variables such as QT_QPA_GENERIC_PLUGINS, QT_QPA_PLATFORM, QT_QPA_PLATFORMTHEME,
QT_QPA_PLATFORM_PLUGIN_PATH, QT_STYLE_OVERRIDE, DISPLAY, etc.

http://doc.qt.io/qt-5/qguiapplication.html#supported-command-line-options
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FILES

/usr/share/mscore-4.0/ contains the application support data (demos, instruments, localization, system-wide plugins, soundfonts, styles, chords,
templates and wallpapers). In the Debian packages, system-wide soundfonts are installed into /usr/share/sounds/sf2/, /usr/share/sounds/sf3/ or
/usr/share/sounds/sfz/, respectively, instead.

The per-user data (extensions, plugins, soundfonts, styles, templates) and files (images, scores) are normally installed into subdirectories under
~/MuseScore4/ but may be changed in the configuration. Note that snapshot, alpha and beta versions use MuseScore4Development instead of MuseScore4 in
all of these paths.

$XDG_CONFIG_HOME/MuseScore/MuseScore4.ini contains the user preferences, list of recently used files and their locations, window sizes and positions, etc.
See above for development version paths.

$XDG_DATA_HOME/data/MuseScore/MuseScore4/ contains updated localization files downloaded from within the program, plugin information, cached scores,
credentials for the musescore.com community site, session information, synthesizer settings, custom key and time signatures and shortcuts. See above
for development version paths.

EXAMPLES

Convert a score to PDF from the command line

mscore -o 'My Score.pdf' 'My Score.mscz'

Run a batch job converting multiple documents

mscore -j job.json

This requires assumes a file job.json exists in the current working directory with content similar to the following:

[
    {
        "in": "MyScore1.mscz",
        "out": "MyScore1.pdf"
    },
    {
        "in": "MyScore2.mscz",
        "plugin": "colornotes.qml",
        "out": [
            "MyScore2-notecolors.pdf",
            "MyScore2-notecolors.svg"
        ]
    },
    {
        "in": "MyScore3.mscz",
        "out": [
            "MyScore3.pdf",
            "MyScore3.musicxml",
            "MyScore3.mid",
            [
                "MyScore3 (",
                " part).pdf"
            ]
        ]
    }
]

If MyScore3.mscz contains excerpts (instrumental parts) then the syntax above would cause files like “MyScore3 (Violin part).pdf” to be generated
alongside the conductor’s PDF and MusicXML files, as well as a MIDI file with the full orchestral sound. If MyScore3.mscz has no excerpts defined then
only the conductor’s PDF, MusicXML, and orchestral MIDI files will be generated, while the request for part PDFs is silently ignored.

MIDI import operations

The attached midi_import_options.xml  is a sample MIDI import operations file for the -M option.

DIAGNOSTICS

The mscore utility exits 0 on success, and >0 if an error occurs.

SEE ALSO

fluidsynth(1), midicsv(1), timidity(1), qtoptions(7)

https://musescore.org/handbook

Online Handbook, full user manual

https://musescore.org/forum

Support Forum

https://musescore.org/en/node/278582

Reverting to factory settings (troubleshooting)

https://github.com/musescore/MuseScore/issues

https://musescore.org/sites/musescore.org/files/midi_import_options_0.xml
https://musescore.org/handbook
https://musescore.org/forum
https://musescore.org/en/node/278582
https://github.com/musescore/MuseScore/issues
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Project Issue Tracker — Please check first to if the bug you’re encountering has already been reported. If you just need help with something, then
please use the support forum  instead.

http://doc.qt.io/qt-5/qguiapplication.html#supported-command-line-optio…

Documentation of automatic Qt command line options

STANDARDS

MuseScore attempts to implement the following standards:

MusicXML 3.1 (score interchange format)
SF2 (SoundFont 2.01)
SF3 (SoundFont with OGG Vorbis-compressed samples)
SFZ (Sforzato soundfont)
SMuFL (Standard Music Font Layout 1.20)

HISTORY

MuseScore was split off the MusE sequencer in 2002 and has since become the foremost Open Source notation software.

AUTHORS

MuseScore is developed by MuseScore BVBA and others.

This manual page was written by mirabilos <tg@debian.org >.

CAVEATS

The automatic Qt command line options are removed from the argument vector before the application has a chance at option processing; this means that
an invocation like mscore -S -reverse has no chance at working because the -reverse is removed by Qt first.

BUGS

MuseScore does not honor /etc/papersize.

Probably some more; check the project’s bug tracker (cf. SEE ALSO).

All keyboard shortcuts

On macOS, make the following substitutions:

Replace Ctrl with Cmd (or ⌘)
Replace Alt with Option (or ⌥)
Replace Home with Fn+Left
Replace End with Fn+Right
Replace PgUp with Fn+Up
Replace PgDn with Fn+Down
Add Fn with function keys

Keyboard Map
Click for full resolution. Print Friendly PDF version

Navigation

https://musescore.org/forum
http://doc.qt.io/qt-5/qguiapplication.html#supported-command-line-options
mailto:tg@debian.org
https://musescore.org/en/print/book/export/html/329209?toc=1#undefined-SEE_ALSO
https://musescore.org/sites/musescore.org/files/2022-11/MuseScore4-Keyboard-Shortcuts-v1.0-toPRINT-black-white.pdf
https://musescore.org/sites/musescore.org/files/2023-05/MuseScore4-Keyboard-Shortcuts-v1.0-3840x2160_0.png
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Page navigation

Action Windows/Linux macOS
Zoom in Ctrl+= Cmd+=
Zoom out Ctrl+- Cmd+-
Zoom to 100% Ctrl+0 Cmd+0
Go to first element in score Ctrl+Home Cmd+Fn+Left
Go to last element in score Ctrl+End Cmd+Fn+Right
Jump to next screen PgUp Fn+Up
Jump to previous screen PgDn Fn+Down
Jump to top of first page Home Fn+Left
Jump to bottom of last page End Fn+Right
Jump to next page Ctrl+PgUp Cmd+Fn+Up
Jump to previous page Ctrl+PgDn Cmd+Fn+Down
Find / Go to Ctrl+F Cmd+F
Accessibility: get location Shift+L Shift+L
Show/hide timeline F12 Fn+F12

Score navigation

Action Windows/Linux macOS
Select next chord Right Right
Select previous chord Left Left
Go to next measure Ctrl+Right Cmd+Right
Go to previous measure Ctrl+Left Cmd+Left
Select next element in score Alt+Right Option+Right
Select previous element in score Alt+Left Option+Left
Select next in-staff element Ctrl+Alt+Shift+Right Cmd+Option+Shift+Right
Select previous in-staff element Ctrl+Alt+Shift+Left Cmd+Option+Shift+Left
Select note/rest above Alt+Up Option+Up
Select note/rest below Alt+Down Option+Down
Select top note in chord Ctrl+Alt+Up Cmd+Option+Up
Select bottom note in chord Ctrl+Alt+Down Cmd+Option+Down
Go to top staff Alt+Shift+Up Option+Shift+Up
Go to bottom staff Alt+Shift+Down Option+Shift+Down

Note input
General

Action Windows/Linux macOS
Note input: toggle note input mode N N
Note input: toggle 're-pitch existing notes' mode Ctrl+Shift+I Cmd+Shift+I
Note input: toggle 'insert' mode Ctrl+I Cmd+I
Show/hide piano keyboard P P
Use voice 1 Ctrl+Alt+1 Cmd+Option+1
Use voice 2 Ctrl+Alt+2 Cmd+Option+2
Use voice 3 Ctrl+Alt+3 Cmd+Option+3
Use voice 4 Ctrl+Alt+4 Cmd+Option+4

Duration

Action Windows/Linux macOS
Set duration 1 – 9 1 – 9
Set duration: 64th note 1 1
Set duration: 32nd note 2 2
Set duration: 16th note 3 3
Set duration: 8th note 4 4
Set duration: quarter note 5 5
Set duration: half note 6 6
Set duration: whole note 7 7
Set duration: double whole note 8 8
Set duration: longa 9 9
Toggle duration dot . .
Enter tuplet Ctrl+2 – Ctrl+9 Cmd+2 – Cmd+9
Enter tuplet: duplet Ctrl+2 Cmd+2
Enter tuplet: triplet Ctrl+3 Cmd+3
Enter tuplet: quadruplet Ctrl+4 Cmd+4
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Enter tuplet: quintuplet Ctrl+5 Cmd+5
Enter tuplet: sextuplet Ctrl+6 Cmd+6
Enter tuplet: septuplet Ctrl+7 Cmd+7
Enter tuplet: octuplet Ctrl+8 Cmd+8
Enter tuplet: nonuplet Ctrl+9 Cmd+9
Add tied note T T
Halve selected duration Q Q
Double selected duration W W
Halve selected duration (includes dotted values) Shift+Q Shift+Q
Double select duration (includes dotted values) Shift+W Shift+W
Insert full measure rest Ctrl+Shift+Del Cmd+Shift+Del

Pitch

Action Windows/Linux macOS
Enter note A – G A – G
Enter note A A A
Enter note B B B
Enter note C C C
Enter note D D D
Enter note E E E
Enter note F F F
Enter note G G G
Add note to chord Shift+A – Shift+G Shift+A – Shift+G
Add note A to chord Shift+A Shift+A
Add note B to chord Shift+B Shift+B
Add note C to chord Shift+C Shift+C
Add note D to chord Shift+D Shift+D
Add note E to chord Shift+E Shift+E
Add note F to chord Shift+F Shift+F
Add note G to chord Shift+G Shift+G
Enter interval Alt+1 – Alt+9 Option+1 – Option+9
Enter interval: unison Alt+1 Option+1
Enter interval: second above Alt+2 Option+2
Enter interval: third above Alt+3 Option+3
Enter interval: fourth above Alt+4 Option+4
Enter interval: fifth above Alt+5 Option+5
Enter interval: sixth above Alt+6 Option+6
Enter interval: seventh above Alt+7 Option+7
Enter interval: octave above Alt+8 Option+8
Enter interval: ninth above Alt+9 Option+9
Toggle accidental: flat - -
Toggle accidental: natural = =
Toggle accidental: sharp + +
Enter rest 0 0
Add grace note: acciaccatura / /

Tablature

Action Windows/Linux macOS
Set duration (TAB) Shift+0 – Shift+9 Shift+0 – Shift+9
Set duration: 128th note (TAB) Shift+0 Shift+0
Set duration: 64th note (TAB) Shift+1 Shift+1
Set duration: 32nd note (TAB) Shift+2 Shift+2
Set duration: 16th note (TAB) Shift+3 Shift+3
Set duration: 8th note (TAB) Shift+4 Shift+4
Set duration: quarter note (TAB) Shift+5 Shift+5
Set duration: half note (TAB) Shift+6 Shift+6
Set duration: whole note (TAB) Shift+7 Shift+7
Enter TAB: fret 0 – 9 0 – 9
Enter TAB: fret A – K A – K
Enter TAB: fret 0 0 0
Enter TAB: fret 1 1 1
Enter TAB: fret 2 2 2

Enter TAB: fret 3 3 3
Enter TAB: fret 4 4 4
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Enter TAB: fret 5 5 5
Enter TAB: fret 6 6 6
Enter TAB: fret 7 7 7
Enter TAB: fret 8 8 8
Enter TAB: fret 9 9 9
Enter TAB: fret 0 A A
Enter TAB: fret 1 B B
Enter TAB: fret 2 C C
Enter TAB: fret 3 D D
Enter TAB: fret 4 E E
Enter TAB: fret 5 F F
Enter TAB: fret 6 G G
Enter TAB: fret 7 H H
Enter TAB: fret 8 J J
Enter TAB: fret 9 K K
Go to string above (TAB) Up Up
Go to string below (TAB) Down Down
Toggle ghost note Shift+X Shift+X

Selecting
Action Windows/Linux macOS

Select all Ctrl+A Cmd+A
Add to selection: previous note/rest Shift+Left Shift+Left
Add to selection: next note/rest Shift+Right Shift+Right
Add to selection: staff above Shift+Up Shift+Up
Add to selection: staff below Shift+Down Shift+Down
Select to beginning of measure Ctrl+Shift+Left Cmd+Shift+Left
Select to end of measure Ctrl+Shift+Right Cmd+Shift+Right
Select to beginning of line Shift+Home Shift+Fn+Left
Select to end of line Shift+End Shift+Fn+Right
Select to beginning of score Ctrl+Shift+Home Cmd+Shift+Fn+Left
Select to end of score Ctrl+Shift+End Cmd+Shift+Fn+Right

Editing
General

Action Windows/Linux macOS
Escape Esc Esc
Undo Ctrl+Z Cmd+Z
Redo Ctrl+Shift+Z Cmd+Shift+Z
Copy Ctrl+C Cmd+C
Cut Ctrl+X Cmd+X
Paste Ctrl+V Cmd+V
Copy/paste: swap with clipboard Ctrl+Shift+X Cmd+Shift+X
Repeat selection R R
Insert one measure before selection Ins Ins
Insert measures before selection Ctrl+Ins Cmd+Ins
Insert one measure at end of score Ctrl+B Cmd+B
Insert measures at end of score Alt+Shift+B Option+Shift+B
Delete Del Del
Delete selected measures Ctrl+Del Cmd+Del
Show/hide properties F8 Fn+F8
Edit element F2 Fn+F2
Move chord/rest left Shift+Left Shift+Left
Move chord/rest right Shift+Right Shift+Right

Duration

Action Windows/Linux macOS
Set duration 1 – 9 1 – 9
Enter tuplet Ctrl+2 – Ctrl+9 Cmd+2 – Cmd+9
Add tied note T T
Halve selected duration Q Q
Double select duration W W
Halve selected duration (includes dotted values) Shift+Q Shift+Q
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Double selected duration (includes dotted
values) Shift+W Shift+W

Paste half duration Ctrl+Shift+Q Cmd+Shift+Q
Paste double duration Ctrl+Shift+W Cmd+Shift+W
Insert full measure rest Ctrl+Shift+Del Cmd+Shift+Del

Pitch

Action Windows/Linux macOS
Toggle accidental: flat - -
Toggle accidental: natural = =
Toggle accidental: sharp + +
Move pitch/selection up Up Up
Move pitch/selection down Down Down
Move pitch up an octave Ctrl+Up Cmd+Up
Move pitch down an octave Ctrl+Down Cmd+Down
Move pitch up diatonically Alt+Shift+Up Option+Shift+Up
Move pitch down diatonically Alt+Shift+Down Option+Shift+Down
Change enharmonic spelling (concert and written
pitch) J J

Change enharmonic spelling (current pitch only) Ctrl+J Cmd+J
Move note to higher string (TAB) Ctrl+Up Cmd+Up
Move note to lower string (TAB) Ctrl+Down Cmd+Down
Toggle ghost note (TAB) Shift+X Shift+X

Notation

Action Windows/Linux macOS
Flip direction X X
Mirror notehead Shift+X Shift+X
Use voice 1 Ctrl+Alt+1 Cmd+Option+1
Use voice 2 Ctrl+Alt+2 Cmd+Option+2
Use voice 3 Ctrl+Alt+3 Cmd+Option+3
Use voice 4 Ctrl+Alt+4 Cmd+Option+4
Move selected note/rest to staff above Ctrl+Shift+Up Cmd+Shift+Up
Move selected note/rest to staff below Ctrl+Shift+Down Cmd+Shift+Down
Toggle multimeasure rest M M

Manual adjustment

Action Windows/Linux macOS
Move text left Left Left
Move text right Right Right
Move text left quickly Ctrl+Left Cmd+Left
Move text right quickly Ctrl+Right Cmd+Right
Move selection up Up Up
Move selection down Down Down
Move selection up quickly Ctrl+Up Cmd+Up
Move selection down quickly Ctrl+Down Cmd+Down

Text
General

Action Windows/Linux macOS
Add text: staff text Ctrl+T Cmd+T
Add text: expression text Ctrl+E Cmd+E
Add text: system text Ctrl+Shift+T Cmd+Shift+T
Add text: tempo marking Alt+Shift+T Option+Shift+T
Add text: rehearsal mark Ctrl+M Cmd+M
Insert special characters Shift+F2 Shift+Fn+F2

Formatting

Action Windows/Linux macOS
Format text: bold face Ctrl+B Cmd+B
Format text: italic Ctrl+I Cmd+I
Format text: underline Ctrl+U Cmd+U
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Insert flat Ctrl+Shift+B Cmd+Shift+B
Insert natural Ctrl+Shift+H Cmd+Shift+H
Insert sharp Ctrl+Shift+# Cmd+Shift+#
Insert dynamics p Ctrl+Shift+P Cmd+Shift+P
Insert dynamics m Ctrl+Shift+M Cmd+Shift+M
Insert dynamics f Ctrl+Shift+F Cmd+Shift+F
Insert dynamics n Ctrl+Shift+N Cmd+Shift+N
Insert dynamics r Ctrl+Shift+R Cmd+Shift+R
Insert dynamics s Ctrl+Shift+S Cmd+Shift+S
Insert dynamics z Ctrl+Shift+Z Cmd+Shift+Z

Lyrics

Action Windows/Linux macOS
Add text: lyrics Ctrl+L Cmd+L
Go to next syllable Space Space
Go to previous syllable Shift+Space Shift+Space
Lyrics: enter hyphen - -
Lyrics: enter melisma _ _
Add lyric verse Return Return
Go to next lyric verse Down Down
Go to previous lyric verse Up Up

Chord symbols, Roman numeral analysis, Nashville numbers, figured bass

Action Windows/Linux macOS
Add text: chord symbol Ctrl+K Cmd+K
Add text: figured bass Ctrl+G Cmd+G
Next text element Space Space
Previous text element Shift+Space Shift+Space
Advance cursor: next beat ; ;
Advance cursor: previous beat Shift+; Shift+;
Advance cursor: duration Ctrl+1 – Ctrl+9 Cmd+1 – Cmd+9

Other score elements
Action Windows/Linux macOS

Show/hide palettes F9 Fn+F9
Search palettes Ctrl+F9 Cmd+Fn+F9
Open master palette Shift+F9 Shift+Fn+F9
Add slur S S
Add articulation: accent Shift+V Shift+V
Add articulation: marcato Shift+O Shift+O
Add articulation: staccato Shift+S Shift+S
Add articulation: tenuto Shift+N Shift+N
Add hairpin: crescendo < <
Add hairpin: decrescendo > >
Add parentheses to element ( (

Score setup and formatting
Action Windows/Linux macOS

Add/remove instruments I I
Open instruments dialog F7 Fn+F7
Toggle visibility of elements V V
Decrease layout stretch { {
Increase layout stretch } }
Add/remove system break Return Return
Add/remove page break Ctrl+Return Cmd+Return
Reset shapes and positions Ctrl+R Cmd+R

File Operations
Action Windows/Linux macOS

New Ctrl+N Cmd+N
Open Ctrl+O Cmd+O
Close Ctrl+W Cmd+W
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Save Ctrl+S Cmd+S
Save as Ctrl+Shift+S Cmd+Shift+S
Print Ctrl+P Cmd+P
Quit Ctrl+Q Cmd+Q

User interface
Playback

Action Windows/Linux macOS
Play Space Space
Show/hide mixer F10 Fn+F10

Accessibility

Action Windows/Linux macOS
Next UI group Tab Tab
Previous UI group Shift+Tab Shift+Tab
Next UI pane/window F6 Fn+F6
Previous UI pane/window Shift+F6 Shift+Fn+F6

Other

Action Windows/Linux macOS
Multiinstances Ctrl+F3 Cmd+Fn+F3
Full screen F11 Fn+F11

Known incompatibilities

Upgrade from MuseScore 3.x

Overview

Important Differences Between MuseScore 3 & MuseScore 4

Keyboard Shortcuts
See All keyboard shortcuts for MuseScore 4. Here are the common ones that have changed or are entirely new:

Action MuseScore 3 MuseScore 4
Add tied note + T
Next Measure (Chord Symbol Entry) Tab Ctrl/Cmd+→
Previous Measure (Chord Symbol Entry) Shift+Tab Ctrl/Cmd+←
Toggle accidental: flat None -
Toggle accidental: natural None =
Toggle accidental: sharp None +
Edit element Alt+Shift+E F2 or Alt+Shift+E
Insert special characters... F2 Shift+F2
Jump to next UI pane None F6 or ` (backtick / grave accent)
Jump to previous UI pane None Shift+F6 or Shift+`
Show / hide selection filter F6 None

Other changes

https://www.youtube.com/watch?v=qM1CcIRzJHE
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What used to be the Inspector  in MuseScore 3 is the Properties tab in MuseScore 4.
The tool to switch between page view and continuous view is now at the bottom right of the MuseScore window.
Same for the Zoom control.
Same for the Concert pitch toggle.
To (temporarily) change the playback speed you now need to undock the Play Panel.
The "Toggle MIDI" button now is behind the Play Panel's cog wheel.
Fermata is now in the Breaths & Pauses palette
Hiding an instrument now mutes it by default. However, you can now hide the individual staves of the instrument, which is more flexible.
The Text tool  is now in the Text Properties, partly 'hidden' behind the __More__ botton.

Missing Features
Due to the nature of the upgrade some features previously present in MuseScore 3 have not (yet) been included. See this page  in the developers'
handbook  for a listing of those items.

Upgrade from MuseScore 2.x or 1.x

Handbook for MuseScore 3.x

Handbook for MuseScore 2.x

Handbook for MuseScore 1.x

Glossary

The list below is a glossary of frequently used terms in MuseScore as well as their meaning. The differences between American English and British
English are marked with "(AE)" and "(BE)", respectively.

A

Acciaccatura

 A short grace note which appears as a small note with a stroke through the stem. It is quickly executed and technically takes no value from
its associated note.

Accidental
A sign appearing in front of a note that raises or lowers its pitch. The most common accidentals are sharps, flats or naturals, but double sharps
and double flats are also used. Also koron, and sori and other quarter tone or microtonal accidentals. Accidentals affect all notes on the same
staff position only for the remainder of the measure in which they occur, but they can be canceled by another accidental. In notes tied across a
barline, the accidental continues across the barline to the tied note, but not to later untied notes on the same staff position in that measure.

Ambitus
Note (or vocal) range used in a staff. Used particularly in early music.

Anacrusis (mostly BE)
See Pickup measure.

Anchor
The point of attachment to the score of objects such as Text and Lines: When the object is dragged, the anchor appears as small brown circle
connected to the object by a dotted line. Depending on the object selected, its anchor may be attached to either (a) a note (e.g. fingering), (b) a
staff line (e.g. staff text), or (c) a barline (e.g. repeats).

Appoggiatura
A long grace note which takes value from its associated note. Its functions include: passing tone, anticipation, struck suspension, and escape
tone.

Arpeggio
An arpeggio tells the performer to break up the chord into the constituent notes, playing them separately and one after the other. An arrow on
the arpeggio indicates the direction in which the player should play the notes of the chord.

Articulation
A marking or symbol indicating how a note should be played, usually by altering the length of a note or shaping its attack and decay.

B

Bar (BE)
See measure.

Barline
Vertical line through a staff, staves, or a full system that separates measures.

Beam
Notes with a duration of an eighth or shorter either carry a flag or a beam. Beams are used for grouping notes.

BPM
Beats Per Minute is the unit for measuring tempo, traditionally counted in quarter note durations. See metronome mark

Breve
Brevis

A double whole note or breve is a note that has the duration of two whole notes.

C

Caesura

https://musescore.org/node/278642
https://musescore.org/en/print/book/export/html/329209?toc=1#node-330537-views
https://musescore.org/en/print/book/export/html/329209?toc=1#node-330537-status-bar
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329716-transposing-instruments
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329738-play-position-and-tempo
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329738-other-commands
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329665-instrument-settings
https://musescore.org/node/278590#text-edit-mode
https://musescore.org/node/334701
https://musescore.org/node/76
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329660-accidentals
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A caesura (//) is a brief, silent pause. Time is not counted for this period, and music resumes when the director signals.

Cent
An interval equal to one hundredth of a semitone.

Chord
A group of two or more notes sounding together. To select a chord in MuseScore, press Shift and click on a note.

Clef
Sign at the beginning of a staff](#staff), used to tell which are the musical notes on the lines and in the spaces.
Some transposing instruments make use of octave transposing clefs or have different clefs in concert pitch vs. transposing pitch.
See also Courtesy clef.

Concert pitch
1. The sounding, or real pitch of a note—as opposed to the written pitch. See Working with transposing instruments.
2. A score viewing mode in Musescore, see Concert pitch box in the status bar.
3. The frequency of A4.

Courtesy clef
A reduced-size clef applied to the end of a system indicating a clef change at the start of the next system.

Cross-staff notation
A musical phrase extending across two neighboring staffs: e.g. bass staff and treble staff.

To notate , see Cross-staff notation.

To notate , see How to span a chord or stem over two staves .
Crotchet (BE)

See Quarter note.

D

Double Flat
A double flat (♭♭ or !) is a sign that indicates that the pitch of a note has to be lowered two semitones.

Double Sharp
A double sharp (♯♯ or ") is a sign that indicates that the pitch of a note has to be raised two semitones.

Demisemiquaver (BE)
A thirty-second note.

Duplet
See tuplet.

Dynamic
A symbol indicating the relative loudness of a note or phrase of music—such as mf (mezzoforte), p (piano), f (forte) etc., starting at that note.

E

Edit mode
The program mode in which you can either edit text in text objects; or which allows you to move non-text objects with the keyboard arrows
(where this is disallowed in normal mode). There are a number of ways to enter this mode, after clicking on the desired object: (1) Double-click
(text only); (2) Press F2 or Alt+Shift+E; (3) Right-click and choose "Edit element".

Eighth note
A note whose duration is an eighth of a whole note (semibreve). Same as a quaver (BE).

Endecalineo

Endecalineo or endecagram, the stave for Solfège. See Solmisation  (tutorial for MuseScore 3, pending update)
Endings

See volta.
Enharmonic notes

Notes that sound the same pitch but are written differently. Example: G♯ and A♭ are enharmonic notes. To quickly switch between enharmonic
spellings, press J.

Explode

https://musescore.org/en/print/book/export/html/329209?toc=1#node-329716-transposing-instruments
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329716-transposed-concert-pitch
https://musescore.org/en/node/8717
https://musescore.org/en/node/318182
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A feature that allows the user to split (or explode) the chords in a passage of music in a single staff into their constituent notes or voices. See
Implode and explode.
See also, Implode

F

Flag
See beam.

Flat
Sign (♭) that indicates that the pitch of a note has to be lowered one semitone.

French Beam

Beams where the stems only extend to the first beam, but don't intersect all the way through. To create use the French Beams  plugin.

G

Grace note
Grace notes appear as small notes in front of a normal-sized main note. See acciaccatura and appoggiatura.

Grand Staff (AE)
Great Stave (BE)

An instrument or part with two or more staves, featuring treble and bass clefs, used to notate music for keyboard instruments and the harp.

H

Half Note
A note whose duration is half of a whole note (semibreve). Same as a minim (BE).

Hemidemisemiquaver (BE)
A sixty-fourth note.

I

Implode

A feature allowing the user to combine voices from separate staves onto one staff. See Implode and explode. This is similar to, but not exactly,
score reduction (wikipedia ).
See also, Explode

Interval
The difference in pitch between two notes, expressed in terms of the scale degree (e.g. major second, minor third, perfect fifth etc.). See Degree
(Music)  (Wikipedia).

Interleaved

 A term used to describe two interlocking, oppositely-beamed sets of notes. To create, use the voice function and the beam
palette. See Interleaved beam directions

J

Jump

https://musescore.org/en/node/350614
https://en.wikipedia.org/wiki/Reduction_(music)
https://en.wikipedia.org/wiki/Degree_(music)
https://musescore.org/en/node/314469#comment-1047136
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In MuseScore, "jumps" are notations such as "D.S. al Coda", found in the "Repeats & Jumps" palette.

K

Key Signature
Set of sharps or flats at the beginning of the staves. It gives an idea about the tonality and avoids repeating those signs all along the staff.
A key signature with B flat means F major or D minor tonality.

Koron
An Iranian accidental which lowers the pitch of a note by a quarter tone (in comparison to the flat which lowers a note by a semitone). It is
possible to use this accidental in a key signature.
See also Sori.

L

Legato
Legato is a play style which involves playing the notes in a slurred manner. Legato may be written as text or shown through the use of slurs.

Local time signature

The time signature on a single staff when different from the overall score time signature. See Adding a local time signature for a single staff.
Longa

A longa is a quadruple whole note.
Ledger Line (AE)
Leger Line (BE)

Line(s) that are added with and for notes above or below the staff.

M

Measure (AE)
A segment of time defined by a given number of beats. Dividing music into measures provides regular reference points to pinpoint locations
within a piece of music. Same as bar (BE).

Metronome mark
Metronome marks are usually given by a note length equaling a certain playback speed in BPM. In MuseScore, metronome marks are used in
Tempo markings.

Minim (BE)
See Half note.

N

Natural
A natural (♮) is a sign that cancels a previous alteration on notes of the same pitch.

Normal mode
The operating mode of MuseScore outside note input mode or edit mode: press Esc to enter it. In Normal mode you can navigate through the
score, select and move elements, adjust Inspector properties, and alter the pitches of existing notes.

Note input mode
The program mode used for entering music notation. Enter it by pressing N or clicking on the pen icon in the note input toolbar.

O

Operating System (OS)
Underlying software that controls and manages the hardware and other software on a computer. Popular OSes are Microsoft Windows, macOS,
and GNU/Linux.

Ossia

An alternative passage which may be played instead of the original passage (from the Italian for "alternatively", meaning "or be it").

P

Part
1. In MuseScore, the music notation for an individual instrument staff extracted from the main score. See Parts.
2. A single melody line in a polyphonic musical composition. MuseScore 4 never uses this definition, but there is a similar feature Voice.
3. Instrument(s) or their staves. MuseScore 4 never uses this definition.

Pickup Measure (mostly AE, also known as an Anacrusis (mostly BE) or Upbeat)
Incomplete first measure of a piece or a section of a piece of music. See Measure duration and Create new score: Pickup measure and also
Exclude from measure count. May or may not be compensated for at the end of the score or section.

Q

Quadruplet
See tuplet.

Quarter note

https://musescore.org/en/print/book/export/html/329209?toc=1#node-329680-Adding_a_local_time_signature_for_a_single_staff
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329660-accidentals
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329660-Entering_note_input_mode
https://musescore.org/en/print/book/export/html/329209?toc=1#node-330546-Ossia
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A note whose duration is a quarter of a whole note (semibreve). Same as a crotchet (BE).
Quaver (BE)

See eighth note.
Quintuplet

See tuplet.

R

Respell Pitches
Tries to guess the right accidentals for the whole score (see Accidental).

Rest
Interval of silence of a specified duration.

Re-pitch mode
Allows you to rewrite an existing passage of music by changing the note pitches without altering the rhythm.

S

Section
In MuseScore, a region of the score between section breaks; also from the start of a score to the first section break, and from the last section
break to the end of the score.

Semibreve (BE)
A whole note (AE). It lasts a whole measure in 4/4 time.

Semiquaver (BE)
A sixteenth note.

Semihemidemisemiquaver (Quasihemidemisemiquaver) (BE)
A hundred and twenty eighth note.

Sextuplet
See tuplet.

SF2
A virtual instrument format developed by E-mu Systems and Creative Labs. See SoundFonts.

SF3
An invention of Werner Schweer, the Musescore developer (source ). This format supports sound sample compression. See SoundFonts.

Shared note head

 A single notehead with two beams—one up, one down. Especially common in guitar music, for example. See Noteheads
Sharp

Sign (♯) that indicates that the pitch of a note has to be raised one semitone.
Slash chord

See Slash chord  (Wikipedia).
Slash notation

A form of music notation using slash marks placed on or above/below the staff to indicate the rhythm of an accompaniment: often found in
association with chord symbols. There are two types: (1) Slash notation consists of a rhythm slash on each beat: the exact interpretation is left to
the player (see Fill with slashes); (2) Rhythmic slash notation indicates the precise rhythm for the accompaniment (see Toggle rhythmic slash
notation).

Slur
A curved line over or under two or more notes, meaning that the notes will be played smooth and connected (legato).
See also tie.

Solmisation
see Endecalineo

Sori
An Iranian accidental which raises the pitch of a note by a quarter tone (in comparison to the sharp which raises it by a semitone). It is possible
to use this accidental in a key signature.
See also Koron.

SoundFont
A virtual instrument format supported by MuseScore. A SoundFont is a special type of file (extension .sf2, or .sf3 if compressed) containing
sound samples of one or more musical instruments. In effect, a virtual synthesizer which acts as a sound source for MIDI files. MuseScore 4
comes with its own native soundfont, MS Basic.

Spatium (plural: Spatia) / Space / Staff Space / sp. (abbr./unit)
The distance between the midpoints of two lines of a music staff (or one-quarter the size of the full five-line staff, assuming a hypothetical staff
line thickness of 0). The sizes of most elements in the score are based on this setting (see Page settings).

Staff / Staffs
A set of lines and spaces, each representing a pitch, on which music is written. In period music notation (before 11th century) the staff may have
any number of lines.

Staff Space
See Spatium (above).

Stave / Staves (BE)
See Staff (above).

Step-time input
MuseScore's default note input mode, allowing you to enter music notation one note (or rest) at a time.

System
Set of staves to be read simultaneously in a score.
See also Operating System (OS).

T

Tie

A curved line between two adjacent notes of the same pitch to indicate a single note of combined duration:

https://musescore.org/en/print/book/export/html/329209?toc=1#node-329660-accidentals
https://musescore.org/en/print/book/export/html/329209?toc=1#node-330535-re-pitch
https://musescore.org/en/node/151611#comment-618066
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329689-shared-noteheads
https://en.wikipedia.org/wiki/Slash_chord
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329684-create-beat-slashes
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329684-rhythmic-slash-notation
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329732-staff-size
https://musescore.org/en/print/book/export/html/329209?toc=1#node-329660-ties
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Quarter note + Tie + Quarter note = Half note
Quarter note + Tie + Eighth note = Dotted Quarter note
Quarter note + Tie + Eighth note + Tie + 16th note = Double Dotted Quarter note
See also slur.

Transposition

The act of moving the pitches of one or more notes up or down by a constant interval. There may be several reasons for transposing a piece, for
example:

The tune is too low or too high for a singer. In this case the whole orchestra will have to be transposed as well—easily done using
MuseScore.
The part is written for a particular instrument but needs to be played by a different one.
The score is written for an orchestra and you want to hear what the individual instruments sound like. This requires changing the
transposing instrument parts to concert pitch.
A darker or a more brilliant sound is desired.

Triplet
See tuplet.

Tuplet
A tuplet divides its next higher note value by a number of notes other than given by the time signature. For example a triplet divides the next
higher note value into three parts, rather than two. Tuplets may be: triplets, duplets, quintuplets, and other.

U

Upbeat
See pickup measure.

V

Velocity
The velocity property controls how loudly the note is played, from 0 (silent) to 127 (maximum). This usage of the term comes from MIDI Velocity:
on a keyboard instrument, it is the speed with which a key is pressed that controls its volume.

Voice
1. In Musescore, voice is a software feature, you can use up to 4 voices per staff, see Working with multiple voices, also see staff.
2. The musical term "voice" refers to a musical line or part which can have its own rhythm. MuseScore does not have a feature to implement the
exact same idea, if the voice feature does not suit your need, try adding separate instruments instead.

Volta
In a repeated section of music, it is common for the last few measures of the section to differ. Markings called voltas are used to indicate how
the section is to be ended each time. These markings are often referred to simply as endings.

W

Written pitch
Transposing instruments (such as the clarinet, French horn, trumpet etc.) are notated at a different pitch (and key signature) to how they sound.
The notated pitch is called the written pitch,

External links

http://www.robertcarney.net/musical-terms-definitions.htm
https://en.wikipedia.org/wiki/List_of_musical_symbols
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Engraving improvements

Cloud storage

Other changes

Create your first score

Entering score information

Entering notes

Adding items from the palettes

Making adjustments in Properties

Inserting and deleting measures

Exporting your score

Saving your score

Viewing and navigation
Accessibility

Setup

Windows
NVDA
JAWS
Narrator

macOS
Linux

Working with the user interface

Working with your score

The user interface

Menu bar

Home tab

My account
Scores
Plugins
Learn

Score tab

Publish tab

Navigating your score

Scrolling

Mouse wheel
Scrollbars
Keyboard

Element navigation

Navigator

Timeline

Views

Page view
Continuous view (horizontal)
Continuous view (vertical)

Zoom

Zoom in

https://musescore.org/en/handbook/4/create-your-first-score
https://musescore.org/en/handbook/4/accessibility
https://musescore.org/en/handbook/4/user-interface
https://musescore.org/en/handbook/4/navigating-your-score
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Zoom out
Status bar zoom controls
Restoring 100% zoom

Find/Go to

Navigating to a numbered measure
Navigating to a numbered page
Navigating to a numerical rehearsal mark
Navigating to an alphabetic rehearsal mark

Timeline

Overview

Meta labels
Instrument labels
Meta rows
Main grid

Meta elements

Basic interactions

Selecting a measure
Selecting multiple measures

Drag selection
[Shift] selection
[Ctrl] selection

Clearing a selection
Meta values selection

Scrolling

Standard scrolling
[Shift] scrolling
[Alt] scrolling
Dragging

Labels interaction

Rearranging meta labels
Collapsing the meta labels
Hiding instruments

Zooming

Context menus

Meta labels context menu
Meta rows context menu
Instrument context menu

Basics
Setting up your score

Overview

Instruments

Choose instruments
Adding instruments
Changing order of instruments
Removing instruments

Create from template

Additional score information

Key signature
Time signature
Tempo
Measures
Title and other text

Changing instruments after score creation

https://musescore.org/en/handbook/4/timeline
https://musescore.org/en/handbook/4/setting-your-score
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Entering notes and rests

Overview

Entering notes

Selecting a start point
Entering note input mode
Selecting duration
Selecting pitch

Selecting pitch using the computer keyboard
Selecting pitch using the mouse
Selecting pitch using a MIDI keyboard
Selecting pitch using the virtual piano keyboard

Entering chords

Entering rests

Accidentals

Selecting an accidental before entering a pitch
Adding an accidental after entering a pitch
Adding courtesy/cautionary accidentals

Ties

See also

Working with multiple voices

Overview

Entering notes and rests in multiple voices

Editing notes and rests in multiple voices

Adjusting rests
Hiding or deleting rests
Positioning rests

Changing voice of existing notes
Combining voices into chords

See also

Alternative note input methods

Accessing alternative note input methods

Rhythm only

Re-pitch

Real-time

Real-time (metronome)
Real-time (foot pedal)

Real-time Advance shortcut

Insert

Adding and removing measures

Inserting measures

The Properties panel
Note input toolbar
Menu bar
Inserting measures with keyboard shortcuts

Deleting measures

Remove empty trailing measures

See also

Selecting elements

https://musescore.org/en/handbook/4/entering-notes-and-rests
https://musescore.org/en/handbook/4/working-multiple-voices
https://musescore.org/en/handbook/4/alternative-note-input-methods
https://musescore.org/en/handbook/4/adding-and-removing-measures
https://musescore.org/en/handbook/4/selecting-elements
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Selecting a single element

Notes
Chords
Overlapping elements

Selecting a list of individual elements

Selecting multiple elements manually
Selecting similar elements automatically

Selecting a range of measures and staves

Selecting a range by dragging
Selecting a range by clicking
Selecting a range using the keyboard
Special range selections

Excluding elements from a range selection

Editing notes and rests

Overview

Making changes in note input mode

Changing duration in note input mode
Changing pitch in note input mode
Replacing notes and rests in note input mode
Deleting notes in note input mode
Moving notes in note input mode

Making changes in normal mode

Changing duration in normal mode
Changing selected notes to a specific note value
Increasing or decreasing the duration of a selected note
Doubling or halving all note values in a range selection

Changing pitch in normal mode
Deleting notes and rests in normal mode
Removing notes and rests and their associated time
Adding ties in normal mode
Changing voice in normal mode

Moving selected notes into another voice
Exchanging the contents of two voices

See also

Copy and paste

Accessing the commands

Copying a range

Copying a single element or list of elements

Moving elements

Swapping a selection with the clipboard

Repeating a selection

Copying a selection to multiple staves

Paste half/double duration

Duplicating individual elements

See also

Using the palettes

Overview

Accessing the palettes panel

Adding palette items to your score

https://musescore.org/en/handbook/4/editing-notes-and-rests
https://musescore.org/en/handbook/4/copy-and-paste
https://musescore.org/en/handbook/4/using-palettes
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Items applied to individual score elements
Items applied to ranges
Items applied to full measures

Expanding and collapsing palettes

Searching and navigating the palettes

Search
Navigation

Accessing more palette items

Adding more palettes

See also

Properties panel

Accessing the Properties panel

Global settings

Show
Score appearance

General settings

Visible
Auto-place
Cue size

Playback settings

Appearance settings

Leading space
Measure width
Minimum distance
Offset
Snap to grid
Arrange
Color

Saving and restoring default settings

Adjusting elements directly

Changing the position of elements

Changing the shape of elements

Working with lines

Changing the range of a line
Creating diagonal lines
Editing line text

See also

Parts

Opening a part

Closing a part

Creating custom parts

Reveal instruments in default parts
Create a new part
Choose which voices appear in each part

Applying styles to parts

Renaming, duplicating and deleting parts

Exporting and printing parts

https://musescore.org/en/handbook/4/properties-panel
https://musescore.org/en/handbook/4/adjusting-elements-directly
https://musescore.org/en/handbook/4/parts
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Default keyboard shortcuts

Navigation

Page navigation
Score navigation

Note input

General
Duration
Pitch
Tablature

Selecting

Editing

General
Duration
Pitch
Notation
Manual adjustment

Text

General
Formatting
Lyrics
Chord symbols, Roman numeral analysis, Nashville numbers, figured bass

Other score elements

Score setup and formatting

File Operations

User interface

Playback

Notation: Instruments, staves, and systems
Working with instruments

Overview

Accessing the panel
Adding instruments
Deleting instruments
Changing the order of instruments

Instrument settings

Hiding/showing instruments
Renaming instruments
Replacing instruments

Adding and configuring staves

To add a staff to an existing instrument
To add a linked staff to an existing instrument
Configuring a staff

Showing staves only where needed

Hiding empty staves

Hiding all empty staves
Excluding specific staves from being hidden

Temporary staves

Cutaway staves

Ossia

https://musescore.org/en/handbook/4/default-keyboard-shortcuts
https://musescore.org/en/handbook/4/working-instruments
https://musescore.org/en/handbook/4/showing-staves-only-where-needed
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Other invisible measures

Implode and explode

Implode

Combine notes from multiple voices in a single staff into one voice
Combine notes from multiple staves into multiple voices on a single staff

Explode

Copy passage of single notes to multiple staves
Separate passage of chords into constituent notes

Mid-score instrument changes

Adding an instrument change

Working with instrument changes

Removing an instrument change
Re-labelling an instrument change
Instrument changes in the mixer
Changing staff type

Staff type change

Adding a staff type change

Setting staff properties

Staff/Part properties

Overview

Staff properties

Advanced style properties

Template (all staves)
Standard and Percussion staff options only
Tablature options only

Fret Marks tab
Note Values tab

Part properties

Instrument
Names
Usable pitch range
Transposition
Strings and frets

Brackets

Adding brackets

Editing brackets

Changing bracket type
Changing bracket span

Deleting brackets

Customizing bracket appearance

Notation: Rhythm, meter, and measures
Time signatures

Overview

Setting the initial time signature for your score

Adding a time signature change to your score

Deleting a time signature

https://musescore.org/en/handbook/4/implode-and-explode
https://musescore.org/en/handbook/4/mid-score-instrument-changes
https://musescore.org/en/handbook/4/staff-type-change
https://musescore.org/en/handbook/4/staffpart-properties
https://musescore.org/en/handbook/4/brackets
https://musescore.org/en/handbook/4/time-signatures
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Controlling the visibility of time signatures

Creating a custom time signature

Adding a local time signature for a single staff

Time signature properties

Appearance
Beam Groups

Time signature style

Stems and flags

Stem direction

Default stem direction
Flipping stem direction

Changing stem length

Creating stemless notes

Stem and flag properties

Stem and flag style

See also

Beams

Controlling which notes are beamed

Setting the default beaming for a time signature
Changing the beaming for selected notes

Controlling the appearance of beams

Changing the angle of a selected beam
Creating a feathered beam

Beam properties

Beam style

Regroup rhythms

Overview

Regrouping rhythms

See also

Tuplets

Creating tuplets

Simple tuplets
In note input mode
In normal mode
Consecutive tuplets

Custom tuplets
Nested tuplets

Changing the display of tuplets

Tuplet properties

Tuplet style

Barlines

Adding double and other special barlines

Changing barline type for all staves
Changing barline type for a single staff

https://musescore.org/en/handbook/4/stems-and-flags
https://musescore.org/en/handbook/4/beams
https://musescore.org/en/handbook/4/regroup-rhythms
https://musescore.org/en/handbook/4/tuplets
https://musescore.org/en/handbook/4/barlines
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Adding mid-measure barlines

Changing barline length

Extending all barlines in a staff
Extending selected barlines in a staff
Creating partial barlines
Creating barlines between staves only (Mensurstrich)

Barline properties

Barline style

See also

Measure numbering

Showing and hiding measure numbers

Showing measure numbers automatically
Showing measure numbers manually
Hiding measure numbers

Changing the measure number sequence

Excluding a measure from the count
Altering the numbering of a measure
Resetting measure numbering for a new section

Changing the position of measure numbers

Measure number properties

Measure number style

See also

Measure rests and multimeasure rests

Measure rest

Multimeasure rest

Enabling and disabling multimeasure rests
Breaking multimeasure rests
Multimeasure rest properties
Multimeasure rest style

See also

Pickup and non-metered measures

Creating a pickup measure

Specifying the pickup duration during score creation
Converting a measure into a pickup

Creating non-metered measures

Inserting notes and rests
Using a keyboard shortcut
Using Insert mode

Joining measures
Splitting a measure

See also

Measure properties

Opening and using the dialog

Staves

Measure duration

Other

https://musescore.org/en/handbook/4/measure-numbering
https://musescore.org/en/handbook/4/measure-rests-and-multimeasure-rests
https://musescore.org/en/handbook/4/pickup-and-non-metered-measures
https://musescore.org/en/handbook/4/measure-properties
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See also

Notation: Pitch
Clefs

Setting the initial clef for a staff

Adding or changing a clef

Add/Change a start clef
Add/Change a mid-measure clef

Delete

Controlling the visibility of clefs

Standard clefs
Courtesy clefs

Clefs and transposition

Using octave clefs
Using different clefs for transposed and concert pitch

Clef properties

Clef style

Key signatures

Overview

Setting the initial key signature for your score

Adding a key signature change to your score

Adding a local key signature for a single staff

Selecting a key signature for a single staff

Replacing an existing key signature

Deleting a key signature

Controlling the visibility of key signatures

Key signatures and transposing instruments

Open/Atonal key signature

Creating a custom key signature

Key signature properties

Key signature style

Format→Style→Page
Format→Style→Accidentals
Format→Style→Measure

See also

Transposition

Overview

Transposing with keyboard shortcuts

Transpose chromatically
Transpose diatonically
Transpose by an octave

Using the transpose dialog

Transpose Chromatically
To transpose chromatically to a specific key:

https://musescore.org/en/handbook/4/clefs
https://musescore.org/en/handbook/4/key-signatures
https://musescore.org/en/handbook/4/transposition
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To transpose chromatically by interval
Transpose Diatonically

Working with transposing instruments

Transposed and concert pitch
Setting the interval of transposition
Controlling enharmonic spelling

Octave lines

Overview

Adding an octave line to your score

Octave line properties

Style tab
Text tab

Octave line style

Noteheads

Changing notehead direction

Changing notehead shape

Sharing noteheads between voices

Notehead sharing rules
Change offset noteheads to a shared notehead
Shared noteheads in tablature

Alternative notehead systems

Adding pitch and velocity information to notes

Notehead properties

Ambitus

Adding an ambitus to your score

Changing the range of an ambitus

Ambitus properties

Respell pitches

Manually changing the enharmonic spelling of notes

Automatically respelling all notes in a selection

Respell pitches

Notation: Expressive markings
Articulations

Adding articulations to your score

Toolbar
Articulations palette
Keyboard shortcuts

Articulations playback

Articulation properties

Articulation style

Dynamics

Adding dynamics to your score

https://musescore.org/en/handbook/4/octave-lines
https://musescore.org/en/handbook/4/noteheads
https://musescore.org/en/handbook/4/ambitus
https://musescore.org/en/handbook/4/respell-pitches
https://musescore.org/en/handbook/4/articulations
https://musescore.org/en/handbook/4/dynamics

